mediola

LAN-Funk Gateway HM-LGW-O-TW-W-EU verliert CCU2 Verbindung

Einrichtung, Anschluss und Programmierung der HomeMatic CCU

Werbung


Re: LAN-Funk Gateway HM-LGW-O-TW-W-EU verliert CCU2 Verbindu

Beitragvon uwe111 » 05.12.2014, 16:42

Bei weiteren Tests ist mir aufgefallen, das mein rfd auf der CCU2 immer mit einem SIGSEGV abstürzt, wenn das HM-Funk-LAN Gateway nicht erreichbar ist.

Da es dafür leider noch immer keinen offiziellen Bugfix gibt, habe ich mir ein kleines Script zur Überwachung des rfd-Prozesses erstellt.

Dieses kleine Script lässt sich als AddOn auf der CCU2 installieren/deinstallieren und überwacht den rfd-Prozess. Sollte der rfd-Prozess abstürzen, dann wird er nach einer Minute automatisch neu gestartet.
Da es bei mir sehr zuverlässig funktioniert, möchte ich es hiermit allen zur Verfügung stellen.

Changelog Version 1.1:
  • Im Zusatzsoftware-Dialog der CCU wird die Anzahl der automatischen rfd-Restarts bzw. rfd-Abstürze angezeigt.

DOWNLOAD auch HIER

Viele Grüße

Uwe
Dateianhänge
rfd_monitor_1.1.tar.gz
RFD-Monitor
(980 Bytes) 166-mal heruntergeladen
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 1.12, RFD-Monitor, Vellemann K8055, SSH KeyDir
211 Kanäle in 118 Geräten und 101 CUxD-Kanäle in 47 CUxD-Geräten:
Benutzeravatar
uwe111
 
Beiträge: 3401
Registriert: 26.02.2011, 22:22

Re: LAN-Funk Gateway HM-LGW-O-TW-W-EU verliert CCU2 Verbindu

Beitragvon eric2905 » 05.12.2014, 19:35

Ich sag mal DANKE für diesen Workaround!

Installation läuft und meine beiden LAN-Gateways habe ich eben wieder aus dem Schrank / der Verpackung geholt und montiere sie gerade.

Bin sehr gespannt, ob es bei mir jetzt durchläuft.

Gruß,
Eric
-----------------------------------------------------------------------------------------------
RaspberryMatic (2.29.22.20171007) auf Pi3 mit zig Aktoren, usw.
ioBroker auf esxi-VM auf Intel NUC D54250WYK (Core i5-4250U) mit 16 GB RAM und 64 / 256 GB SSD
Benutzeravatar
eric2905
 
Beiträge: 803
Registriert: 04.04.2011, 12:50

Re: LAN-Funk Gateway HM-LGW-O-TW-W-EU verliert CCU2 Verbindu

Beitragvon grissli1 » 05.12.2014, 22:23

Hi,
super, vielen Dank Uwe! Wird zur Sicherheit auch installiert.

Viele Grüße
Chris

Unterwegs @ G-Pad
System: RaspberryMatic 2.27.8–Final auf RPi2, ReverseProxy auf RPi3, Mediola Gateway v2 und Harmony Hubs
grissli1
 
Beiträge: 2129
Registriert: 22.06.2012, 16:46
Wohnort: Tirol/Austria

Re: LAN-Funk Gateway HM-LGW-O-TW-W-EU verliert CCU2 Verbindu

Beitragvon hmpdr » 07.12.2014, 22:24

Hallo Uwe,

Danke für dieses Hilfs-Tool. Bei mir tritt dieses Problem immer wieder auf und stellt den Einsatz der Homematic in Frage!
Ich habe nun das Tool installiert und werde weiter beobachten.
Eine Frage habe ich noch: kann ich irgendwie feststellen, ob die Recovery Routine aktiv werden musste? Daran könnte ich den Erfolg sehr genau feststellen.

Nochmals Danke
und Gruss
Peter
256 Kanäle in 97 Geräten, 1x CCU2 und 2 LAN-GW
hmpdr
 
Beiträge: 14
Registriert: 22.02.2014, 12:45

Re: LAN-Funk Gateway HM-LGW-O-TW-W-EU verliert CCU2 Verbindu

Beitragvon uwe111 » 07.12.2014, 23:30

Hallo Peter,

bei jedem Crash wird die Meldung "rfd crashed" ins Syslog der CCU (/var/log/messages) geschrieben.
Danach wird der rfd dann neu gestartet.

Bei mir sieht das z.B. so aus:

Dec 5 20:53:39 homematic-ccu2 user.err rfd: LGWPortWrapper::keepAliveThreadFunction(): Error sending keepalive.
Dec 5 20:53:39 homematic-ccu2 user.debug rfd: Closing socket 10
Dec 5 20:53:39 homematic-ccu2 user.debug rfd: Closing socket 9
Dec 5 20:54:22 homematic-ccu2 user.err : Error setting rf-lgw info led
Dec 5 20:55:37 homematic-ccu2 user.notice logger: rfd crashed
Dec 5 20:55:40 homematic-ccu2 user.info rfd: BidCoS-Service started
Dec 5 20:55:40 homematic-ccu2 user.info rfd: XmlRpc Server is listening on TCP port 2001

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 1.12, RFD-Monitor, Vellemann K8055, SSH KeyDir
211 Kanäle in 118 Geräten und 101 CUxD-Kanäle in 47 CUxD-Geräten:
Benutzeravatar
uwe111
 
Beiträge: 3401
Registriert: 26.02.2011, 22:22

Re: LAN-Funk Gateway HM-LGW-O-TW-W-EU verliert CCU2 Verbindu

Beitragvon eric2905 » 08.12.2014, 08:47

Hallo zusammen,

eric2905 hat geschrieben:Bin sehr gespannt, ob es bei mir jetzt durchläuft.


kurzer Zwischenstand:

Teil 1
Erst lief es gar nicht ... der Dienst war weg, die obligatorische Meldung kam und das wars ....
Unter LAN-Gateways war kein Gerät mehr einem GW zugeordnet und die WS waren alle ohne Status.
Nur ein Reboot der CCU2 hat geholfen.

Teil 2
Die Gateways werden mit DHCP (aber mit Reservierung!) mit einer IP versorgt.
Irgendwo hatte ich gelesen, das man die IP in der Konfiguration des Gateways in der CCU mit angeben sollte - ist zwar optional, aber versuchen kann man es ja mal (frisst ja kein Brot).
Und siehe da, wenn der Dienst mal wieder abschmiert, kommt er dank der Scripts zuverlässig wieder hoch und die Gateways werden auch wieder verbunden.

Fazit (bei mir)
Zum Gateway sollte bei der Konfig in der CCU die jeweilige IP-Adresse mit angegeben werden
Zusammen mit dem Script (nochmals DANKE!) läuft es bei mir nun problemlos.

Gruß,
Eric
-----------------------------------------------------------------------------------------------
RaspberryMatic (2.29.22.20171007) auf Pi3 mit zig Aktoren, usw.
ioBroker auf esxi-VM auf Intel NUC D54250WYK (Core i5-4250U) mit 16 GB RAM und 64 / 256 GB SSD
Benutzeravatar
eric2905
 
Beiträge: 803
Registriert: 04.04.2011, 12:50

Re: LAN-Funk Gateway HM-LGW-O-TW-W-EU verliert CCU2 Verbindu

Beitragvon root » 25.12.2014, 12:03

Hallo zusammen,

gleiches Problem wie Andreas. Habe deshalb mal den Versuch mit lxccu (V 2.11.6) auf Raspi gestetet (etwas stärkere Hardware). Auch hier gibt es das Problem, dass das Lan-Gateway ab und an verloren wird. Habe deshalb mal den RFD-Moitor installiert.

Melde bei Gelegenheit den Erfolg oder Mißerfolg.

Anmerkung: Herzlichen Dank an UWE für sein Script.

mfg
Jimi Bondi
root
 
Beiträge: 4
Registriert: 12.03.2013, 13:21

Re: LAN-Funk Gateway HM-LGW-O-TW-W-EU verliert CCU2 Verbindu

Beitragvon grissli1 » 25.12.2014, 12:16

Hi,
wie bereits im LXCCU Thread geschrieben:
Bei meiner LXCCU und dem LAN Gateway treten keine Probleme auf. Alles läuft mit statischer IP. Sogar wenn ich das LAN Gateway stromlos mache und wieder anstecke läuft nach ein paar Sekunden wieder alles weiter.

Viele Grüße
Chris

Unterwegs @ G-Pad
System: RaspberryMatic 2.27.8–Final auf RPi2, ReverseProxy auf RPi3, Mediola Gateway v2 und Harmony Hubs
grissli1
 
Beiträge: 2129
Registriert: 22.06.2012, 16:46
Wohnort: Tirol/Austria

Re: LAN-Funk Gateway HM-LGW-O-TW-W-EU verliert CCU2 Verbindu

Beitragvon root » 27.12.2014, 09:39

Hallo zusammen,

hoffe Ihr hattet ein ertragreiches und ruhiges Weihnachten.

Mein Raspi-lxccu mit RFD-Monitor läuft seit rund zwei Tagen ohne Probs., sogar auch die Diagramme. Habe auch mit der Installation des RM eine feste IP mit dem Homematic-Net-Finder dem Lan-Gateway hinzu zugefügt.

Die Kombination aus Raspi, lxccu und RFD-Mon. kann ich wirklich empfehlen.

mfg
Jimi Bondi
root
 
Beiträge: 4
Registriert: 12.03.2013, 13:21

Re: LAN-Funk Gateway HM-LGW-O-TW-W-EU verliert CCU2 Verbindu

Beitragvon inidona » 27.12.2014, 23:36

Hallo anli,

gibts zu meinem Problem Neuigkeiten ?

danke
Andreas
inidona
 
Beiträge: 325
Registriert: 17.09.2013, 17:30

VorherigeNächste

Zurück zu HomeMatic Zentrale (CCU / CCU2)

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 9 Gäste







© homematic-forum.de & Lizenzgebern. Alle Rechte vorbehalten. Alle Bilder & Texte auf dieser Seite sind Eigentum
der jeweiligen Besitzer und dürfen ohne deren Einwilligung weder kopiert noch sonstwie weiter verwendet werden.