CUXD-Geräte in CCU verschwunden

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Antworten
mhuhn
Beiträge: 21
Registriert: 10.07.2011, 20:13

CUXD-Geräte in CCU verschwunden

Beitrag von mhuhn » 21.07.2021, 09:07

Ich hatte über CUXD 6 Geräte eingerichtet und in der CCU erfolgreich im Einsatz. Dann habe ich neulich einen Konfigurationsfehler gemacht und mir damit CUXD geschrottet, die CUXD-Admin-UI ging nicht mehr auf. Ich habe CUXD daraufhin neu als Addon aufgespielt, nun läuft es anscheinend wieder, die Oberfläche ist aufrufbar und zeigt mir sogar in der Geräteliste von CUXD noch all meine Geräte. Allerdings sind die CUXD-Geräte in der CCU verschwunden. Gehe ich in CUXD auf „Gerät bearbeiten“ und „Gerät auf CCU ändern“, kommt der Hinweis „param update!“, den ich nicht verstehe.

Ich habe mal in das CCU-Backup gesehen und dort in der Regadom-Datei gesehen, dass die Geräte eigentlich alle noch aufgelistet sind, allerdings erscheinen sie in der CCU Web-Oberfläche in der Geräteliste nicht und die damit geschriebenen Programme funktionieren auch nicht.

Was kann ich tun?

Ich verwende pivCCU auf eine Raspberry PI 3.

Benutzeravatar
uwe111
Beiträge: 4387
Registriert: 26.02.2011, 22:22
Hat sich bedankt: 1 Mal
Danksagung erhalten: 95 Mal
Kontaktdaten:

Re: CUXD-Geräte in CCU verschwunden

Beitrag von uwe111 » 21.07.2021, 09:31

mhuhn hat geschrieben:
21.07.2021, 09:07
Was kann ich tun?
Beschreibe bitte Deinen Konfigurationsfehler vor der CUxD Neuinstallation.
Wie sieht die CUxD Statusseite aus?
Kannst Du neue CUxD-Geräte anlegen?

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.6, SSH KeyDir

mhuhn
Beiträge: 21
Registriert: 10.07.2011, 20:13

Re: CUXD-Geräte in CCU verschwunden

Beitrag von mhuhn » 21.07.2021, 12:29

Vielen Dank für das Feedback.

Der Konfigurationsfehler vor Update war vermutlich, dass ich das Setting USERACCESS=1 hinzugefügt hatte. Ich hatte Probleme, einen Befehl mit sudo zu starten und dachte, das könne ich so lösen. Dann funktionierte es aber nicht mehr und auch das manuelle Herausnehmen dieser Änderung aus der ini über das Terminal hat nichts gebracht.

Die Status-Seite sagt u.a. folgendes:
Erfolgreich mit HomeMatic-CCU … verbunden!
als RPC-Server(INIT) von HomeMatic-CCU (63714) angefordert!
HM-Config: …regadom OK!
Aktuelle Geräteeinstellungen - 6 Geräte, 96 Channels
CUX2800004:1 state(1) timer(0s)
….
gefundene Adressen f(3): (danach kommt nichts mehr)

Neues Gerät hinzufügen geht, es erscheint dann im Posteingang und in der Geräteliste, die anderen aber nicht.

Benutzeravatar
uwe111
Beiträge: 4387
Registriert: 26.02.2011, 22:22
Hat sich bedankt: 1 Mal
Danksagung erhalten: 95 Mal
Kontaktdaten:

Re: CUXD-Geräte in CCU verschwunden

Beitrag von uwe111 » 21.07.2021, 14:35

Keine Ahnung, was da passiert ist.
Entweder ein altes Backup einspielen oder Du kannst versuchen, die 'alten' CUxD Geräte im CUxD zu löschen und danach erneut anzulegen.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.6, SSH KeyDir

mhuhn
Beiträge: 21
Registriert: 10.07.2011, 20:13

Re: CUXD-Geräte in CCU verschwunden

Beitrag von mhuhn » 21.07.2021, 18:15

Vielen Dank. Ich verstehe die Funktionsweise und Konfiguration von CUXD offenbar nicht ausreichend, um es wirklich zu beherrschen. Ich werde die mit CUXD laufenden Skripte auf ioBroker umbauen, das habe ich gefühlt mehr im Griff. Die CCU nutze ich dann nur noch als Gateway.

Antworten

Zurück zu „CUxD“