HomeMatic CCU2 bei ELV bestellen

Treiber auf der CCU2

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Werbung


Re: Treiber auf der CCU2

Beitragvon dondaik » 29.08.2017, 19:25

wie wäre es den mal mit bilder vom UNO ?,
wenn nicht defekt .. warum auch? würde ich sagen das ist ein clone-chip ( ist mir auch schon untergekommen ) ist.
-------
wer schreibfehler findet darf sie behalten.
dondaik
 
Beiträge: 7340
Registriert: 16.01.2009, 19:48
Wohnort: Steingaden

Re: Treiber auf der CCU2

Beitragvon olifall » 30.08.2017, 09:04

Hier die Screenshots.

Die Kommunikation in Windows, mit der Arduino Software funktioniert.

Danke schon mal für eure Hilfe. :)
Dateianhänge
Arduino.JPG
Mein Arduino
Nach.JPG
Gerätemanager nach dem einstecken
Vor.JPG
Gerätemanager vor dem einstecken
olifall
 
Beiträge: 75
Registriert: 17.07.2016, 09:48

Re: Treiber auf der CCU2

Beitragvon cmjay » 30.08.2017, 10:19

Wir nähern uns der Identifizierung der Problemursache - und ich hab wieder was gelernt. :)
Dein UNO ist offensichtlich ein Original (sowas ist mir bisher noch nicht untergekommen ...) und auf http://www.arduino.cc findet sich der Hinweis:
Differences with other boards
The Uno differs from all preceding boards in that it does not use the FTDI USB-to-serial driver chip. Instead, it features the Atmega16U2 (Atmega8U2 up to version R2) programmed as a USB-to-serial converter.
...
An ATmega16U2 on the board channels this serial communication over USB and appears as a virtual com port to software on the computer. The 16U2 firmware uses the standard USB COM drivers, and no external driver is needed. However, on Windows, a .inf file is required.


So weit, so gut.

AAAABER:
Wenn man mal DuckDuckGo mit den Suchbegriffen "original arduino uno usb problem linux" füttert, dann stellt sich raus, dass es - zumindest bei älteren Versionen des UNO / ATmega16U2 Probleme mit einer fehlerhaften Firmware gab / gibt, die dazu führten, dass der UNO unter Linux nicht richtig funktioniert.
https://harhar.net/blog/archives/3
https://blog.arduino.cc/2011/02/15/fix-to-uno-and-mega-2560-linux-serial-problems/
Keine Ahnung, ob dein UNO eines der betroffenen Modelle ist, aber ich könnte mir vorstellen, dass die buggy Firmware die Ursache deines Problems ist.
Schau dir mal die obigen Links an, die beschreiben, wie man dem Problem abhelfen können sollte.
Aber meiner Meinung nach wäre es am einfachsten, wenn du dir einen anderen Arduino mit FTDI Chip besorgst ...
Es kann leider nicht ganz ausgeschlossen werden, dass ich mich irre.

ACHTUNG! Per Portweiterleitung aus dem Internet erreichbare CCU2-WebUI ist unsicher! AUCH MIT PASSWORTSCHUTZ! Daher: Portweiterleitung deaktivieren!
cmjay
 
Beiträge: 236
Registriert: 19.09.2012, 10:53
Wohnort: Jottweedee

Re: Treiber auf der CCU2

Beitragvon olifall » 30.08.2017, 11:15

Super, dass werde ich versuchen und mich wieder melden. :D

Vielen Dank cmjay
olifall
 
Beiträge: 75
Registriert: 17.07.2016, 09:48

Re: Treiber auf der CCU2

Beitragvon olifall » 30.08.2017, 12:38

Hallo cmjay,

du bist mein Held, er funktioniert wieder. Das Firmware Update war nicht ganz so einfach, habe das noch nie gemacht. Gottseidank
gibt es Youtube. :D

Vielen Dank für deine Hilfe

Gruss glücklicher Oli
olifall
 
Beiträge: 75
Registriert: 17.07.2016, 09:48

Re: Treiber auf der CCU2

Beitragvon cmjay » 30.08.2017, 14:09

Gestern noch ein Held gewesen,
Ist man heute schon ein Schurke.
Heinrich Heine


Freut mich, dass es wieder läuft.
Vielleicht könntest du für andere Hilfesuchende der Vollständigkeit halber den Link zu dem YouTube Video einstellen, mit dessen Hilfe du das Firmware Update bewerkstelligt hast.
Dann ist dieser Thread komplett.
Es kann leider nicht ganz ausgeschlossen werden, dass ich mich irre.

ACHTUNG! Per Portweiterleitung aus dem Internet erreichbare CCU2-WebUI ist unsicher! AUCH MIT PASSWORTSCHUTZ! Daher: Portweiterleitung deaktivieren!
cmjay
 
Beiträge: 236
Registriert: 19.09.2012, 10:53
Wohnort: Jottweedee

Re: Treiber auf der CCU2

Beitragvon olifall » 31.08.2017, 11:32

Klar hier noch der Link zum Video.

https://www.youtube.com/watch?v=fSXZMVdO5Sg
olifall
 
Beiträge: 75
Registriert: 17.07.2016, 09:48

Vorherige

Zurück zu CUxD

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste







© homematic-forum.de & Lizenzgebern. Alle Rechte vorbehalten. Alle Bilder & Texte auf dieser Seite sind Eigentum
der jeweiligen Besitzer und dürfen ohne deren Einwilligung weder kopiert noch sonstwie weiter verwendet werden.