Cuxd CUL-Stick Firmware funktioniert nicht

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

justl82
Beiträge: 100
Registriert: 23.03.2015, 16:55
Wohnort: Dresden

Cuxd CUL-Stick Firmware funktioniert nicht

Beitrag von justl82 » 27.02.2017, 06:43

Hallo und guten Morgen an alle, ich habe ein Problem beim Durchführen des Firmwareupdates im Cuxd. Ich will bei mir die Firmware flashen auf 1.66 und komme einfach nicht weiter. Also ich gehe wie folgt vor, ich versetze den CUL in den Updatemodus das passt alles, dann kommt "Gerät 'ATm32U4DFU' bereit zum Update!". Anschließend drücke ich auf Update und es kommt kann nicht durchgeführt werden.

Im log steht nur folgendes drin:

Command: unzip -o dfu/atmega32u4.zip -d /tmp
Archive: dfu/atmega32u4.zip
inflating: CUL_V3_166.hex
inflating: CUL_V3_ZWAVE_166.hex
inflating: EUL_USB2TCM.hex

Was muß ich machen das es klappt, muß ich die Firmwaredatei in den Addon-ordner kopieren? Im Netz finde ich dazu nix.

LG und Danke justl82

lklages
Beiträge: 28
Registriert: 16.02.2017, 08:03

Re: Cuxd CUL-Stick Firmware funktioniert nicht

Beitrag von lklages » 06.03.2017, 08:27

Hab da ein ähnliches Problem. Stick ist im Update Modus ich kann aber keine Firmware auswählen.

Benutzeravatar
uwe111
Beiträge: 3740
Registriert: 26.02.2011, 22:22
Kontaktdaten:

Re: Cuxd CUL-Stick Firmware funktioniert nicht

Beitrag von uwe111 » 06.03.2017, 09:33

lklages hat geschrieben:Hab da ein ähnliches Problem. Stick ist im Update Modus ich kann aber keine Firmware auswählen.
Das ist aber ein völlig anderes Problem. Was zeigt denn Deine CUxD-Statusseite an?

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.2.0, RFD-Monitor, Vellemann K8055, SSH KeyDir

lklages
Beiträge: 28
Registriert: 16.02.2017, 08:03

Re: Cuxd CUL-Stick Firmware funktioniert nicht

Beitrag von lklages » 11.04.2017, 19:50

Sry das ich so spät antworte.

Das steht auf der ersten Seite.

USB 1-1 - (9514) [HUB] - Tue Apr 11 19:45:46 2017
USB 1-1.1 - (ec00) [FF] - no driver - Tue Apr 11 19:45:46 2017
USB 1-1.2 - ATm32U4DFU [00] - no driver - Tue Apr 11 19:45:46 2017
Kein TTY-Device connected!

Erfolgreich mit HomeMatic-CCU 127.0.0.1:8181 verbunden!

als RPC-Server(INIT) von HomeMatic-CCU (2328) angefordert!

Diese Web-Seite wurde aufgerufen von: 192.168.2.108

CUxD-Uptime(1.8a): 0 Tag(e) 00:00:21, 31688 Bytes belegt, Compiled Nov 28 2016 19:59:20
CCU-Uptime(2.25.15.20170114): 3 Tag(e) 05:26:00, load-average: 0.11 0.09 0.07, 10s-cpu-load: 1.1%
Speicher: Total 910512k Used 216760k Free 693752k (Cached 62784k)

Filesystem: / ext4 (ro) Total 443086k Used 324117k (73.1%) Free 118969k (26.9%)
Filesystem: /dev devtmpfs (rw) Total 450932k Used 0k ( 0.0%) Free 450932k (100.0%)
Filesystem: /dev/shm tmpfs (rw) Total 455256k Used 0k ( 0.0%) Free 455256k (100.0%)
Filesystem: /tmp tmpfs (rw) Total 455256k Used 268k ( 0.1%) Free 454988k (99.9%)
Filesystem: /run tmpfs (rw) Total 455256k Used 0k ( 0.0%) Free 455256k (100.0%)
Filesystem: /var tmpfs (rw) Total 455256k Used 1016k ( 0.2%) Free 454240k (99.8%)
Filesystem: /usr/local ext4 (rw) Total 3332240k Used 208692k ( 6.3%) Free 3123548k (93.7%)
Filesystem: /boot vfat (ro) Total 32686k Used 6962k (21.3%) Free 25724k (78.7%)

CCU-MAC: B8:27:EB:AB:79:12
HM-Config: /etc/config/homematic.regadom(1366836) OK! - Tue Apr 11 19:26:45 2017
CUxD-Config: /usr/local/addons/cuxd/cuxd.ps(41) - Tue Apr 11 19:45:46 2017

aktuelle Parameter: (* = bei Änderung Neustart erforderlich)

*LISTENPORT '8700'
*HM-SCRIPTHOST '127.0.0.1'
*HM-SCRIPTPORT '8181'
*RPCHOST '127.0.0.1'
*RPCPORT '8701'
HTTP-REFRESH '5'
TERMINALLINES '25'
RCVLOGSIZE '10000'
CUXINITCMD 'X21'
LOGFILE ''
LOGLEVEL '1'
LOGSIZE '1000000'
LOGFILEMOVE ''
DEVLOGFILE ''
DEVLOGSIZE '100000'
DEVLOGMOVE ''
DEVLOGMOVE-HR ''
DEVLOGEXPORT ''
DEVTIMEFORMAT '%Y-%m-%dT%X'
DEVDATAFORMAT ''
DEVLOGOLDALIAS '0'
SUBSCRIBE-RF '1'
SUBSCRIBE-WR '1'
AUTOSAVE '1'
MOUNTCMD ''
UMOUNTCMD ''
BACKUPCMD ''
SYSLOGMOVE ''
SYSLOGMOVEDAILY ''
TH-DIR ''
TH-DIR-FILTER ''
ADDRESS-BUFFER '120'
CLOUDMATIC_CMD '/etc/config/addons/mh/cloudmatic'
WEBCAMCONFIG '/usr/local/addons/cuxd/webcamconfig.ini'
WEBCAMSNAPSHOT '/tmp/snapshots'
WEBCAMCACHE '/tmp/webcams'
SYSLOGFILENAME '/var/log/messages'
CUXD-CHARTS '/etc/config/addons/www/cuxchart/index.html'


Aktuelle Geräteeinstellungen - 1 Gerät(e), 16 Channel(s):

CUX2800001:1 state(1) timer(0s)
CUX2800001:2 state(1) timer(0s)
CUX2800001:3 state(1) timer(0s)
CUX2800001:4 state(1) timer(0s)
CUX2800001:5 state(1) timer(0s)
CUX2800001:6 state(1) timer(0s)
CUX2800001:7 state(1) timer(0s)
CUX2800001:8 state(1) timer(0s)
CUX2800001:9 state(1) timer(0s)
CUX2800001:10 state(1) timer(0s)
CUX2800001:11 state(1) timer(0s)
CUX2800001:12 state(1) timer(0s)
CUX2800001:13 state(1) timer(0s)
CUX2800001:14 state(1) timer(0s)
CUX2800001:15 state(1) timer(0s)
CUX2800001:16 state(1) timer(0s)


gefundene Adressen (aktuelle zuerst 19:46:07):

schneidy76
Beiträge: 288
Registriert: 18.11.2016, 22:36
Wohnort: ziemlich weit unten

Re: Cuxd CUL-Stick Firmware funktioniert nicht

Beitrag von schneidy76 » 11.04.2017, 19:56

Versuche mal über die Flashsoftware vom busware. Bei mir gings über CuxD nicht. Mit Powershell und den Flashsoftware problemlos.
Ist bei busware super beschrieben.
Vg Torsten
http://busware.de/tiki-index.php?page=CUL

lklages
Beiträge: 28
Registriert: 16.02.2017, 08:03

Re: Cuxd CUL-Stick Firmware funktioniert nicht

Beitrag von lklages » 11.04.2017, 20:05

schneidy76 hat geschrieben:Versuche mal über die Flashsoftware vom busware. Bei mir gings über CuxD nicht. Mit Powershell und den Flashsoftware problemlos.
Ist bei busware super beschrieben.
Vg Torsten
http://busware.de/tiki-index.php?page=CUL
Hast du zufällig einen Link dazu? Ich finde da leider nichs

schneidy76
Beiträge: 288
Registriert: 18.11.2016, 22:36
Wohnort: ziemlich weit unten

Re: Cuxd CUL-Stick Firmware funktioniert nicht

Beitrag von schneidy76 » 11.04.2017, 20:15

Hab ihn nachgereicht. Alles in ein Verzeichnis kopieren - wichtig die Firmware muss auch dahin.
Dann die beschriebenen Befehle über CMD oder Powershell (hier sind die Befehle wie unter Linux).
Vg Torsten

lklages
Beiträge: 28
Registriert: 16.02.2017, 08:03

Re: Cuxd CUL-Stick Firmware funktioniert nicht

Beitrag von lklages » 11.08.2017, 19:34

So nach langer zeit komme ich mal wieder dazu weiter zu machen. Leider ohne erfolg.
Gibt es vieleicht eine Deutche Step by Step Anleitung um diesen Stick zum laufen zu bekommen?

Benutzeravatar
uwe111
Beiträge: 3740
Registriert: 26.02.2011, 22:22
Kontaktdaten:

Re: Cuxd CUL-Stick Firmware funktioniert nicht

Beitrag von uwe111 » 13.08.2017, 19:18

lklages hat geschrieben:Gibt es vieleicht eine Deutche Step by Step Anleitung um diesen Stick zum laufen zu bekommen?
Hast Du es mal mit der aktuellen CUxD-Version gestestet?
Welche Log-Meldungen werden angezeigt?

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.2.0, RFD-Monitor, Vellemann K8055, SSH KeyDir

lklages
Beiträge: 28
Registriert: 16.02.2017, 08:03

Re: Cuxd CUL-Stick Firmware funktioniert nicht

Beitrag von lklages » 14.08.2017, 20:15

Mit der neusten Version kann ich zumindest jetzt eine Software zum Flashen aussuchen.

Auf der Rechten Seite steht dann: Gerät 'ATm32U4DFU' bereit zum Update!
und dann kommt diese Meldung:

unpack 'atmega32u4.zip'
erase atmega32u4 - OK
flash atmega32u4 'CUL_V3_167.hex' - ERROR exit(6)
start atmega32u4 - OK

Antworten

Zurück zu „CUxD“