Netzlaufwerk mit CUxD mounten

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

LibertyX
Beiträge: 335
Registriert: 10.11.2012, 20:47

Netzlaufwerk mit CUxD mounten

Beitrag von LibertyX » 23.06.2017, 22:42

Hi,

ich versuche ein Freigabe von meinem NAS zu mounten
über SSH funktioniert es mit

mount -t cifs -o rw,user=XXX,password=XXX //192.168.2.251/Backup /usr/local/Backup

Im CUxD geht es leider nicht, das Laufwerk wird nicht eingehängt.
RaspberryMatic (2.35.16.20180715) @RPI3 | 156 Kanäle in 51 Geräten und 37 CUxD-Kanäle in 3 CUxD-Geräten | iobroker.pro (Alexa) - CuxD

LibertyX
Beiträge: 335
Registriert: 10.11.2012, 20:47

Re: Netzlaufwerk mit CUxD mounten

Beitrag von LibertyX » 24.06.2017, 14:34

Also es scheint am Parameter "password=" zu liegen, denn im SysLog gibt es folgende Meldung

Jun 24 14:29:38 homematic-raspi daemon.err cuxd[504]: MOUNT system(xxxxxx //192.168.2.251/Backup/HomeMatic/CCU_Backup /usr/local/Backup) exit(127)

An der Stelle von xxxxxx steht das Passwort, kennt CUxD den Parameter nicht?
RaspberryMatic (2.35.16.20180715) @RPI3 | 156 Kanäle in 51 Geräten und 37 CUxD-Kanäle in 3 CUxD-Geräten | iobroker.pro (Alexa) - CuxD

sailor79ac

Re: Netzlaufwerk mit CUxD mounten

Beitrag von sailor79ac » 24.06.2017, 17:07

Nur ein Verdachts-Versuch:

Ändern mal dein Kennwort zu dem User auf dem NAS und versuche es nochmal.

LibertyX
Beiträge: 335
Registriert: 10.11.2012, 20:47

Re: Netzlaufwerk mit CUxD mounten

Beitrag von LibertyX » 24.06.2017, 17:26

User root und user auf dem NAS haben nun das selbe Kennwort.
Nur mit dem Parameter "user" erhalte ich dann folgende Fehlermeldung

Code: Alles auswählen

Jun 24 17:17:43 homematic-raspi user.notice kernel: [16777.618874] Status code returned 0xc000006d NT_STATUS_LOGON_FAILURE
Lasse ich dann auch noch den Parameter "user" weg also ohne "user" und "password" erhalte ich diese Fehlermeldung

Code: Alles auswählen

Jun 24 17:17:58 homematic-raspi user.err kernel: [16792.994032] CIFS VFS: No username specified#
Zuletzt geändert von LibertyX am 24.06.2017, 17:39, insgesamt 2-mal geändert.
RaspberryMatic (2.35.16.20180715) @RPI3 | 156 Kanäle in 51 Geräten und 37 CUxD-Kanäle in 3 CUxD-Geräten | iobroker.pro (Alexa) - CuxD

sailor79ac

Re: Netzlaufwerk mit CUxD mounten

Beitrag von sailor79ac » 24.06.2017, 17:35

1. Hast Du denn das Kennwort geändert? (Es ist nämlich möglich, dass der dazugehörige Schlüssel abgelaufen ist).
2. Was manchmal auch hilft, ist die zusätzlicher Option workgroup=XXX

also in deinem Fall

Code: Alles auswählen

mount -t cifs -o rw,user=XXX,password=XXX,workgroup=XXX //192.168.2.251/Backup /usr/local/Backup
Ansonsten kann man nur raten

LibertyX
Beiträge: 335
Registriert: 10.11.2012, 20:47

Re: Netzlaufwerk mit CUxD mounten

Beitrag von LibertyX » 24.06.2017, 17:41

Welches ? Das auf der CCU oder das auf dem NAS? geändert habe ich das auf dem NAS
Eine Workgroup gibt es auf meinem NAS nicht ich glaube auch nicht das es damit etwas zu tun hat, denn über SSH (CCU) funktioniert der mount ja ohne Fehler, nur über CUxD nicht.

Normal müsste die Zeile im LOG so aussehen

Code: Alles auswählen

Jun 24 17:14:56 homematic-raspi daemon.err cuxd[504]: MOUNT system(mount -t cifs -o user=user1,password=1234 //192.168.2.251/Backup /usr/local/Backup)exit(1)
denn bei umount sieht sie so aus

Code: Alles auswählen

Jun 24 17:15:49 homematic-raspi daemon.err cuxd[504]: UMOUNT system(umount /usr/local/Backup) exit(1)
Die mount Zeile sieht aber so aus

Code: Alles auswählen

Jun 24 17:14:56 homematic-raspi daemon.err cuxd[504]: MOUNT system(1234 //192.168.2.251/Backup /usr/local/Backup)exit(150)
also CUxD lässt alles vor dem Kennwort weg, eingetragen ist es aber richtig

Code: Alles auswählen

MOUNTCMD=mount -t cifs -o user=user1,password=1234 //192.168.2.251/Backup /usr/local/Backup
Fehler im CUxD ?
RaspberryMatic (2.35.16.20180715) @RPI3 | 156 Kanäle in 51 Geräten und 37 CUxD-Kanäle in 3 CUxD-Geräten | iobroker.pro (Alexa) - CuxD

sailor79ac

Re: Netzlaufwerk mit CUxD mounten

Beitrag von sailor79ac » 24.06.2017, 17:46

Das mit der Workgroup kann je nach Linux-Version auf deinem NAS schon sein, weil es da mal einen Bug gab.
Exit(1) heißt übrigens Abbruch wegen Fehler, wenn müsste es Exit(0) zurückgeben.

CuxD denke ich nicht, da es bei anderen wie auch bei mir funktioniert.

LibertyX
Beiträge: 335
Registriert: 10.11.2012, 20:47

Re: Netzlaufwerk mit CUxD mounten

Beitrag von LibertyX » 24.06.2017, 17:53

Wenn ich doch aber ber SSH auf die CCU gehe und dort den Befehl

mount -t cifs -o user=xxx,password=xxx //192.168.2.251/Backup /usr/local/Backup

ausführe, wird das Laufwerk ohne Fehler eingehängt, nur über CUxD nicht, dann kann das Problem doch nur am CuxD liegen, denn das ist der einzige Unterschied.
sailor79ac hat geschrieben:Exit(1) heißt übrigens Abbruch wegen Fehler, wenn müsste es Exit(0) zurückgeben.
Mein Fehler, dass war als ich unmount gedrückt habe als das Laufwerk nicht eingehängt war.
Wenn es eingehängt ist und unmount gedrückt wird kommt folgendes

Code: Alles auswählen

Jun 24 21:00:47 homematic-raspi daemon.info cuxd[504]: UMOUNT system(umount /usr/local/Backup)
Okay wie sieht den deine MOUNTCMD Zeile aus?
Zuletzt geändert von LibertyX am 24.06.2017, 21:06, insgesamt 1-mal geändert.
RaspberryMatic (2.35.16.20180715) @RPI3 | 156 Kanäle in 51 Geräten und 37 CUxD-Kanäle in 3 CUxD-Geräten | iobroker.pro (Alexa) - CuxD

dondaik
Beiträge: 8923
Registriert: 16.01.2009, 19:48
Wohnort: Steingaden

Re: Netzlaufwerk mit CUxD mounten

Beitrag von dondaik » 24.06.2017, 17:58

... oder am aufbau der befehlszeile für cuxd.?
-------
wer schreibfehler findet darf sie behalten.

LibertyX
Beiträge: 335
Registriert: 10.11.2012, 20:47

Re: Netzlaufwerk mit CUxD mounten

Beitrag von LibertyX » 24.06.2017, 18:05

Also ich habe es jetzt auch einmal mit

Code: Alles auswählen

mount -t cifs -o user=xx,password=xxx,workgroup=WORKGROUP //192.168.2.251/Backup /usr/local/Backup
versucht, aber das gleiche

Code: Alles auswählen

Jun 24 18:01:30 homematic-raspi daemon.err cuxd[504]: MOUNT system(WORKGROUP //192.168.2.251/Backup /usr/local/Backup) exit(127)
Also für mich sieht das so aus als wenn CUxD hier alles vor dem letzten Parameter weg lässt und den Befehl dadurch nicht richtig ausführt, denn hier fehlt auch wieder alles vor "WORKGROUP"

Edit: Kann es sein, dass es am "=" liegt, denn es fehlt eigentlich alles vor dem letzten "=" ?
dondaik hat geschrieben:... oder am aufbau der befehlszeile für cuxd.?
Schließe ich nicht aus, daher würde ich ja gerne mal wissen wie eine Funktionierende aussieht, vielleicht ist es auch nur ein Syntaxfehler.

Laut Doku soll Sie so aussehen

Code: Alles auswählen

MOUNTCMD=mount -t nfs -o nolock 192.168.5.67:/Public/ccu /home
RaspberryMatic (2.35.16.20180715) @RPI3 | 156 Kanäle in 51 Geräten und 37 CUxD-Kanäle in 3 CUxD-Geräten | iobroker.pro (Alexa) - CuxD

Antworten

Zurück zu „CUxD“