Seite 1 von 4

nach einem Firmwareupdate läuft CUxD nicht mehr

BeitragVerfasst: 07.08.2017, 19:37
von markuswil
Hallo Homematic-Fans,

habe gerade meine Firmware auf 2.29.18 upgedatet. Danach Cuxdm auf 1.10a. Leider funktioniert CuxD nun Überhaupt nicht mehr und ich erhalte wenn ich den Daemon starte nur:

Service >>> CUxD-Admin
File-Browser
Prozessliste
restart SSH Dienst
Java HM-Server deaktivieren (CCU-Neustart erforderlich)
Java HM-Server aktivieren (CCU-Neustart erforderlich)

Bitte wählen:
CUxD-Restart
CUxD-Stop
DOM-Save
DOM-Save & CCU-Restart
CCU-Restart
DOM-Save & CCU-SafeMode
CCU-SafeMode
Set root password to
Shell command


Was kann ich nur machen?

LG Markus

Re: nach einem Firmwareupdate läuft CUxD nicht mehr

BeitragVerfasst: 07.08.2017, 21:14
von alchy
Wenn du nur diese Seite bekommst, sollte der Cuxd nicht laufen, also würde ich Restart wăhlen.

Alchy

Re: nach einem Firmwareupdate läuft CUxD nicht mehr

BeitragVerfasst: 08.08.2017, 11:57
von uwe111
Hallo Markus,

es empfiehlt sich immer das CUxD-Update VOR einem Firmware Update einzuspielen.
Hast Du mal geprüft, ob die aktuelle CUxD-Version 1.10a auch wirklich installiert ist?
Und hast Du das richtige Paket für Deine Hardware installiert?

Viele Grüße

Uwe

Re: nach einem Firmwareupdate läuft CUxD nicht mehr

BeitragVerfasst: 08.08.2017, 14:23
von markuswil
Hi,
es ist zum verzweifeln.

Die CCU2-Firmware ist auf dem aktuellen Stand 2.29.18. Habe mal rückwärts die CuxD-Updates aufgespiel. Die letzte Version die funktioniert ist die Version 1.5.

Trotzdem erscheint:

USB 1-1 - {CUX} CUL868 [COMM] - /dev/ttyACM0 {:789s} - V 1.57 CUL868 (CUL_V3) - Tue Aug 8 15:07:32 2017

Nicht mit HomeMatic-CCU 127.0.0.1:8181 verbunden!

als RPC-Server(INIT) von HomeMatic-CCU (1380) angefordert!

Diese Web-Seite wurde aufgerufen von: 192.168.178.20

CUxD-Uptime(1.5): 0 Tag(e) 00:13:41, 41816 Bytes belegt, Compiled Dec 8 2015 17:48:58
CCU-Uptime(2.29.18): 0 Tag(e) 00:14:01, load-average: 1.18 0.91 0.70, 10s-cpu-load: 95.1%
Speicher: Total 255392k Used 149696k Free 105696k (Cached 46164k)

Filesystem: / ubifs (ro) Total 172716k Used 79380k (46.0%) Free 93336k (54.0%)
Filesystem: /dev devtmpfs (rw) Total 127636k Used 0k ( 0.0%) Free 127636k (100.0%)
Filesystem: /dev/shm tmpfs (rw) Total 127696k Used 0k ( 0.0%) Free 127696k (100.0%)
Filesystem: /tmp tmpfs (rw) Total 127696k Used 116k ( 0.1%) Free 127580k (99.9%)
Filesystem: /media tmpfs (rw) Total 127696k Used 0k ( 0.0%) Free 127696k (100.0%)
Filesystem: /var tmpfs (rw) Total 200704k Used 552k ( 0.3%) Free 200152k (99.7%)
Filesystem: /usr/local ubifs (rw) Total 41284k Used 12820k (31.1%) Free 28464k (68.9%)
Filesystem: /media/sd-mmcblk0 vfat (rw) Total 15638608k Used 57696k ( 0.4%) Free 15580912k (99.6%)

und die Geräte werden nicht im Gerätefenter angezeigt. Trotzdem lassen Sie sich bedienen.

Bei allen CuxD-Versionen danch geht nix und es kommt :


Service >>> CUxD-Admin
File-Browser
Prozessliste
restart SSH Dienst
Java HM-Server deaktivieren (CCU-Neustart erforderlich)
Java HM-Server aktivieren (CCU-Neustart erforderlich)

Bitte wählen:
CUxD-Restart
CUxD-Stop
DOM-Save
DOM-Save & CCU-Restart
CCU-Restart
DOM-Save & CCU-SafeMode
CCU-SafeMode
Set root password to
Shell command

Bin völlig ratlos.

LG Markus Wilczek

Re: CUxD 1.10a

BeitragVerfasst: 08.08.2017, 14:46
von markuswil
Hi,
es ist zum verzweifeln.

Die CCU2-Firmware ist auf dem aktuellen Stand 2.29.18. Habe mal rückwärts die CuxD-Updates aufgespiel. Die letzte Version die funktioniert ist die Version 1.5.

Trotzdem erscheint:

USB 1-1 - {CUX} CUL868 [COMM] - /dev/ttyACM0 {:789s} - V 1.57 CUL868 (CUL_V3) - Tue Aug 8 15:07:32 2017

Nicht mit HomeMatic-CCU 127.0.0.1:8181 verbunden!

als RPC-Server(INIT) von HomeMatic-CCU (1380) angefordert!

Diese Web-Seite wurde aufgerufen von: 192.168.178.20

CUxD-Uptime(1.5): 0 Tag(e) 00:13:41, 41816 Bytes belegt, Compiled Dec 8 2015 17:48:58
CCU-Uptime(2.29.18): 0 Tag(e) 00:14:01, load-average: 1.18 0.91 0.70, 10s-cpu-load: 95.1%
Speicher: Total 255392k Used 149696k Free 105696k (Cached 46164k)

Filesystem: / ubifs (ro) Total 172716k Used 79380k (46.0%) Free 93336k (54.0%)
Filesystem: /dev devtmpfs (rw) Total 127636k Used 0k ( 0.0%) Free 127636k (100.0%)
Filesystem: /dev/shm tmpfs (rw) Total 127696k Used 0k ( 0.0%) Free 127696k (100.0%)
Filesystem: /tmp tmpfs (rw) Total 127696k Used 116k ( 0.1%) Free 127580k (99.9%)
Filesystem: /media tmpfs (rw) Total 127696k Used 0k ( 0.0%) Free 127696k (100.0%)
Filesystem: /var tmpfs (rw) Total 200704k Used 552k ( 0.3%) Free 200152k (99.7%)
Filesystem: /usr/local ubifs (rw) Total 41284k Used 12820k (31.1%) Free 28464k (68.9%)
Filesystem: /media/sd-mmcblk0 vfat (rw) Total 15638608k Used 57696k ( 0.4%) Free 15580912k (99.6%)

und die Geräte werden nicht im Gerätefenter angezeigt. Trotzdem lassen Sie sich bedienen.

Bei allen CuxD-Versionen danch geht nix und es kommt :


Service >>> CUxD-Admin
File-Browser
Prozessliste
restart SSH Dienst
Java HM-Server deaktivieren (CCU-Neustart erforderlich)
Java HM-Server aktivieren (CCU-Neustart erforderlich)

Bitte wählen:
CUxD-Restart
CUxD-Stop
DOM-Save
DOM-Save & CCU-Restart
CCU-Restart
DOM-Save & CCU-SafeMode
CCU-SafeMode
Set root password to
Shell command

Bin völlig ratlos.

LG Markus Wilczek

Re: nach einem Firmwareupdate läuft CUxD nicht mehr

BeitragVerfasst: 08.08.2017, 15:08
von Cash
das verstehe ich nun nicht.

Version 1.6 wir benötigt für Versionen CCU2 ab FW 2.17.14

bzw Version 1.9 ab CCU-Firmware 2.27.x

Wie kann nun die 1.5 bei Deiner CCU mit 2.29.18 laufen?

Re: nach einem Firmwareupdate läuft CUxD nicht mehr

BeitragVerfasst: 08.08.2017, 17:53
von markuswil
Ich verstehe es ja auch alles nicht.

Die 1.5 läuft auch nicht richtig. Ich kann im Dämon keine Geräte sehen, aber ich kann sie alle ansprechen. Bei höheren CuxD-Versionen bekomme ich immer obige Fehlermeldung.

LG Markus

Re: nach einem Firmwareupdate läuft CUxD nicht mehr

BeitragVerfasst: 08.08.2017, 18:01
von mpcc
Die CCU2 selbst hattest du aber auch neu gestartet ?

Re: nach einem Firmwareupdate läuft CUxD nicht mehr

BeitragVerfasst: 08.08.2017, 18:08
von JRiemann
Experimente mit alten Versionen sind sinnlos!
CUxD sollte IMMER in der neuestes Version verwendet werden.
Viele Updates enthalten unter anderem Anpassungen die wichtig dafür sind das CUxD mit den neuesten Firmwareversionen der CCU funktioniert.
Wichtig ist es auch darauf zu achten das man das richtige Installationspaket für seine verwendete Plattform auswählt (CCU2, RaspiMatic).

Re: CUxD 1.10a

BeitragVerfasst: 08.08.2017, 18:11
von JRiemann
Das selbe Problem in 2 Threads öffentlich zu machen löst das Problem auch nicht schneller!!!
Doppelte Anfragen sind eher kontraproduktiv!!

Zum Problem:
Wie auch im anderen Thread gilt hier: Neueste Version 1.10a nutzen!