Raspberrymatic mit CCU und NanoCul

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Benutzeravatar
3PO
Beiträge: 22
Registriert: 29.10.2017, 00:01
Wohnort: Schwabenländle
Kontaktdaten:

Re: Raspberrymatic mit CCU und NanoCul

Beitrag von 3PO » 09.11.2017, 21:24

Danke, habe ich gefunden. ;)

Allerdings habe ich noch nicht verstanden, weshalb es mit dem nanoCUL nicht geht?

Wenn ich das richtig verstanden habe, wird doch Funkmodul via "serial" angebunden, wäre es denn da nicht denkbar, das Funkmodul via USB2Serial Adapter an einem x86_64 System zu betreiben?

Benutzeravatar
uwe111
Beiträge: 3677
Registriert: 26.02.2011, 23:22
Kontaktdaten:

Re: Raspberrymatic mit CCU und NanoCul

Beitrag von uwe111 » 09.11.2017, 22:34

3PO hat geschrieben:Allerdings habe ich noch nicht verstanden, weshalb es mit dem nanoCUL nicht geht?
Firmware und Hardware vom CUL und HM-MOD-RPI-PCB Funkmodul sind unterschiedlich.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.1.0, RFD-Monitor, Vellemann K8055, SSH KeyDir

Gelegenheitsbastler
Beiträge: 237
Registriert: 15.10.2017, 07:29

Re: Raspberrymatic mit CCU und NanoCul

Beitrag von Gelegenheitsbastler » 03.12.2017, 08:56

3PO hat die Frage etwas weiter vorne schon gestellt. Leider fehlt eine Antwort.

"Gibt es denn eigentlich irgendwo eine Anleitung zum Einbinden eines nanoCULs?"

Mich würde eine verständliche Anleitung ebenfalls interessieren. Vielleicht hat ja jemand einen Link?
Das Komplizierteste an der Hausautomatisation ist der WAF.™ ​

RaspberryMatic 2.31.25.20180625 auf Raspberry Pi 3B mit HomeMatic Funkmodul von ELV und RTC
FritzBox 7490 FW 6.93 mit Mesh
FritzRepeater 1750E FW 6.93 mit Mesh
FRITZ!DECT 200 (als CUxD Gerät eingebunden)
Etliche selbst gebaute Aktoren und Sender

Murdock
Beiträge: 1
Registriert: 11.12.2017, 00:16

Re: Raspberrymatic mit CCU und NanoCul

Beitrag von Murdock » 11.12.2017, 00:24

Hallo, der Frage nach einer Anleitung zur erfolgreichen Anbindung eines nanoCUL an die Raspberrymatic CCU kann ich mich nur anschließen. Ich habe eigentlich genau das gleiche Problem. Wollte einen KS300 Kombisensor mittels nanoCUL an die Raspberrymatic anbinden, in der Statusliste wird der CUL auch erkannt, jedoch findet er keine Adressen.
In meinem Fall habe ich einen nanoCUL USB Stick FTDI CC1101 868MHz.
Nachfolgend meine CUxD-Statusliste. Hat jemand noch einen Tipp, was beim nanoCUL evtl. zu beachten ist?

Besten Dank im Voraus!


USB 1-1 - (9514) [HUB] - Sun Dec 10 00:37:02 2017
USB 1-1.1 - (ec00) [FF] - no driver - Sun Dec 10 00:37:02 2017
USB 1-1.3 - {CUX} NANO CUL [FF] - /dev/ttyUSB0 {:81480s} - connected - Sun Dec 10 00:42:46 2017

Erfolgreich mit HomeMatic-CCU 127.0.0.1:8181 verbunden!

als RPC-Server(INIT) von HomeMatic-CCU (1979) angefordert!

Diese Web-Seite wurde aufgerufen von: 192.168.178.32

CUxD-Uptime(1.11): 0 Tag(e) 22:53:37, 50912 Bytes belegt, Compiled Aug 6 2017 21:47:22
CCU-Uptime(2.29.22.20170902): 1 Tag(e) 00:02:40, load-average: 0.08 0.06 0.03, 10s-cpu-load: 2.3%
Speicher: Total 949596k Used 231528k Free 718068k (Cached 82108k)
CPU(1): ARMv7 Processor rev 5 (v7l) [38.40 bogomips]
CPU(2): ARMv7 Processor rev 5 (v7l) [38.40 bogomips]
CPU(3): ARMv7 Processor rev 5 (v7l) [38.40 bogomips]
CPU(4): ARMv7 Processor rev 5 (v7l) [38.40 bogomips]
Linux version 4.9.46-v7 (damato@bilbo) (gcc version 6.4.0 (Buildroot 2017.08-00619-gc3bb765) ) #1 SMP PREEMPT Sat Sep 2 19:59:12 CEST 2017

Filesystem: / ext4 (ro) Total 487652k Used 346559k (71.1%) Free 141093k (28.9%)
Filesystem: /dev devtmpfs (rw) Total 470188k Used 0k ( 0.0%) Free 470188k (100.0%)
Filesystem: /dev/shm tmpfs (rw) Total 474796k Used 0k ( 0.0%) Free 474796k (100.0%)
Filesystem: /tmp tmpfs (rw) Total 474796k Used 116k ( 0.0%) Free 474680k (100.0%)
Filesystem: /run tmpfs (rw) Total 474796k Used 76k ( 0.0%) Free 474720k (100.0%)
Filesystem: /var tmpfs (rw) Total 474800k Used 6576k ( 1.4%) Free 468224k (98.6%)
Filesystem: /media tmpfs (rw) Total 474796k Used 0k ( 0.0%) Free 474796k (100.0%)
Filesystem: /usr/local ext4 (rw) Total 14712196k Used 820076k ( 5.6%) Free 13892120k (94.4%)
Filesystem: /boot vfat (ro) Total 32686k Used 7424k (22.7%) Free 25262k (77.3%)

CCU-MAC: B8:27:EB:14:73:0A
HM-Config: /etc/config/homematic.regadom(3514519) OK! - Sun Dec 10 23:19:34 2017
CUxD-Config: /usr/local/addons/cuxd/cuxd.ps(1338) - Sun Dec 10 22:27:09 2017

aktuelle Parameter: (* = bei Änderung Neustart erforderlich)

*LISTENPORT '8700'
*HM-SCRIPTHOST '127.0.0.1'
*HM-SCRIPTPORT '8181'
*RPCHOST '127.0.0.1'
*RPCPORT '8701'
HTTP-REFRESH '5'
TERMINALLINES '25'
RCVLOGSIZE '10000'
CUXINITCMD 'X21'
LOGFILE ''
LOGLEVEL '1'
LOGSIZE '1000000'
LOGFILEMOVE ''
DEVLOGFILE ''
DEVLOGSIZE '100000'
DEVLOGMOVE ''
DEVLOGMOVE-HR ''
DEVLOGEXPORT ''
DEVTIMEFORMAT '%Y-%m-%dT%X'
DEVDATAFORMAT ''
DEVLOGOLDALIAS '0'
SUBSCRIBE-RF '1'
SUBSCRIBE-WR '1'
AUTOSAVE '1'
MOUNTCMD ''
UMOUNTCMD ''
BACKUPCMD ''
SYSLOGMOVE ''
SYSLOGMOVEDAILY ''
TH-DIR ''
TH-DIR-FILTER ''
ADDRESS-BUFFER '120'
CLOUDMATIC_CMD '/etc/config/addons/mh/cloudmatic'
WEBCAMCONFIG '/usr/local/addons/cuxd/webcamconfig.ini'
WEBCAMSNAPSHOT '/tmp/snapshots'
WEBCAMCACHE '/tmp/webcams'
SYSLOGFILENAME '/var/log/messages'
CUXD-CHARTS '/etc/config/addons/www/cuxchart/index.html'
DFU_ERASE './dfu-programmer $TARGET$ erase'
DFU_FLASH './dfu-programmer $TARGET$ flash $HEXFILE$'
DFU_START './dfu-programmer $TARGET$ start'

TTY Konfiguration:

ttyUSB0:38400:8N1 {CUX}


Aktuelle Geräteeinstellungen - 2 Gerät(e), 17 Channel(s):

CUX3100001: RAINFKT(295.00) STAT CHECK
CUX2801001:1 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:2 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:3 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:4 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:5 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:6 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:7 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:8 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:9 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:10 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:11 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:12 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:13 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:14 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:15 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()
CUX2801001:16 rmax(65535) t(3600s) p(0)
KEY-SHORT CMD_SHORT()
KEY-LONG CMD_LONG()


gefundene Adressen (aktuelle zuerst 23:20:46):

Loddar56
Beiträge: 1
Registriert: 04.05.2018, 15:38

Re: Raspberrymatic mit CCU und NanoCul

Beitrag von Loddar56 » 04.05.2018, 15:56

In dem Handbuch steht aber auch :
5.6 (29) BidCos Geräte {CUX}
Da dieses Protokoll ein anderes Datenübertragungsverfahren nutzt, ist der Empfang nur über einen eigenen CUL möglich. Bei gleichzeitigem Empfang von FS20-Geräten (1kHz, AM) und BidCos-Geräten (20kHz, FM) müssen zwei CULs an die CCU angeschlossen werden. Die Initialisierung des BidCos CULs kann dann mit TTYINIT erfolgen (z.B: TTYINIT=ttyACM1:X21\nAr). Danach werden vom CUL auch alle HomeMatic-Datenpakete empfangen.

Meinen nanoCUL habe ich erfolgreich installiert und kann damit FS20 Aktoren schalten und auch die Wetterdaten der KS300 empfangen.

KS300:1

Garten
Wetter
04.05.2018 15:32:07
Temperatur: 23.00°C Rel. Luftfeuchte: 35%
Windgeschwindigkeit: 0.50km/h aktuell kein Regen
[DEW_POINT]: 6.70°C [ABS_HUMIDITY]: 7.20g/m³
Regenmenge: 213.58mm [WIND_MAX_24H]: 0.00km/h
[TEMP_MIN_24H]: 0.00°C [TEMP_MAX_24H]: 0.00°C
[HUM_MIN_24H]: 0.00% [HUM_MAX_24H]: 0.00%
[RAIN_CTR_24H]: 0.00mm [MISS_24H]: 0
Regen heute: 0.00 mm


Da habe ich aber auch noch eine Frage zu dem Senden/Empfang von Bidos Kommandos:

Hat die obrige Lösung mal einer ausprobiert?

Ich habe einen zweiten nanoCUL installiert, bekomme den aber nicht auf BidCOS geswitcht. Ein HM-MOD_RPI_PCB habe ich nicht installiert.

Beide CUL werden initialisiert, sind aber beide im SlowRF Modus.

Hab da von Raspian leider keine Ahnung. :roll:
Aus dem Setup:

TTYPARAM=ttyUSB0:38400:8N1
TTYASSIGN=ttyUSB0:CUX
TTYPARAM=ttyUSB1:38400:8N1
TTYASSIGN=ttyUSB1:CUX
TTYINIT=ttyUSB1:X21\nAr

Antworten

Zurück zu „CUxD“