Mounten eines Fritz!NAS-Verzeichnis

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

MediolaDaniel
Beiträge: 16
Registriert: 27.07.2019, 19:50
Hat sich bedankt: 1 Mal

Re: Mounten eines Fritz!NAS-Verzeichnis

Beitrag von MediolaDaniel » 26.07.2021, 20:02

Vielen Dank für die Hilfe,

also es ist so, wenn ich das Nas mounte, geht es mit media. Da werden mir auch alle Dateien angezeigt.

Code: Alles auswählen

mount -t nfs -o nolock IP-Adressse:/volume2/homematic/ /media
Wenn ich die Fritzbox Mounten will, kommt

Code: Alles auswählen

mount: mounting //192.168.177.1/fritz.nas on /media failed: No such device

PaulM
Beiträge: 188
Registriert: 16.02.2015, 17:05
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 56 Mal
Danksagung erhalten: 12 Mal

Re: Mounten eines Fritz!NAS-Verzeichnis

Beitrag von PaulM » 27.07.2021, 08:41

ist auf Fritzbox username und passwort (mit entsprechenden Berechtigungen) eingerichtet ?

den SSH Befehl ergänzen

Gruß
Mit Mut und Entschlossenheit gegen Intoleranz

MediolaDaniel
Beiträge: 16
Registriert: 27.07.2019, 19:50
Hat sich bedankt: 1 Mal

Re: Mounten eines Fritz!NAS-Verzeichnis

Beitrag von MediolaDaniel » 27.07.2021, 09:03

Der Benutzer hat Berechtigung auf Nas Inhalte.

Was meinst mit SSH Befehl erweitern? Ich hab den von oben genommen mit User und Passwort

Gruß

PaulM
Beiträge: 188
Registriert: 16.02.2015, 17:05
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 56 Mal
Danksagung erhalten: 12 Mal

Re: Mounten eines Fritz!NAS-Verzeichnis

Beitrag von PaulM » 27.07.2021, 09:50

das meinte ich
zeig deinen SSH Befehl mit Leerzeichen, Komma etc mit ersetztem Benutzer/Passwort
Gruß Paul
Mit Mut und Entschlossenheit gegen Intoleranz

Michel2017
Beiträge: 46
Registriert: 30.03.2017, 07:58
Hat sich bedankt: 18 Mal
Danksagung erhalten: 3 Mal

Re: Mounten eines Fritz!NAS-Verzeichnis

Beitrag von Michel2017 » 27.07.2021, 10:22

Hallo zusammen,

ein anderes Problem:
das mounten eines Fritz!NAS Verzeichnisses auf meiner Fritz!Box 7490 funktioniert wie in diesem thread beschrieben einwandfrei.

Code: Alles auswählen

mount -t cifs -o noserverino,vers=3.0,user='xxx',password='xxx' //192.168.178.1/FRITZ.NAS/Intenso-ExternalUSB3-0-01/CCU /media/fritzbox-ext
Ich kopiere täglich meine backups vom USB Stick auf Fritz!NAS. Allerdings hat mein log file dann für jede kopierte Datei folgende Einträge:

Code: Alles auswählen

Jul 27 04:30:00 homematic-raspi user.err kernel: [1329444.205344] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:01 homematic-raspi user.err kernel: [1329444.858138] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:01 homematic-raspi user.err kernel: [1329444.878705] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:04 homematic-raspi user.err kernel: [1329447.485294] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:04 homematic-raspi user.err kernel: [1329447.950023] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:04 homematic-raspi user.err kernel: [1329448.106722] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:04 homematic-raspi user.err kernel: [1329448.352199] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:05 homematic-raspi user.err kernel: [1329448.585942] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:05 homematic-raspi user.err kernel: [1329448.844654] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:05 homematic-raspi user.err kernel: [1329449.242928] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:06 homematic-raspi user.err kernel: [1329449.397082] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:06 homematic-raspi user.err kernel: [1329449.548876] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:06 homematic-raspi user.err kernel: [1329449.715279] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:06 homematic-raspi user.err kernel: [1329449.861741] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:06 homematic-raspi user.err kernel: [1329450.073543] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:07 homematic-raspi user.err kernel: [1329450.627052] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:07 homematic-raspi user.err kernel: [1329450.752146] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:07 homematic-raspi user.err kernel: [1329450.883481] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:07 homematic-raspi user.err kernel: [1329451.014181] CIFS: VFS: bogus file nlink value 0
Jul 27 04:30:10 homematic-raspi user.warn kernel: [1329454.287294] cifs_all_info_to_fattr: 13 callbacks suppressed
Das Problem scheint generell bekannt zu sein, und man findet mit Google auch eine Lösung: Man muß den
Mount-Parameter 'noserverino' verwenden. Dies tue ich sowieso, nur tauchen diese Fehlermeldungen trotzdem auf; mit und ohne 'noserverino'. Fritz!OS ist immer aktuell.

Die Fehlermeldungen scheinen aber keine Auswirkungen zu haben, da alle kopierten Dateien auf Fritz!NAS vorhanden sind und auch "funktionieren"; z.B. sind die Backups brauchbar, Dateien lesbar, etc.

Weiß jemand, woran diese Fehlermeldungen sonst noch liegen könnten?

Danke,

Michel

jp112sdl
Beiträge: 9555
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 596 Mal
Danksagung erhalten: 1407 Mal
Kontaktdaten:

Re: Mounten eines Fritz!NAS-Verzeichnis

Beitrag von jp112sdl » 27.07.2021, 11:37

Michel2017 hat geschrieben:
27.07.2021, 10:22
Weiß jemand, woran diese Fehlermeldungen sonst noch liegen könnten?
Das liegt am SMB-Server der Fritte.
Wenn AVM das nicht irgendwann mal ausbessert (wobei sie da wohl nicht zugänglich sind, wenn ich die Forenbeiträge im Internet so lese), bleibt dir nur die CIFS-Unterstützung selbst zu kompilieren und die Meldung aus den Source zu entfernen
https://elixir.bootlin.com/linux/v5.10. ... ode.c#L728

Hier ist übrigens sehr ausführlich erklärt, warum es zu dieser Fehlermeldung kommen kann:
https://unix.stackexchange.com/question ... ink-values

VG,
Jérôme ☕️

---
Support for my Homebrew-Devices: Download JP-HB-Devices Addon

PN sind deaktiviert!

MediolaDaniel
Beiträge: 16
Registriert: 27.07.2019, 19:50
Hat sich bedankt: 1 Mal

Re: Mounten eines Fritz!NAS-Verzeichnis

Beitrag von MediolaDaniel » 27.07.2021, 19:50

Also jetzt mal von vorne und alle Einstellungen. Finde leider den Fehler nicht.
1.JPG
Der Benutzer der Fritzbox.
2.JPG
2.JPG (21.44 KiB) 252 mal betrachtet
SMB Aktivierung in der Fritzbox
3.JPG
3.JPG (15.52 KiB) 252 mal betrachtet
Dateistruktur CCU2
4.JPG
4.JPG (19.28 KiB) 252 mal betrachtet
SSH Befehl mit Fehler

Viele Grüße

Michel2017
Beiträge: 46
Registriert: 30.03.2017, 07:58
Hat sich bedankt: 18 Mal
Danksagung erhalten: 3 Mal

Re: Mounten eines Fritz!NAS-Verzeichnis

Beitrag von Michel2017 » 27.07.2021, 20:00

Vielleicht liegt's an der Verwendung des /media Verzeichnisses? Ich habe bei mir ein Unterverzeichnis /media/fritzbox-ext angelegt

Code: Alles auswählen

mount -t cifs -o noserverino,vers=3.0,user='xxx',password='xxx' //192.168.178.1/FRITZ.NAS/Intenso-ExternalUSB3-0-01/CCU /media/fritzbox-ext

MediolaDaniel
Beiträge: 16
Registriert: 27.07.2019, 19:50
Hat sich bedankt: 1 Mal

Re: Mounten eines Fritz!NAS-Verzeichnis

Beitrag von MediolaDaniel » 27.07.2021, 20:32

Im media Verzeichnis, kann ich keine Ordner anlegen.

Habe jetzt alternativ auch mal tmp und var versucht mit Unterordner. Da kann ich welche anlegen, kann aber nicht mounten

PaulM
Beiträge: 188
Registriert: 16.02.2015, 17:05
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 56 Mal
Danksagung erhalten: 12 Mal

Re: Mounten eines Fritz!NAS-Verzeichnis

Beitrag von PaulM » 27.07.2021, 22:24

probier mal auf der Fritzbox
-Name
-Benutzer
-Passwort
alles in Kleinbuchstaben

denn (FRITZ.NAS ist nicht gleich fritz.nas)

und evtl. probier mal das Standardverzeichnis zum mounten auf der CCU "/mnt"

Gruß
Paul
Mit Mut und Entschlossenheit gegen Intoleranz

Antworten

Zurück zu „CUxD“