CuXD und Pushover-Nachrichten funktionieren nicht

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Roland G673
Beiträge: 7
Registriert: 27.03.2018, 22:30

CuXD und Pushover-Nachrichten funktionieren nicht

Beitrag von Roland G673 » 28.03.2018, 01:00

Hallo liebes Forum,

ich hatte die fixe Idee Push-Nachrichten von der CCU2 auf dem Handy empfangen zu müssen.

Ich habe mir dazu CuXD (1.12) für die CCU2 heruntergeladen und installiert. Danach habe ich ein Gerät (28)-System als Exec eingerichtet und auf der CCU2 bestätigt. Neustart der CCU2 durchgeführt und ein Script angelegt:

dom.GetObject("CUxD.CUX2801001:1.CMD_EXEC").State("LD_LIBRARY_PATH=/usr/local/addons/cuxd /usr/local/addons/cuxd/curl -s -k -d token=a53j4hkanu52tb6545xxxxxxxx -d user=uwcd1c87xxxxxxxxx -d message=TEST -d https://api.pushover.net/1/messages.json");

Die CUxD-Seriennumer stimmt mit meinem Gerät üerein, aber es kommt nichts an. Direkt über die Pushover-Internetsite funktioniert alles, auch per Mail. Nur die CCU2 will nicht. Die Bedingung in den Programmen wird ausgeführt, da ich vor der Ausführung des Skripts noch eine LED aktiviert habe. Diese signalisiert mir, dass die Bedingung abgearbeitet wurde.

Muss man CuXD wirklich öfter installieren/deinstallieren? Das hatte ich im Forum schon einmal gelesen.
Ich habe schon drei Mal neu installiert, aber es tut sich nichts. In den Foren finde ich auch immer wieder den gleichen Code, mal mehr oder weniger ausgeschmückt, aber keine Lösung für mein Problem

Hat jemand bitte einen Tipp für mich? Ich bin echt am verzweifeln. :?

VG

Roland

Benutzeravatar
uwe111
Beiträge: 3600
Registriert: 26.02.2011, 23:22
Kontaktdaten:

Re: CuXD und Pushover-Nachrichten funktionieren nicht

Beitrag von uwe111 » 28.03.2018, 08:41

Roland G673 hat geschrieben:Muss man CuXD wirklich öfter installieren/deinstallieren? Das hatte ich im Forum schon einmal gelesen.
Nein, muss man nicht!
Roland G673 hat geschrieben:Ich habe schon drei Mal neu installiert, aber es tut sich nichts.
Das bringt überhaupt nichts.
Roland G673 hat geschrieben:Hat jemand bitte einen Tipp für mich? Ich bin echt am verzweifeln. :?
Steht im CUxD-Syslog eine Fehlermeldung? Melde Dich auf der CCU2 per Ssh an und teste Deinen Curl-Befehl mal auf der Kommandozeile der CCU.
Roland G673 hat geschrieben:dom.GetObject("CUxD.CUX2801001:1.CMD_EXEC").State("LD_LIBRARY_PATH=/usr/local/addons/cuxd /usr/local/addons/cuxd/curl ...
Diesen Teil "LD_LIBRARY_PATH=/usr/local/addons/cuxd" kannst Du bei einem Aufruf innerhalb von CUxD auch weglassen.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.0.1, RFD-Monitor, Vellemann K8055, SSH KeyDir

Roland G673
Beiträge: 7
Registriert: 27.03.2018, 22:30

Re: CuXD und Pushover-Nachrichten funktionieren nicht

Beitrag von Roland G673 » 28.03.2018, 10:36

Hallo Uwe,

In den Logs steht nur, dass der Befehl ausgeführt wurde. Es wird kein Error ausgewiesen. Das verwundert mich eben.
Hab jetzt spaßhalber mal mit Telegram getestet, aber auch da kommt nichts an.

Ich habe jetzt ein SSH-Kennwort vergeben, mir ist aber unklar, wo ich den Befehl erfassen muss. Ich bin mit Filezilla auf die CCU gegangen. Gibt es was einfacheres?

Ich benötige hier noch ein wenig Unterstützung, da ich noch nicht soooo oft mit Filezilla gearbeitet habe.

Danke nochmal..

VG

Roland

P.S. Ich habe mir mal schnell ein VBA-Programm geschrieben und dort den Request abgesetzt. Hier kam die Push-Meldung an. Die ID's der API und User stimmen also. Kann m.E. also nur an CuxD oder dem Programm in der CCU liegen.
Zuletzt geändert von Roland G673 am 28.03.2018, 12:42, insgesamt 1-mal geändert.

Roland G673
Beiträge: 7
Registriert: 27.03.2018, 22:30

Re: CuXD und Pushover-Nachrichten funktionieren nicht

Beitrag von Roland G673 » 28.03.2018, 10:42

Hallo nochmal,

ich hoffe ich habe in der CuXD-Oberfläche die "Kommandozeile" gefunden: (s. Datei)
Da passiert aber nichts... Es öffnet sich ein neues Browser-Tab und das wars dann...

VG

Roland
Dateianhänge
CuXD-Befehl.png
CuXD-Befehl.png (12.98 KiB) 281 mal betrachtet

Benutzeravatar
uwe111
Beiträge: 3600
Registriert: 26.02.2011, 23:22
Kontaktdaten:

Re: CuXD und Pushover-Nachrichten funktionieren nicht

Beitrag von uwe111 » 28.03.2018, 12:25

Hallo Roland,

Zur Anmeldung per SSH kannst Du Putty (https://www.putty.org/) nutzen. Mit FileZilla kannst Du nur Files übertragen.

Den Befehl (per Putty auf der CCU) musst Du ohne die HM-Script Funktion ausführen. Also so:

Code: Alles auswählen

LD_LIBRARY_PATH=/usr/local/addons/cuxd /usr/local/addons/cuxd/curl -s -k -d token=a53j4hkanu52tb6545xxxxxxxx -d user=uwcd1c87xxxxxxxxx -d message=TEST -d https://api.pushover.net/1/messages.json
Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.0.1, RFD-Monitor, Vellemann K8055, SSH KeyDir

Roland G673
Beiträge: 7
Registriert: 27.03.2018, 22:30

Re: CuXD und Pushover-Nachrichten funktionieren nicht

Beitrag von Roland G673 » 28.03.2018, 12:48

Hallo Uwe,

danke für den Hinweis - wie gesagt da in ich leider nicht fit. Daher habe ich in VBA getestet, da kenne ich mich aus :-)

Nach Eingabe des von Dir genannten Befehls in Putty erhalte ich folgende Fehlermeldung:

curl: no URL specified!
curl: try 'curl --help' or 'curl --manual' for more information

@Uwe: Was kann ich tun?

Benutzeravatar
uwe111
Beiträge: 3600
Registriert: 26.02.2011, 23:22
Kontaktdaten:

Re: CuXD und Pushover-Nachrichten funktionieren nicht

Beitrag von uwe111 » 28.03.2018, 13:34

Roland G673 hat geschrieben:@Uwe: Was kann ich tun?
Ganz einfach. Dein Curl Befehl stimmt nicht. Google mal nach Curl Beispielen.
Ich habe da ganz spontan diese Seite gefunden:
https://thomas-falkner.de/2011/01/25/cu ... -erklaert/

Aufgrund der Fehlermeldung würde ich einfach mal den -d Parameter vor der URL am Ende des Befehls weglassen.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.0.1, RFD-Monitor, Vellemann K8055, SSH KeyDir

Roland G673
Beiträge: 7
Registriert: 27.03.2018, 22:30

Re: CuXD und Pushover-Nachrichten funktionieren nicht

Beitrag von Roland G673 » 28.03.2018, 14:18

Die Befehle wiederholen sich aber genauso im Netz...

z.B: https://homematic.simdorn.net/push-meldung/

Ich habe nur meine Daten ergänzt. Der Code sieht in anderen Foren/Beiträgen identisch aus. Diese müssten dann ja alle falsch sein?! Oder hat sich seit letztem Jahr etwas gravierendes verändert? Der Artikel auf der o.g. Site ist von 2017.

Benutzeravatar
uwe111
Beiträge: 3600
Registriert: 26.02.2011, 23:22
Kontaktdaten:

Re: CuXD und Pushover-Nachrichten funktionieren nicht

Beitrag von uwe111 » 28.03.2018, 15:55

Roland G673 hat geschrieben:Ich habe nur meine Daten ergänzt.
und dabei wohl einen Fehler gemacht...
Auch auf Deiner verlinkten Website steht kein -d vor der URL!

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.0.1, RFD-Monitor, Vellemann K8055, SSH KeyDir

Roland G673
Beiträge: 7
Registriert: 27.03.2018, 22:30

Re: CuXD und Pushover-Nachrichten funktionieren nicht

Beitrag von Roland G673 » 28.03.2018, 16:05

Hi Uwe,

Sorry, das hatte ich beim vielen rumprobieren übersehen. Im Originalcode war noch die Priorität gesetzt. Da diese lt. API nur optional ist, habe ich diese zu Test gelöscht und dabei den Befehl -d stehen lassen.

Jetzt habe ich Putty mit folgendem Code gefüttert:

LD_LIBRARY_PATH=/usr/local/addons/cuxd /usr/local/addons/cuxd/curl -s -k -d token=a53j4hkanuxxxxxxx -d user=uwcd1c87xh7kum6xxxxxx -d message=TEXT -d priority=1 https://api.pushover.net/1/messages.json

Putty wartet dann einige Sekunden bis die nächste Eingabezeile angezeigt wird, aber es passiert einfach nichts. Wie gesagt, das gleiche mit Telegram.

Ich bekomme schon graue Haare...

VG

Roland

Antworten

Zurück zu „CUxD“