HTTP-Request schaltet nicht

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Antworten
Latot73
Beiträge: 6
Registriert: 26.12.2018, 15:25

HTTP-Request schaltet nicht

Beitrag von Latot73 » 26.12.2018, 15:45

Hallo,

mein erster Beitrag nachdem ich bisher nur still mitgelesen habe.

Ich habe folgendes Problem. Ich habe einen Raspberry mit Pilight laufen, mit dem ich verschieden 433MHz Steckdosen schalte.
Für Homematic nutze ich eine CCU2.

Um nicht immer in zwei verschiedenen Oberflächen hin und her zu springen, wollte ich das Ganze jetzt in Homematic mit CUXD und per CURL einbinden. Ich habe bereits Sonoff (S20) Steckdosen mit der Firmware SonoffHMLOX am laufen und dachte mir, dass ich einfach in dem vorhanden CUXD-Gerät den nächsten Schalter nutze und es genauso mache wir bei der Sonoff Steckdose.
Bei den Sonoff Steckdosen rufe ich über die Parameter Switch|CM_Short/Long den Befehl

Code: Alles auswählen

/usr/local/addons/cuxd/curl -s http://ipsonoff/0
/usr/local/addons/cuxd/curl -s http://ipsonoff/1
Das funktioniert auch soweit.

Bei den Pilight-Steckdosen ist der URL-Aufruf etwas komplizierter:

Code: Alles auswählen

http://IPRaspberry:88/control?device=Steckdose&state=off
http://IPRaspberry:88/control?device=Steckdose&state=on
Ich habe sehr schnell dank des Forums herausgefunden, dass ich die Sonderzeichen entsprechend codieren muss.
Somit sieht der Aufruf bei Switch|CM_Short/Long folgendermaßen aus:

Code: Alles auswählen

/usr/local/addons/cuxd/curl -s http://ipRaspberry:88/control?device~3DSteckdose_3~26state~3Doff
/usr/local/addons/cuxd/curl -s http://ipRaspberry:88/control?device~3DSteckdose_3~26state~3Don
Leider schaltet hierbei gar nichts der Aufruf der URL funktioniert im Browser aber einwandfrei. Hat noch jemand eine Idee woran es liegt?
Ich habe auch bereits sicherheitshalber das Fragezeichen und den Doppelpunkt beim Port codiert, leider alles ohne erfolg.

Gruß

Gunnar

Benutzeravatar
uwe111
Beiträge: 3935
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: HTTP-Request schaltet nicht

Beitrag von uwe111 » 26.12.2018, 16:39

Hallo Gunnar,
Latot73 hat geschrieben:
26.12.2018, 15:45
Leider schaltet hierbei gar nichts der Aufruf der URL funktioniert im Browser aber einwandfrei.
Dann teste Deinen Curl Aufruf (ohne Kodierung der Sonderzeichen) mal bitte direkt von der CCU aus.
Zum Besipiel indem Du Dich vorher über Putty an der CCU anmeldest.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.3.3, RFD-Monitor, Vellemann K8055, SSH KeyDir

Latot73
Beiträge: 6
Registriert: 26.12.2018, 15:25

Re: HTTP-Request schaltet nicht

Beitrag von Latot73 » 26.12.2018, 17:49

Hallo Uwe,

beim Aufruf direkt von der CCU aus mit Curl ohne Codierung, kommt eine Failed-Meldung von Pilight zurück. Codiere ich die Gleich-Zeichen und das Und-Zeichen mit %3d und %26 funktioniert der Aufruf auf der CCU mit Curl und die Stekckdose schaltet.
Eine Codierung mit der ~ statt % auf der CCU funktioniert nicht, sollte es vermutlich auch nicht, wenn ich das richtig verstanden habe.

Gruß

Gunnar

Benutzeravatar
uwe111
Beiträge: 3935
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: HTTP-Request schaltet nicht

Beitrag von uwe111 » 26.12.2018, 18:30

Hallo Gunnar,

na dann nutze doch den funktionierenden Aufruf als CMD_... Parameter.
Bitte poste das nächste Mal auch den funktionierenden Aufruf in Deinem Beitrag.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.3.3, RFD-Monitor, Vellemann K8055, SSH KeyDir

Latot73
Beiträge: 6
Registriert: 26.12.2018, 15:25

Re: HTTP-Request schaltet nicht

Beitrag von Latot73 » 26.12.2018, 19:16

Hallo Uwe,

da hatte ich wohl ein Brett vor dem Kopf ich habe es gar nicht mit der %-Codierung versucht da ich gelesen habe das ich mit ~ codieren muss .
Vielen Dank für deine Hilfe.

Somit lauten die nun funktionierenden Codes bei mir wie folgt:

Code: Alles auswählen

/usr/local/addons/cuxd/curl -s http://ipRaspberry:88/control?device%3DSteckdose_3%26state%3Doff
/usr/local/addons/cuxd/curl -s http://ipRaspberry:88/control?device%3DSteckdose_3%26state%3Don


Gruß

Gunnar

Benutzeravatar
uwe111
Beiträge: 3935
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 1 Mal
Kontaktdaten:

Re: HTTP-Request schaltet nicht

Beitrag von uwe111 » 26.12.2018, 19:24

Hallo Gunnar,

Du musst nur die Sonderzeichen in der Befehlszeile kodieren.
Da Deine Befehlszeile aber keine Sonderzeichen mehr enthält (sind ja bereits mittels % kodiert), musst Du nichts kodieren.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.3.3, RFD-Monitor, Vellemann K8055, SSH KeyDir

Antworten

Zurück zu „CUxD“