Ich dreh bald ab 433Mhz :(

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Antworten
ftpgonzo
Beiträge: 194
Registriert: 16.12.2014, 20:03

Ich dreh bald ab 433Mhz :(

Beitrag von ftpgonzo » 25.02.2019, 17:15

Hallo zusammen , seit nunmehr 14 Tagen und gefühlt 100 Stunden versuche ich eins meiner 433 Mhz Geräte anzusteuern. Vor 14 Tagen ca besorgte ich mir einen Nano und ein cc1001 Modul habe alles gesteckt Geflasht (unterschiedliche Firmware bis einschliesslich 1.67).. Narda er Sendet nix und Empfängt nix. Ok dachte ich mir evtl hast was falsch gemacht neue Anleitung neu gesteckt usw usw Narda nickes .. vor 1 Woche hab ich es dann Aufgegeben... und einen Originalen Busware 433 über Kleinanzeigen erworben. Er war konfiguriert und lief beim vorbesitzer (L.T seiner Ausage) Nun habe ich das Phänomen .. er Empfängt von irgendwo ein FS20 Gerät und eine Wetterstation aber nicht meine 433er Geräte auch neu Flashen etc brachte nix . Culconfig und co kennt der Stick nicht
ccconf is unknown) Use one of A B b C e F G h i K k L l M m N R T t U u V W X x Y Z
verschiende Parmeter wie X21 ,X8,X99 werden ausgeführt aber meine Geräte will er einfach nicht ...

Jetzt würde jeder sagen .. deine 433 Geräte werden nicht Unterstützt... ABER wenn ich an meinen Pi3 meine China Module anschliesse
(siehe anhang) werden sie erkannt .. aber die Reichweite ist Grottenschlecht deswegen die Überlegung mit dem Cul.

Hier mein System:
CCU2 mit FW 2.41.5
Cux mit Version 2.20
CUL mit Version 1.67 (von Busware)
Setup vom Cux :
*LISTENPORT '8700'
*HM-SCRIPTHOST '127.0.0.1'
*HM-SCRIPTPORT '8181'
*RPCHOST '127.0.0.1'
*RPCPORT '8701'
HTTP-REFRESH '5'
TERMINALLINES '25'
RCVLOGSIZE '10000'
CUXINITCMD 'X21'
LOGFILE ''
LOGLEVEL '1'
LOGSIZE '1000000'
LOGFILEMOVE ''
DEVLOGFILE ''
DEVLOGSIZE '100000'
DEVLOGMOVE ''
DEVLOGMOVE-HR ''
DEVLOGEXPORT ''
DEVTIMEFORMAT '%Y-%M-%DT%X'
DEVDATAFORMAT ''
DEVLOGOLDALIAS '0'
SUBSCRIBE-RF '1'
SUBSCRIBE-WR '1'
AUTOSAVE '1'
MOUNTCMD ''
UMOUNTCMD ''
BACKUPCMD ''
SYSLOGMOVE ''
SYSLOGMOVEDAILY ''
TH-DIR ''
TH-DIR-FILTER ''
ADDRESS-BUFFER '120'
CLOUDMATIC_CMD '/ETC/CONFIG/ADDONS/MH/CLOUDMATIC'
WEBCAMCONFIG '/USR/LOCAL/ADDONS/CUXD/WEBCAMCONFIG.INI'
WEBCAMSNAPSHOT '/TMP/SNAPSHOTS'
WEBCAMCACHE '/TMP/WEBCAMS'
SYSLOGFILENAME '/VAR/LOG/MESSAGES'
CUXD-CHARTS '/ETC/CONFIG/ADDONS/WWW/CUXCHART/INDEX.HTML'
DFU_ERASE './DFU-PROGRAMMER $TARGET$ ERASE --FORCE'
DFU_FLASH './DFU-PROGRAMMER $TARGET$ FLASH $HEXFILE$'
DFU_START './DFU-PROGRAMMER $TARGET$ START' [/quote


Mit
TTYPARAM=ttyUSB0:38400:8N1
TTYASSIGN=ttyUSB0:CUX hab ich auch schon Probiert änder nix

Evtl weiß ja einer von euch noch ein Rat :?:

Danke

Benutzeravatar
uwe111
Beiträge: 3836
Registriert: 26.02.2011, 22:22
Kontaktdaten:

Re: Ich dreh bald ab 433Mhz :(

Beitrag von uwe111 » 25.02.2019, 18:04

ftpgonzo hat geschrieben:
25.02.2019, 17:15
ABER wenn ich an meinen Pi3 meine China Module anschliesse (siehe anhang) werden sie erkannt ..
Um welche Geräte handelt es sich? Ich habe keinen Anhang gesehen. :roll:
ftpgonzo hat geschrieben:
25.02.2019, 17:15
Evtl weiß ja einer von euch noch ein Rat :?:
Was steht auf Deiner CUxD Statusseite?

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.2.0, RFD-Monitor, Vellemann K8055, SSH KeyDir

ftpgonzo
Beiträge: 194
Registriert: 16.12.2014, 20:03

Re: Ich dreh bald ab 433Mhz :(

Beitrag von ftpgonzo » 25.02.2019, 18:17

Hallo Uwe , dann hier nochmal den Anhang und meine Statusseite :)
index.jpg
index.jpg (6.57 KiB) 291 mal betrachtet
USB 1-1 - {CUX} CUL433 [COMM] - /dev/ttyACM0 {:3087s} - V 1.67 CUL433 (CUL_V3) - Mon Feb 25 17:23:15 2019

Erfolgreich mit HomeMatic-CCU 127.0.0.1:8181 verbunden!

als RPC-Server(INIT) von HomeMatic-CCU (3316) angefordert!
gefundene Adressen (aktuelle zuerst 18:16:28):

Letzte Status Device Gerät 'CODE'
18:16:21 [?] ttyACM0 FS20(3122 2312 - 1243) '85611E' (-42dBm)
Bei C99 und ganz normal über X21

danke schonmal

Benutzeravatar
uwe111
Beiträge: 3836
Registriert: 26.02.2011, 22:22
Kontaktdaten:

Re: Ich dreh bald ab 433Mhz :(

Beitrag von uwe111 » 25.02.2019, 18:28

Also Dein CUL wird erstmal richtig erkannt.

Am Ende der CUxD Doku habe ich beschrieben, wie man die aktuelle Frequenz des CULs auslesen kann.
Vielleicht ist da was verstellt, da FS20 auf 868 MHz arbeitet.

Dein Gerät kenne ich leider nicht.Was ist das? Was macht das?

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.2.0, RFD-Monitor, Vellemann K8055, SSH KeyDir

ftpgonzo
Beiträge: 194
Registriert: 16.12.2014, 20:03

Re: Ich dreh bald ab 433Mhz :(

Beitrag von ftpgonzo » 25.02.2019, 20:30

Hallo Uwe, das ist ein ganz normaler no-name china 433 Mhz empfänger den man eigentlich an jeden Gerät anstecken kann. Das Set aus Sender und Empfänger kostet keine 5 euro :lol: .

Mit FS20 hatte ich auch gelesen das es 868 MHZ wäre .. der Stick soll aber 433 Mhz sein ... die Firmware auf dem Stick selber ist auch 433 :?:

Ist es nicht Richtig wenn ich die Culconfig aufrufe im Terminal das da etwas kommen muss ? Evtl ist ja der Stick fritte :evil:


Danke :mrgreen:

Benutzeravatar
uwe111
Beiträge: 3836
Registriert: 26.02.2011, 22:22
Kontaktdaten:

Re: Ich dreh bald ab 433Mhz :(

Beitrag von uwe111 » 25.02.2019, 21:08

ftpgonzo hat geschrieben:
25.02.2019, 20:30
das ist ein ganz normaler no-name china 433 Mhz empfänger den man eigentlich an jeden Gerät anstecken kann.
Und welches Protokoll versteht das Teil genau? Wie hattest Du es zuvor am Pi3 angeschlossen?
ftpgonzo hat geschrieben:
25.02.2019, 20:30
der Stick soll aber 433 Mhz sein ... die Firmware auf dem Stick selber ist auch 433
Die Culfw Firmware ist auf beiden Sticks gleich. Nur die Hardware der Sticks ist auf die jeweilige Frequenz (433 oder 868 MHz) optimiert.
Die aktuelle Frequenz wird im EEPROM abgespeichert. In der CUxD Doku (am Ende) habe ich beschrieben, wie Du sie auslesen und anpassen kannst.
Da Du einen gebrauchten Stick gekauft hast, kann die Frequenz ja unter Umständen geändert worden sein.
ftpgonzo hat geschrieben:
25.02.2019, 20:30
Ist es nicht Richtig wenn ich die Culconfig aufrufe im Terminal das da etwas kommen muss ?
Nein, ist nicht richtig!
Die Culfw kennt keinen Befehl, der so heißt. Die gültigen Befehle hat er Dir ja im Terminal ausgegeben.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.2.0, RFD-Monitor, Vellemann K8055, SSH KeyDir

ftpgonzo
Beiträge: 194
Registriert: 16.12.2014, 20:03

Re: Ich dreh bald ab 433Mhz :(

Beitrag von ftpgonzo » 26.02.2019, 20:34

Hallo Uwe, ein Kumpel war heute bei mir der hat alles nochmal neu geflasht mit gefühlt 10 verschieden Firmware versionen (unter linux und windoof) jetzt sieht es so aus als wenn der Stick endlich mal was macht :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen:

aber ... unter gefunde Geräte Statusseite steht nix .. wenn ich meinen Wassermelder auslöse kommt ein Code im Status Screen

iC73CA927

Muss ich diesen Umrechnen oder einfach als Gerät einfügen ... ich steh gerade echt auf den Schlauch ... Beim Raspberry hab ich das einfach via Sniffer gelöst :!: :?: :mrgreen:

Benutzeravatar
uwe111
Beiträge: 3836
Registriert: 26.02.2011, 22:22
Kontaktdaten:

Re: Ich dreh bald ab 433Mhz :(

Beitrag von uwe111 » 26.02.2019, 20:45

ftpgonzo hat geschrieben:
26.02.2019, 20:34
iC73CA927

Muss ich diesen Umrechnen oder einfach als Gerät einfügen ...
Ich gehe mal davon aus, dass dieser Code im CUxD-Terminal zu sehen war.

Wenn das so ist, dann kannst Du im CUxD das Gerät "(40) 16 Kanal Universalsteuerung" anlegen und entsprechend der CUxD-Doku mit den empfangenen Daten konfigurieren.

Wie hattest Du die Geräte denn zuvor am Raspberry angeschlossen?

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.2.0, RFD-Monitor, Vellemann K8055, SSH KeyDir

ftpgonzo
Beiträge: 194
Registriert: 16.12.2014, 20:03

Re: Ich dreh bald ab 433Mhz :(

Beitrag von ftpgonzo » 26.02.2019, 21:01

Hi Uwe, dann Teste ich das mal :)
So

Bild

lg

Antworten

Zurück zu „CUxD“