nanoCUL nicht erkannt -> no driver! Rock64+ pivccu3 +HM MOD PCB + CUxD + nanoCUL

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Antworten
walli18
Beiträge: 8
Registriert: 26.11.2018, 22:54

nanoCUL nicht erkannt -> no driver! Rock64+ pivccu3 +HM MOD PCB + CUxD + nanoCUL

Beitrag von walli18 » 29.06.2019, 13:47

Hallo,
Mein besthendes System, welches aus Orange PI2 + pivccu2 + CUxD + nanoCUL besteht und wunderbar funktioniert wollte ich auf den Rock64 wegen den 4 GB RAM umziehen.

Leider ist dieser Umzug sehr schwierig! Als erstes probierte ich das Rock64 Image unter: https://www.pivccu.de/images/?dir=piVCCU3. Leider geht in diesem Image kein USB Port (Anscheinend bekanntes Problem bei dieser Kernel Version...), jedoch das HM MOD PCB. --> nano CUL ist so nicht nutztbar.

Unter dem Ordner https://www.pivccu.de/images/?dir=piVCCU3/old konnte ich ein älteres Image für den Rock64 mit pivccu3 finden und habe das getestet. Dabei funktionieren die USB-Ports und der HM-MOD-PCB wird auch erkannt, Jackpot. Pivccu3 startet und ich habe das aktuelle 2.3.2 CUxD installiert, was wunderbar klappte. Der CUL ist wie im angehängten Bild sichtbar und anscheinend gemountet, jedoch steht dahinter no driver und kein TTY Device Connected. Die Eintragungen mit Baudrate... wurden natürlich wie beim Orange Pi getätigt in CUxD. Jetzt stellt sich mir die Frage, warum erkennt er den CUL nicht?
Rock64PIVCCU.JPG
Screenshot des Rock64, bei dem steht no driver!


Zusätzliche Hinweise: sudo dpkg-reconfigure pivccu3 hatte ich schon probiert, da zeigt er keinen CUL an, aber USB-Sticks und mountet die auch erfolgreich in CUxD. Ich habe auch schon probiert auf einem aktuellen Armbian Image piVCCU zu installieren, bin jedoch daran gescheitert, das HM-MOD-PCB mit der geänderten Baudrate und Pinmapping zum laufen zu bekommen, was leider nicht wirklich dokumentiert ist.
Hinzugefügte Parameter im Setup von CUxD:

Code: Alles auswählen

TTYPARAM=ttyUSB0:38400:8N1
TTYASSIGN=ttyUSB0:CUX
Ich bin echt verzweifelt und bitte um eure Hilfe!
Vielen Dank!
Dateianhänge
OPI_CUXd.JPG
Screenshot des Orange PI, bei dem alles funktioniert!

Benutzeravatar
uwe111
Beiträge: 3948
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 2 Mal
Kontaktdaten:

Re: nanoCUL nicht erkannt -> no driver! Rock64+ pivccu3 +HM MOD PCB + CUxD + nanoCUL

Beitrag von uwe111 » 30.06.2019, 23:18

walli18 hat geschrieben:
29.06.2019, 13:47
jedoch steht dahinter no driver und kein TTY Device Connected.
Das bedeutet, dass der Kernel Driver für den USB-Serial Chip auf Deinem nanoCUL fehlt bzw. nicht geladen ist.
Wenn das Kernel-Modul vorhanden ist, kannst Du es auch manuell beim CUxD-Start mittels STARTUPCMD=modprobe ... laden.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.3.3, RFD-Monitor, Vellemann K8055, SSH KeyDir

walli18
Beiträge: 8
Registriert: 26.11.2018, 22:54

Re: nanoCUL nicht erkannt -> no driver! Rock64+ pivccu3 +HM MOD PCB + CUxD + nanoCUL

Beitrag von walli18 » 01.07.2019, 20:51

Hallo Uwe,
STARTUPCMD=modprobe ftdi_sio
Habe ich nach googeln gefunden und getestet, jedoch geht es damit auch nicht.
Diesen nanoCUL mit FTDI Chip habe ich:
https://www.ebay.de/itm/372282512150

Vielen Dank!
uwe111 hat geschrieben:
30.06.2019, 23:18
walli18 hat geschrieben:
29.06.2019, 13:47
jedoch steht dahinter no driver und kein TTY Device Connected.
Das bedeutet, dass der Kernel Driver für den USB-Serial Chip auf Deinem nanoCUL fehlt bzw. nicht geladen ist.
Wenn das Kernel-Modul vorhanden ist, kannst Du es auch manuell beim CUxD-Start mittels STARTUPCMD=modprobe ... laden.

Viele Grüße

Uwe

Benutzeravatar
uwe111
Beiträge: 3948
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 2 Mal
Kontaktdaten:

Re: nanoCUL nicht erkannt -> no driver! Rock64+ pivccu3 +HM MOD PCB + CUxD + nanoCUL

Beitrag von uwe111 » 02.07.2019, 20:33

Vielleicht hilft ein Blick ins Kernel-Log?
Sonst fällt mir dazu leider nichts mehr ein.
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.3.3, RFD-Monitor, Vellemann K8055, SSH KeyDir

walli18
Beiträge: 8
Registriert: 26.11.2018, 22:54

Re: nanoCUL nicht erkannt -> no driver! Rock64+ pivccu3 +HM MOD PCB + CUxD + nanoCUL

Beitrag von walli18 » 02.07.2019, 21:41

Hallo Uwe,
Vielen Dank!
uwe111 hat geschrieben:
02.07.2019, 20:33
Vielleicht hilft ein Blick ins Kernel-Log?
Sonst fällt mir dazu leider nichts mehr ein.
Ich habe weiter nachgeforscht und viel gelesen und mit dem laufenden OrangePI verglichen.
aktueller Erkenntnisstand:
Im Orangepi passt alles, siehe Bild1.

Im vergleich beim Rock64 (Bild2) wird unter LSUSB das Gerät erkannt, jedoch kein ttyUSB0 Device angelegt, ich vermute, dass deswegen auch die konfiguration im CUxD nichts bringt.... Unter Bild 3 sieht man, dass auch kein ttyUSB angelegt ist. Weitere Bilder von dmesg zur Info, falls das was hilft.

In Verwendung ist folgender nanoCUL mit FTDI Chip:
https://www.ebay.de/itm/372282512150

Ich hoffe das hilf dir weiter!
Dateianhänge
OPI TTY.JPG
Anhang zur Info dmesg
dmesg.JPG
Anhang zur Info dmesg
dmesg.JPG (15.47 KiB) 489 mal betrachtet
DSrivers.JPG
Bild3: Kein ttyUSB0
Rock64 lsusb.JPG
Bild2: Erkannter CUL im Rock64 und nicht vorhandenes ttyUSB0
FTDI OPI.JPG
Bild1: Erkannter CUL im Orangepi und korrekt angelegtes ttyUSB0

deimos
Beiträge: 2974
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 5 Mal
Danksagung erhalten: 37 Mal
Kontaktdaten:

Re: nanoCUL nicht erkannt -> no driver! Rock64+ pivccu3 +HM MOD PCB + CUxD + nanoCUL

Beitrag von deimos » 02.07.2019, 23:06

Hi,

habe das Thema jetzt erst gesehen.

Bei älteren Armbian Kernel für den Rock64 war der Support für USB tty Geräte nicht einkompiliert, wenn mich nicht alles täuscht ist dieser auch bei dem alten Image im Einsatz.

Insgesamt muss man leider sagen, dass der Rock64 bei Armbian etwas stiefmütterlich behandelt wird. Ich könnte mir vorstellen, dass das an der nicht wirklich sauber umgesetzten Hardware liegt.

Viele Grüße
Alex

walli18
Beiträge: 8
Registriert: 26.11.2018, 22:54

Re: nanoCUL nicht erkannt -> no driver! Rock64+ pivccu3 +HM MOD PCB + CUxD + nanoCUL

Beitrag von walli18 » 04.07.2019, 08:56

Hi Alex,
Ich habe mal das aktuelle Armbian Stretch 4.4 legacy kernel installiert. In diesem sind sämtliche Treiber auch der benötigte FTDI vorhanden (Bild1).
Dieser wird auch erfolgreich geladen und kann genutzt werden (Bild2).
Leider wird das Format nicht unterstützt, wenn ich das *.ko File in das von dir bereitgestellte Image reinlade, was aber fast logisch war :)
Ich habe mir mal von einem Freund hilfe geholt, der sich deutlich besser mit Kernels und Linux auskennt...
Seine Meinung war, wenn du die Build Umgebung für das 2018/11 er Rock64 Image noch hast könntest du die USBSerial und FTDI_sio mit rein kompillieren und mir zukommen lassen, dann kann ich die mit reinladen... Oder du könntest ein neues Image erstellen, was sehr nett wäre :) Oder alternativ die kernel konfig geben, dass wir uns selber eins bauen und dann hoffentlich auch der HM-MOD-PCB geht :/

Vielen Dank dir!
Lars
deimos hat geschrieben:
02.07.2019, 23:06
Hi,

habe das Thema jetzt erst gesehen.

Bei älteren Armbian Kernel für den Rock64 war der Support für USB tty Geräte nicht einkompiliert, wenn mich nicht alles täuscht ist dieser auch bei dem alten Image im Einsatz.

Insgesamt muss man leider sagen, dass der Rock64 bei Armbian etwas stiefmütterlich behandelt wird. Ich könnte mir vorstellen, dass das an der nicht wirklich sauber umgesetzten Hardware liegt.

Viele Grüße
Alex
Dateianhänge
photo_2019-07-04_08-47-50.jpg
Bild2
photo_2019-07-04_08-47-50.jpg (17.66 KiB) 427 mal betrachtet
photo_2019-07-04_08-46-25.jpg
Bild1

deimos
Beiträge: 2974
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 5 Mal
Danksagung erhalten: 37 Mal
Kontaktdaten:

Re: nanoCUL nicht erkannt -> no driver! Rock64+ pivccu3 +HM MOD PCB + CUxD + nanoCUL

Beitrag von deimos » 04.07.2019, 09:28

Hi,

Kernel 4.4 wird nicht funktionieren, die Binaries der CCU sind so kompiliert, dass mind. Kernel 4.14 Vorraussetzung ist und daran kann ich nichts ändern.

Wie sieht das ganze denn aus, wenn du mit dem aktuellen piVCCU Image für den Rock64 ein Update des Kernels über den normalen Armbian Weg mit apt machst?

Viele Grüße
Alex

walli18
Beiträge: 8
Registriert: 26.11.2018, 22:54

Re: nanoCUL nicht erkannt -> no driver! Rock64+ pivccu3 +HM MOD PCB + CUxD + nanoCUL

Beitrag von walli18 » 04.07.2019, 11:22

Vielen Dank Alex für den Hinweis, jetzt habe ich es endlich!

APT-update und APT-upgrade hat dazu geführt, dass USB wieder geht und auch der FTDI Treiber da ist.
Danach nochmal pivccu reconfig, cul einbinden und es läuft!

Vielen Dank!!!

Mfg
Lars

Antworten

Zurück zu „CUxD“