Illegal instruction

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Benutzeravatar
uwe111
Beiträge: 3968
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 2 Mal
Kontaktdaten:

Re: Illegal instruction

Beitrag von uwe111 » 17.09.2019, 17:18

Könnt ihr es mal bitte mit dieser Version testen und mir dann eine Rückmeldung geben?

*Link gelöscht*

Viele Grüße

Uwe
Zuletzt geändert von uwe111 am 18.09.2019, 12:09, insgesamt 1-mal geändert.
Grund: Link gelöscht
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.3.3, RFD-Monitor, Vellemann K8055, SSH KeyDir

Ricomat
Beiträge: 18
Registriert: 03.12.2018, 16:40

Re: Illegal instruction

Beitrag von Ricomat » 18.09.2019, 07:30

Negativ, 2.3.4 lässt sich nicht auf dem PI 1 installieren. Werde aber bald die Hardware updaten.

Benutzeravatar
uwe111
Beiträge: 3968
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 2 Mal
Kontaktdaten:

Re: Illegal instruction

Beitrag von uwe111 » 18.09.2019, 12:08

Ok, dann bitte nochmal mit dieser Version testen:

http://cuxd.de/download/cuxd_2.3.4.1_ccu3.tar.gz

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.3.3, RFD-Monitor, Vellemann K8055, SSH KeyDir

Ricomat
Beiträge: 18
Registriert: 03.12.2018, 16:40

Re: Illegal instruction

Beitrag von Ricomat » 18.09.2019, 12:34

Nein, meldet zwar, dass die Zusatzsoftware installiert wurde. Läuft aber dann doch nicht.
Cuxd_2.3.4.1.JPG
Cuxd_2.3.4.1.JPG (18.2 KiB) 157 mal betrachtet

Benutzeravatar
uwe111
Beiträge: 3968
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 2 Mal
Kontaktdaten:

Re: Illegal instruction

Beitrag von uwe111 » 18.09.2019, 13:37

Kommt beim Start auch wieder die "Illegal instruction" Meldung?
Ich habe die letzte Version mit -march=armv6 compiliert.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.3.3, RFD-Monitor, Vellemann K8055, SSH KeyDir

Benutzeravatar
jmaus
Beiträge: 5019
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 6 Mal
Danksagung erhalten: 79 Mal
Kontaktdaten:

Re: Illegal instruction

Beitrag von jmaus » 18.09.2019, 13:55

uwe111 hat geschrieben:
29.07.2019, 23:08
Also der einzige Unterschied ist, dass ich die neue CCU3-Version mit einem aktuelleren gcc (Debian 6.3.0-18+deb9u1) 6.3.0 20170516 compiliert habe.
Könnte es daran liegen? Kennt sich jemand damit aus?

Version 2.2:
cuxd: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, for GNU/Linux 2.6.26, BuildID[sha1]=d361cfb3ae4974ceff23aa4d02872c4bb37e9d46, stripped

Version 2.3:
cuxd: ELF 32-bit LSB shared object, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, for GNU/Linux 3.2.0, BuildID[sha1]=a92bc58b99eeb1e63cb80bed488bdfea4f766afb, stripped
Daran liegt es ganz sicher. Mit solchen Compiler Updates solltest du höchst vorsichtig sein weil ARM ja nicht gleich ARM ist und du ja auch schön allgemeine Binares haben willst die nicht nur unter Raspbian/Debian mit einer speziellen gilbc oder co funktionieren sollte.

Ich verwende hier für ReGaHss z.B. weiterhin den von der RaspberryPi Foundation zur Verfügung gestellten Cross Compiler:

https://github.com/raspberrypi/tools/tr ... -gnueabihf

D.h. der meldet sich wie folgt:

Code: Alles auswählen

gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611)
Insofern würde ich dir empfehlen den selben compiler zu nehmen. Der lässt sich auch einfachst installieren in dem du das "raspberrypi/tool" GitHub repository wie folgt auscheckst:

Code: Alles auswählen

git clone https://github.com/raspberrypi/tools raspberrypi-tools
Und dann einfach in deinen Makefiles den compiler wie folgt aufrufen:

Code: Alles auswählen

raspberrypi-tools/arm-bcm2708/arm-linux-gnueabihf/bin/arm-linux-gnueabihf-gcc
Dann sollten da auch binaries rauskommen die garantiert auf jedem RaspberryPi lauffähig sind.
RaspberryMatic 3.47.18.20190918 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

Ricomat
Beiträge: 18
Registriert: 03.12.2018, 16:40

Re: Illegal instruction

Beitrag von Ricomat » 18.09.2019, 13:59

Nein, ich gehe über Systemsteuerung > Zusatzsoftware installiern... dann kommt die Meldung: Die Installation des Addons war erfolgreich....
Dann habe ich RasbberryMatic neu gestartet, wieder zu Zusatzsoftware bei Cux-Daemon auf Neustart geklickt und es öffnet sich ein Fenster: CUxD Eine Komponente der HM Zentrale reagiert nicht mehr...
Das kann ich belibig wiederholen, ändert aber nichts.
Wenn ich auf CUxd-Daemon > Einstenn klicke oder gleich in der Systemsteuerung auf den Cuxd Button öffnet sich ein neues WebUi Fenster.
Danach Cuxd 2.2 drüber installiert und alles läuft direkt wieder.

cmjay
Beiträge: 588
Registriert: 19.09.2012, 10:53
Wohnort: Jottweedee
Hat sich bedankt: 7 Mal
Danksagung erhalten: 10 Mal

Re: Illegal instruction

Beitrag von cmjay » 18.09.2019, 14:15

Nur der Vollständigkeit halber wollte ich hier ergänzen, dass ich genau das beschriebene Fehlerbild für Cuxd 2.3 auch auf einem Raspi Zero (mit der finalen Version 2.xx der RaspberryMatic vor 3.xx) habe, weshalb ich auch wieder auf Cuxd 2.2 downgraden musste.
Übrigens lassen sich bei mir auf dem Raspi Zero auch die 3.xx Versionen der RM nicht stabil zum Laufen bringen. Aber das ist ein anderes Thema.
Es kann leider nicht ganz ausgeschlossen werden, dass ich mich irre.

ACHTUNG! Per Portweiterleitung aus dem Internet erreichbare CCU-WebUI ist unsicher! AUCH MIT PASSWORTSCHUTZ! Daher: Portweiterleitung deaktivieren!

Benutzeravatar
uwe111
Beiträge: 3968
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 2 Mal
Kontaktdaten:

Re: Illegal instruction

Beitrag von uwe111 » 18.09.2019, 17:51

Die aktuelle Version 2.3.4 sollte jetzt funktionieren: viewtopic.php?f=37&t=15298
jmaus hat geschrieben:
18.09.2019, 13:55
D.h. der meldet sich wie folgt:

Code: Alles auswählen

gcc version 4.9.3 (crosstool-NG crosstool-ng-1.22.0-88-g8460611)
Da ich ein 32bit System habe, meldet sich mein gcc jetzt nur so:

Code: Alles auswählen

gcc version 4.8.3 20140106 (prerelease) (crosstool-NG linaro-1.13.1-4.8-2014.01 - Linaro GCC 2013.11)
Hoffentlich funktioniert es trotzdem.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.3.3, RFD-Monitor, Vellemann K8055, SSH KeyDir

Ricomat
Beiträge: 18
Registriert: 03.12.2018, 16:40

Re: Illegal instruction

Beitrag von Ricomat » 18.09.2019, 18:52

Ja, super jetzt gehts !

USB 1-1 - (9514) [HUB] - Wed Sep 18 18:47:28 2019
USB 1-1.1 - (ec00) [FF] - no driver - Wed Sep 18 18:47:28 2019
USB 1-1.5 - SD Card Reader [STORAGE] - Wed Sep 18 18:47:28 2019
Kein TTY-Device connected!

Erfolgreich mit HomeMatic-CCU 127.0.0.1:8183 verbunden!

als RPC-Server(INIT) von HomeMatic-CCU (1239) angefordert!

Diese Web-Seite wurde aufgerufen von: 192.168.178.40

CUxD-Uptime(2.3.4): 0 Tag(e) 00:00:05, 101704 Bytes belegt, Compiled Sep 18 2019 17:32:06
CCU-Uptime(3.47.15.20190831): 0 Tag(e) 06:24:07, load-average: 0.74 0.41 0.31, 10s-cpu-load: 50.0%
Speicher: Total 474276k Used 207276k Free 267000k (Cached 77652k) Available 349680k
CPU(1): ARMv6-compatible processor rev 7 (v6l) [697.34 bogomips]
Linux version 4.19.68 ([email protected]) (gcc version 7.4.0 (Buildroot 2019.05.1-02041-g295908a5-dirty)) #1 PREEMPT Fri Aug 30 14:59:24 CEST 2019
aktive CCU-Prozesse: ReGaHss(1) rfd(1) hs485d(0) java(1)

Antworten

Zurück zu „CUxD“