Nach Update Verzeichnis /media/sd-mmcblk0/cuxd/devlog"weg"?

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Antworten
joesch
Beiträge: 675
Registriert: 03.02.2007, 14:57

Nach Update Verzeichnis /media/sd-mmcblk0/cuxd/devlog"weg"?

Beitrag von joesch » 05.11.2019, 09:39

Hallo zusammen,

ich hatte vor dem letzten Update ein Verzeichnis '/media/sd-mmcblk0/cuxd/devlog' angelegt, um Logdaten zu speichern. Als ich einige Tage nach dem Update CUxD-Highcharts aufrief, stellte ich fest, dass nur noh die Daten des aktuellen Tages verfügbar waren. Mir ist aufgefallen, dass vorgenanntes Verzeichnis nicht mehr vorhanden war. "Verschwindet" dies mit dem Update? Habe ich ggf. etwas übersehen?

VG,
joesh

g60vx
Beiträge: 150
Registriert: 16.04.2015, 21:48
Hat sich bedankt: 9 Mal

Re: Nach Update Verzeichnis /media/sd-mmcblk0/cuxd/devlog"weg"?

Beitrag von g60vx » 06.11.2019, 13:16

Hi Joesch,

dieses Phänomen kenne ich auch, nach jedem Neustart. Lösung war glaube ich das dauerhafte Mounten, festschreiben, in der CuxD-Ini.

joesch
Beiträge: 675
Registriert: 03.02.2007, 14:57

Re: Nach Update Verzeichnis /media/sd-mmcblk0/cuxd/devlog"weg"?

Beitrag von joesch » 02.01.2020, 11:29

Vielen Dank für den Hinweis. Da ich mich mit dem Mount-Kommando nicht so auskenne:
Muss ich bei einem bereits vorhandenen Verzeichnis noch Parameter mit übergeben oder genügt es, die Zeile im Setup wie folgt zu ergänzen:

Code: Alles auswählen

MOUNTCMD=mount /media/sd-mmcblk0/cuxd/devlog
VG,
joesch

Benutzeravatar
uwe111
Beiträge: 4051
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 23 Mal
Kontaktdaten:

Re: Nach Update Verzeichnis /media/sd-mmcblk0/cuxd/devlog"weg"?

Beitrag von uwe111 » 25.01.2020, 14:26

Hallo Joesch,
joesch hat geschrieben:
02.01.2020, 11:29
Da ich mich mit dem Mount-Kommando nicht so auskenne:
Hier ist das Kommando beschrieben: https://www.shellbefehle.de/befehle/mount/

Warum machst Du es dann nicht so, wie ich es in der CUxD Doku in Kapitel 11 FAQ beschrieben habe?

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.3.3, RFD-Monitor, Vellemann K8055, SSH KeyDir

joesch
Beiträge: 675
Registriert: 03.02.2007, 14:57

Re: Nach Update Verzeichnis /media/sd-mmcblk0/cuxd/devlog"weg"?

Beitrag von joesch » 01.02.2020, 12:07

Hallo Uwe,

vielen Dank für deine Rückmeldung! Bis zu den FAQ's war ich in der Tat nicht. Bin im Kapitel 7.1. "hängen" geblieben.

Ich habe jetzt folgendes konfiguriert:

Code: Alles auswählen

MOUNTCMD=mount -o bind /media/sd-mmcblk0 /mnt
Starte ich nur den CuxD neu, wird das Verzeichnis gemountet. Im Syslog steht dazu:

Code: Alles auswählen

Feb  1 12:07:02 homematic-raspi daemon.info cuxd[2153]: AUTOMOUNT system(mount -o bind /media/sd-mmcblk0 /mnt)
Starte ich den Rasperrimatic neu, dann erhalte ich folgenden Fehler (CuxD-Syslog):

Code: Alles auswählen

Feb  1 11:58:58 homematic-raspi daemon.err cuxd[699]: AUTOMOUNT system(mount -o bind /media/sd-mmcblk0 /mnt) exit(255)
Kannst du einschätzen, ob das eher ein Raspi oder ein CuxD Problem oder ein Anwenderfehler ;-) ist?

Vielen Dank und VG, joesch

Benutzeravatar
uwe111
Beiträge: 4051
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 23 Mal
Kontaktdaten:

Re: Nach Update Verzeichnis /media/sd-mmcblk0/cuxd/devlog"weg"?

Beitrag von uwe111 » 01.02.2020, 19:04

joesch hat geschrieben:
01.02.2020, 12:07
Kannst du einschätzen, ob das eher ein Raspi oder ein CuxD Problem oder ein Anwenderfehler ;-) ist?
Ja, CUxD kannst Du ausschließen, da der Befehl ja ausgeführt wird. Mehr Funktion ist an dieser Stelle nicht.
Vielleicht ist es ein Timing Problem beim Hochfahren?
Kannst Du das Laufwerk nicht über die WebUI mounten?

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.3.3, RFD-Monitor, Vellemann K8055, SSH KeyDir

joesch
Beiträge: 675
Registriert: 03.02.2007, 14:57

Re: Nach Update Verzeichnis /media/sd-mmcblk0/cuxd/devlog"weg"?

Beitrag von joesch » 02.02.2020, 11:48

Hallo Uwe,
uwe111 hat geschrieben:
01.02.2020, 19:04
Kannst Du das Laufwerk nicht über die WebUI mounten?
Manuelles Mount/Unmount übder die WebUI des CuxD funktioniert, so lange das System läuft. Nach dem Neustart des Raspi läuft auch der manuelle Mount auf den gleichen Fehler. Das vor dem restart existente Verzeichnis scheint samt Daten schlicht weg zu sein. Lege ich es neu an, klappt auch das manuelle Mounten wieder.

VG, joesch

Benutzeravatar
uwe111
Beiträge: 4051
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 23 Mal
Kontaktdaten:

Re: Nach Update Verzeichnis /media/sd-mmcblk0/cuxd/devlog"weg"?

Beitrag von uwe111 » 02.02.2020, 21:14

joesch hat geschrieben:
02.02.2020, 11:48
Lege ich es neu an, klappt auch das manuelle Mounten wieder.
Meinst Du /media/sd-mmcblk0? Das solltest Du nicht manuell anlegen.
Du musst zuerst den Namen des Gerätes rausbekommen, das Du mounten möchtest.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.3.3, RFD-Monitor, Vellemann K8055, SSH KeyDir

joesch
Beiträge: 675
Registriert: 03.02.2007, 14:57

Re: Nach Update Verzeichnis /media/sd-mmcblk0/cuxd/devlog"weg"?

Beitrag von joesch » 08.02.2020, 14:09

Hallo Uwe!
uwe111 hat geschrieben:
02.02.2020, 21:14
Meinst Du /media/sd-mmcblk0? Das solltest Du nicht manuell anlegen.
Ja.
Mit dem Gerätenamen komme ich allerdings nicht so richtig klar. Vielleicht ist das auch mein Fehler?

Auf einer CCU3 lege ich ich mit

Code: Alles auswählen

mkdir -p /media/sd-mmcblk0/cuxd/devlog 
das Verzeichnis /cuxd/devlog auf dem Gerät sd-mmcblk0 (der externen SD-Karte) an?
Auf dem Raspi gibt es dieses Gerät nicht, da "media" ja bereits die sd-Karte ist?
Ich muss demzufolge auf dem Raspi kein MountCmd ausführen, da die SD-Karte ja bereits die "Systemplatte" und gemountet ist?
Daher habe ich nunmehr das Verzeichnis /cuxd/devlog/ auf /media/usb1 angelegt und das "Verschiebekommando" wie folgt angepasst:

Code: Alles auswählen

DEVLOGMOVE=/media/usb1/cuxd/devlog
Ergebnis: Das Verzeichnis überlebt den Reboot, die Daten sind danach verfügbar. Ich kann die Charts darstellen.

Vielen Dank für deine Mühen ;-)

joesch

Antworten

Zurück zu „CUxD“