CUxD-Einstellungen für Eltako FGW14-USB

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

drive_electric
Beiträge: 52
Registriert: 06.06.2021, 12:23
System: sonstige

Re: CUxD-Einstellungen für Eltako FGW14-USB

Beitrag von drive_electric » 13.06.2021, 09:34

Hallo.
Habe jetzt das noch eingetragen

Code: Alles auswählen

TTYPARAM=ttyUSB0:57600
TTYASSIGN=ttyUSB0:ESP2
und jetzt startet cuxd nicht mehr.......

wo finde ich die cuxd.ini im filebrowser zum editieren?

[edit]
mit abgestecktem FGW14-USB startet cuxd wieder, jetzt habe ich die parameter gelöscht, und jetzt steht autom. wieder ESP3 im Infofenster.

[edit]
also cuxd startet nur wenn nichts weiter eingetragen ist, oder FGW14 nicht angesteckt ist. wo stelle ich jetzt ESP2 ein?

Benutzeravatar
uwe111
Beiträge: 4385
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 81 Mal
Kontaktdaten:

Re: CUxD-Einstellungen für Eltako FGW14-USB

Beitrag von uwe111 » 13.06.2021, 10:39

drive_electric hat geschrieben:
13.06.2021, 09:34
Habe jetzt das noch eingetragen
Ich kann leider erst in der nächsten Woche prüfen, welche Einstellungen dafür notwendig sind.
Bei Dir wird das FGW14-USB jedenfalls aktuell nicht erkannt. Mit dem KEY hat das nichts zu tun.
Ich verstehe nur nicht, woher das ESP3 im Status kam.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.6, SSH KeyDir

drive_electric
Beiträge: 52
Registriert: 06.06.2021, 12:23
System: sonstige

Re: CUxD-Einstellungen für Eltako FGW14-USB

Beitrag von drive_electric » 13.06.2021, 10:42

Danke.
muss selber heute in die schicht, vielleicht mittwoch wieder vor raspberry. aber verbindung steht ja. nur wsrum schreibt das log, not send, nokey? welcher key ist damit gemeint?
ob das mit FAM14 leichter ginge?
lg

mpcc
Beiträge: 682
Registriert: 09.03.2007, 16:38
Wohnort: Eichwalde bei Berlin
Hat sich bedankt: 2 Mal
Danksagung erhalten: 18 Mal
Kontaktdaten:

Re: CUxD-Einstellungen für Eltako FGW14-USB

Beitrag von mpcc » 13.06.2021, 13:34

Danke erst mal an @Mittelhessen ... er findet immer zur rechten Zeit die
richtigen Worte.

Wir haben gerade mal im Lizenzsierungstool des CUXD eine Rücküberprüfung gemacht
und wie schon Uwe sagte istr es eher kein KEY Fehler. Die MAC ist richtig und der Key ist
auch richtig. Da brauchst du also auch nicht weiter suchen.

Bei der Einstellung der ttyParams im CUXD Setup muss man immer darauf achten,
dass wenn man weitere Sticks dran hat , die Einstellungen für alle Sticks durchführen
muss !

Hier jetzt ein Bespiel für eine USB Stick + FGW14 Setup-Konfiguration:

;MP USB
TTYPARAM=ttyUSB0:57600
TTYASSIGN=ttyUSB0:ESP3
;MP FGW14-USB
TTYPARAM=ttyUSB1:9600
TTYASSIGN=ttyUSB1:ESP2

Diese Konfiguration führt dann zu folgendem Ergebnis auf der Startseite:

USB 1-1 - (9514) [HUB] - Sun Jun 13 13:18:59 2021
USB 1-1.1 - (ec00) [FF] - no driver - Sun Jun 13 13:18:59 2021
USB 1-1.4 - {ESP3} USB Serial [FF] - /dev/ttyUSB0 [R] {:3s} - TCM SW 1.2.8.0, API 1.3.4.0, CID xxxxxxxx - KEY - Sun Jun 13 13:18:59 2021
USB 1-1.5 - {ESP2} FT232R USB UART [FF] - /dev/ttyUSB1 [R] {:2s} - FGW14, ID 3 - KEY - Sun Jun 13 13:25:57 2021

Das sollte also auch bei Dir funktionieren.
Gruss Marco Pniok
http://www.piotek-smarthome.de, eQ-3 Fachpartner, Joonior Systemintegrator, PEHA EnOcean, Eltako-Partner, Viessmann Vitocontrol200 Partner, HomeMatic, HomeMatic IP, PioTek-Tracker , IP-Symcon, Symbox, IPS-Studio, Wibutler ....

drive_electric
Beiträge: 52
Registriert: 06.06.2021, 12:23
System: sonstige

Re: CUxD-Einstellungen für Eltako FGW14-USB

Beitrag von drive_electric » 13.06.2021, 17:29

Danke.
soll ich es so eintragen oder anpassen? am zsb hängt nur der FGW

lg

mpcc
Beiträge: 682
Registriert: 09.03.2007, 16:38
Wohnort: Eichwalde bei Berlin
Hat sich bedankt: 2 Mal
Danksagung erhalten: 18 Mal
Kontaktdaten:

Re: CUxD-Einstellungen für Eltako FGW14-USB

Beitrag von mpcc » 13.06.2021, 17:46

na ich hatte geschrieben :

"Hier jetzt ein Beispiel für eine"

Also wirst du wohl anpasssen müssen, sonst geht es ja wieder nicht, wie bei deinem
ersten Versuch.

Was genau bitte schön ist ein zsb ???
Gruss Marco Pniok
http://www.piotek-smarthome.de, eQ-3 Fachpartner, Joonior Systemintegrator, PEHA EnOcean, Eltako-Partner, Viessmann Vitocontrol200 Partner, HomeMatic, HomeMatic IP, PioTek-Tracker , IP-Symcon, Symbox, IPS-Studio, Wibutler ....

Benutzeravatar
uwe111
Beiträge: 4385
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 81 Mal
Kontaktdaten:

Re: CUxD-Einstellungen für Eltako FGW14-USB

Beitrag von uwe111 » 13.06.2021, 18:30

drive_electric hat geschrieben:
13.06.2021, 17:29
soll ich es so eintragen oder anpassen?
:roll: Laut Deinen bisherigen Beiträgen steckt Dein FGW14-USB bei Dir an ttyUSB0.
Also müssen im CUxD Setup nur die folgenden Parameter stehen, damit Dein FGW14-USB erkannt wird:

Code: Alles auswählen

TTYPARAM=ttyUSB0:9600
TTYASSIGN=ttyUSB0:ESP2
Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.6, SSH KeyDir

drive_electric
Beiträge: 52
Registriert: 06.06.2021, 12:23
System: sonstige

Re: CUxD-Einstellungen für Eltako FGW14-USB

Beitrag von drive_electric » 13.06.2021, 19:06

das hatte ich schon, aber dann startet cuxd nicht mehr wenn am usb der fgw steckt.....
ich werds nochmal testen, frühestens mittwoch.
danke

Benutzeravatar
uwe111
Beiträge: 4385
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 81 Mal
Kontaktdaten:

Re: CUxD-Einstellungen für Eltako FGW14-USB

Beitrag von uwe111 » 13.06.2021, 20:10

drive_electric hat geschrieben:
13.06.2021, 19:06
das hatte ich schon, aber dann startet cuxd nicht mehr wenn am usb der fgw steckt.....
Du hattest in Deinem Beitrag aber nicht 9600, sondern 57600 als Baudrate gesetzt. Und mit 57600 funktioniert die Verbindung zum FGW14-USB nicht!
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.6, SSH KeyDir

drive_electric
Beiträge: 52
Registriert: 06.06.2021, 12:23
System: sonstige

Re: CUxD-Einstellungen für Eltako FGW14-USB

Beitrag von drive_electric » 13.06.2021, 22:36

ok, richtig.

Antworten

Zurück zu „CUxD“