CUxD 2.4.4 Fehler bei abweichenden Geräte-Icon

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Antworten
Benutzeravatar
Roland M.
Beiträge: 5961
Registriert: 08.12.2012, 15:53
System: CCU
Wohnort: Graz, Österreich
Hat sich bedankt: 67 Mal
Danksagung erhalten: 356 Mal

CUxD 2.4.4 Fehler bei abweichenden Geräte-Icon

Beitrag von Roland M. » 28.09.2020, 22:29

Hallo Uwe!

Ich spiele gerade mit einer neuen Installation von einer virtuellen RaspberryMatic (aktuelle Version) auf einem Proxmox-Server mit dem Hintergedanke, irgendwann auch mein produktives System dorthin zu übersiedeln.

Beim Installieren von CUxD 2.4.4 ist mir folgendes aufgefallen:

Legt man ein neues CUxD-Gerät an (bei mir Timer und Exec) und wählt dabei unter Geräte-Icon ein abweichendes Icon (in meinem Fall Wetterstation), ergibt das folgendes Bild:
CUxD.PNG
CUxD.PNG (14.04 KiB) 196 mal betrachtet
Die Funktion scheint allerdings nicht beeinträchtigt zu sein.

Dass das erste Gerät eine "Sonderbehandlung" in Form eines CCU-Neustarts benötigt, ist hier mit berücksichtigt. Der Fehler ist auch bei nachfolgenden Geräten reproduzierbar.

Gehässige Frage: bug or feature?


Roland
Zur leichteren Hilfestellung bitte unbedingt beachten:
  • Bezeichnung (HM-...) der betroffenen Geräte angeben (nicht Artikelnummer)
  • Kurzbeschreibung des Soll-Zustandes (Was soll erreicht werden?)
  • Kurzbeschreibung des Ist-Zustandes (Was funktioniert nicht?)
  • Fehlermeldungen genau abschreiben, besser noch...
  • Screenshots von Programmen, Geräteeinstellungen und Fehlermeldungen (direkt als jpg/png) einstellen!

-----------------------------------------------------------------------
1. CCU2 mit ~100 Geräten
2. CCU2 per VPN mit ~30 Geräten
3. CCU2 per VPN mit ~40 Geräten
CCU1, Test-CCU2, Raspi mit Funkmodul, Raspberrymatic als VM unter Proxmox, Access Point,...

Baxxy
Beiträge: 1788
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 158 Mal
Danksagung erhalten: 257 Mal

Re: CUxD 2.4.4 Fehler bei abweichenden Geräte-Icon

Beitrag von Baxxy » 28.09.2020, 22:43

Roland M. hat geschrieben:
28.09.2020, 22:29
Gehässige Frage: bug or feature?
Ich sag's mal so... Du Glückspilz hast wahrscheinlich genau das eine Symbol genommen was nicht will. :wink:
CUxD-Symbole.JPG
Ich habe aber nicht alle Symbole durchgetestet.
Grüße
Baxxy

Benutzeravatar
Roland M.
Beiträge: 5961
Registriert: 08.12.2012, 15:53
System: CCU
Wohnort: Graz, Österreich
Hat sich bedankt: 67 Mal
Danksagung erhalten: 356 Mal

Re: CUxD 2.4.4 Fehler bei abweichenden Geräte-Icon

Beitrag von Roland M. » 28.09.2020, 23:22

Hallo!

Danke für die Rückmeldung!
Baxxy hat geschrieben:
28.09.2020, 22:43
Ich sag's mal so... Du Glückspilz hast wahrscheinlich genau das eine Symbol genommen was nicht will. :wink:
Offensichtlich!
Ich habe aber nicht alle Symbole durchgetestet.
Ich auch nicht, aber ein paar andere funktionieren einwandfrei...


Roland
Zur leichteren Hilfestellung bitte unbedingt beachten:
  • Bezeichnung (HM-...) der betroffenen Geräte angeben (nicht Artikelnummer)
  • Kurzbeschreibung des Soll-Zustandes (Was soll erreicht werden?)
  • Kurzbeschreibung des Ist-Zustandes (Was funktioniert nicht?)
  • Fehlermeldungen genau abschreiben, besser noch...
  • Screenshots von Programmen, Geräteeinstellungen und Fehlermeldungen (direkt als jpg/png) einstellen!

-----------------------------------------------------------------------
1. CCU2 mit ~100 Geräten
2. CCU2 per VPN mit ~30 Geräten
3. CCU2 per VPN mit ~40 Geräten
CCU1, Test-CCU2, Raspi mit Funkmodul, Raspberrymatic als VM unter Proxmox, Access Point,...

Benutzeravatar
uwe111
Beiträge: 4158
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 45 Mal
Kontaktdaten:

Re: CUxD 2.4.4 Fehler bei abweichenden Geräte-Icon

Beitrag von uwe111 » 29.09.2020, 12:18

Hallo Roland,
Roland M. hat geschrieben:
28.09.2020, 22:29
Gehässige Frage: bug or feature?
In der Datei /usr/local/addons/cuxd/devicelist.inc sind alle vom CUxD in der Geräteauswahl angebotenen Geräte(-Icons) konfiguriert.
Diese Geräte müssen natürlich mit der passenden BaseID in der CCU Firmware vorhanden sein, damit das Icon in der WebUI richtig dargestellt wird.
Als BaseID für die HomeMatic-Wetterstation ist aktuell WS550 konfiguriert. Das könntest Du anpassen.
Bevor Du Deinem Gerät die geänderte BaseID (Icon) zuordnen kannst, musst Du den CUxD aber neustarten.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.4.4, RFD-Monitor, Vellemann K8055, SSH KeyDir

Antworten

Zurück zu „CUxD“