Cuxd verliert Kommunikation

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

mpcc
Beiträge: 639
Registriert: 09.03.2007, 16:38
Wohnort: Eichwalde bei Berlin
Hat sich bedankt: 2 Mal
Danksagung erhalten: 17 Mal
Kontaktdaten:

Re: Cuxd verliert Kommunikation

Beitrag von mpcc » 14.02.2021, 10:08

Absolut möglich ! Beide System senden im 868 MHz Band
WMBus Signal kommt selten , HM Update macht viele Daten.
Wenn HM als wesentlich stärker ausgelegtes Signal das wenige
an Daten des WMBus überlappt ist die Info weg ...
Gruss Marco Pniok
http://www.piotek-smarthome.de, eQ-3 Fachpartner, Joonior Systemintegrator, PEHA EnOcean, Eltako-Partner, Viessmann Vitocontrol200 Partner, HomeMatic, HomeMatic IP, PioTek-Tracker , IP-Symcon, Symbox, IPS-Studio, Wibutler ....

aha
Beiträge: 70
Registriert: 24.07.2020, 18:01
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: Cuxd verliert Kommunikation

Beitrag von aha » 14.02.2021, 13:59

Ich habe den Idle Timer nach dem Ausfall mit 10min hinzugefügt und gewartet, ob es sich wieder berappelt. Das war nicht der Fall.

Cuxd Restart und es funktioniert wieder. Liegt es vielleicht doch an Cuxd?

Benutzeravatar
uwe111
Beiträge: 4265
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 73 Mal
Kontaktdaten:

Re: Cuxd verliert Kommunikation

Beitrag von uwe111 » 15.02.2021, 23:28

aha hat geschrieben:
14.02.2021, 13:59
Ich habe den Idle Timer nach dem Ausfall mit 10min hinzugefügt und gewartet, ob es sich wieder berappelt. Das war nicht der Fall.
Hat der CUxD die Verbindung zum Stick neu hergestellt?
Welche Idle Zeit wurde zuvor beim USB-Stick angezeigt?
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.5, SSH KeyDir

aha
Beiträge: 70
Registriert: 24.07.2020, 18:01
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: Cuxd verliert Kommunikation

Beitrag von aha » 24.02.2021, 18:51

uwe111 hat geschrieben:
15.02.2021, 23:28
aha hat geschrieben:
14.02.2021, 13:59
Ich habe den Idle Timer nach dem Ausfall mit 10min hinzugefügt und gewartet, ob es sich wieder berappelt. Das war nicht der Fall.
Hat der CUxD die Verbindung zum Stick neu hergestellt?
Welche Idle Zeit wurde zuvor beim USB-Stick angezeigt?
Ich hab gerade alles abgesucht... ich finde nix. Wo genau muss ich schauen? Hab aktuell nicht das Gefühl, dass der Idletimer irgendwas macht... meinst du die uhrzeit hinter dem stick? Dann kann ich sicher sagen der timer funktioniert nicht, denn die seit ist aktuell 10 tage her, obwohl ich die 130 sekunden eingestellt habe, die du vorgeschlagen hast.

Benutzeravatar
uwe111
Beiträge: 4265
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 73 Mal
Kontaktdaten:

Re: Cuxd verliert Kommunikation

Beitrag von uwe111 » 25.02.2021, 18:56

aha hat geschrieben:
24.02.2021, 18:51
Wo genau muss ich schauen?
Da ich Deine Konfiguration nicht kenne, kann ich Dir leider wenig helfen.
Bei dem Stick werden die Idle-Zeit als auch die Zeit vom letzten Connect angezeigt.
aha hat geschrieben:
24.02.2021, 18:51
Dann kann ich sicher sagen der timer funktioniert nicht, denn die seit ist aktuell 10 tage her, obwohl ich die 130 sekunden eingestellt habe, die du vorgeschlagen hast.
Ja und? Funktioniert der Stick denn seit 10 Tagen nicht mehr? Sonst ist doch alles ok.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.5, SSH KeyDir

aha
Beiträge: 70
Registriert: 24.07.2020, 18:01
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: Cuxd verliert Kommunikation

Beitrag von aha » 25.02.2021, 20:52

uwe111 hat geschrieben:
25.02.2021, 18:56
aha hat geschrieben:
24.02.2021, 18:51
Wo genau muss ich schauen?
Da ich Deine Konfiguration nicht kenne, kann ich Dir leider wenig helfen.
Bei dem Stick werden die Idle-Zeit als auch die Zeit vom letzten Connect angezeigt.
aha hat geschrieben:
24.02.2021, 18:51
Dann kann ich sicher sagen der timer funktioniert nicht, denn die seit ist aktuell 10 tage her, obwohl ich die 130 sekunden eingestellt habe, die du vorgeschlagen hast.
Ja und? Funktioniert der Stick denn seit 10 Tagen nicht mehr? Sonst ist doch alles ok.

Viele Grüße

Uwe
Das ist doch deine software? Was hat das mit meiner konfiguration zu tun? Warum weisst du nicht wo das in deiner software angezeigt wird? Sollte man als entwickler der software doch bestens wissen? Also - wo kann ich sehen, dass der init alle 130 sekunden stattfindet?

Die funkverbindung lief auch früher länger wie 10 tage. Ich hab ja gesag - ca. 6 wochen. Dieses mal war es wirklich extrem kurz. Scheint also zufall zu sein.

Jetzt sieht es so aus, dass der maxidle timeout 130 keine wirkung hat und nur ein cuxd restart hilft. Es sieht also schwer danach aus, dass es eher ein bug in cuxd ist als im stick. Den sollte man dann sicher fixen können ohne den stick hersteller.

Ein screenshor dürfte helfen.

Benutzeravatar
uwe111
Beiträge: 4265
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 73 Mal
Kontaktdaten:

Re: Cuxd verliert Kommunikation

Beitrag von uwe111 » 26.02.2021, 09:29

Also ich denke, so kommen wir hier leider zu keinem Ergebnis.
aha hat geschrieben:
25.02.2021, 20:52
wo kann ich sehen, dass der init alle 130 sekunden stattfindet?
Prüfe einfach selbst die Idle/Maxidle Zeiten in der TTY-Zeile auf der CUxD Statusseite.
aha hat geschrieben:
25.02.2021, 20:52
Es sieht also schwer danach aus, dass es eher ein bug in cuxd ist als im stick.
Wenn der Stick plötzlich keine Daten mehr sendet, klingt das für mich erstmal unlogisch.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.5, SSH KeyDir

aha
Beiträge: 70
Registriert: 24.07.2020, 18:01
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: Cuxd verliert Kommunikation

Beitrag von aha » 26.02.2021, 21:37

uwe111 hat geschrieben:
26.02.2021, 09:29
Also ich denke, so kommen wir hier leider zu keinem Ergebnis.
aha hat geschrieben:
25.02.2021, 20:52
wo kann ich sehen, dass der init alle 130 sekunden stattfindet?
Prüfe einfach selbst die Idle/Maxidle Zeiten in der TTY-Zeile auf der CUxD Statusseite.
aha hat geschrieben:
25.02.2021, 20:52
Es sieht also schwer danach aus, dass es eher ein bug in cuxd ist als im stick.
Wenn der Stick plötzlich keine Daten mehr sendet, klingt das für mich erstmal unlogisch.

Viele Grüße

Uwe
Also ich sehe, zwar, dass dort 130s dort ausgegeben werden bei tty konfiguration, aber ich sehe nicht, wann der stick seinen letzten init bekommen hat. In keinem der logs wird angezeigt, dass der stick runter gefahren und neu initialisiert wird. Man könnte sich fragen, ob der init wirklich stattfindet, oder die konfiguration einfach ignoriert wird. Das könnte vieleicht erklären, ob der stick still und heimlich verreckt oder doch noch antwortet und dann vieleicht cuxd keine kommunikation mehr annimmt.

Wie versetze ich cuxd in den richtigen debug mode, damit man alles sieht was da passiert oder eben auch nicht passiert. Ich denke man sollte mal auf unterster ebene sehen, was auf dem usb passiert. Unter windows gibts wireshark für usb... hab es aber noch nie gebraucht/genutzt und unter linux noch weniger... ?

Antworten

Zurück zu „CUxD“