Docker RaspberryMatic: iM871A USB-Stick Problem

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

ms2013
Beiträge: 9
Registriert: 29.03.2021, 19:58
System: Alternative CCU (auf Basis OCCU)

Docker RaspberryMatic: iM871A USB-Stick Problem

Beitrag von ms2013 » 29.03.2021, 20:28

hallo und guten tag,

habe mir schon einige tips und lösungen aus diesem tollen forum holen können!

aber jetzt stehe ich vor einem problem, wo ich einfach nicht weiterkomme.

mein setup: Docker RaspberryMatic auf HypriotOS bzw. aktuellstem RaspberryOS, ioBroker und CUxD 2.5.1 und iM871A USB-Stick mit WmBus lizenz.
boote ich von der SD-card klappt alles: der iM871A USB-Stick (angeschlossen an USB 2.0) bindet sich korrekt ein und ich kann meine Letrika wechselrichter monitoren.
dann habe ich umgestellt auf booten von SSD drive (SD card image auf SSD drive übertragen) welches an USB 3.0 hängt und der stick wird erkannt, bindet sich ohne erkennbare fehler ein, aber findet meine Letrikas nicht mehr (keine adressen aufgelistet).
hänge ich das SSD drive an den USB2.0 port, funktioniert es wieder. unabhängig davon wo der iM871A angesteckt ist.
kennt jemand das problem oder könnte mich mit tips in eine richtung lotsen?

grüße
ms

Baxxy
Beiträge: 3129
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 227 Mal
Danksagung erhalten: 524 Mal

Re: Docker RaspberryMatic: iM871A USB-Stick Problem

Beitrag von Baxxy » 29.03.2021, 20:38

ms2013 hat geschrieben:
29.03.2021, 20:28
kennt jemand das problem oder könnte mich mit tips in eine richtung lotsen?
Ähm ja.
Der Pi4B (ist doch einer oder?) hat die unschöne Eigenschaft bei per USB3 angeschlossenen Geräten extrem starke Funkstörungen zu erzeugen. Vermutlich überlagern die die "Empfangsstärke" deines iM871A USB-Stick's.

Da es mit USB2 funktioniert würde ich das so lassen. Die paar Sekunden kürze Bootzeit durch USB3 sind es, meiner Meinung nach, nicht Wert sich die Probleme vom USB3 reinzuholen. Alternativ kannst du den Stick per USB-Verlängerung vom Pi absetzen. 1m würde ich da mindestens empfehlen.

ms2013
Beiträge: 9
Registriert: 29.03.2021, 19:58
System: Alternative CCU (auf Basis OCCU)

Re: Docker RaspberryMatic: iM871A USB-Stick Problem

Beitrag von ms2013 » 29.03.2021, 22:33

genau, ist ein PI 4B und der stick ist 2m vom Pi weg.
mit SSD an USB2 ist der durchsatz um die 30MB/s, mit USB3.0 halt 250 MB/s und davon würde ichschon gerne gebrauch machen.
ich hatte schon mit diversen einstellungen und versionen getestet (eeprom firmware, RaspberryOS, quirks für die SSD platte) es lief immer auf das gleiche hinaus:
anschluß an USB3.0 und boot und es funktioniert nicht. über USB2.0 und es klappt.

mpcc
Beiträge: 650
Registriert: 09.03.2007, 16:38
Wohnort: Eichwalde bei Berlin
Hat sich bedankt: 2 Mal
Danksagung erhalten: 18 Mal
Kontaktdaten:

Re: Docker RaspberryMatic: iM871A USB-Stick Problem

Beitrag von mpcc » 30.03.2021, 08:04

Du hast aber nicht bei den angelegten SMI Geräten ein bestimmtes ttyDevice
z.B. USB0 eingestellt welches nach Anschluss der SSD nicht mehr stimmt ?
Gruss Marco Pniok
http://www.piotek-smarthome.de, eQ-3 Fachpartner, Joonior Systemintegrator, PEHA EnOcean, Eltako-Partner, Viessmann Vitocontrol200 Partner, HomeMatic, HomeMatic IP, PioTek-Tracker , IP-Symcon, Symbox, IPS-Studio, Wibutler ....

ms2013
Beiträge: 9
Registriert: 29.03.2021, 19:58
System: Alternative CCU (auf Basis OCCU)

Re: Docker RaspberryMatic: iM871A USB-Stick Problem

Beitrag von ms2013 » 30.03.2021, 18:32

der stick wird immer über /dev/ttyUSB0 eingebunden, egal an welchem physischen USB-port er hängt.
er wird ja auch erkannt vom CUxD
USB 1-1.3 - {WMOD} WiMOD iM871A-usb [FF] - /dev/ttyUSB0 [R] {:0s} - Other:S2:RSSI, SN xxxxxx, FW 1.3, HCI 1 - KEY2 - Tue Mar 30 18:28:02 2021

mpcc
Beiträge: 650
Registriert: 09.03.2007, 16:38
Wohnort: Eichwalde bei Berlin
Hat sich bedankt: 2 Mal
Danksagung erhalten: 18 Mal
Kontaktdaten:

Re: Docker RaspberryMatic: iM871A USB-Stick Problem

Beitrag von mpcc » 30.03.2021, 19:13

ok ... dann muss es doch irgendeine Störung sein ...
Gruss Marco Pniok
http://www.piotek-smarthome.de, eQ-3 Fachpartner, Joonior Systemintegrator, PEHA EnOcean, Eltako-Partner, Viessmann Vitocontrol200 Partner, HomeMatic, HomeMatic IP, PioTek-Tracker , IP-Symcon, Symbox, IPS-Studio, Wibutler ....

ms2013
Beiträge: 9
Registriert: 29.03.2021, 19:58
System: Alternative CCU (auf Basis OCCU)

Re: Docker RaspberryMatic: iM871A USB-Stick Problem

Beitrag von ms2013 » 31.03.2021, 19:34

gibt es möglichkeiten zu tracen? also was der zuständige treiber/modul so macht?
irgendwo muss ja ein grund für dieses verhalten vorliegen.

mpcc
Beiträge: 650
Registriert: 09.03.2007, 16:38
Wohnort: Eichwalde bei Berlin
Hat sich bedankt: 2 Mal
Danksagung erhalten: 18 Mal
Kontaktdaten:

Re: Docker RaspberryMatic: iM871A USB-Stick Problem

Beitrag von mpcc » 01.04.2021, 10:52

sicher ... aber das musst du auf deinem "HypriotOS" machen ... was ich z.b.
nicht kenne ...
Gruss Marco Pniok
http://www.piotek-smarthome.de, eQ-3 Fachpartner, Joonior Systemintegrator, PEHA EnOcean, Eltako-Partner, Viessmann Vitocontrol200 Partner, HomeMatic, HomeMatic IP, PioTek-Tracker , IP-Symcon, Symbox, IPS-Studio, Wibutler ....

ms2013
Beiträge: 9
Registriert: 29.03.2021, 19:58
System: Alternative CCU (auf Basis OCCU)

Re: Docker RaspberryMatic: iM871A USB-Stick Problem

Beitrag von ms2013 » 01.04.2021, 17:15

unter RaspiOS (Buster) ist das gleiche verhalten. hatte ich installiert, um HypriotOS auszuschließen.

mpcc
Beiträge: 650
Registriert: 09.03.2007, 16:38
Wohnort: Eichwalde bei Berlin
Hat sich bedankt: 2 Mal
Danksagung erhalten: 18 Mal
Kontaktdaten:

Re: Docker RaspberryMatic: iM871A USB-Stick Problem

Beitrag von mpcc » 01.04.2021, 17:57

und wie ist es unter Raspberrymatic direkt installiert ?
Gruss Marco Pniok
http://www.piotek-smarthome.de, eQ-3 Fachpartner, Joonior Systemintegrator, PEHA EnOcean, Eltako-Partner, Viessmann Vitocontrol200 Partner, HomeMatic, HomeMatic IP, PioTek-Tracker , IP-Symcon, Symbox, IPS-Studio, Wibutler ....

Antworten

Zurück zu „CUxD“