CUxD Geräte

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Benutzeravatar
Bernd-Joras
Beiträge: 518
Registriert: 26.03.2016, 09:33
Hat sich bedankt: 13 Mal
Danksagung erhalten: 19 Mal

Re: CUxD Geräte

Beitrag von Bernd-Joras » 15.05.2021, 13:12

Hallo Uwe,
ja ... ich habe auch das HUE Adon in Version 3.2.0 installiert.
Ich habe mir auch das /issues/44 auf Github durchgelesen ...

Ich glaube Deinen Hinweis nicht zu verstehen ...
Bei mir stellt sich das Problem doch etwas diferenter dar ...

Wenn ich die Version 2.6 rüber installiere gibt es keine Verbindung zur CCU ...
Wenn ich den CUxD vorher deinstalliere und dann die Version 2.6 installiere habe ich keine CUX Geräte mehr in der RBM.

Ich habe ja diverse 28 System CUX-Geräte installiert ...
Soll das bedeuten ich muss die alle neu installieren und auch alle Programme dann wieder anfassen und aktualisieren ?

Stehe irgendwie auf dem Schlauch ... glaube ich ... Bernd
RPi3B+ RaspberryMatic 3.57.5.20210525 / RPI-RF-MOD | Externe USB-Platinen Antenne | 2x LAN_RF_GW | 1x LAN_RS485_GW | ca. 100 Geräte davon 10x IP | ca. 180 Programme |>400 Kanäle | Addons: CUX-Daemon, XML-API, hm_pdetect, E-Mail, CCU-Historian, Philips Hue, HConnectVPN, Sonos Player

Benutzeravatar
Bernd-Joras
Beiträge: 518
Registriert: 26.03.2016, 09:33
Hat sich bedankt: 13 Mal
Danksagung erhalten: 19 Mal

Re: CUxD Geräte

Beitrag von Bernd-Joras » 15.05.2021, 13:36

Nur mal als Info ... ich bin nun mit den threads ein wenig durcheinander geraten ... sorry ... meiner war/ist =>
viewtopic.php?f=37&t=67694&e=1&view=unread#unread
RPi3B+ RaspberryMatic 3.57.5.20210525 / RPI-RF-MOD | Externe USB-Platinen Antenne | 2x LAN_RF_GW | 1x LAN_RS485_GW | ca. 100 Geräte davon 10x IP | ca. 180 Programme |>400 Kanäle | Addons: CUX-Daemon, XML-API, hm_pdetect, E-Mail, CCU-Historian, Philips Hue, HConnectVPN, Sonos Player

Benutzeravatar
uwe111
Beiträge: 4334
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 78 Mal
Kontaktdaten:

Re: CUxD Geräte

Beitrag von uwe111 » 15.05.2021, 15:38

Hallo Bernd,
Bernd-Joras hat geschrieben:
15.05.2021, 13:12
Ich glaube Deinen Hinweis nicht zu verstehen ...
Bei mir stellt sich das Problem doch etwas diferenter dar ...
Genau deshalb hatte ich ein neues Thema erstellt. Ich habe Deine Beiträge jetzt nochmal entwirrt.
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.6, SSH KeyDir

Benutzeravatar
Bernd-Joras
Beiträge: 518
Registriert: 26.03.2016, 09:33
Hat sich bedankt: 13 Mal
Danksagung erhalten: 19 Mal

Re: CUxD Geräte

Beitrag von Bernd-Joras » 15.05.2021, 17:54

Dankeschön für's Entwirren... und Tschuldigung...
RPi3B+ RaspberryMatic 3.57.5.20210525 / RPI-RF-MOD | Externe USB-Platinen Antenne | 2x LAN_RF_GW | 1x LAN_RS485_GW | ca. 100 Geräte davon 10x IP | ca. 180 Programme |>400 Kanäle | Addons: CUX-Daemon, XML-API, hm_pdetect, E-Mail, CCU-Historian, Philips Hue, HConnectVPN, Sonos Player

Benutzeravatar
Bernd-Joras
Beiträge: 518
Registriert: 26.03.2016, 09:33
Hat sich bedankt: 13 Mal
Danksagung erhalten: 19 Mal

Re: CUxD Geräte

Beitrag von Bernd-Joras » 17.05.2021, 09:37

Ergänzend …

Habe das halbe WE damit verbracht irgendwie die CUX 2.6 Version so zu installieren, dass diese bei meinem System funktionierend läuft.
Leider ist mir das nicht gelungen …

Habe alles möglich probiert … z.B. Alle anderen Addon´s vorher deinstalliert … neue Hardware … System neu aufgesetzt und Backup eingespielt … cuxd.ps Datei kopiert und wieder eingespielt … roboot, reboot reboot … auch vermutlich völlig unsinnige Sachen probiert …

CUX 2.6 über die 2.5.1 rüber installiert:
Nicht mit HomeMatic-CCU 127.0.0.1:8183 verbunden!
Geräte werden im CUX NICHT angezeigt
Geräte in der RBM weiter vorhanden/sichtbar, diese funktionieren aber nicht!
Neue Geräte anlegen funktioniert nicht!

CUX 2.5.1 deinstalliert => CUX 2.6 installiert (mit u. ohne reboot dazwischen)
Erfolgreich mit HomeMatic-CCU 127.0.0.1:8183 verbunden!
Geräte werden im CUX angezeigt
Geräte in der RBM NICHT vorhanden!
Neue Geräte anlegen funktioniert problemlos jedoch funktionieren diese dann teilweise nicht in der RBM nicht!

Ich habe die gleichen, viele , andere , unterschiedlich Test auch mit der CUX Version 2.5.1 gemacht.
Hier hat sich das anlegen und die Funktion der Geräte so gezeigt wie erwartet .. diese funktionierten.

So, nun sagen die Profis bestimmt wieder … OK => egal … anderes Thema …
Ich bekomme die CUX Version 2.6 auf meinem System nicht so zum laufen, dass hinterher alles funktioniert.
Nicht einmal wenn ich den CUX deinstalliere neu installiere und dann alle CUX Geräte neu anlege …
Auch die neu angelegten CUX Geräte funktionieren nicht so wie erwartet … z.B. CUX HUE Switch anlegen mit JAN´s Addon … schaltet in der CUX Version 2.6 nicht!

Hat noch jemand eine Idee? Bin mittlerweile auch für vollkommen abgedrehte Vorschläge offen … :?

Danke, Bernd
RPi3B+ RaspberryMatic 3.57.5.20210525 / RPI-RF-MOD | Externe USB-Platinen Antenne | 2x LAN_RF_GW | 1x LAN_RS485_GW | ca. 100 Geräte davon 10x IP | ca. 180 Programme |>400 Kanäle | Addons: CUX-Daemon, XML-API, hm_pdetect, E-Mail, CCU-Historian, Philips Hue, HConnectVPN, Sonos Player

roe1974
Beiträge: 650
Registriert: 17.10.2017, 16:15
Wohnort: Wien
Hat sich bedankt: 31 Mal
Danksagung erhalten: 7 Mal

Re: CUxD Geräte

Beitrag von roe1974 » 17.05.2021, 10:35

Sind in der 2.6 Funktionen enthalten die Du unbedingt benötigst ? ... sonst würde ich auf 2.5.1 bleiben ;-)

Benutzeravatar
Bernd-Joras
Beiträge: 518
Registriert: 26.03.2016, 09:33
Hat sich bedankt: 13 Mal
Danksagung erhalten: 19 Mal

Re: CUxD Geräte

Beitrag von Bernd-Joras » 17.05.2021, 11:38

Ja das stimmt schon... Ich glaube die 2.6er Version nicht unbedingt zu brauchen... Ich wollte mich nur proaktiv damit beschäftigen um später gwapnet zu sein... Wollte mein System Aktuell halten damit ich nicht irgendwann einmal abgehängt bzw. ausgeschlossen bin. Irgendwann gibt es sicherlich Abhängigkeiten und dann kommt halt alles problematische auf einmal.
Meine Sorge jetzt ist, scheinbar ist nur mein System betroffen... Somit ist bei mir irgendwas faul... Das macht mir halt Sorgen...
Ich warte nun aber mal ab... manchmal erledigt sich ja auch etwas von allein... BG BERND
RPi3B+ RaspberryMatic 3.57.5.20210525 / RPI-RF-MOD | Externe USB-Platinen Antenne | 2x LAN_RF_GW | 1x LAN_RS485_GW | ca. 100 Geräte davon 10x IP | ca. 180 Programme |>400 Kanäle | Addons: CUX-Daemon, XML-API, hm_pdetect, E-Mail, CCU-Historian, Philips Hue, HConnectVPN, Sonos Player

Benutzeravatar
uwe111
Beiträge: 4334
Registriert: 26.02.2011, 22:22
Danksagung erhalten: 78 Mal
Kontaktdaten:

Re: CUxD Geräte

Beitrag von uwe111 » 17.05.2021, 17:37

Bernd-Joras hat geschrieben:
17.05.2021, 11:38
Ich wollte mich nur proaktiv damit beschäftigen um später gwapnet zu sein...
Das ist auch gut so!

Wenn das hue.tcl Problem gelöst ist, können wir uns ja mal intensiver damit beschäftigen.
Bislang bist Du leider noch der Einzige mit diesem Problem nach dem Update.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.6, SSH KeyDir

Benutzeravatar
Bernd-Joras
Beiträge: 518
Registriert: 26.03.2016, 09:33
Hat sich bedankt: 13 Mal
Danksagung erhalten: 19 Mal

Re: CUxD Geräte

Beitrag von Bernd-Joras » 25.05.2021, 20:01

Hallo ... vorsichtig weiter fragend ...

Ich vermute meine Probleme auch bei/mit der Version 2.6 kommen eventuell daher, dass ich scheinbar irgendwo noch Geräte im System habe, die es aber nicht mehr gibt. Ich habe früher einmal viele CUX Geräte angelegt und wieder gelöscht.
Direkt nach einem restart sind nachfolgende Zeilen im LOG zu sehen ...
Diese Geräte gibt es bei mir nicht mehr in der CCU und auch nicht unterm CUX.
Auch wenn ich versuche die Geräte neu anzulegen um diese dann wieder sauber zu löschen, verliert der CUX auch in der Version 2.5.1 sofort die Verbindung zur CCU => (Nicht mit HomeMatic-CCU 127.0.0.1:8183 verbunden!)

Code: Alles auswählen

May 25 17:34:02 RBM daemon.warn cuxd[824]: 192.168.5.110 called unknown instance 'getParamsetDescription' 'CUX2801005:1' ()
May 25 17:34:04 RBM daemon.warn cuxd[824]: 192.168.5.110 called unknown instance 'getParamsetDescription' 'CUX2801013:1' ()
May 25 17:34:05 RBM daemon.warn cuxd[824]: 192.168.5.110 called unknown instance 'getParamsetDescription' 'CUX2801013:2' ()
May 25 17:34:05 RBM daemon.warn cuxd[824]: 192.168.5.110 called unknown instance 'getParamsetDescription' 'CUX2801013:3' ()
May 25 17:34:05 RBM daemon.warn cuxd[824]: 192.168.5.110 called unknown instance 'getParamsetDescription' 'CUX2803002:1' ()
May 25 17:34:06 RBM daemon.warn cuxd[824]: 192.168.5.110 called unknown instance 'getParamsetDescription' 'CUX2803002:2' ()
May 25 17:34:07 RBM daemon.warn cuxd[824]: 192.168.5.110 called unknown instance 'getParamsetDescription' 'CUX2801011:3' ()
May 25 17:34:07 RBM daemon.warn cuxd[824]: 192.168.5.110 called unknown instance 'getParamsetDescription' 'CUX2801011:4' ()
Hat jemand eine Idee oder kann mir jemand sagen, ob es irgendwo eine Stelle oder Datei gibt, die ich bearbeiten und/oder berichtigen kann?

Danke vorab ... Bernd
RPi3B+ RaspberryMatic 3.57.5.20210525 / RPI-RF-MOD | Externe USB-Platinen Antenne | 2x LAN_RF_GW | 1x LAN_RS485_GW | ca. 100 Geräte davon 10x IP | ca. 180 Programme |>400 Kanäle | Addons: CUX-Daemon, XML-API, hm_pdetect, E-Mail, CCU-Historian, Philips Hue, HConnectVPN, Sonos Player

Benutzeravatar
Bernd-Joras
Beiträge: 518
Registriert: 26.03.2016, 09:33
Hat sich bedankt: 13 Mal
Danksagung erhalten: 19 Mal

Re: CUxD Geräte

Beitrag von Bernd-Joras » 20.06.2021, 09:11

Hallöchen …. Uwe ... alle Mitlesenden ...

Ich habe weit über 100h intensiver Tests und Fehlersuche hinter mich gebracht ohne mein“ Problem lösen zu können.
Ich schaffe es nicht die CUX Version 2.6 in Betrieb zu nehmen und dabei die schon vorhandenen CUX Geräte funktionstüchtig zu erhalten.

Diverse Versuche mit und ohne neu Installationen … reboots zwischendurch .. vorher einzelne Geräte deinstallieren … andere Addon deinstallieren … alte RBM Versionen … etc. … alles erfolglos.

Bekomme die CUX Version 2.6 bei mir nur zum Laufen, wenn ich alle vorhandenen CUX Geräte sauber deinstalliere (entferne) … RBM reboot …. CUX 2.5.1 deinstalliere … RBM reboot … CUX 2.6 installieren …
Danach müsste ich dann meine 8 CUX Geräte bzw. weit über 200 Kanäle neu zu installieren.

Das ist für mich nicht wirklich ein Option … das bekommen ich innerhalb einer angemessenen Zeit nicht geregelt … jedenfalls nicht ohne das meine Frau entweder mich oder den Raspberry PI aus dem Fenster wirft.

Somit bleibt mir jetzt im Moment also nur, alles so zu lassen wie es ist … Schauen wir mal wie lange so ein System seine Dienste verrichtet wenn man keine Update´s mehr fährt …

Falls jemand noch irgendeine Idee oder ein Tipp hat … gerne DANKE … Bernd
RPi3B+ RaspberryMatic 3.57.5.20210525 / RPI-RF-MOD | Externe USB-Platinen Antenne | 2x LAN_RF_GW | 1x LAN_RS485_GW | ca. 100 Geräte davon 10x IP | ca. 180 Programme |>400 Kanäle | Addons: CUX-Daemon, XML-API, hm_pdetect, E-Mail, CCU-Historian, Philips Hue, HConnectVPN, Sonos Player

Antworten

Zurück zu „CUxD“