Pushover geht nicht

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

cmjay
Beiträge: 1592
Registriert: 19.09.2012, 10:53
System: CCU
Wohnort: Jottweedee
Hat sich bedankt: 165 Mal
Danksagung erhalten: 179 Mal

Re: Pushover geht nicht

Beitrag von cmjay » 11.07.2021, 15:40

Es tut sich auch mit diesem Script nichts.
Vielleicht ist deine Installation nicht up-to-date. Versuch es zum Test nochmal mit dem alten curl-Pfad.

Code: Alles auswählen

string nachricht = "Dies ist ein Test";
dom.GetObject("CUxD.CUX2801002:1.CMD_EXEC").State("LD_LIBRARY_PATH=/usr/local/addons/cuxd /usr/local/addons/cuxd/curl -s -d token=XXX -d user=XXX -d message='"#nachricht#"' -d priority=0 http://api.pushover.net/1/messages.json");
Es kann leider nicht ganz ausgeschlossen werden, dass ich mich irre.
HmIP muss leider draussen bleiben.
ACHTUNG! Per Portweiterleitung aus dem Internet erreichbare CCU-WebUI ist unsicher! AUCH MIT PASSWORTSCHUTZ! Daher: Portweiterleitung deaktivieren!

Wichtelmann007
Beiträge: 62
Registriert: 26.02.2013, 21:11
Hat sich bedankt: 4 Mal

Re: Pushover geht nicht

Beitrag von Wichtelmann007 » 11.07.2021, 16:07

cmjay hat geschrieben:
11.07.2021, 15:40
Es tut sich auch mit diesem Script nichts.
Vielleicht ist deine Installation nicht up-to-date. Versuch es zum Test nochmal mit dem alten curl-Pfad.

Code: Alles auswählen

string nachricht = "Dies ist ein Test";
dom.GetObject("CUxD.CUX2801002:1.CMD_EXEC").State("LD_LIBRARY_PATH=/usr/local/addons/cuxd /usr/local/addons/cuxd/curl -s -d token=XXX -d user=XXX -d message='"#nachricht#"' -d priority=0 http://api.pushover.net/1/messages.json");
Nichts!
Was kann denn grundsätzliches noch falsch sein? Muss ich ggf in Pushover sonst noch irgendwas konfigurieren vorher? Prowl (jedoch per Script ohne CuxD) funktioniert…

cmjay
Beiträge: 1592
Registriert: 19.09.2012, 10:53
System: CCU
Wohnort: Jottweedee
Hat sich bedankt: 165 Mal
Danksagung erhalten: 179 Mal

Re: Pushover geht nicht

Beitrag von cmjay » 11.07.2021, 16:34

Du führst das Skript unter "Programme und Verknüpfungen > Skript testen" aus?
Kommt denn irgendeine Fehlermeldung?
Was sagt das Fehlerprotokoll? viewtopic.php?f=26&t=2418&p=150866#p150866
Es kann leider nicht ganz ausgeschlossen werden, dass ich mich irre.
HmIP muss leider draussen bleiben.
ACHTUNG! Per Portweiterleitung aus dem Internet erreichbare CCU-WebUI ist unsicher! AUCH MIT PASSWORTSCHUTZ! Daher: Portweiterleitung deaktivieren!

Wichtelmann007
Beiträge: 62
Registriert: 26.02.2013, 21:11
Hat sich bedankt: 4 Mal

Re: Pushover geht nicht

Beitrag von Wichtelmann007 » 11.07.2021, 17:53

Unter Status und Bedienung starte ich das Programm manuell.

Hilft das Protokoll?
Dateianhänge
2889094D-0C31-413F-B267-D015D13742D7.jpeg

Benutzeravatar
Baxxy
Beiträge: 4158
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 286 Mal
Danksagung erhalten: 728 Mal

Re: Pushover geht nicht

Beitrag von Baxxy » 11.07.2021, 17:59

Wichtelmann007 hat geschrieben:
11.07.2021, 17:53
Hilft das Protokoll?
Nein.
Geh mal auf die CUxD Statusseite --> "Info" (rechts oben) --> "Full Syslog" (links unten)

Grüße
Baxxy

Edit: Idealerweise vorher bei "Setup" (mitte oben) den Wert für

Code: Alles auswählen

TERMINALLINES=
erhöhen. (Standard ist 25 glaube ich)

Edit2: Hinweis von Uwe. Der Wert muss nicht erhöht werden, es reicht wenn man oben rechts auf "Open" drückt.

Wichtelmann007
Beiträge: 62
Registriert: 26.02.2013, 21:11
Hat sich bedankt: 4 Mal

Re: Pushover geht nicht

Beitrag von Wichtelmann007 » 11.07.2021, 19:43

1. Erfolgserlebnis, diese Programm geht nun. Glaube ich hatte ein Leerzeichen vor dem = und den Keys.

Code: Alles auswählen

 string nachricht = "Dies ist ein Test";
dom.GetObject("CUxD.CUX2801002:1.CMD_EXEC").State("LD_LIBRARY_PATH=/usr/lib /usr/bin/curl -s -d token=acXXXXXXXXXxtiw8nv -d user=u2YYYYYYYYYYdygdemr -d message='"#nachricht#"' -d priority=0 http://api.pushover.net/1/messages.json");


Aber das andere Script noch nicht:

Code: Alles auswählen

 !Pushover - Skript by technikkram.net
!------------------------------

!__Pushover Keys
string po_api_user="u2XXXXXXXXXXygdemr";
string po_api_token="acYYYYYYYYYtiw8nv";

!__Nachricht
string po_title="Beispieltitel";
string po_message="Beispieltext";
string po_sound="none";
string po_priority="2";

!___Nur benoetigt wenn Prioritaet auf Emergency (2) gesetzt ist
string po_retry="30";
string po_expires="3600";

!___Erlaeuterungen
! Sounds: pushover, bike, bugle, cashregister, classical, cosmic, falling, gamelan, incoming, intermission, magic, mechanical, pianobar, siren, spacealarm, tugboat, alien, climb, persistent, echo, updown, none
!Prioritaeten: 0=Normal; 1=High (AudioVibration auch waehrend quiet hour); 2=Emergency (Meldung Muss bestätigt werden, solange sound/Vibration); -1=Low ; -2=Lowest
! Bei Prio 2: po_retry gibt an (in sekunden), wie hauefig eine Nachricht vom Server geschickt wird (z.B. alle 30s)
! Bei Prio 2: po_expires gibt an (in Sekunden), wie lange nachrichten geschickt werden sollen. Bestätigt der User, stoppt die Benachrichtigung. Beispiel: Alle 30 sekunden wird eine Nachricht geschickt, das passiert eine Stunde lang (1 Stunde = 3600 sekunden).

!------ NICHT MODIFIZIEREN-------
string po_request;
if(po_priority=="2"){
po_request="/usr/local/addons/cuxd/curl -X POST -k -H \"Content-Type: application/x-www-form-urlencoded\" -d \"token=" # po_api_token # "&user=" # po_api_user # "&title=" # po_title # "&priority="# po_priority # "&sound=" # po_sound # "&retry="# po_retry # "&expire=" # po_expires # "&message=" # po_message # "\" https://api.pushover.net/1/messages.json";
}
else{
po_request="/usr/local/addons/cuxd/curl -X POST -k -H \"Content-Type: application/x-www-form-urlencoded\" -d \"token=" # po_api_token # "&user=" # po_api_user # "&title=" # po_title # "&priority="# po_priority # "&sound=" # po_sound # "&message=" # po_message # "\" https://api.pushover.net/1/messages.json";
}
dom.GetObject("CUxD.CUX2801002:1.CMD_EXEC").State(po_request);
Hier das CuxD Protokoll

Code: Alles auswählen

Jul 11 19:32:12 ccu2 daemon.info cuxd[26723]: system(/usr/local/addons/cuxd/curl -X POST -k -H "Content-Type: application/x-www-form-urlencoded" -d "token=acaXXXXXXXXXxtiw8nv&user=u2YYYYYYYYYYygdemr&title=Beispieltitel&priority=2&sound=none&retry=30&expire=3600&message=Beispieltext" https://api.pushover.net/1/messages.json) exit(127) 0s
Jul 11 19:32:33 ccu2 daemon.info cuxd[26741]: system(/usr/local/addons/cuxd/curl -X POST -k -H "Content-Type: application/x-www-form-urlencoded" -d "token=acaXxxxxxxtiw8nv&user=u2YYYYYYYYYYygdemr&title=Beispieltitel&priority=2&sound=none&retry=30&expire=3600&message=Beispieltext" https://api.pushover.net/1/messages.json) exit(127) 0s
Jul 11 19:33:09 ccu2 daemon.warn cuxd[405]: process_rpc_request(192.168.178.20) - illegal XMLRPC(ping) request
Jul 11 19:33:27 ccu2 local0.err ReGaHss: ERROR: ScriptRuntimeError: system.SetSessionVar("sessionCTV", "true"); [ExecError():iseESPexec.cpp:12723]
Jul 11 19:34:09 ccu2 local0.err ReGaHss: ERROR: ScriptRuntimeError: system.SetSessionVar("sessionCTV", "true"); [ExecError():iseESPexec.cpp:12723]
Jul 11 19:35:09 ccu2 daemon.warn cuxd[405]: process_rpc_request(192.168.178.20) - illegal XMLRPC(init) request
Jul 11 19:35:59 ccu2 local0.err ReGaHss: ERROR: ScriptRuntimeError: system.SetSessionVar("sessionCTV", "true"); [ExecError():iseESPexec.cpp:12723]
Jul 11 19:36:14 ccu2 daemon.info cuxd[26865]: system(/usr/local/addons/cuxd/curl -X POST -k -H "Content-Type: app

cmjay
Beiträge: 1592
Registriert: 19.09.2012, 10:53
System: CCU
Wohnort: Jottweedee
Hat sich bedankt: 165 Mal
Danksagung erhalten: 179 Mal

Re: Pushover geht nicht

Beitrag von cmjay » 11.07.2021, 19:56

Aber das andere Script noch nicht:
Dann schau dir doch nochmal genau die Pfadangabe von curl in der Variable "po_request" an und vergleiche mit derjenigen (hinterer Anteil) im funktionierenden Skript ...
Es kann leider nicht ganz ausgeschlossen werden, dass ich mich irre.
HmIP muss leider draussen bleiben.
ACHTUNG! Per Portweiterleitung aus dem Internet erreichbare CCU-WebUI ist unsicher! AUCH MIT PASSWORTSCHUTZ! Daher: Portweiterleitung deaktivieren!

Wichtelmann007
Beiträge: 62
Registriert: 26.02.2013, 21:11
Hat sich bedankt: 4 Mal

Re: Pushover geht nicht

Beitrag von Wichtelmann007 » 11.07.2021, 20:23

cmjay hat geschrieben:
11.07.2021, 19:56
Aber das andere Script noch nicht:
Dann schau dir doch nochmal genau die Pfadangabe von curl in der Variable "po_request" an und vergleiche mit derjenigen (hinterer Anteil) im funktionierenden Skript ...

Code: Alles auswählen

 !Pushover - Skript by technikkram.net
!------------------------------

!__Pushover Keys
string po_api_user="XXXXXXXX";
string po_api_token="YYYYYYYY";

!__Nachricht
string po_title="Beispieltitel";
string po_message="Beispieltext";
string po_sound="none";
string po_priority="2";

!___Nur benoetigt wenn Prioritaet auf Emergency (2) gesetzt ist
string po_retry="30";
string po_expires="3600";

!___Erlaeuterungen
! Sounds: pushover, bike, bugle, cashregister, classical, cosmic, falling, gamelan, incoming, intermission, magic, mechanical, pianobar, siren, spacealarm, tugboat, alien, climb, persistent, echo, updown, none
!Prioritaeten: 0=Normal; 1=High (AudioVibration auch waehrend quiet hour); 2=Emergency (Meldung Muss bestätigt werden, solange sound/Vibration); -1=Low ; -2=Lowest
! Bei Prio 2: po_retry gibt an (in sekunden), wie hauefig eine Nachricht vom Server geschickt wird (z.B. alle 30s)
! Bei Prio 2: po_expires gibt an (in Sekunden), wie lange nachrichten geschickt werden sollen. Bestätigt der User, stoppt die Benachrichtigung. Beispiel: Alle 30 sekunden wird eine Nachricht geschickt, das passiert eine Stunde lang (1 Stunde = 3600 sekunden).

!------ NICHT MODIFIZIEREN-------
string po_request;
if(po_priority=="2"){
po_request="/usr/lib /usr/bin/curl -X POST -k -H \"Content-Type: application/x-www-form-urlencoded\" -d \"token=" # po_api_token # "&user=" # po_api_user # "&title=" # po_title # "&priority="# po_priority # "&sound=" # po_sound # "&retry="# po_retry # "&expire=" # po_expires # "&message=" # po_message # "\" https://api.pushover.net/1/messages.json";
}
else{
po_request="/usr/lib /usr/bin/curl -X POST -k -H \"Content-Type: application/x-www-form-urlencoded\" -d \"token=" # po_api_token # "&user=" # po_api_user # "&title=" # po_title # "&priority="# po_priority # "&sound=" # po_sound # "&message=" # po_message # "\" https://api.pushover.net/1/messages.json";
}
dom.GetObject("CUxD.CUX2801002:1.CMD_EXEC").State(po_request);
Also das fett gedruckte /usr/lib /usr/bin/curl durch „ /usr/lib /usr/bin/curl“ ersetzen? Hatte ich bereits versucht…

cmjay
Beiträge: 1592
Registriert: 19.09.2012, 10:53
System: CCU
Wohnort: Jottweedee
Hat sich bedankt: 165 Mal
Danksagung erhalten: 179 Mal

Re: Pushover geht nicht

Beitrag von cmjay » 11.07.2021, 20:25

Also das fett gedruckte durch „ /usr/lib /usr/bin/curl“ ersetzen?
Also das fett gedruckte durch „ /usr/lib /usr/bin/curl“ ersetzen?
Es kann leider nicht ganz ausgeschlossen werden, dass ich mich irre.
HmIP muss leider draussen bleiben.
ACHTUNG! Per Portweiterleitung aus dem Internet erreichbare CCU-WebUI ist unsicher! AUCH MIT PASSWORTSCHUTZ! Daher: Portweiterleitung deaktivieren!

Wichtelmann007
Beiträge: 62
Registriert: 26.02.2013, 21:11
Hat sich bedankt: 4 Mal

Re: Pushover geht nicht

Beitrag von Wichtelmann007 » 11.07.2021, 20:37

Mensch das war aber eine Geburt! Aber nun klappt es…

Vielen Dank für die Hilfe!!!

Antworten

Zurück zu „CUxD“