433 MHz Steckdosen mit CUxD gehen aus aber nicht an

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Antworten
TobiH
Beiträge: 16
Registriert: 06.10.2021, 13:32
System: sonstige

433 MHz Steckdosen mit CUxD gehen aus aber nicht an

Beitrag von TobiH » 20.10.2021, 19:36

Hallo,

über CUxD habe ich eine 16 Kanal Universalsteuerung (Taster) angelegt. Zum Ausschalten setze ich dem Code der Steckdosen entsprechend ein: is00000FFF0FF0 (die letzten beiden Stellen F0 senden "aus", und FF sendet "an" ). Ausschalten klappt wunderbar, aber ein nicht mehr. Dass es geht weiß ich, weil es letzte Woche geklappt hat. Dann hat irgendein Depp, ich glaube das war ich, das CUxD-Gerät gelöscht und heute neu angelegt. Den Artikel finde ich leider auch nicht mehr, wo ein findiges Forenmitglied das mit dem Code is00000FFFF und FF/F0 rausgefunden und gepostet hat.

Vielen Dank für Tipps.
Screenshot 2021-10-20 193549.jpg

Matsch
Beiträge: 2560
Registriert: 30.05.2019, 11:37
System: CCU
Wohnort: Chemnitz
Hat sich bedankt: 44 Mal
Danksagung erhalten: 307 Mal

Re: 433 MHz Steckdosen mit CUxD gehen aus aber nicht an

Beitrag von Matsch » 20.10.2021, 19:50

Also bei meinen Steckdosen sind die letzten beiden Stellen 0F und F0, aber nicht FF.

TobiH
Beiträge: 16
Registriert: 06.10.2021, 13:32
System: sonstige

Re: 433 MHz Steckdosen mit CUxD gehen aus aber nicht an

Beitrag von TobiH » 21.10.2021, 07:19

Und damit kannst du im Terminal ein- und ausschalten? Klappt bei mir nicht (mehr).

Nur nochmal zur Sicherheit, aufgedröselt an meinem Beispiel:
00000 für den Hauscode (oder Gerätecode, weiß ich leider nicht mehr)
FFFFF für den Gerätecode (oder eben Hauscode)
Zum Ausschalten F0 anhängen, also is00000FFFFFF0
Zum Einschalten FF anhängen, also is00000FFFFFFF

AchMänno.....

Matsch
Beiträge: 2560
Registriert: 30.05.2019, 11:37
System: CCU
Wohnort: Chemnitz
Hat sich bedankt: 44 Mal
Danksagung erhalten: 307 Mal

Re: 433 MHz Steckdosen mit CUxD gehen aus aber nicht an

Beitrag von Matsch » 21.10.2021, 10:07

Ich habe bei mir den Sendecode am Original-Handsender am Oszi angesehen und der Originalsender sendet eben die letzten beiden Bits negiert zueinander, also entweder F0 oder 0F, nie eine andere Kombination.
Es hängt dann aber wieder von der Empfängerhardware ab, ob die nun nur das letzte oder auch das vorletzte Bit auswertet. Wird nur das letzte Bit ausgewertet, dann ist es egal, ob das vorletzte Bit nun F oder 0 hat.

Rein theoretisch hat ja jede Codestelle 3 Zustände (0, 1 und F), aber anscheinend wird 1 in keinem Produkt genutzt.

Und damit es noch verwirrender wird:

Das ganze bezieht sich nur auf die Decoder-ICs PT2272A-L2 (und baugleiche).

Es gibt auch Geräte, die den Decoder PT2272-L2 (ohne A) benutzen, bei dem liegen die beiden Schaltbits/Datenbits nicht am Ende der Bitfolge mit Bit 10 und 11, sondern mitten drin im Gerätecode (Bit 6 und 7)!
TobiH hat geschrieben:
21.10.2021, 07:19
Und damit kannst du im Terminal ein- und ausschalten?
Nein, mein (recht alter) Aufbau ist quasi ein Gateway, das als HM-Gerät Befehle empfängt und diese als 433MHz-Code sendet, CUxD ist darin nicht beteiligt. Dazu mußte ich mich mit den verschiedenen PT2272-ICs und deren Unterschiede und Bitfolgen herumschlagen ...
Dabei "mißbrauche" ich noch die beiden Datenbits als Helligkeitsstufen, also 00 ist Aus und FF die größte Helligkeit (die Empfangsgeräte sind natürlich dann auch Eigenbau, so was gibt's nicht kommerziell).

Vermutlich wird eher in deiner CUxD-Umsetzung das Problem liegen, dazu kann ich nichts beitragen.

Antworten

Zurück zu „CUxD“