CUL Stick 433 MHz sendet, empfängt jedoch nicht´s mehr

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Antworten
widder17
Beiträge: 93
Registriert: 25.11.2013, 22:30
Hat sich bedankt: 4 Mal
Danksagung erhalten: 3 Mal

CUL Stick 433 MHz sendet, empfängt jedoch nicht´s mehr

Beitrag von widder17 » 14.12.2021, 16:50

Hallo zusammen,

ich habe ein kleines Problem und brauche eure Hilfe.

Bin mit meiner Raspberrymatic eigentlich erfolgreich von einem Raspberry 3 auf eine Synology DS220+ (VM) umgezogen. Nur eine Kleinigkeit bekomme ich nicht ans laufen.
Der CUL Stick (433MHz von SHK) wurde in CUxD korrekt erkannt. Anfänglich hat dieser die Daten nach einem Tastendruck auf einer Intertechno Fernbedienung im Terminal angezeigt.
Intertechno Steckdosen ließen sich leider nur in einem Umkreis von 2 Metern schalten. Nach viel lesen im Forum und im Internet gab es irgendwo den Tipp, den Stick per XLoader neu zu flashen. Dies hat gut funktioniert und ich konnte die Steckdosen im ganzen Haus wieder schalten.

Nach dem flashen ist es jedoch so, das nun keine Daten mehr von der Intertechno Fernbedienung empfangen werden, wenn ich nicht gerade 50 cm davor stehe.

Habe zum testen des Sticks nochmals einen Raspberry mit Rasperrymatic und CUxD aufgesetzt. An diesem sendet und empfängt der Stick alle Daten problemlos.

Nach dem umstecken auf dei Synolgy kann ich wieder keine Daten empfangen

Hat evtl. jemand eine Idee, woran das liegen könnte?
SYSTEM:
Raspberrymatic auf einer VM (Syology DS220+ mit 10GB Ram)
HB-RF-ETH (POE) mit RPI-RF-MOD

MODULE:
- Eltako EnOcean USB Gateway FAM-USB mit EnOcean Lizenz
- CUL Stick 433MHz (SHK)

KOMPONENTEN:
- Homematic
- Homematic IP
- Homematic IP Wired
- Eltako Dimmer (FUD61NPN)
- Intertechno Steckdosen und Fernbedienung

Benutzeravatar
Baxxy
Beiträge: 4989
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 322 Mal
Danksagung erhalten: 919 Mal

Re: CUL Stick 433 MHz sendet, empfängt jedoch nicht´s mehr

Beitrag von Baxxy » 14.12.2021, 16:59

widder17 hat geschrieben:
14.12.2021, 16:50
Hat evtl. jemand eine Idee, woran das liegen könnte?
Klingt nach Funkstörsignalen durch die Synology.
USB-Verlängerung nutzen um weiter von der Syno wegzukommen könnte helfen.

Grüße, Baxxy

widder17
Beiträge: 93
Registriert: 25.11.2013, 22:30
Hat sich bedankt: 4 Mal
Danksagung erhalten: 3 Mal

Re: CUL Stick 433 MHz sendet, empfängt jedoch nicht´s mehr

Beitrag von widder17 » 14.12.2021, 17:15

Baxxy hat geschrieben:
14.12.2021, 16:59

USB-Verlängerung nutzen um weiter von der Syno wegzukommen könnte helfen.

Grüße, Baxxy
Sorry, vergessen zu erwähnen. Eine Verlängerung brachte keinen Erfolg.

Trotzdem schon einmal danke für die Info.
SYSTEM:
Raspberrymatic auf einer VM (Syology DS220+ mit 10GB Ram)
HB-RF-ETH (POE) mit RPI-RF-MOD

MODULE:
- Eltako EnOcean USB Gateway FAM-USB mit EnOcean Lizenz
- CUL Stick 433MHz (SHK)

KOMPONENTEN:
- Homematic
- Homematic IP
- Homematic IP Wired
- Eltako Dimmer (FUD61NPN)
- Intertechno Steckdosen und Fernbedienung

widder17
Beiträge: 93
Registriert: 25.11.2013, 22:30
Hat sich bedankt: 4 Mal
Danksagung erhalten: 3 Mal

Re: CUL Stick 433 MHz sendet, empfängt jedoch nicht´s mehr

Beitrag von widder17 » 17.12.2021, 00:04

Kurzes Update:

Habe mir einen zweiten Stick eines anderen Herstellers zugelegt.

1) Mit der Firmware aCUL_V3_12603_433MHz kann ich nun Befehle empfangen. Leider werden die Befehle zum Senden nur jedes 10 - 20x von den Steckdosen empfangen.

2) Mit der Firmware CUL_V3_167 kann ich Befehle senden, die auch alle sofort am Ziel ankommen. Hier funktioniert das Empfangen jedoch gar nicht.

3) Getestet wurde dies auf der Synology VM, sowie einer komplett frisch und nur für den Test aufgesetzten Raspberrymatic (auf einem Raspberry 3) mit der aktuellesten Version (RaspberryMatic 3.61.5.20211113) mit CuxD in der Version 2.6.

4) Verschiedene Baudraten (9600 & 38400) brachten leider keinen Erfolg. Genausowenig wie die Befehle X21, X67, X69, X99, x05 - x09,...

Hat ggf. doch noch jemand eine Idee warum das senden und empfangen gleichzeitig nicht funktioniert?

Nochmals vielen Dank!
SYSTEM:
Raspberrymatic auf einer VM (Syology DS220+ mit 10GB Ram)
HB-RF-ETH (POE) mit RPI-RF-MOD

MODULE:
- Eltako EnOcean USB Gateway FAM-USB mit EnOcean Lizenz
- CUL Stick 433MHz (SHK)

KOMPONENTEN:
- Homematic
- Homematic IP
- Homematic IP Wired
- Eltako Dimmer (FUD61NPN)
- Intertechno Steckdosen und Fernbedienung

turrican944
Beiträge: 429
Registriert: 29.05.2019, 22:19
Wohnort: Bargfeld
Hat sich bedankt: 3 Mal
Danksagung erhalten: 31 Mal

Re: CUL Stick 433 MHz sendet, empfängt jedoch nicht´s mehr

Beitrag von turrican944 » 17.12.2021, 09:25

Moin
Da wird mit Sicherheit irgendwas Stören, evtl. kommen die Störung über das USB Kabel rein (auf der Datenleitung oder dem Strom Pfad) evtl. hilft hier ein Ferritkern auf dem USB Kabel.
Ich finde diese CUL433Mhz Dinger sowieso nicht so toll. Ich habe so einen mit der CUL1.67 (die alternative ging immer irgendwas nicht). Der hängt bei mir am Odroid N2 aber der Empfang für Intertechno ist auch nicht so zuverlässig, war es bei mir noch nie mit dem CUL. Ich nutze Intertechno auch nur noch für die Weihnachtsbeleuchtung und die Fernbedienungen kaum noch.
Ich habe meine Intertechno Fernbedienungen immer mit einen RTL SDR Stick und RTL433 empfangen, das läuft bei mir sehr zuverlässig. Antenne ist auch ca 5m vom Stick weg. RTL433 schickt die Daten per MQTT die ich dann auswerte.

Vielleicht ist auch einfach das CC1101 Modul auf dem CUL schlecht. Kommt ja auch ggf. mal vor.

ich habe aber mittlerweile alle 433MHz IT Fernbedienungen durch Homematic ersetzt (selbstbau)
Gruß Florian

Antworten

Zurück zu „CUxD“