Tasmota variable wird nicht erkannt

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Antworten
MarKiesCo
Beiträge: 22
Registriert: 11.04.2023, 21:07
System: CCU
Hat sich bedankt: 7 Mal

Tasmota variable wird nicht erkannt

Beitrag von MarKiesCo » 16.04.2023, 11:40

Hallo,

bin am verzeifeln, aber ich versuche vergeblich herauszufinden, warum mein script in Tasmota Smartmeter eine Variable nicht mehr findet und somit 0 übergibt. In der Web UI von Tasmota wird mir jedoch ein Wert unter 'Power_curr' angezeigt.
Das Problem konnte ich zumindest soweit eingrenzen, dass bereits im Tasmota script was falsch läuft, da die Tasmota Concole den Fehler 'var not found: SML#Power_curr' ausgibt. Sehe ich den Wald vor lauter Bäume nicht, oder warum ist meine Vaiablendeklaration falsch?

Final soll der state des Energiezählers über CUxD an eine CCU3 Systemvariable "Stromzaehler_Schaltschrank" übergeben werden, was gestern noch einwandfrei funzte.

Das Tasmota Script ist:

Code: Alles auswählen

>D
var1=0
>S
var1=SML#Power_curr
=>WebSend [192.168.10.28:8181]/cuxd.exe?ret=dom.GetObject('Stromzaehler_Schaltschrank').State(%var1%)
>B
->sensor53 r
>M 1
+1,5,s,0,9600,SML
1,77070100010800ff@1000,Verbrauch_Summe,kWh,Total_Summe,1
1,77070100020800ff@1000,Einspeisung_Summe,kWh,Total_out,1
1,77070100100700ff@1,Current consumption,W,Power_curr,0
#
Jetzt sehe ich in der Tasmota Console die Fehlermeldung:

Code: Alles auswählen

09:52:03.207 var not found: SML#Power_curr
09:52:03.209 Script: performs "WebSend [192.168.10.28:8181]/cuxd.exe?ret=dom.GetObject('Stromzaehler_Schaltschrank').State(0.00)"
09:52:03.254 RSL: RESULT = {"WebSend":"Done"}
Gruß,
MarKiesCo

MarKiesCo
Beiträge: 22
Registriert: 11.04.2023, 21:07
System: CCU
Hat sich bedankt: 7 Mal

Re: Tasmota variable wird nicht erkannt

Beitrag von MarKiesCo » 16.04.2023, 12:54

nach 2 Stunden der Suche, und des Ausprobierens, verschwand der Fehler plötzlich nachdem ich das >S durch ein >T ersetzt habe, was irgendwie keinen Sinn ergibt, da ja das S lediglich einen Sekundentakt definiert.
Zumal ich das innerhalb meiner Fehlersuche vorher auch schon mal probiert hatte, um auszuschließen, dass irgendeine Art von Leerzeichen oder so aufgegriffen wird.

Vorher

Code: Alles auswählen

>S
var1=SML#Power_curr
Nachher

Code: Alles auswählen

>T
var1=SML#Power_curr

Antworten

Zurück zu „CUxD“