Kanal 2 eines CUXD Gerätes funktioniert nicht richtig.

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

Antworten
bador
Beiträge: 50
Registriert: 14.07.2023, 08:38
System: CCU
Hat sich bedankt: 8 Mal
Danksagung erhalten: 2 Mal

Kanal 2 eines CUXD Gerätes funktioniert nicht richtig.

Beitrag von bador » 09.11.2023, 09:54

Guten Tag

Ich habe vor ein paar Monaten eine Alexa gekauft und wollte damit meine CUXD Geräte steuern. Dafür konnte ich gleich mein Cloudmatic Konto nutzen, welches Alexa ja unterstützt.

Bei meinen Schalt und Jalousieaktoren gab es auf der Cloudmatic Alexa Seite aber einen Bug es wurden nämlich nicht alle Kanäle angezeigt. Den Aktor habe ich folgendermassen im CUXD Addon angelegt hier ein Beispiel:
CUXD 4 Kanal Jalousieaktor.PNG
CUXD 4 Kanal Jalousieaktor.PNG (13.54 KiB) 329 mal betrachtet
Das Gerät habe ich dann im Posteingang der RaspberryMatic Zentrale eingestellt und hinzugefügt.
4 Kanal Jalousieaktor Kanäle.PNG
4 Kanal Jalousieaktor Einstellungen.PNG
Um das Problem mit der Alexa zu lösen habe ich also im CUXD Addon einfach für jeden Aktor Kanal ein einzelnes Gerät erstellt. Bei einem 4 Kanal Jalousieaktor habe ich also 4 einzelne 1 Kanal Jalousieaktoren erstellt.

Hier wäre ein Beispiel:
CUXD 1 Kanal Jalousieaktor.PNG
CUXD 1 Kanal Jalousieaktor.PNG (13.59 KiB) 329 mal betrachtet
Von diesen Geräten habe ich dann wie gesagt 4 erstellt und habe im Posteingang einfach allen den gleichen Code des 4 Kanal Aktors gegeben also z.B. 01234567 (dieser bekommt jedes der 4 Geräte, weil es so wie ein 4Kanal Jalousieaktor funktioniert) und ich habe jedem Aktor die ID einzeln eingetragen also beim Gerät 1 die ID 1 weil es ja der erste Kanal ist.

Dies sah dann so aus:
1 Kanal Jalousieaktoren.PNG
Und in den Einstellungen des Gerätes sieht es so aus:
1 Kanal Jalousieaktor Kanal 2 Einstellungen.PNG
1 Kanal Jalousieaktor Kanal 2 Einstellungen.PNG (23.88 KiB) 329 mal betrachtet
Hier habe ich wie gesagt den Code und die ID eingetragen, dieses Gerät ist jetzt also der Kanal 2 des Jalousieaktors.

So hat das ganze dann mit der Alexa Problemlos funktioniert aber jetzt kommen wir zu meinem eigentlichen Problem, was mir aber erst jetzt aufgefallen ist.

Ich habe ja mehrere 4 Kanal Jalousieaktoren, das heisst sehr viele einzelne Geräte auf meiner Raspberry Matic Zentrale.

Und immer bei den Geräten welche den 2. Kanal ansteuern gibt es öfters Mal Probleme. Nämlich geht der Rollladen dort manchmal einfach nicht aber was noch viel Öfters passiert ist, dass man die Lamellen manuell nicht bedienen kann, also sie lassen sich einfach nicht ansteuern. Bei den anderen Kanälen geht dies einwandfrei. Dies ist mir wie gesagt es kürzlich aufgefallen aber bevor ich die ganzen 4 Kanal Aktoren zu einzelnen 1 Kanal Aktoren gemacht habe konnte man die Lamellen Problemlos steuern. Es ist aber wirklich immer der 2. Kanal welcher nicht geht ich habe mir das extra Mal notiert.

Meine Frage ist jetzt, liegt das wirklich an den neuen CUXD Geräten oder an was sonst? Ich habe mit meinem EnOcean Tool mit welchem ich die physischen Aktoren angelegt habe mal geschaut ob ich eine Meldung bekomme und ja es wird eine Meldung abgeschickt aber es passiert nichts. Es kann also nicht auf dieser Seite liegen und auf der Raspberry Matic Seite nehme ich auch nicht an. Es muss irgendwas auf der CUXD Seite sein aber ich weiss nicht was... Könnt Ihr mir hier weiterhelfen, damit ich die Lamellen wieder steuern kann?

Gruss
Bador

Benutzeravatar
uwe111
Beiträge: 4822
Registriert: 26.02.2011, 22:22
Hat sich bedankt: 3 Mal
Danksagung erhalten: 246 Mal
Kontaktdaten:

Re: Kanal 2 eines CUXD Gerätes funktioniert nicht richtig.

Beitrag von uwe111 » 09.11.2023, 11:42

Hallo Bador,
bador hat geschrieben:
09.11.2023, 09:54
Ich habe ja mehrere 4 Kanal Jalousieaktoren, das heisst sehr viele einzelne Geräte auf meiner Raspberry Matic Zentrale.
Funktionieren die 4 Kanäle unter Alexa, wenn Du als Geräte-Icon den Rollandenaktor 4fach (WR) auswählst?
bador hat geschrieben:
09.11.2023, 09:54
Meine Frage ist jetzt, liegt das wirklich an den neuen CUXD Geräten oder an was sonst?
Im CUxD Terminallog werden alle gesendeten Befehle aufgezeichnet. Damit könntest Du prüfen, ob es Unterschiede beim Verwenden des 1-Kanal Gerätes im Vergleich zum 4-Kanal Gerät bei Steuerung des gleichen EnOcean Jalousieaktor-Kanals (also Kanal 2) gibt. Sollte es Unterschiede geben, kann ich das gerne mal prüfen. Wenn es keine Unterschiede gibt, dann wird vom CUxD genau das Richtige gesendet und das Problem müsste am Aktor liegen.

Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.11, SSH KeyDir

Antworten

Zurück zu „CUxD“