CUxD unerwünschte Verzögerung

Anbindung von FS20-Komponenten, ELV-Wetterstationen, EnOcean und DMX an HomeMatic

Moderator: Co-Administratoren

forstner-m
Beiträge: 11
Registriert: 27.12.2023, 14:21
System: CCU

Re: CUxD unerwünschte Verzögerung

Beitrag von forstner-m » 26.05.2024, 17:17

Hallo Uwe,

die alten Einstellungen habe ich wieder reingebracht. Vielen Dank! Hier scheint aber auch ein Bug zu sein, wenn man die Zeile löschen und speichern kann, aber dann ist der Eintrag wieder drinnen.

Wie ich hier ein Programm schreiben soll um die Verzögerung von curl zu messen, ist mir unklar. Dazu kenne ich mich in Linux zu wenig aus.

Ich kann aber in der Kommandozeile den curl-Befehl eingeben und keine merkbare Verzögerung feststellen. Daher muss dies im Millisekundenbereich liegen.

Kann es sein, dass die empfangene Daten von curl von CUxD nicht verarbeitet werden können? Dieses xml kommt zurück:

Code: Alles auswählen

<xml>
	<ret>true</ret>
</xml>
Vielleicht kommt daher so oft das Zahnrad im WebUI.

Vielen Dank!

Schöne Gruße
Michael

Benutzeravatar
uwe111
Beiträge: 4827
Registriert: 26.02.2011, 22:22
Hat sich bedankt: 3 Mal
Danksagung erhalten: 246 Mal
Kontaktdaten:

Re: CUxD unerwünschte Verzögerung

Beitrag von uwe111 » 26.05.2024, 20:28

Hallo Michael,
forstner-m hat geschrieben:
26.05.2024, 17:17
Hier scheint aber auch ein Bug zu sein, wenn man die Zeile löschen und speichern kann, aber dann ist der Eintrag wieder drinnen.
Ja, dabei handelt es sich um einen bekannten Bug der WebUI.
forstner-m hat geschrieben:
26.05.2024, 17:17
Kann es sein, dass die empfangene Daten von curl von CUxD nicht verarbeitet werden können?
Nein, die Curl Daten werden bei Deinem Aufruf nicht verarbeitet.
forstner-m hat geschrieben:
26.05.2024, 17:17
Wie ich hier ein Programm schreiben soll um die Verzögerung von curl zu messen, ist mir unklar. Dazu kenne ich mich in Linux zu wenig aus.
zum Beispiel mit diesem Befehl zum Setzen der Befehlszeile:

Code: Alles auswählen

/usr/local/addons/cuxd/extra/timer.tcl CUxD.CUX2801003:4.CMD_SETL "(echo -n '2: ';date +%s.%N) >>/tmp/delay.txt;extra/curl -s http://192.168.0.4/vir_lg_rgbw_dim_ch/04/long?value:0?white:2000;(echo -n '3: ';date +%s.%N) >>/tmp/delay.txt"
und dann z.B. über die WebUI aufrufen.

Oder über den LEVEL Datenpunkt ohne WebUI:

Code: Alles auswählen

(echo -n '1: ';date +%s.%N) >>/tmp/delay.txt;/usr/local/addons/cuxd/extra/timer.tcl CUxD.CUX2801003:4.LEVEL 1
Viele Grüße

Uwe
Alle sagten: Das geht nicht. Dann kam einer, der wußte das nicht und hat's einfach gemacht.
SPENDEN :wink: Download: CUxD 2.11, SSH KeyDir

forstner-m
Beiträge: 11
Registriert: 27.12.2023, 14:21
System: CCU

Re: CUxD unerwünschte Verzögerung

Beitrag von forstner-m » 28.05.2024, 19:16

Hallo Uwe,

ich habe nun die Zeit mit den Befehlen mal gemessen. Es ist ziemlich unterschiedlich. Von 200 - 500ms kann die Verzögerung sein. Vermutlich gibt es an mehreren Stellen Verzögerungen welchen sich addieren und zu 2 - 3 Sekunden führen. Ich habe auch schon den Verdacht, dass sich der Sensor und Aktuator über Funk stören und dann eine Wiederholung der Datenpakete verursacht. Im gleichen Frequenzbereich sind die Teile jedenfalls.

Ich habe aber nun eine andere Lösung für das Problem gefunden. Die zeitkritischen Anwendungen werden über direkte Verknüpfungen gelöst. Wenn es nicht so kritisch ist, lasse ich es über curl usw. ausführen.

Vielen Dank für die ausführliche Hilfe!

Schöne Grüße
Michael

forstner-m
Beiträge: 11
Registriert: 27.12.2023, 14:21
System: CCU

Re: CUxD unerwünschte Verzögerung

Beitrag von forstner-m » 22.06.2024, 09:32

An den Einstellungen habe ich nichts geändert, aber nun ist die Verzögerung weg. Keine Ahnung wo das Problem war!

Antworten

Zurück zu „CUxD“