Servicemeldungen bei Verbindungsabbruch zum Funk-LAN Gateway

Homematic-, TCL- und Shell-Script, Toolchain, C, etc.

Moderator: Co-Administratoren

dtp
Beiträge: 7020
Registriert: 21.09.2012, 08:09
Wohnort: Stuttgart
Hat sich bedankt: 10 Mal
Danksagung erhalten: 39 Mal

Servicemeldungen bei Verbindungsabbruch zum Funk-LAN Gateway

Beitrag von dtp » 10.07.2019, 07:32

Hallo,

man kann ja bekanntlich den Verbindungsabbruch zwischen CCU und Funk-LAN Gateway recht einfach über den Duty Cycle abfragen. Ist er -1, so besteht keine Verbindung mehr. Ich frage mich aber, warum es hier keine generelle Servicemeldung seitens des Herstellers gibt? Für jede HM- und HMIP-Komponente gibt es das. Nur nicht für das Funk-LAN Gateway.

Gestern um ca. 23:00 Uhr hat sich mein Funk-LAN Gateway kurzzeitig verabschiedet und ich habe auch eine entsprechende Meldung darüber erhalten, weil ich den DC abfrage. Heute Morgen hatte ich dann ca. 20 Servicemeldungen mit Kommunikationsstörungen. Kurios war, dass das Funk-LAN Gateway im WebUI immer noch als verbunden angezeigt wurde. Der DC war aber die ganze Zeit -1.

Das Funk-LAN Gateway wird meiner Auffassung nach eh immer noch recht stiefmütterlich behandelt. So ist z.B. nach wie vor keine Sortierung der Geräteübersicht für das Gateway im WebUI anhand der Gerätenamen möglich. Man muss sich da bei über hundert Komponenten schon jedes Mal ziemlich durchwurschteln.

Also, zwei Wünsche:

1. Eine vom LAN-Gateway erzeugte Servicemeldung UNREACH, wenn die Verbindung abgebrochen ist.
2. Eine Möglichkeit zum Sortieren der Geräteübersicht für das Funk-LAN Gateway anhand der Gerätenamen. Am besten noch gekoppelt mit einer Filtermöglichkeit, wie man es auch bei den übrigen Listen im WebUI schon kennt.

Ein weiteres Problem ist, dass nach einem Verbindungsabbruch kein automatischer Reconnect zwischen CCU und Funk-LAN Gateway stattfindet. Zumindest ist das bei mir so. Ich muss dann meine CCU3 neu starten, damit das Gateway wieder erkannt wird. Oder gibt es da einen Workaround?

Gruß,

Thorsten
CCU3 mit stets aktueller FW und den Addons "CUxD" und "Programmedrucken", ioBroker auf Synology DiskStation DS718+ im Docker-Container, Homebridge auf Raspberry Pi 3B+;
einige Projekte: zentrales Push-Nachrichten-Programm zPNP, DoorPi-Videotürsprechanlage, An- und Abwesenheitsdetektion per Haustürschloss, zentrales Programm zur Steuerung von Beschattungsgeräten zBSP.

jp112sdl
Beiträge: 3629
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 58 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: Servicemeldungen bei Verbindungsabbruch zum Funk-LAN Gateway

Beitrag von jp112sdl » 12.07.2019, 06:41

dtp hat geschrieben:
10.07.2019, 07:32
Oder gibt es da einen Workaround?
per SSH einloggen und

Code: Alles auswählen

/etc/init.d/S61rfd restart
ausführen.
Sollte sich aber auch einfach über "Skript testen" mit system.Exec() bewerkstelligen lassen.

VG,
Jérôme

jp112sdl
Beiträge: 3629
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 58 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: Servicemeldungen bei Verbindungsabbruch zum Funk-LAN Gateway

Beitrag von jp112sdl » 12.07.2019, 06:50

dtp hat geschrieben:
10.07.2019, 07:32
1. Eine vom LAN-Gateway erzeugte Servicemeldung UNREACH, wenn die Verbindung abgebrochen ist.
Zwar keine Service- aber eine Alarmmeldung könntest du dir selbst erzeugen mit einem WebUI Programm.
WENN DC = -1 DANN GatewayAlarm = true
Evlt. ist ein kleines Skript notwendig.
viewtopic.php?t=6798#p45818

VG,
Jérôme

dtp
Beiträge: 7020
Registriert: 21.09.2012, 08:09
Wohnort: Stuttgart
Hat sich bedankt: 10 Mal
Danksagung erhalten: 39 Mal

Re: Servicemeldungen bei Verbindungsabbruch zum Funk-LAN Gateway

Beitrag von dtp » 12.07.2019, 06:57

Die Meldung erzeuge ich mir bereits. Ich frag mich halt nur, warum es da keine Servicemeldung seitens des Herstellers gibt.
CCU3 mit stets aktueller FW und den Addons "CUxD" und "Programmedrucken", ioBroker auf Synology DiskStation DS718+ im Docker-Container, Homebridge auf Raspberry Pi 3B+;
einige Projekte: zentrales Push-Nachrichten-Programm zPNP, DoorPi-Videotürsprechanlage, An- und Abwesenheitsdetektion per Haustürschloss, zentrales Programm zur Steuerung von Beschattungsgeräten zBSP.

jp112sdl
Beiträge: 3629
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 58 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: Servicemeldungen bei Verbindungsabbruch zum Funk-LAN Gateway

Beitrag von jp112sdl » 13.07.2019, 23:15

dtp hat geschrieben:
12.07.2019, 06:57
Die Meldung erzeuge ich mir bereits. Ich frag mich halt nur, warum es da keine Servicemeldung seitens des Herstellers gibt.
Weil Servicemeldungen nur zu angelernten Geräten erzeugt werden.
Das Gateway ist eine abgesetzte Schnittstelle... Wenn das interne Funkmodul nicht mehr funktioniert, wird auch keine Servicemeldung erzeugt.

VG,
Jérôme

Daimler
Beiträge: 6133
Registriert: 17.11.2012, 10:47
Wohnort: Köln
Danksagung erhalten: 15 Mal

Re: Servicemeldungen bei Verbindungsabbruch zum Funk-LAN Gateway

Beitrag von Daimler » 14.07.2019, 06:36

Hi,
dtp hat geschrieben:
10.07.2019, 07:32
Ein weiteres Problem ist, dass nach einem Verbindungsabbruch kein automatischer Reconnect zwischen CCU und Funk-LAN Gateway stattfindet.
Da stimmt aber dann etwas in deiner Umgebung nicht - das / die Gateway(s) reconnecten sich bei mir binnen ~ 10 Sekunden.
- Ich habe allerdings noch nie getestet, wie es aussieht, wenn ein Gateway über Stunden offline war. :!:
Wie hast du das Gateway angebunden - Lan?
dtp hat geschrieben:
10.07.2019, 07:32
Eine Möglichkeit zum Sortieren der Geräteübersicht für das Funk-LAN Gateway anhand der Gerätenamen.
Bis einschließlich CCU2 konntest du doch Olivers HmCompanion dazu verwenden!
Und bei der 3er bietet sich der 'Homematic Manager' an.

jp112sdl hat geschrieben:
13.07.2019, 23:15
Wenn das interne Funkmodul nicht mehr funktioniert, wird auch keine Servicemeldung erzeugt.
Und das ist ein Armutszeugnis - wimre selbst bei Wired- und IP-Wired Gateways nicht.
Was nützen mir 1000 SM, wenn die Störung der Hauptkomponente(n) nicht gemeldet wird - egal über welche Meldungsart /-Bezeichnung.
Gruß Günter

pivccx mit 3.45.7 in Produktiv, pivccx mit 3.47.15 Testsystem, pivccx mit 3.47.15 im 2. Testsystem, 3 * HPCx Studio 4.1,
6 * L-Gateway, 3 * RS-L-Gateway, FHZ200x, vereinzelt noch FS2x-Komponenten.
HM: Zur Zeit knapp 250 Komponenten mit ~ 650 Kanälen .

Ich übernehme für alle von mir gegebenen Hinweise, Tipps und Links keine Haftung! Das Befolgen meiner Tipps ist nur für Fachkundige gedacht und erfolgt auf eigene Gefahr!

roe1974
Beiträge: 442
Registriert: 17.10.2017, 16:15
Wohnort: Wien
Hat sich bedankt: 5 Mal

Re: Servicemeldungen bei Verbindungsabbruch zum Funk-LAN Gateway

Beitrag von roe1974 » 12.09.2019, 17:31

jp112sdl hat geschrieben:
12.07.2019, 06:41
dtp hat geschrieben:
10.07.2019, 07:32
Oder gibt es da einen Workaround?
per SSH einloggen und

Code: Alles auswählen

/etc/init.d/S61rfd restart
ausführen.
Sollte sich aber auch einfach über "Skript testen" mit system.Exec() bewerkstelligen lassen.
Ich habe ein LGW über eine OVPN Verbindung (LTE in der Garage) verbunden ... funktioniert gut.
alle 12h wird jedoch die LTE verbindung up/down genommen (hat Gründe der Verrechung)
da hilft immer nur ein "reboot" des LGW damit die CCU es wieder "sieht".
Könnte ich auch nur den Netzwerkdienst neu starten ? ... den neu starten des LGW Dienstes hilft auch nicht ....

lg Richard

jp112sdl
Beiträge: 3629
Registriert: 20.11.2016, 20:01
Hat sich bedankt: 58 Mal
Danksagung erhalten: 111 Mal
Kontaktdaten:

Re: Servicemeldungen bei Verbindungsabbruch zum Funk-LAN Gateway

Beitrag von jp112sdl » 12.09.2019, 21:51

Bei einem GW über VPN und LTE kommen ja noch unterirdische Latenzen hinzu...
Das läuft stabil?

VG,
Jérôme

Daimler
Beiträge: 6133
Registriert: 17.11.2012, 10:47
Wohnort: Köln
Danksagung erhalten: 15 Mal

Re: Servicemeldungen bei Verbindungsabbruch zum Funk-LAN Gateway

Beitrag von Daimler » 12.09.2019, 21:54

Latenzen bei 5G - gibbet doch nicht . :lol:
Gruß Günter

pivccx mit 3.45.7 in Produktiv, pivccx mit 3.47.15 Testsystem, pivccx mit 3.47.15 im 2. Testsystem, 3 * HPCx Studio 4.1,
6 * L-Gateway, 3 * RS-L-Gateway, FHZ200x, vereinzelt noch FS2x-Komponenten.
HM: Zur Zeit knapp 250 Komponenten mit ~ 650 Kanälen .

Ich übernehme für alle von mir gegebenen Hinweise, Tipps und Links keine Haftung! Das Befolgen meiner Tipps ist nur für Fachkundige gedacht und erfolgt auf eigene Gefahr!

roe1974
Beiträge: 442
Registriert: 17.10.2017, 16:15
Wohnort: Wien
Hat sich bedankt: 5 Mal

Re: Servicemeldungen bei Verbindungsabbruch zum Funk-LAN Gateway

Beitrag von roe1974 » 13.09.2019, 08:45

jp112sdl hat geschrieben:
12.09.2019, 21:51
Bei einem GW über VPN und LTE kommen ja noch unterirdische Latenzen hinzu...
Das läuft stabil?
das läuft perfekt !!!! ... mit annähernd 0 verzögerung ....
nur eben dieser LTE up/down alle 12h ist ärgerlich ....
der LTE router startet bei einem LTE up/down jedesmal das LGW neu (Mikrotik Router kann scripts ausführen) ....
nur das LGW Service neu starten half nicht immer....
jetzt die Frage...kann ich den "Netzwerkdienst" am LGW neu starten, wenn ja wie ?

reicht ein

Code: Alles auswählen

/etc/init.d/S40network restart
????

lg RIchard

Antworten

Zurück zu „Softwareentwicklung für die HomeMatic CCU“