Gosund WLan Steckdosen

Themen, die in keine andere Kategorie passen

Moderator: Co-Administratoren

t0mk
Beiträge: 33
Registriert: 08.08.2018, 20:13

Re: Gosund WLan Steckdosen

Beitrag von t0mk » 10.02.2019, 18:03

Hallo zusammen,

ich habe mir gestern eine HM-Platine für den Gosund-Zwischenstecker zusamengelötet. Ich muss dazu sagen, es ist das erste Mal, dass ich was mit einem Atmega 644 und mit einem Resonator zu tun habe, deswegen tue ich mich etwas schwer damit. Das Problem ist, dass ich zwar initial die Fuses setzen konnte:

Code: Alles auswählen

avrdude -p m644p -P usb -c usbasp -B 3 -U lfuse:w:0xFF:m -U hfuse:w:0xD2:m -U efuse:w:0xFF:m -U lock:w:0x2F:m
Aber anschließend ist der Atmega nicht mehr per ISP ansprechbar. Das kann ja viele Ursachen haben:
1: Resonator funktioniert nicht oder ist falsch dimensioniert. Ich habe diese hier gekauft https://www.aliexpress.com/item/10PCS-C ... 58c2poexPK, habe auch 2 unterschiedliche aus der Lieferung ausprobiert. Kann jemand bestätitgen, dass ich keine falschen Teile bestellt habe?
2: Resonator falsch rum angeschlossen. Ich habe keine Markierungen entdeckt, habe daraus geschlossen, dass es egal ist, wie rum ich das Ding anschließe... Richtitg oder falsch?
3: Die Fuses falsch gesetzt. Ich habe die Fuses gemäß stan23 Anleitung gesetz (Ext: 0xFF High: 0xD2 Low: 0xFF (für den internen Takt: 0xE2)), hätte ich irgendwas anders machen sollen?
4: Das Funkmodul war beim Flashen bereits drauf, anders als in stan23 Anleitung beschrieben, doch das sollte doch kein Problem sein, oder?

stan23
Beiträge: 525
Registriert: 13.12.2016, 21:14
Wohnort: Altmühltal
Kontaktdaten:

Re: Gosund WLan Steckdosen

Beitrag von stan23 » 11.02.2019, 04:33

Hi,
die Resonatoren sehen richtig aus. Die haben keine Polarität, nur eine Vorzugsrichtung. Erkennt man laut Datenblatt am Aufdruck.

Eigentlich müsste das so passen, also kann es eigentlich nur daran liegen dass der Resonator nicht schwingt.

Kannst du mal messen ob es keinen Kurzschluss gegen Masse gibt, und dass bei Leitungen zum ATMega Durchgang haben?
Viele Grüße
Marco

RaspberryMatic
~60 Geräte (HM, HmIP, HMW, HBW, AskSin)

t0mk
Beiträge: 33
Registriert: 08.08.2018, 20:13

Re: Gosund WLan Steckdosen

Beitrag von t0mk » 12.02.2019, 21:09

Hi,

Danke für Deine Antwort!

Es waren die XTAL-Pins am Atmega. Nachdem ich nochmal alle nachgelötet habe, meldet sich der Atmega wieder per ISP.

t0mk
Beiträge: 33
Registriert: 08.08.2018, 20:13

Re: Gosund WLan Steckdosen

Beitrag von t0mk » 30.05.2019, 23:05

Guten Abend,

ich habe mir bereits vor einigen Monaten 2.3er Platinen von Marco gekauft, um meine Gosund-Zwischenstecker auf Homematic umzurüsten. Leider stelle ich fest, dass es die Revision 2.4 ist, obwohl ich sie im Dezember gekauft habe, als hier noch über die Revision 2.3 diskutiert wurde. Nun ja, Pech gehabt, die Frage ist halt, wie stelle ich fest, dass sie vielleicht was die Steuerplatine angeht, gleich sind? Im Tasmota-Wiki werden die beiden Revisionen in einem Artikel geführt, auf den Fotos sehen zumindest die Rückseiten der Steuerplatinen ziemlich gleich aus. Gibt es noch was, was anders sein kann, weswegen ich doch die Finger davon lassen sollte (zumindest mit der Platine, die für die Revision 2.3 bestimmt ist)?
Dateianhänge
IMG_20181210_184957_2_4r.jpg
V 2.4 (Quelle: Christof, googledrive)
20181107_201738_2_3.jpg
V 2.3 (Quelle: www.bastelbunker.de)

stan23
Beiträge: 525
Registriert: 13.12.2016, 21:14
Wohnort: Altmühltal
Kontaktdaten:

Re: Gosund WLan Steckdosen

Beitrag von stan23 » 31.05.2019, 10:40

Meines Wissens sind die 2.3 und die 2.4 von der Pinbelegung gleich.
Viele Grüße
Marco

RaspberryMatic
~60 Geräte (HM, HmIP, HMW, HBW, AskSin)

Antworten

Zurück zu „OffTopic“