RaspberryMatic - RealTimeClock (RTC) Installation

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Benutzeravatar
jmaus
Beiträge: 3695
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Kontaktdaten:

Re: RaspberryMatic - RealTimeClock (RTC) Installation

Beitrag von jmaus » 17.07.2018, 18:44

muggel hat geschrieben:
17.07.2018, 18:33
ich habe mir die RTC aus dem ersten Beitrag angeschafft (PiFace shim RTC), wie beschrieben installiert (Batterie nach oben, Pins ganz aussen benutzt, da wo das Funkmodul auch sitzt) und erhalte leider beim Aufruf "hwclock" stets "RTC_RD_TIME" als Antwort.
Kennt jemand diesen Fehler und kann mir sagen, woher dieser kommt?
Bitte mal Monitor+Tastatur anschliessen und dann beim Booten ALT+F2 drücken. Dann ganz oben bei der RTC Initialisierung schauen was er da ausgibt. Ggf. steht da eine Fehlermeldung. Des Weiteren mal in die Datei /var/hm_mode schauen, da müsste es eine Variable HM_RTC geben die entsprechend gesetzt sein müsste.
RaspberryMatic 3.41.11.20181126 @ TinkerS mit ~150 HomeMatic Geräten + ioBroker – GitHubPayPal

muggel
Beiträge: 68
Registriert: 27.06.2018, 06:56

Re: RaspberryMatic - RealTimeClock (RTC) Installation

Beitrag von muggel » 17.07.2018, 18:54

Da steht die gleiche Fehlermeldung:

Code: Alles auswählen

Initializing RTC Clock: hwclock: RTC_RD_TIME: Invalid argument

Benutzeravatar
jmaus
Beiträge: 3695
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Kontaktdaten:

Re: RaspberryMatic - RealTimeClock (RTC) Installation

Beitrag von jmaus » 17.07.2018, 18:59

Und in der Datei /var/hm_mode ?

und was passiert wenn du

Code: Alles auswählen

/bin/setHWClock.sh
aufrufst?
RaspberryMatic 3.41.11.20181126 @ TinkerS mit ~150 HomeMatic Geräten + ioBroker – GitHubPayPal

muggel
Beiträge: 68
Registriert: 27.06.2018, 06:56

Re: RaspberryMatic - RealTimeClock (RTC) Installation

Beitrag von muggel » 17.07.2018, 19:29

Hallo,

in der /var/hm_mode steht bei HM_RTC:
HM_RTC=' '

Versuche ich das Skript auszuführen, so passiert nichts:

Code: Alles auswählen

# /bin/setHWClock.sh
#

roe1974
Beiträge: 253
Registriert: 17.10.2017, 16:15
Wohnort: Wien

Re: RaspberryMatic - RealTimeClock (RTC) Installation

Beitrag von roe1974 » 17.07.2018, 21:29

wird eigentlich die RTC regelmäßig im Betrieb gesynct ?
oder nur beim boot ?

habe seit heute eine eingebaut ... eigentlich ohne probleme ... aber

mit hwclock -w kann ich die RTC mit der aktuellen zeit beschreiben ... soweit so gut

nach einigerzeit sehe ich aber zwischen „hwclock -r“ und „date „ einen unterschied von 2h

Code: Alles auswählen

# hwclock -r
Tue Jul 17 20:04:47 2018  0.000000 seconds
# date
Tue Jul 17 22:04:53 CEST 2018
# 
verstehe ich nicht ...
der wert von „date“ stimmt .....

lg richard

Benutzeravatar
jmaus
Beiträge: 3695
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Kontaktdaten:

Re: RaspberryMatic - RealTimeClock (RTC) Installation

Beitrag von jmaus » 17.07.2018, 23:52

muggel hat geschrieben:
17.07.2018, 19:29
in der /var/hm_mode steht bei HM_RTC:
HM_RTC=' '

Versuche ich das Skript auszuführen, so passiert nichts:

Code: Alles auswählen

# /bin/setHWClock.sh
#
Wenn da in der HM_RTC variable nichts drinsteht wird deine RTC einfach nicht korrekt erkannt. Ggf. kaputt oder nicht richtig angesteckt. Schau mal was das Kommando "dmesg" so ausgibt und ob da was von "rtc" drinsteht.
RaspberryMatic 3.41.11.20181126 @ TinkerS mit ~150 HomeMatic Geräten + ioBroker – GitHubPayPal

Benutzeravatar
jmaus
Beiträge: 3695
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Kontaktdaten:

Re: RaspberryMatic - RealTimeClock (RTC) Installation

Beitrag von jmaus » 17.07.2018, 23:55

roe1974 hat geschrieben:
17.07.2018, 21:29
wird eigentlich die RTC regelmäßig im Betrieb gesynct ?
oder nur beim boot ?
Klar, da gibt es einen cronjob der regelmäßig /bin/setHWClock.sh aufruft.
habe seit heute eine eingebaut ... eigentlich ohne probleme ... aber

mit hwclock -w kann ich die RTC mit der aktuellen zeit beschreiben ... soweit so gut

nach einigerzeit sehe ich aber zwischen „hwclock -r“ und „date „ einen unterschied von 2h

Code: Alles auswählen

# hwclock -r
Tue Jul 17 20:04:47 2018  0.000000 seconds
# date
Tue Jul 17 22:04:53 CEST 2018
# 
verstehe ich nicht ...
der wert von „date“ stimmt .....
Hast du schon einmal etwas von UTC und CEST Zeit gehört? ;-) Ruf einfach mal folgende beiden Kommandos hintereinander auf:

Code: Alles auswählen

hwclock -ru
und dann

Code: Alles auswählen

date
Und schon wirst du sehen das beide das selbe ausgeben. Ergo: du brauchst das "u" als zusätzliche option wenn du die Zeit aus der RTC ausliest damit die vergleichbar ist mit deiner lokalen Zeit, denn eine RTC speichert die zeit in UTC zeit und die lokale ist eben die Zeit aus der Zeitzone CEST.
RaspberryMatic 3.41.11.20181126 @ TinkerS mit ~150 HomeMatic Geräten + ioBroker – GitHubPayPal

roe1974
Beiträge: 253
Registriert: 17.10.2017, 16:15
Wohnort: Wien

Re: RaspberryMatic - RealTimeClock (RTC) Installation

Beitrag von roe1974 » 18.07.2018, 06:28

aahhhhhhhhhhhhhhhhhhhh DANKE !
Wieder etwas gelernt ;-)

lg Richard

muggel
Beiträge: 68
Registriert: 27.06.2018, 06:56

Re: RaspberryMatic - RealTimeClock (RTC) Installation

Beitrag von muggel » 18.07.2018, 07:37

jmaus hat geschrieben:
17.07.2018, 23:52

Wenn da in der HM_RTC variable nichts drinsteht wird deine RTC einfach nicht korrekt erkannt. Ggf. kaputt oder nicht richtig angesteckt. Schau mal was das Kommando "dmesg" so ausgibt und ob da was von "rtc" drinsteht.
Naja, beim Anstecken kann man ja nicht soviel falsch machen... auf den Pins nach ganz oben habe ich die RTC geschoben. Ausser festlöten geht ja nicht mehr.

Daher vermute ich (da ich die Batterie durchgemessen hab und alles ok ist), dass die RTC nicht ok ist - geht daher zurück. Liest man ja auch mehrfach, dass bei einigen die erste RTC defekt war.

Hackertomm
Beiträge: 23
Registriert: 18.04.2018, 12:32

Re: RaspberryMatic - RealTimeClock (RTC) Installation

Beitrag von Hackertomm » 23.07.2018, 15:12

Ich habe ebenfalls die PiFace Shim RTC Erweiterung installiert.
Funktioniert soweit, nur stimmt da anscheinend die Zeitzone nicht.
Soll heißen dir RTC geht so 1 oder 2h nach.

Die Frage ist jetzt einfach, welche Zeitzone man da wählen muss, damit sie sie richtige Uhrzeit anzeigt?

PS. Welche Zeitzone da jetzt eingestellt ist, kann ich erst heute Abend abfragen, momentan bin ich nicht in der Nähe der Raspberry matic.


Hat sich erledigt, scheint jetzt zu passen.
Eingestellt ist "GMT/BST (UTC -0/+1)
Der zeitserver ist Deaktiviert bzw. leer.

Antworten

Zurück zu „RaspberryMatic“