Anlernen von Homematic IP-Geräten an RaspberryMatic

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

hoedlmoser
Beiträge: 95
Registriert: 19.01.2015, 07:42

Re: Anlernen von Homematic IP-Geräten an RaspberryMatic

Beitrag von hoedlmoser » 01.12.2018, 16:13

hoedlmoser hat geschrieben:
01.12.2018, 16:05
in /boot/config.txt den parameter arm_freq auf 1200 setzen, laut https://www.raspberrypi.org/documentati ... locking.md

Code: Alles auswählen

# switch back speed of 3B+ to max speed of 3B
arm_freq=1200
da wollte ich den @jmaus noch fragen warum er denn core_freq=250 gesetzt hat, default wäre 400 MHz.
RaspberryMatic 3.41.11.20181126 on Charly with Pi 3B+ binded by openHAB 2.4.0 M7
Wahrheit kann erst wirken, wenn der Empfänger für sie reif ist. Nicht an der Wahrheit liegt es daher, wenn die Menschen noch so voller Unweisheit sind. Alle Geheimnisse liegen in vollkommener Offenheit vor uns. Nur wir stufen uns gegen sie ab, vom Stein bis zum Seher. Es gibt keine Geheimnisse an sich, es gibt nur Uneingeweihte aller Grade. (Christian Morgenstern)

hoedlmoser
Beiträge: 95
Registriert: 19.01.2015, 07:42

Re: Anlernen von Homematic IP-Geräten an RaspberryMatic

Beitrag von hoedlmoser » 01.12.2018, 20:45

hoedlmoser hat geschrieben:
01.12.2018, 16:05
ich versuch das mal bei mir auch nachzustellen, hab zwar keinen BSL, aber ein paar [...]
nach

Code: Alles auswählen

rm -rf /etc/config/hmip_*.conf /etc/config/crRFD/*
und einem reboot ließen sich an die HmIP-jungfräuliche RM folgende komponenten anlernen und bedienen
  • HmIP-MOD-OC8,
  • HmIP-MOD-RC8,
  • HmIP-STHO und
  • HmIP-STHD
(lediglich muß ich immer Geräte und Bedienung bzw Einstellungen > Geräte etwas zeit geben, damit die GUI nicht in einen timeout läuft und das HmIP-RF als tot meldet, aber das ist denke ich eine andere baustelle).
RaspberryMatic 3.41.11.20181126 on Charly with Pi 3B+ binded by openHAB 2.4.0 M7
Wahrheit kann erst wirken, wenn der Empfänger für sie reif ist. Nicht an der Wahrheit liegt es daher, wenn die Menschen noch so voller Unweisheit sind. Alle Geheimnisse liegen in vollkommener Offenheit vor uns. Nur wir stufen uns gegen sie ab, vom Stein bis zum Seher. Es gibt keine Geheimnisse an sich, es gibt nur Uneingeweihte aller Grade. (Christian Morgenstern)

Schattenschimmer
Beiträge: 117
Registriert: 20.03.2016, 20:49

Re: Anlernen von Homematic IP-Geräten an RaspberryMatic

Beitrag von Schattenschimmer » 01.12.2018, 22:20

@hoedlmoser, Dein Tip und die entsprechende Anweisung in der /boot/config.txt sind Gold wert! :)

Natürlich war es okay, daß Du mein Quoting umgestylt hast. Ich habe nun in meinem Posting die Antworten farblich hervorgehoben.
Und ja, der HMIP-BSL ist mein einziges HMIP-Gerät.

Nun denn, hier meine Testergebnisse.

Erst einmal eine kleine Definition:
Warmstart = Neustart per Software (z.B. "reboot now"), Spannungsversorgung nicht unterbrochen
Kaltstart = Unterbrechung der Spannungsversorgung

Ich habe meinen Raspi 3B+ wieder hervorgekramt und das kleine Funkmodul und eine SD-Karte mit einem jungfräulichen Image V3.41.11.20181126 in den Raspi gesteckt. HMIP-BSL und diesen Raspi auf den Tisch gelegt und mit Spannung versorgt.
Netzwerkverbindung zwischen Raspi und Notebook hergestellt, für den Raspi keine www-Verbindung.

1. Versuch
Der BSL läßt sich nicht anlernen, mehrfach probiert.
Keine Überraschung, sondern das von mir erwartete Verhalten

2. Versuch
Taktfrequenz auf 1200MHz begrenzt (siehe Posting von hoedlmoser weiter oben), indem ich die /boot/config.txt bearbeitet und den Raspi warm gestartet habe.
Kontrolle mit dem Kommando "lscpu" zeigte eine max. Frequenz von 1200MHz an. lscpu habe ich in den folgenden Versuchen nach jeder Änderung der Taktfrequenz angewendet.
BSL ließ sich spontan anlernen!
In meinem Fall offline mit Eingabe der beiden Keys, da der Raspi nur eine IP-Verbindung mit meinem Notebook hat, also kein Weg ins www vorhanden. Ich gehe übrigens davon aus, daß die Art des Anlernens (on- oder offline) egal ist.
BSL läßt sich gut bedienen, die Seite "Status und Bedienung" -> "Geräte" war schnell geladen. Ich konnte den Kontakt im BSL und die LEDs gut bedienen.
Auffällig war lediglich, daß auf der Bedienseite die virtuellen Kanäle nicht angezeit wurden. Diese wurde in keinem der folgenden Tests angezeigt, die Ursache mag irgendwo anders liegen (HM-System war bis auf den angelernten BSL jungfräulich).

3. Versuch
Den neuen Eintrag in der config.txt zur Begrenzung der Taktfrequenz auskommentiert (deaktiviert), anschließend Warmstart.
Der BSL ließ sich normal bedienen, genau wie beim 2. Versuch.

4. Versuch
Kaltstart des Raspi
Die Bedienseite der Geräte ließ sich kaum laden: Entweder gar nicht oder sie wurde erst nach ca. 1 Minute angezeigt.
Bedienung des BSL möglich, aber eher etwas träge, zeitweise unzuverlässig.
Die Geräteliste wird normal geladen.

5. Versuch
Taktfrequenz auf 1200MHz begrenzt, Kaltstart des Raspi
BSL läßt sich genau so auffällig bedienen wie im 4. Versuch. Die Bedienseite der Geräte lädt extrem langsam.
BSL über Geräteliste gelöscht. Wanrmeldung, daß der BSL nicht erreicht werden könne, um diesen zurückzusetzen, 2 Sekunden später war der BSL automatisch (ohne daß ich etwas gemacht hatte) aus der Liste gelöscht und blinkte orange im 10s-Rhythmus (=Werkszustand, Anmeldemodus aktiv) vor sich hin.

6. Versuch
Taktfrequenz wieder auf 1400MHz, Kaltstart
BSL läßt sich registrieren!
Bedienung unauffällig!

7. Versuch
BSL über Geräteliste gelöscht.
BSL neu angelernt.
Funktioniert, als wenn nie etwas gewesen wäre..... :shock: :?:

Einige weitere Versuche mit Warm- und Kaltstarts änderten nichts mehr. Aktuell bekomme ich den Ursprungszustand mit dem Problem in diesem Testumfeld nicht wieder hergestellt.


Mein Fazit:
Die ganze Problematik hängt mit der Taktfrequenz zusammen. Gut möglich, daß es hier wirklich timing-Probleme gibt.
Durch die Begrenzung der Taktfrequenz läßt sich dies beheben.

Offensichtlich gibt es irgendwo eine Art Lern- oder Anpassungseffekt, da der BSL aktuell bei mir mit 1400MHz funktioniert.
Grundsätzlich vorstellbar, daß es irgendwo eine Art automatische Konfiguration gibt. Dann wäre aber die Frage, wo diese Werte gespeichert werden. Haben der Raspi oder das Funkmodul entsprechende (Flash-)Speicher? Oder wird das vom Linux gehändelt?
Im 2. Fall würde ein weiteres jungräuliches Image Aufschluß geben...vielleicht sollte ich mich mal auf die Suche nach einer weiteren SD-Karte machen....
Oder weiß jemand etwas über solche Mechanismen?


Jetzt ihr :)
Ich gespannt, ob jemand meine Ergebnisse nachvollziehen kann. Wenn ja, dann könnte die Begrenzung des Taktes auch bei anderen Usern einige Probleme lösen. Ich denke hier an mehrache Versuche des Anlernens, in einigen Bereichen eine träge hm, unzuverlässige Datenübertragung, usw.
Ich bin noch mehr gespannt, ob jemand eine gute Erklärung dafür hat.


Ich werden den 3B+ trotz des erst einmal guten Ergebnisses nicht life nehmen, sondern erst einmal weitere Fakten und Erfahrungen - und vor allem Feedback aus diesem Forum - sammeln.


Viele Grüße,
Carsten
NAT ist heutzutage keine sicherere Technik, um Netzwerkgeräte aus dem www erreichbar zu machen!

hoedlmoser
Beiträge: 95
Registriert: 19.01.2015, 07:42

Re: Anlernen von Homematic IP-Geräten an RaspberryMatic

Beitrag von hoedlmoser » 02.12.2018, 20:12

Schattenschimmer hat geschrieben:
01.12.2018, 22:20
Ich habe meinen Raspi 3B+ wieder hervorgekramt [...]
lass mich das mal zusammenfassen: anlernen des HmIP-BSL nur wenn der 3B+ auf 1200 MHz heruntergetaktet ist, betrieb oder neuerliches anlernen funktioniert aber auch mit der standardfrequenz des 3B+ von 1400 MHz.
unabhängig von der frequenz des 3B+ ist Status und Bedienung > Geräte etwas zäh.

letzten punkt beobachte ich bei mir auch, dabei sehe ich folgende auffällige meldungen im syslog (ja, das ist von einem externe syslog-server).

Code: Alles auswählen

2018-12-02T19:54:44.402693+01:00 hmserver: de.eq3.cbcs.legacy.bidcos.rpc.LegacyServiceHandler TRACE [vert.x-worker-thread-2] RPCMethod: getValue called 000D1709A59368:12 -> STATE 
2018-12-02T19:54:44+01:00 ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000D1709A59368:12","STATE"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: STATE"] [iseXmlRpc.cpp:2605]
2018-12-02T19:54:44.416450+01:00 hmserver: de.eq3.cbcs.legacy.bidcos.rpc.LegacyServiceHandler TRACE [vert.x-worker-thread-0] RPCMethod: getDeviceDescription called for 000D1709A59368 
2018-12-02T19:54:44.417564+01:00 hmserver: de.eq3.cbcs.legacy.bidcos.rpc.LegacyServiceHandler TRACE [vert.x-worker-thread-0] RPCMethod: getDeviceDescription called finished for 000D1709A59368 
2018-12-02T19:54:44+01:00 ReGaHss: Info: IseXmlRpc::CallXmlrpcMethod: method =getDeviceDescription params = {"000D1709A59368"} result = [ADDRESS:"000D1709A59368",AES_ACTIVE:1,AVAILABLE_FIRMWARE:"0.0.0",CHILDREN:{"000D1709A59368:0","000D1709A59368:1","000D1709A59368:2","000D1709A59368:3","000D1709A59368:4","000D1709A59368:5","000D1709A59368:6","000D1709A59368:7","000D1709A59368:8","000D1709A59368:9","000D1709A59368:10","000D1709A59368:11","000D1709A59368:12","000D1709A59368:13","000D1709A59368:14","000D1709A59368:15","000D1709A59368:16","000D1709A59368:17","000D1709A59368:18","000D1709A59368:19","000D1709A59368:20","000D1709A59368:21","000D1709A59368:22","000D1709A59368:23","000D1709A59368:24","000D1709A59368:25","000D1709A59368:26","000D1709A59368:27","000D1709A59368:28","000D1709A59368:29","000D1709A59368:30","000D1709A59368:31","000D1709A59368:32","000D1709A59368:33","000D1709A59368:34","000D1709A59368:35","000D1709A59368:36","000D1709A59368:37","000D1709A59368:38","000D1709A59368:39","000D1709A59368:40","000D1
also einen ReGaHss Error. bis ca 20:04 hats dann gedauert bis die seite vollständig war, um 20:07 konnte ich die komponenten dann wie gewohnt bedienen.

falls wer mein debug/trace log haben will, gerne, da ist aber alles drinn. ein log mit nur einem HmIP device kann ich frühestens am mittwoch liefern.
RaspberryMatic 3.41.11.20181126 on Charly with Pi 3B+ binded by openHAB 2.4.0 M7
Wahrheit kann erst wirken, wenn der Empfänger für sie reif ist. Nicht an der Wahrheit liegt es daher, wenn die Menschen noch so voller Unweisheit sind. Alle Geheimnisse liegen in vollkommener Offenheit vor uns. Nur wir stufen uns gegen sie ab, vom Stein bis zum Seher. Es gibt keine Geheimnisse an sich, es gibt nur Uneingeweihte aller Grade. (Christian Morgenstern)

Schattenschimmer
Beiträge: 117
Registriert: 20.03.2016, 20:49

Re: Anlernen von Homematic IP-Geräten an RaspberryMatic

Beitrag von Schattenschimmer » 02.12.2018, 21:13

hoedlmoser hat geschrieben:
02.12.2018, 20:12
lass mich das mal zusammenfassen: anlernen des HmIP-BSL nur wenn der 3B+ auf 1200 MHz heruntergetaktet ist, betrieb oder neuerliches anlernen funktioniert aber auch mit der standardfrequenz des 3B+ von 1400 MHz.
unabhängig von der frequenz des 3B+ ist Status und Bedienung > Geräte etwas zäh.

letzten punkt beobachte ich bei mir auch, dabei sehe ich folgende auffällige meldungen im syslog (ja, das ist von einem externe syslog-server).
[...]
Im Grunde korrekt zusammengefasst.
Beim letzten Punkt jedoch, der mit der zähen Bedienung, bin ich noch nicht ganz sicher.
Ich halte es für möglich, daß die Bedienung träge ist, wenn der Raspi 3B+ während des Anlernens oder danach mal zwischendurch auf 1400MHz lief.
Ich weiß noch nicht, wie gut bei mir der BSL funktioniert, wenn der 3B+ dauerhaft auf 1200MHz läuft. Einen Test über mehrere Stunden/Tage habe ich vorhin gestartet.

Ich habe übrigens den Raspi seit gestern Abend dauerhaft auf 1400MHz laufen lassen. Heute vormittag war der BSL nicht mehr in der Geräteliste. Er war weg, einfach so.
BSL wieder angelernt (ging spontan) und ein Programm geschrieben, mit dem eine LED des BSL nach Tastendruck am BSL ein- und ausgeschaltet wird. Eine Art kleiner Selbsttest.
Vorhin komme ich nach Hause, der BSL ist wieder aus der Geräteliste verschwunden. Das Programm ist ebenfalls verschwunden, funktioniert aber noch.
Ich habe die Taktfrequenz auf 1200MHz gebremst, einen Kaltstart des Raspi durchgeführt und der BSL war als neues Gerät gelistet. Programm natürlich futsch.
Sicherheitshalber habe ich den BSL zurückgesetzt und bei 1200MHz neu angelernt. So lasse ich den Raspi jetzt einige Zeit laufen.

Ich möchte wissen, ob das System bei 1200MHz nun stabil funktioniert oder ob der BSL wieder Geist spielt und einfach aus der Geräteliste verschwindet.
NAT ist heutzutage keine sicherere Technik, um Netzwerkgeräte aus dem www erreichbar zu machen!

Benutzeravatar
jmaus
Beiträge: 3690
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Kontaktdaten:

Re: Anlernen von Homematic IP-Geräten an RaspberryMatic

Beitrag von jmaus » 02.12.2018, 23:01

Kannst du mal bitte sagen welches Funkmodul du benutzt und welches Netzteil und wo genau du das angeschlossen hast (Funkmodul oder via microUSB an den RaspberryPi?)
RaspberryMatic 3.41.11.20181126 @ TinkerS mit ~150 HomeMatic Geräten + ioBroker – GitHubPayPal

Schattenschimmer
Beiträge: 117
Registriert: 20.03.2016, 20:49

Re: Anlernen von Homematic IP-Geräten an RaspberryMatic

Beitrag von Schattenschimmer » 03.12.2018, 22:04

Am Test-Raspi 3B+ nutze ich aktuell das kleine, alte Funkmodul und ein 3A-USB-Netzteil.
Daraus resultiert der Anschluß via Mikro-USB ;)

Auf 1200MHz und nach ca. 24h hat dieser 3B+ den Test-BSL noch nicht "vergessen", auch nach drei Kaltstarts keine Funktionseinschränkung am BSL erkennbar. Ich lasse ihn noch weiterlaufen.
Zur Erinnerung: Vorgestern/Gestern bei 1400MHz hatte dieser 3B+ den BSL 2x nach je ca. 12h (da ist es mir aufgefallen) nicht mehr in der Geräteliste.
NAT ist heutzutage keine sicherere Technik, um Netzwerkgeräte aus dem www erreichbar zu machen!

Schattenschimmer
Beiträge: 117
Registriert: 20.03.2016, 20:49

Re: Anlernen von Homematic IP-Geräten an RaspberryMatic

Beitrag von Schattenschimmer » 05.12.2018, 20:30

Zwei Tage später: Der BSL und der auf 1200MHz gedrosselte Raspi 3B+ funktionieren unauffällig, keine Probleme erkennbar.

Mein persönliches Fazit: Der Raspi 3B+ funktioniert gut, wenn er auf 1200MHz gedrosselt wird.
Erfahrungen von anderen Usern wären super!
NAT ist heutzutage keine sicherere Technik, um Netzwerkgeräte aus dem www erreichbar zu machen!

Gluehwurm
Beiträge: 8664
Registriert: 19.03.2014, 00:37

Re: Anlernen von Homematic IP-Geräten an RaspberryMatic

Beitrag von Gluehwurm » 05.12.2018, 20:33

Immer schauen, daß man vor lauter unsinniger Signatur den eigentlichen Kommentar noch findet :roll:

Gruß
Bruno

Schattenschimmer
Beiträge: 117
Registriert: 20.03.2016, 20:49

Re: Anlernen von Homematic IP-Geräten an RaspberryMatic

Beitrag von Schattenschimmer » 05.12.2018, 23:00

fixed.

Schlimm zu sehen, wie viele hm-System im www erreichbar sind.... :shock:
NAT ist heutzutage keine sicherere Technik, um Netzwerkgeräte aus dem www erreichbar zu machen!

Antworten

Zurück zu „RaspberryMatic“