[GELÖST] USV via USB an RaspberryMatic (NUT Server)

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Duesendaniel
Beiträge: 15
Registriert: 28.10.2017, 17:27

Re: [GELÖST] USV via USB an RaspberryMatic (NUT Server)

Beitrag von Duesendaniel » 17.07.2018, 10:59

Die Powerwalker USV VI650SH verträgt sich wohl nicht mit dem Treiber usbhid-ups,
daher die fehlenden Werte und die falsche Statusanzeige im WinNUT Client.

Code: Alles auswählen

/usr/local/etc/config/nut$ upsc -L
vi650sh: VI650SH

/usr/local/etc/config/nut$ upsc vi650sh@localhost
battery.charge: 100
battery.runtime: 3600
battery.type: PbAc
battery.voltage: 14
device.mfr: PPC
device.model: Offline UPS
device.serial: 000000000   
device.type: ups
driver.name: usbhid-ups
driver.parameter.pollfreq: 30
driver.parameter.pollinterval: 2
driver.parameter.port: auto
driver.parameter.synchronous: no
driver.version: 2.31.25.20180625-58-gb99cf5b
driver.version.data: Phoenixtec/Liebert HID 0.3
driver.version.internal: 0.41
ups.load: 9
ups.mfr: PPC
ups.model: Offline UPS
ups.productid: ffff
ups.serial: 000000000   
ups.status: OL CHRG
ups.vendorid: 06da
Die Alarmmeldungen funktionieren, das Herunterfahren des RPi habe ich noch nicht getestet.
RM RPI 3, S.USV, HM-MOD-RPI-PCB; RPI 3, RPI-RF-MOD; externe Antennen; USV; 24 Geräte HM/HMIP

Duesendaniel
Beiträge: 15
Registriert: 28.10.2017, 17:27

Re: [GELÖST] USV via USB an RaspberryMatic (NUT Server)

Beitrag von Duesendaniel » 03.08.2018, 07:20

Ich habe den Versuch mit der Powerwalker USV VI650SH erst mal abgebrochen,
da es täglich zu Kommunikationsabbrüchen kam und Alarmzone 1 ausgelöst wurde.
Kommunikation USV/RPi war nur durch Aus-/Einstecken des USB Kabels an der USV
wieder aktivierbar. Ob die USV der Verursacher der Kommunikationsabrüche war,
muss ich bei Gelegenheit irgendwie mal testen.
RM RPI 3, S.USV, HM-MOD-RPI-PCB; RPI 3, RPI-RF-MOD; externe Antennen; USV; 24 Geräte HM/HMIP

4_motion
Beiträge: 25
Registriert: 24.01.2016, 12:13

Re: [GELÖST] USV via USB an RaspberryMatic (NUT Server)

Beitrag von 4_motion » 21.10.2018, 17:03

Hallo Jens,

ich habe es genauso wie Du auch, USV an Synology und IP vom Raspi in der Synology eingetragen. Wie bekomme ich in der Homematic jetzt einen Status der USV, den ich in Programmen auswerten kann. Ich habe im Forum in Google gesucht, aber nichts gefunden, was mir hilft (wenn ich nichts übersehen habe). Es wäre schöne, wenn Du mir das mal beschreiben könntest.

Vielen Dank

Myron
Beiträge: 15
Registriert: 01.11.2018, 20:34

Re: [GELÖST] USV via USB an RaspberryMatic (NUT Server) - APC Back-UPS BX950UI funktioniert

Beitrag von Myron » 29.11.2018, 09:18

Hallo,

so, um mal wieder auf das ursprüngliche Thema zurückzukommen (ja, es geht hier um die direkte Anbindung per USB, NICHT per Netzwerk! :x ), und weil hier jemand danach gefragt hat, ob die APC Back-UPS BX-Serie am RaspberryMatic funktioniert, und ich nirgendwo eine Antwort finden konnte:

Ja, das funktioniert!
APC Back-UPS BX950UI
RaspberryMatic Version 3.41.11.20181126

Und damit nachfolgende Menschen nicht wieder so viel Zeit für Recherche investieren müssen, dokumentiere ich das hier mal:

Ich nutze seit gestern eine APC Back-UPS BX950UI an meiner RaspberryMatic, zusammen mit einem GigaCube, VoIP-Basisstation von Gigaset und einem kleinen Netzwerk-Switch, hängt nun eine Leistung von 14W an dieser USV. Zumindest nach Angabe von "PowerChute Personal Edition".
Diese USV ist mittels USB mit der RaspberryMatic verbunden.

Ich bin dabei weitestgehend gemäß dieser Anleitung vorgegangen:
https://files.elv.com/Assets/Produkte/1 ... _v2_um.pdf

Jedoch habe ich den Schritt "Filesystem auf rw mounten" übersprungen, weil der nicht notwendig war.
Denn ich habe nicht mit WinSCP gearbeitet, sondern ich habe per SSH auf der Konsole zur Editierung "nano" genutzt, weil ich mich mit dem gut auskenne und üblicherweise nutze.
nano ist standardmäßig NICHT bei RaspberryMatic installiert. Der muss als Addon hinzugefügt werden: viewtopic.php?t=43703


Ich habe nur Dateien in diesem Verzeichnis geändert:
/usr/local/etc/config/nut

Hier zur Doku, welche Dateien ich geändert habe:

Hinweis 1: Ich habe in diesen Dateien nach den passenden Parametern gesucht und diese auskommentiert und geändert.
Hinweis 2: Ich habe die Bezeichnung "apcbx950ui" gewählt. Das ist aber nur eine Art Alias, für die Funktion absolut irrelevant. Die könnte man auch problemlos z.B. "usv" oder "hanswurst" nennen.


Datei "ups.conf":

Code: Alles auswählen

[apcbx950ui]
driver = usbhid-ups
port = auto
desc = "USB UPS"

Datei "nut.conf":

Code: Alles auswählen

MODE=netserver

Datei "upsd.conf":

Code: Alles auswählen

LISTEN localhost 3493
LISTEN 192.168.1.222 3493

Datei "upsd.users":

Code: Alles auswählen

[upsmon]
		password  = 1111
		upsmon master

Datei "upsmon.conf":

Code: Alles auswählen

MONITOR apcbx950ui@localhost 1 upsmon 1111 slave

--> Anschließend RaspberryMatic neu starten (die USV muss natürlich zuvor per USB angeschlossen worden sein).


Nach dem Start eine Funktionskontrolle durchführen:
1. per SSH verbinden

2. folgenden Befehl eingeben:

Code: Alles auswählen

upsc apcbx950ui@localhost


Es sollte eine Ausgabe dieser Art erfolgen:

Code: Alles auswählen

battery.charge: 100
battery.charge.low: 10
battery.charge.warning: 50
battery.date: 2001/09/25
battery.mfr.date: 2018/07/16
battery.runtime: 12664
battery.runtime.low: 120
battery.type: PbAc
battery.voltage: 14.1
battery.voltage.nominal: 12.0
device.mfr: American Power Conversion
device.model: Back-UPS XS 950U
device.serial: ******************
device.type: ups
driver.name: usbhid-ups
driver.parameter.pollfreq: 30
driver.parameter.pollinterval: 2
driver.parameter.port: auto
driver.parameter.synchronous: no
driver.version: 3.41.11.20181124-9-g92b40b03
driver.version.data: APC HID 0.96
driver.version.internal: 0.41
input.sensitivity: medium
input.transfer.high: 280
input.transfer.low: 155
input.voltage: 230.0
input.voltage.nominal: 230
ups.beeper.status: disabled
ups.delay.shutdown: 20
ups.firmware: 925.T2 .I
ups.firmware.aux: T2
ups.load: 1
ups.mfr: American Power Conversion
ups.mfr.date: 2018/07/16
ups.model: Back-UPS XS 950U
ups.productid: 0002
ups.realpower.nominal: 480
ups.serial: *********************
ups.status: OL
ups.test.result: No test initiated
ups.timer.reboot: 0
ups.timer.shutdown: -1
ups.vendorid: 051d

Sieht somit schon mal alles gut aus. :D


Wie im Handbuch steht, und hier auch schon irgenwo jemand erwähnt hat, sollte man bei dieser geringen Last noch die Einstellung der USV ändern. Denn im Handbuch steht:
"Wenn sich die USV im Batteriebetrieb befindet und erkennt, dass die angeschlossenen Geräte über einen Zeitraum von mehr als 15 Minuten weniger als 15W aufnehmen, schaltet sie sich zum Ernergiesparen aus. [...]"

Mit meinen 14W liege ich knapp darunter, löaufe somit Gefahr, dass sich die USV zu früh abschaltet. :shock:

Wie in der Anleitung unter Punkt 5, "Automatische Spannungsregelung" beschrieben, habe ich meine USV entsprechend umgestellt auf die folgende Einstellung:
Spannungsempfindlichkeit "Mittel"
Abschalten bei Fehlen einer Last: "Deaktiviert"
(LED blinkt Rot / kein akustisches Signal)


Gruß
Myron

Antworten

Zurück zu „RaspberryMatic“