[GELÖST] Wochenprogramm für HmIP wird nicht abgespeichert

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

jojota
Beiträge: 3
Registriert: 14.11.2017, 16:35

Re: [GELÖST] Wochenprogramm für HmIP wird nicht abgespeicher

Beitrag von jojota » 14.11.2017, 18:23

Super, funktioniert!

beckerpa
Beiträge: 57
Registriert: 15.04.2018, 08:34
Wohnort: 56329 St. Goar
Hat sich bedankt: 3 Mal

Re: [GELÖST] Wochenprogramm für HmIP wird nicht abgespeicher

Beitrag von beckerpa » 15.04.2018, 09:04

jmaus hat geschrieben:Danke für's überprüfen. Dann wird es wohl zum kommenden Wochenende ein neues Release geben müssen :)

Achja, und dein Einzeiler könnte man noch wie folgt verbessern:

Code: Alles auswählen

mount -o remount,rw / && echo "server.max-request-field-size = 65536" >> /etc/lighttpd/lighttpd.conf && mount -o remount,ro / && /etc/init.d/S50lighttpd restart
:)
Hallo zusammen, hallo Jens.

Vorweg - vllt. war ich ein wenig voreilig und hätte das auf Grund der neuesten Software gar nicht machen dürfen.

Zum Problem:

Bin gerade dabei eine Klimaanlage einzubinden über IO-Broker auf Raspberrymatic, quasi soll in die Steuerung ein Zeitprofil von HmIP-BWTH umgesetzt werden.
Soweit, so gut- funktioniert auch einwandfrei, bis ich heute morgen versucht habe, Zeitprofile 2-6 zu programmieren, leider übernimmt das Ding diese nicht.
Also mit anderen Räumen probiert, auch ohne Erfolg. Die Zeiten werden übernommen, die Temperaturen selbstständig ersetzt.

Also habe ich im Forum geschaut nach ner Problemlösung und diesen Post gefunden und umgesetzt.
Nun habe ich leider keinen Zugriff mehr auf die WEB-UI, bzw. Fernzugriff (Tinymatic).

Per Putty komme ich noch auf den Raspberry drauf.

Vllt. kann mir jemand auf die Sprünge helfen.

Vielen Dank im Voraus und nen schönen Sonnatag.

Patrick
Raspi 3B mit RaspberryMatic mit 104 Geräten HmIP, 29 Geräten HM, CUxD, hm_pdetect, 98 Programmen
Raspi 4B mit ioBroker
HmIP AP mit 79 Geräten

Benutzeravatar
jmaus
Beiträge: 7218
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 183 Mal
Danksagung erhalten: 730 Mal
Kontaktdaten:

Re: [GELÖST] Wochenprogramm für HmIP wird nicht abgespeicher

Beitrag von jmaus » 15.04.2018, 10:53

beckerpa hat geschrieben: Vllt. kann mir jemand auf die Sprünge helfen.
Du scheinst ja inzwischen anscheinend ungeduldig gewesen zu sein und hast einen Duplikat-Post eröffnet (bitte sowas in Zukunft unterlassen). Dort hatte ich ja bereits die Lösung des Problems benannt:
Die Lösung des Problems is hingegen einfach. Einfach Backup machen, img neu auf SD karte machen und dann backup zurückspielen. Und in Zukunft die Finger von solchen Dingen lassen wenn man nicht exakt weiss was diese anrichten können...
RaspberryMatic 3.57.5.20210424 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

beckerpa
Beiträge: 57
Registriert: 15.04.2018, 08:34
Wohnort: 56329 St. Goar
Hat sich bedankt: 3 Mal

Re: [GELÖST] Wochenprogramm für HmIP wird nicht abgespeicher

Beitrag von beckerpa » 15.04.2018, 12:17

Wenn ich ehrlich bin, ja. Dachte weil dort [GELÖST] steht, war der Post falsch, deshalb der neue.
Sorry, ist mein erstes Forum, bin aber lernwillig.

Vielen Dank für deine Antwort, das war wohl die schnellste Lösung des kompletten Problems. Läuft alles noch schneller als vorher und komischerweise werden jetzt die Heizprofile auch übernommen.
Muss man nicht verstehen denke ich.

Angefangen hat das ganze gestern, habe in einem Programm, welches auf eine Sysvariable reagiert (Klimasteuerung) festgelegt, dass ein Aktor die Spannungsversorgung herstellt und das Wandthermostat auf Kühlen stellt. (Rest anderer Raspberry mit IOBroker)
Das verursachte einen ziemlichen Absturz, in den Griff zu bekommen nur durch ein schnell angelegtes Programm, welches ich aus der App startete und schnell bevor alles gestartet wurde den WTH wieder auf heizen umstellte.
Danach lief alles wieder wunderbar, bis ich mich heute morgen an die Heizprofile setzte.

Traue mich schon gar nicht mehr den anzusteuern und auf "kühlen" zu setzen.


Also nochmals vielen Dank, auch für das Super-Image und deine hervorragende Arbeit!

Schönen Sonntag noch.

Gruß
Patrick
Raspi 3B mit RaspberryMatic mit 104 Geräten HmIP, 29 Geräten HM, CUxD, hm_pdetect, 98 Programmen
Raspi 4B mit ioBroker
HmIP AP mit 79 Geräten

binzi
Beiträge: 5
Registriert: 19.06.2019, 16:40
Danksagung erhalten: 1 Mal

Re: [GELÖST] Wochenprogramm für HmIP wird nicht abgespeichert

Beitrag von binzi » 19.06.2019, 16:50

Ich hole den etwas älteren Thread mal hoch, da bei mir das gleiche Problem auftritt und mich jede Google Suche wieder auf diesen Thread bringt.

Ich bin aktuell auf Raspberrymatic mit Firmwareversion 3.45.7.20190511 und habe 6 HmIP-BROLL im Einsatz. Steuerung per Taster, Programm usw. funktioniert zuverlässig.

Wenn ich ein Wochenprogramm erstelle und es mit "ok" an den BROLL übertragen möchte, bleibt die Oberfläche ewig bei "Geräte/Kanaleinstellungen werden an Komponenten übertragen..." hängen. Die "Knight Rider Anzeige" geht fleissig hin und her, es passiert aber nichts mehr. Im Syslog finde ich keine Fehlermeldungen. Das Wochenprogramm wird auch nach längerem Warten nicht übertragen.


Laut cat /etc/lighttpd/lighttpd.conf stimmt die Größe des Request Headers:

##
## Maximum size of a request headers in kilobytes.
## By default it is 8k (8192).
##
## Requests with a header larger than this will end in a 431 error.
##
server.max-request-field-size = 65536


Hat jemand eine Idee, woran das liegen könnte?

binzi
Beiträge: 5
Registriert: 19.06.2019, 16:40
Danksagung erhalten: 1 Mal

Re: [GELÖST] Wochenprogramm für HmIP wird nicht abgespeichert

Beitrag von binzi » 19.06.2019, 21:30

Sieht so aus, als hätte ich es gelöst: Es liegt anscheinend daran, dass ich von remote über cloudmatic auf den Raspberry zugegriffen habe. Wenn ich im lokalen WLAN direkt auf den Raspi gehe, funktioniert es. Ich prüfe nochmal, ob es evtl. an verschiedenen Endgeräten, Browsern oder Browsercache gelegen hat. Aktuell sieht es aber nach dem Zugriff über cloudmatic aus.

dehell
Beiträge: 50
Registriert: 14.10.2014, 12:35

Re: [GELÖST] Wochenprogramm für HmIP wird nicht abgespeichert

Beitrag von dehell » 14.08.2020, 11:49

binzi hat geschrieben:
19.06.2019, 21:30
Sieht so aus, als hätte ich es gelöst: Es liegt anscheinend daran, dass ich von remote über cloudmatic auf den Raspberry zugegriffen habe. Wenn ich im lokalen WLAN direkt auf den Raspi gehe, funktioniert es. Ich prüfe nochmal, ob es evtl. an verschiedenen Endgeräten, Browsern oder Browsercache gelegen hat. Aktuell sieht es aber nach dem Zugriff über cloudmatic aus.
Da wäre ich ja NIE drauf gekommen!! Ich habe das gleiche Problem mit dem neuen Dreifachdimmer HmIP-DRDI3 und dachte, da fehlt evtl. noch eine Umsetzung in der CCU / Raspberry.
Ich probiere heute noch aus, ob die Übertragung lokal geht.

Danke für den Hinweis.

Bitjoe
Beiträge: 8
Registriert: 09.11.2019, 06:09
Hat sich bedankt: 1 Mal

Re: [GELÖST] Wochenprogramm für HmIP wird nicht abgespeichert

Beitrag von Bitjoe » 29.03.2021, 21:23

Scheinbar ein "altes" Problem, neu aufgetaucht. Ursache scheint aber eine andere zu sein:

Bei meinen HmIP-Broll lassen sich die Wochenprogramme nicht mehr speichern.
Bekomme ebenfalls den "Ladebalken" das die Einstellungen an die Komponenten übertragen werden, der Duty-Cycle steigt auch fleissig.
Gespeichert wird aber nichts.

Der Wert in der lighttpd.conf ist wie oben beschrieben gesetzt.

Woran könnte es noch liegen ?
Firmware 3.57.4.20210320

Benutzeravatar
jmaus
Beiträge: 7218
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 183 Mal
Danksagung erhalten: 730 Mal
Kontaktdaten:

Re: [GELÖST] Wochenprogramm für HmIP wird nicht abgespeichert

Beitrag von jmaus » 29.03.2021, 21:26

Bitjoe hat geschrieben:
29.03.2021, 21:23
Scheinbar ein "altes" Problem, neu aufgetaucht. Ursache scheint aber eine andere zu sein:
[...]
Woran könnte es noch liegen ?
Firmware 3.57.4.20210320
Genau daran liegt es. Downgrade auf die Vorversion oder abwarten bis die neue Version rauskommt (Mitte April) oder ein nightly build auf eigene Gefahr einsetzen. Mehr Details dazu hier:

https://github.com/jens-maus/RaspberryMatic/issues/1189
RaspberryMatic 3.57.5.20210424 @ ESXi, ~190 Hm-RF/HmIP-RF/HmIPW Geräte, ioBroker – RaspberryMatic GitHub Projekt / Twitter

Baxxy
Beiträge: 3167
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 229 Mal
Danksagung erhalten: 531 Mal

Re: [GELÖST] Wochenprogramm für HmIP wird nicht abgespeichert

Beitrag von Baxxy » 29.03.2021, 21:28

Bitjoe hat geschrieben:
29.03.2021, 21:23
Woran könnte es noch liegen ?
Es könnte daran liegen das dies ein Bug in der aktuellen RaspberryMatic ist. Nachzulesen irgendwo im Thread zur aktuellen Version, oder hier.

Antworten

Zurück zu „RaspberryMatic“