Problem: HUE virtuelles Gerät nicht löschbar

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

cerberus
Beiträge: 27
Registriert: 09.11.2009, 17:02

Re: Problem: HUE virtuelles Gerät nicht löschbar

Beitrag von cerberus » 26.10.2018, 18:32

alchy hat geschrieben:
26.10.2018, 18:29
cerberus hat geschrieben:
26.10.2018, 18:20
taucht aber nach dem Neustart wieder auf
Nach einem regulärem Neustart oder Steckerziehen?

Alchy
Nach einem regulärem Neustart unter Zentralen-Wartung

Kai_2
Beiträge: 41
Registriert: 03.11.2013, 12:51

Re: Problem: HUE virtuelles Gerät nicht löschbar

Beitrag von Kai_2 » 27.10.2018, 14:48

cerberus hat geschrieben:
26.10.2018, 18:20
Kai_2 hat geschrieben:
21.10.2018, 09:41
acidoverflow hat geschrieben:
12.10.2018, 23:24
Moin,

da auch ich immer mal wieder vor dem Problem stehe und viel rumprobiert habe, nochmal der Hinweis auf das Skript von tubozz viewtopic.php?f=65&t=43690#p435781
:?
´´
Super, jetzt bin ich endlich die letzten zwei Leuchten los, die sich nicht löschen lassen wollten.
Das Gerät wird zwar gelöscht taucht aber nach dem Neustart wieder auf :?
Stimmt, bei mir sind sie auch wieder da und ich bekomme sie nicht weg.
Screenshot_2018-10-27 Channel List.png
Beim löschen über devconfig kommt nur die Meldung: An internal error was detected in the service software. The diagnostics are being emailed to the service system administrator (root).

Benutzeravatar
NilsG
Beiträge: 949
Registriert: 09.08.2013, 23:44
Hat sich bedankt: 14 Mal
Kontaktdaten:

Re: Problem: HUE virtuelles Gerät nicht löschbar

Beitrag von NilsG » 28.10.2018, 17:06

Hallo ...

Wie ist denn nun der Stand der Dinge?!
Klappt das mit dem Script???

so wie die letzten Schilderungen sind/waren, funktioniert es ja nicht, bzw. ist es genau so, als würde man die Leuchten in der Geräteliste löschen und nach dem Neustart sind die wieder da ... :(

Nils

andybau
Beiträge: 78
Registriert: 18.11.2014, 18:29

Re: Problem: HUE virtuelles Gerät nicht löschbar

Beitrag von andybau » 30.10.2018, 22:39

Das selbe Problem habe ich auch. Über die WebUI hatte ich zuvor zwei Geräte nicht löschen können.
Genau diese beiden virtuellen Hue Geräte funktionierten auch nicht korrekt. Beide Lampen ließen sich nicht bedienen.

Habe es nun mit Hilfe dieses Script probiert. Schien auch erstmal geklappt zu haben.
Die nicht löschbaren Hue Geräte wurden entfernt.

Jetzt das aber:
Nach Neustart der CCU waren sämtliche zuvor gelöschten virtuellen Hue Geräte wieder in der Geräteliste.

Nun die Frage:
Wie werde ich diese wieder los?

alchy
Beiträge: 8601
Registriert: 24.02.2011, 01:34
Hat sich bedankt: 6 Mal
Danksagung erhalten: 54 Mal

Re: Problem: HUE virtuelles Gerät nicht löschbar

Beitrag von alchy » 30.10.2018, 22:48

Ich weiß das tubozz sich in Südafrika rumtreibt. Der wird wie üblich wieder mal komplett außerhalb der Zivilisation unterwegs sein und gaaaanz sicher hier nicht mitlesen.

Das Löschen von Objekten wie im Script funktioniert aber normalerweise durchaus so.
Ich selber habe aber keine Hue Anbindung und kann es damit nicht nachvollziehen.
Bleiben noch andere User....

Alchy

...................
Ignoranz ist die Summe aller Maßnahmen die man ergreift, um bestehende Tatsachen nicht sehen zu müssen.

© Sandra Pulsfort (*1974)

Lies bitte die Logik von WebUI Programmen und die Tipps und Tricks für Anfänger.

Wichtig auch CUxD ersetzt System.exec. Die HM Script Doku (Downloadart Skripte) hilft auch weiter.
Zum Testen von Scripten den >> HomeMatic Script Executor << von Anli benutzen.

pedromania
Beiträge: 12
Registriert: 17.02.2017, 22:21

Re: Problem: HUE virtuelles Gerät nicht löschbar

Beitrag von pedromania » 30.10.2018, 23:24

Guten Tag,

ich hatte das gleiche Problem.

mit diesem Script habe ich die virt. Hue-Geräte endgültig (auch nach einem Raspi-Neustart) löschen können.

viewtopic.php?f=26&t=46271&p=463045&hil ... en#p463078

Viele Grüße
Pedromania

andybau
Beiträge: 78
Registriert: 18.11.2014, 18:29

Re: Problem: HUE virtuelles Gerät nicht löschbar

Beitrag von andybau » 30.10.2018, 23:29

Genau das Script habe ich benutzt

cerberus
Beiträge: 27
Registriert: 09.11.2009, 17:02

Re: Problem: HUE virtuelles Gerät nicht löschbar

Beitrag von cerberus » 11.11.2018, 18:02

Im ersten Moment ist es weg. Mache ich einen Neustart und aktualisiere nochmal die Seite mit der Geräteliste, ist der Eintrag wieder da. :(

NoRiskNoFun
Beiträge: 2
Registriert: 29.08.2019, 23:38

Re: Problem: HUE virtuelles Gerät nicht löschbar

Beitrag von NoRiskNoFun » 29.08.2019, 23:50

Also ich glaube ich habe des Rätsels Lösung gefunden :roll:

Der Fehler kommt aus dem Philips Hue Gateway. Von dort werden immer wieder die "fehlerhaften Geräte" ausgelesen.

Also als erstes den Philips Hue Gateway in den Werkszustand zurück setzen.

Auf der CCU den inhalt des verzeichnisses /etc/config/eshlight löschen und die CCU neustarten.
Danach sind alle Philips Hue Geräte einschließlich des Gateway verschwunden, nur die "fehlerhaften" sind noch da.

danach das Script ausführen.

Code: Alles auswählen

object obj = dom.GetObject("Name des fehlerhaften Geräts");
if(obj){
WriteLine("Object vorhanden");
dom.DeleteObject(obj.ID());
WriteLine("Object gelöscht");
! system.Save()
! WriteLine("Regadom gespeichert");
}else{WriteLine("Object ist nicht vorhanden");}
CCU neu starten, und bei mir war alles verschwunden.

Danach hab ich meine 4 Hue's am Gateway neu angelernt und die Kopplung durchgeführt,
und nun sind nur noch die Geräte in der CCU, die auch Funktion haben.

Antworten

Zurück zu „RaspberryMatic“