Wired / RS485 reagiert langsam

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Benutzeravatar
Wortmann30
Beiträge: 1238
Registriert: 21.03.2014, 21:39

Wired / RS485 reagiert langsam

Beitrag von Wortmann30 » 03.07.2018, 17:08

Hallo zusammen,

ich habe bei mir ca. 180 Geräte in Betrieb alles HM RF und HM wired, keine HMIP.
Ich arbeite derzeit Pi2 und Raspberrymatic 2.31.25.20180526.

Mir ist aufgefallen das meine Wired Geräte teils sehr verzögert reagieren. Also wie dem Beispiel unten, da ist es so, ich drücke den Taster und erst verzögert um 2-3 Sec. wird die Aktion ausgeführt.
Das lässt den WAF leider sinken...

Wobei Z.B. ein HMW-LC-Dim1L-DR Dimmer oder ein HMW-LC-SW2-DR 2 Fach Schaltaktor die mit direktverknüpfungen zu bedienen sind, davon nicht betroffen sind. Nur Geräte wie das HMW-IO-12-Sw14-DR 14/12 Ein- Ausgangs Modul welches keine direktverknüpfungen kann ist dafür anfällig. Von diesen habe ich 3 Stück in Betrieb.
Also im Prinzip dinge die per Programm abgearbeitet werden zischen Wired zu Wired.

Hier ein Programm das unter anderen betroffen ist.
Unbenannt.JPG
Wenn aber einmal das Programm mit Verzögerung ausgeführt wurde reagiert es darauf wieder normal. Also ich schalte das Licht ein und kurz darauf wieder aus ist keine Verzögerung mehr da.
Bis nach einer längeren Pause von ein paar stunden das wieder vorkommen kann.

Was ich auch schon war, war das sich der RS485 Bus ganz verabschiedet hatte und auch die Direkt Verknüpfungen nicht mehr funktionierten. Da half nur 24VDC ausschalten und alles im RS485 Bus neu starten, ein Neustart der Pi war dabei nicht notwendig.
Diese Ausfälle hatte ich Zwei mal noch mit der Raspberrymatic Version 2.31.25.20180225 die bei mir bis zum Wechsel auf 2.31.25.20180526 104 Tage ohne Neustart durchlief! Das lässt den WAF sinken... :(

An der Hardware hatte ich diese Jahr noch gar nichts geändert. Auch Die Programme habe ich in den 104 Tagen eigentlich nicht angefasst da ich auf Grund von Zeitmangel nicht dazu kam.

Wie kann ich das Problem angehen, wo kann das Problem liegen.
Grüsse


To be continued...

Daimler
Beiträge: 5766
Registriert: 17.11.2012, 10:47
Wohnort: Köln

Re: Wired / RS485 reagiert langsam

Beitrag von Daimler » 04.07.2018, 23:17

Hi,

Wie sieht deine Wired Verkabelung aus - Bus oder Stern?
Welchen Abschlusswiderstand setzt du ein - hast du es einmal ohne getestet??
Wie ist das RS-Gateway auf der Lan-Seite verbunden?

Da Aktor interne DVs ja anscheinend funktioniern, glaube ich es zwar nicht- aber trotzdem die Frage:
Wie stabil ist die Wired-Spannungsversorgung?
Reagieren RF-Aktoren normal?
Gruß Günter

pivccx mit 2.35.16 in Produktiv, pivccx mit 3.43.15 Testsystem, Yahx 2.35.16 im 2. Testsystem, 3 * HPCx Studio 4.1,
4 * L-Gateway, 3 * RS-L-Gateway, FHZ200x, vereinzelt noch FS2x-Komponenten.
HM: Zur Zeit knapp 250 Komponenten mit ~ 650 Kanälen .

Ich übernehme für alle von mir gegebenen Hinweise, Tipps und Links keine Haftung! Das Befolgen meiner Tipps ist nur für Fachkundige gedacht und erfolgt auf eigene Gefahr!

Benutzeravatar
Wortmann30
Beiträge: 1238
Registriert: 21.03.2014, 21:39

Re: Wired / RS485 reagiert langsam

Beitrag von Wortmann30 » 05.07.2018, 12:50

Hi Günter,

Meine Bus Topologie hat sich nicht verändert es ist weitestgehend durchgeschleift bis auf eine Stelle an ein Wired RS485 I/O Modul mit 12 Eingängen das ich nicht durchschleifen konnte.
Der Abschluss Wiederstand ins am Ende des durchgeschleiften Busses in einem Überspannungsschutz integriert.
LAN seitig hängt der Gateway an einem 16er Gigabit Switch mit allen anderen HM Geräten zusammen.

An dieser Topologie hat sich auch nichts geändert sein ca. 1 Jahr. Das erste mal das sich der Bus so aufgehängt hat das gar nichts mehr geht war vor ca. 3 Monaten.

Zu den internen DV die funktionieren auch nicht im Fall eines Aufhängens das zwei mal vorgekommen ist in den 104 Betriebstagen.

Erst wieder nach Neustart der Spannungsversorgung (24VDC) welches von einem Pulse Netzteil 24VDC 3 A kommt also Power sollte mehr als genug da sein.

Was ich machen kann ich kann die Redundanz der Spannungsversorgung nutzen und das Zweite Netzteil mal anwerfen und ein paar Tage durchlaufen lassen um zu sehen ob die Verzögerungen weg sind. Aber ich kann es mir nur schwer vorstellen da diese Pulse Netzteile doch sehr robust sind und wenn sich ein Schaltnetzteil verabschiedet dann normalerweise ziemlich plötzlich.

Die RF Aktoren habe keine Verzögerung zumindest habe ich bisher keine wesentlichen Verzögerungen die vorher nicht auch schon waren festgestellt.
Grüsse


To be continued...

Daimler
Beiträge: 5766
Registriert: 17.11.2012, 10:47
Wohnort: Köln

Re: Wired / RS485 reagiert langsam

Beitrag von Daimler » 05.07.2018, 16:31

Hi Mr. G..,
Wortmann30 hat geschrieben:Zu den internen DV die funktionieren auch nicht im Fall eines Aufhängens
Wortmann30 hat geschrieben:Wobei Z.B. ein HMW-LC-Dim1L-DR Dimmer oder ein HMW-LC-SW2-DR 2 Fach Schaltaktor die mit direktverknüpfungen zu bedienen sind, davon nicht betroffen sind.
:?:
Wortmann30 hat geschrieben:Der Abschluss Wiederstand ins am Ende des durchgeschleiften Busses in einem Überspannungsschutz integriert.
Also ein HMW-Sys-OP-DR?
Ist zum. mein spezieller Freund - damit habe ich mir bereits ein RS-Lan-Gateway zerschossen und kommt mir nicht mehr an den Bus.
Wortmann30 hat geschrieben:Erst wieder nach Neustart der Spannungsversorgung (24VDC)....
Das muss ja nicht auf die SV hindeuten.
Denn mit dem Ab- / Anschalten resettest du mehr oder weniger alle W-Aktoren.
Wortmann30 hat geschrieben:An dieser Topologie hat sich auch nichts geändert sein ca. 1 Jahr.
Irgendwann geht halt immer irgendetwas defekt.

Ich würde es erst einmal mit einem anderen Abschluss (notfalls überhaupt keinem) testen.
Wenn das nicht hilft, wird dir verm. nichts anderes übrig bleiben als Aktor für Aktor abzunabeln und beobachten.

Es sei denn, du findest etwas Aussagekräftiges im (auf alles loggen eingestellten) Log!
Gruß Günter

pivccx mit 2.35.16 in Produktiv, pivccx mit 3.43.15 Testsystem, Yahx 2.35.16 im 2. Testsystem, 3 * HPCx Studio 4.1,
4 * L-Gateway, 3 * RS-L-Gateway, FHZ200x, vereinzelt noch FS2x-Komponenten.
HM: Zur Zeit knapp 250 Komponenten mit ~ 650 Kanälen .

Ich übernehme für alle von mir gegebenen Hinweise, Tipps und Links keine Haftung! Das Befolgen meiner Tipps ist nur für Fachkundige gedacht und erfolgt auf eigene Gefahr!

Benutzeravatar
Wortmann30
Beiträge: 1238
Registriert: 21.03.2014, 21:39

Re: Wired / RS485 reagiert langsam

Beitrag von Wortmann30 » 09.07.2018, 19:34

Daimler hat geschrieben:
05.07.2018, 16:31
Hi Mr. G..,
Wortmann30 hat geschrieben:Zu den internen DV die funktionieren auch nicht im Fall eines Aufhängens
Wortmann30 hat geschrieben:Wobei Z.B. ein HMW-LC-Dim1L-DR Dimmer oder ein HMW-LC-SW2-DR 2 Fach Schaltaktor die mit direktverknüpfungen zu bedienen sind, davon nicht betroffen sind.
:?:
Nee is klar... habe ich falsch erklärt.
Die DV funktionieren nur dann nicht wenn der Bus komplett aussteigt, das war jetzt schon 2 mal der fall.

Die Verzögerungen sind immer wieder. Haben also nichts driekt mit dem Aufhängen des Buses zu tun.
Daimler hat geschrieben:
05.07.2018, 16:31
Wortmann30 hat geschrieben:Der Abschluss Wiederstand ins am Ende des durchgeschleiften Busses in einem Überspannungsschutz integriert.
Also ein HMW-Sys-OP-DR?
Ist zum. mein spezieller Freund - damit habe ich mir bereits ein RS-Lan-Gateway zerschossen und kommt mir nicht mehr an den Bus.
Habe nun mal nen anderen Abschlusswiderstand drinnen, mir scheint es vielleicht etwas besser zu sein aber das kann auch nur Subjektiv sein.
Werde das noch ein paar Tage beobachten.
Sollte es nicht besser sein werde ich die Spannungsversorgung 24VDC mal auf die Sekundäre (Redundanz) legen mal sehen ob dann was besser wird.

Ich bleibe dran und werde berichten.
Grüsse


To be continued...

Daimler
Beiträge: 5766
Registriert: 17.11.2012, 10:47
Wohnort: Köln

Re: Wired / RS485 reagiert langsam

Beitrag von Daimler » 09.07.2018, 22:21

Hi,
Wortmann30 hat geschrieben:
09.07.2018, 19:34
Die DV funktionieren nur dann nicht wenn der Bus komplett aussteigt, das war jetzt schon 2 mal der fall.
Und genau das würde mir bei 'Geräteinternen' DVs zu denken geben.
Wired-erfahrenere User mögen mich korrigieren - aber hier sollte der Bus doch überhaupt keine Rolle spielen?
Gruß Günter

pivccx mit 2.35.16 in Produktiv, pivccx mit 3.43.15 Testsystem, Yahx 2.35.16 im 2. Testsystem, 3 * HPCx Studio 4.1,
4 * L-Gateway, 3 * RS-L-Gateway, FHZ200x, vereinzelt noch FS2x-Komponenten.
HM: Zur Zeit knapp 250 Komponenten mit ~ 650 Kanälen .

Ich übernehme für alle von mir gegebenen Hinweise, Tipps und Links keine Haftung! Das Befolgen meiner Tipps ist nur für Fachkundige gedacht und erfolgt auf eigene Gefahr!

Benutzeravatar
Wortmann30
Beiträge: 1238
Registriert: 21.03.2014, 21:39

Re: Wired / RS485 reagiert langsam

Beitrag von Wortmann30 » 10.07.2018, 11:58

Hi,

du hast recht aber in diesem Falle wenn die DV nicht gehen, gehen alle DV`s nicht mehr...

Meinst du das ein Gerät in die Suppe reinspuckt? Sollte dem so sein muss ich warten bis das wirklich oft auftritt. Denn eine Fehleranalyse auf so einen seltenen Fehler????

Das Log kann da vielleicht was dazu sagen im Falle...
Grüsse


To be continued...

darkbrain85
Beiträge: 792
Registriert: 27.06.2015, 22:17

Re: Wired / RS485 reagiert langsam

Beitrag von darkbrain85 » 11.07.2018, 16:03

Hast du eventuell zu viel traffic auf dem Bus?

Leider hat der Überspannungsschutz keine LED für die Aktivität. Der HMW-Sys-Tm-DR hat dagegen eine LED mit deren Hilfe man die Aktivität auf dem Bus besser überwachen kann.

Ich hatte mal einen ähnlichen Fall. Damals hat ein Tastereingang der permanent geriggert wurde, für erhebliche Last auf dem Bus geführt und damit zu Kollisionen und Kommunikationsstörungen. Die genauen Umstände weiss ich nicht mehr, daher kann ich nur empfehlen den oben genannten HMW-Sys-Tm-DR zu besorgen und den Abschluss an dem Überspannungsschutz zu deaktiveren. Im Ruhezustand sollte die LED aus bleiben und nur bei Aktivität blinken.

Vielleicht bringt es Dich irgendwie weiter....

stan23
Beiträge: 409
Registriert: 13.12.2016, 21:14
Wohnort: Altmühltal
Kontaktdaten:

Re: Wired / RS485 reagiert langsam

Beitrag von stan23 » 11.07.2018, 20:07

Wie ist das eigentlich mit der Aktivitäts-LED, ist die ganz simpel zwischen A und B geschaltet, oder mit einem OpAmp zur Entkopplung?
Viele Grüße
Marco

RaspberryMatic
~60 Geräte (HM, HmIP, HMW, HBW, AskSin)

shartelt
Beiträge: 2251
Registriert: 14.01.2015, 14:59

Re: Wired / RS485 reagiert langsam

Beitrag von shartelt » 11.07.2018, 22:05

ist es nicht normal, dass Programme diese Gedenksekunde haben im Vergleich zur Direktverknüpfung?

Zumindest bei meinen ausschließlich Funk sachen ist das so :)

Antworten

Zurück zu „RaspberryMatic“