Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Lutzemann66
Beiträge: 1
Registriert: 22.07.2018, 11:25

Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von Lutzemann66 » 22.07.2018, 11:41

Hallo

ich habe mir ein komplettes Set RB Pi 3 + mit neuer Funkplatine, SD-Karte (Intenso 4 GB) , Gehäuse und Netzteil als Bundle von ELV geholt und war nach der ersten Inbetriebnahme mit der neuesten Raspberrymatic 2.35.16.20180715 von Mitte Juli war ich sehr begeistert.

Leider änderte sich das nach kurzer Zeit :( , da die HM-Software (HMServer) nach RP-Neustart nicht mehr zuverlässig booten wollte. Die Fehlermeldung das der HMServer keine IP-Adresse gefunden hat, war mir unverständlich. Auf der Konsole habe ich herausgefunden, dass beim Booten immer wieder Schreibprobleme wegen Schreibschutz bestanden. SD-Karte war aber nicht schreibgeschützt! EIn neuflashen der Karte brachte dann Abhilfe.
Das kann doch aber nicht die Lösung sein, dass ich ständig wieder die Karte flashen muß!

Ich suche ein zuverlässiges System!
Hat jemand eine Idee?
LG
Lutzemann66

deimos
Beiträge: 2790
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Kontaktdaten:

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von deimos » 22.07.2018, 11:51

Hi,

für mich klingt das nach dem Beginn einer sterbenden SD Karte. Die Intensio Karten sind bei mir jetzt auch nicht unbedingt unter "sehr zuverlässig" eingeordnet, sondern eher unter billig.
Ich würde dir auf jeden Fall eine High Endurance Karte von einem Markenhersteller empfehlen. (Welche dann durchaus mal 20+ € kostet)

Viele Grüße
Alex

Icefeldt
Beiträge: 5
Registriert: 28.11.2017, 22:01

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von Icefeldt » 27.07.2018, 19:19

Gleiches Problem bei mir.
Jedoch mit einer Kingston 16Gb "Premium" SD Karte, welche vllt 6 Monate alt ist

Hab nun 2x schon neu geflasht.

Hab nun mal auf eine andere SD gewechselt und beobachte das Problem mal.

nicolas-eric
Beiträge: 3062
Registriert: 07.01.2015, 23:26
Wohnort: Scheeßel

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von nicolas-eric » 27.07.2018, 19:34

Ich hab in der RM seit Anfang an ne günstige 16er von Transcend drin.
Ohne Probleme.
Ne 8er von intenso ging im Homebridge Raspi auch recht schnell kaputt. Da steckt jetzt auch so eine von Transcend drin und es läuft ohne Probleme.

mcbert
Beiträge: 69
Registriert: 03.07.2018, 18:51

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von mcbert » 27.07.2018, 19:58

Nutze zwar pivccu, da gibt es soweit ich weiß mehr Möglichkeiten im Vergleich zu RMatic aber generell:
- es gibt tools zur Anzeige der Prozesse mit lese/schreibzugriffe (z.B. iotop, glaub das kannst du aber nicht installieren oder?)
- auf raspberry Seiten gibt es etliche Tipps zum Dauerbetrieb (z.B. logging deaktivieren, swapping abschalten, usb Stick für Schreibzugriffe....)

Evtl. kannst du so auch deine SD Karte noch etwas schonen.

Wie gesagt unter Vorbehalt da ich mit pivCCU unterwegs bin.

vigeland
Beiträge: 43
Registriert: 29.11.2009, 16:55

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von vigeland » 07.08.2018, 21:20

Hallo,

Ich habe das gleiche Problem und zwar hat es angefangen nachdem ich von einer Version von März auf aktuelle Version upgedatet habe.
Verlauf.
Backup -> Runterfahren -> Backup der SD Karte -> Mit Etcher neues Image installiert. Gestartet -> Backup zurückgespielt.
Alle OK.
Am nächsten Morgen ist mit die Sicherung rausgeflogen, Pi Started nicht mehr , Read Only keine IP ( Statisch bei mir)
Gut denke ich SD Karten Problem, ganz neue SD Karte genommen. Echter->Backup->Alles ok.
2 Tage später, ziehe ich den falschen Stecker.
Wieder das gleiche PI bootet nicht, Readonly keine IP.

Interessanterweise hatte ich vor dem Update nie Problem.
Da scheint was faul zu sein würde ich sagen, warum kommt beim booten kein Filecheck, normal kenne ich Readonly nur wenn das System nicht clean ist.
Man hat auch keine Chance, mit ALT-F2 kann man sich nicht einloggen. ( sshd mit Passwort ging nach dem Setup )

Gruß

jklasen
Beiträge: 27
Registriert: 24.01.2015, 01:07

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von jklasen » 20.08.2018, 19:52

Hallo zusammen,

habe Jens Maus grade eine PN mit den gleichen Problemen geschrieben und als Antwort folgendes erhalten:

"Tschuldigung, aber solche dinge gehören ins Forum und nicht in eine PN damit andere such davon profitieren..."

Um diesem gerecht zu werden jetzt hier mein Beitrag.
Auch bei mir ist anscheinend die SD Karte regelmäßig "defekt" d.h. ich benutze SanDisk 16GB SD Karten.
Habe es soeben geschafft diese an einem MAC zu mounten.. d.h. ich kann die SD Karte "lesen" ...
IM Raspi-Charlie aber eben nur "read only" mit der Fehlermeldung im Bildschirm "No IP address set".
Das gleiche auch das ich mich ebenfalls nicht mit root und meinem SSH password anmelden kann.
Würde auch gern mal wissen was ich da falsch mache .
Ich installiere JETZT auch mal auf eine 8GB Transcend SD Karte...

Meine "neuinstallation" hat jetzt 12 Servicemeldungen.. habe auch gleichmal das backup eingerichtet.
Auf meine Synology wird jetzt wie von Jens Maus hier beschrieben um 0 Uhr ein backup erstellt.
viewtopic.php?f=65&t=38703&hilit=backup#p381273

Ärgerlich ist es dennoch das die RaspiMatic recht schnell SD Karten "frisst" ... warum auch immer..


Grüße,

Jens

darkbrain85
Beiträge: 1002
Registriert: 27.06.2015, 22:17

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von darkbrain85 » 22.08.2018, 09:35

jklasen hat geschrieben:
20.08.2018, 19:52

Ärgerlich ist es dennoch das die RaspiMatic recht schnell SD Karten "frisst" ... warum auch immer..
Nein, Raspberrymatic frisst überhaupt nichts.
Ich habe meine Karte jetzt fast ein Jahr im Einsatz und keinerlei Probleme. In dem Fall eine Sandisk Ultra mit 16 GB.

erwin23
Beiträge: 42
Registriert: 27.11.2013, 18:20

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von erwin23 » 22.08.2018, 09:54

Hallo ,
gibt es nicht ein Tool oder ein Linux Script welches die Schreib- und Lesezugriffe
der SD Karte mitprotokolliert oder mitzählt? Kann man dann ja temporär mitlaufen lassen. Ich nutze eine Sandisk Industrial 16 GB seit 2 Jahren.
Beste Grüsse erwin

nicolas-eric
Beiträge: 3062
Registriert: 07.01.2015, 23:26
Wohnort: Scheeßel

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von nicolas-eric » 22.08.2018, 10:10

Ich nutze in den Raspis seit Jahren ohne Probleme Intenso 16GB Class10 für unter 10 Euro das Stück.
Anfangs hatte ich mit ausfallenden deutlich teureren SanDisks und Samsungs die selben hier beschriebenen Probleme.

Antworten

Zurück zu „RaspberryMatic“