Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

jklasen
Beiträge: 27
Registriert: 24.01.2015, 01:07

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von jklasen » 23.08.2018, 18:15

Hallo zusammen,

also meine "SanDisk Ultra 16Gb 10 A1 MicroSDHC 1" ist soweit OK.
Das filesystem war / ist im read-only mode und das nach einem Stromausfall.
Hatte das gleiche schonmal vor c.a. 6 Wochen mit einer anderen SD Karte aber ebenfalls SanDisk.

Mich wundert es nur das ich das jetzt zweimal hintereinander hatte.

Werde mich jetzt mal im Forum u.s.w. umschauen wie ich eine art USV für den Raspi bauen kann.
Wird halt denke ich schwierig mit der EVL Charlie Version mit Steckernetzteil.

Bin aber dennoch mal gespannt ob noch mehr das Problem mit dem Filesystem bekommen ..

Grüße in die Runde,

Jens

jklasen
Beiträge: 27
Registriert: 24.01.2015, 01:07

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von jklasen » 23.08.2018, 19:09

So,

es ist wieder soweit.
Strom aus... RaspberryMatic blinkt rot = tot !
Strom wieder aus... Monitor dran... Stecker rein....

"Starting HMServer"..... für c.a. 5min auf dem Monitor zu sehen.
20180823_190247.jpg
Ende dann mit 2.35.16.20180715 -- ERROR: No IP address set
20180823_190403.jpg
Ist für mich jetzt quasi reproduzierbar.

Gibt es noch andere die das hier bestätigen können oder muss / soll ich einen neuen Thread aufmachen?

Grüße,

Jens

deimos
Beiträge: 2872
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 2 Mal
Danksagung erhalten: 13 Mal
Kontaktdaten:

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von deimos » 23.08.2018, 19:12

Hi,

jetzt mal zum Verständnis: Du hast das Problem jeweils nach Stromausfällen?

Viele Grüße
Alex

jklasen
Beiträge: 27
Registriert: 24.01.2015, 01:07

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von jklasen » 23.08.2018, 19:14

Hi,

ja genau.

Strom aus... Strom wieder da .. Problem we beschrieben.

:-(

Bin grade dabei noch eine SD Karte zu formatieren und wieder mit etcher zu bespielen - backup rein - u.s.w. ist echt nervig. :-(

Grüße,

Jens

nicolas-eric
Beiträge: 3097
Registriert: 07.01.2015, 23:26
Wohnort: Scheeßel
Hat sich bedankt: 1 Mal
Danksagung erhalten: 3 Mal

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von nicolas-eric » 23.08.2018, 19:15

Stecker ziehen mag mein Raspi auch überhaupt nicht. Danach braucht er immer diverse Anläufe zum Starten. Manchmal ist danach auch die SD Karte unbrauchbar. Daher fährt man den auch per WebUI runter, dann bootet der auch ordentlich. Falls mal Strom ausfällt, habe ich auch ne USV dran.

deimos
Beiträge: 2872
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 2 Mal
Danksagung erhalten: 13 Mal
Kontaktdaten:

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von deimos » 23.08.2018, 19:19

Hi,

kann es sein, dass dein Router und/oder Switch nicht schnell genug hochgefahren sind uns das Problem daher kommt?

Unabhängig davon: Ein Trennen vom Strom kann bei jeden OS zu Datenverlusten führen. Wenn das bei dir so häufig vorkommt, dann solltest du dir auf jeden Fall eine USV zulegen.

Viele Grüße
Alex

jklasen
Beiträge: 27
Registriert: 24.01.2015, 01:07

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von jklasen » 23.08.2018, 19:23

LOL bei einem Stromausfall runterfahren :-)

Ja, eine USV macht bei mir langsam sinn.

Ist jetzt halt wieder verdammt ärgerlich.... :-(

Ich brauch immer "ewig" bis die ganzen Meldungen "Kommunikationsfehler" weg sind... :-(

Benutzeravatar
jmaus
Beiträge: 4803
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Danksagung erhalten: 32 Mal
Kontaktdaten:

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von jmaus » 23.08.2018, 19:24

Die screenshots sind leider recht nichtssagend. Bitte beim hochfahren ALT+F2 drücken damit man auch Fehlerausgaben sehen kann.
RaspberryMatic 3.47.10.20190713 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

jklasen
Beiträge: 27
Registriert: 24.01.2015, 01:07

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von jklasen » 23.08.2018, 19:46

Anbei die gewünschen fotos des bootvorgangs...
20180823_194301.jpg
und nach c.a. 5min... die Darstellungsfehler liegen nicht an meinem Bildschirm
20180823_194408.jpg

deimos
Beiträge: 2872
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 2 Mal
Danksagung erhalten: 13 Mal
Kontaktdaten:

Re: Hm-Server findet kein Netzwerk wegen schreibgeschützer SD-Karte

Beitrag von deimos » 23.08.2018, 19:58

Hi,

dir hat es das Filesystem mit den Config Files zerschossen. Dass das jetzt gleich bei mehreren Stromausfällen hintereinander passiert ist Pech, aber nichts, was man mit Sicherheit von der Software aus verhindern kann. Einzig wirkliche Lösung ist eine USV mit sauberem Runterfahren bei (längerem) Stromausfall.

Viele Grüße
Alex

Antworten

Zurück zu „RaspberryMatic“