RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

roe1974
Beiträge: 250
Registriert: 17.10.2017, 16:15
Wohnort: Wien

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von roe1974 » 06.12.2018, 22:03

Hat sich mit der aktuellen Version etwas mit der Speicherverwaltung geändert ? (Siehe Screenshot) ... da wird irgendwie weniger freigegeben wie früher ..... lg Richard
Unbenannt.JPG

Outlaw
Beiträge: 76
Registriert: 18.11.2016, 11:13

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von Outlaw » 07.12.2018, 13:30

Kann Wandthermostat mit dieser FW nicht updaten:

Heute im WebIf angezeigt bekommen: Neue Geräte-Firmware verfügbar (3)

Darin enthalten: 2x Update für HM-CC-RT-DN => Updates durchgeführt, ok.

1x HM-TC-IT-WM-W-EU Update von 1.3 auf 1.4 => fehlgeschlagen.

Problem: Beim Update über das WebIf (nach Upload der FW auf RaspberryMatic) erscheint nach dem Klick auf "Update" eine Meldung:

"Homematic Information" (und der OK Button)

ohne weitere Infos. nach Klick auf OK ist kommt man wieder zurück. Es passiert also NICHTS.

Und jetzt ??

Benutzeravatar
jmaus
Beiträge: 3690
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Kontaktdaten:

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von jmaus » 07.12.2018, 13:40

Outlaw hat geschrieben:
07.12.2018, 13:30
Problem: Beim Update über das WebIf (nach Upload der FW auf RaspberryMatic) erscheint nach dem Klick auf "Update" eine Meldung:

"Homematic Information" (und der OK Button)

ohne weitere Infos. nach Klick auf OK ist kommt man wieder zurück. Es passiert also NICHTS.

Und jetzt ??
Warten. Dein DutyCycle hat sein Limit erreicht und er kann das weitere Update erst anwenden wenn dieser wieder entsprechend gesunken ist. Ergo: DutyCycle im Auge behalten und vor allem Geduld (mehrere Stunden) haben!
RaspberryMatic 3.41.11.20181126 @ TinkerS mit ~150 HomeMatic Geräten + ioBroker – GitHubPayPal

Outlaw
Beiträge: 76
Registriert: 18.11.2016, 11:13

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von Outlaw » 07.12.2018, 13:42

Ok, Danke für die Info, das lässt hoffen.

Grüße
Outi

EDIT: Hab jetzt den RasPi neu gestartet, danach ging es auf Anhieb.

1techone
Beiträge: 75
Registriert: 19.01.2016, 10:23

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von 1techone » 07.12.2018, 17:22

Hallo,

am 02.12.2018, 17:22 schilderte ich bereits mein Problem und bekam reichlich Hilfe, danke dafür, aber das Problem habe ich leider nicht beseitigen können.

Nachdem ich nun mehrfach vergeblich versucht habe,
> auf einen mit RaspberryMatic 3.41.11.20181126 einwandfrei laufenden Raspi 3+ mit neuem HF-Modul<
mein Backup von einem mit gleicher Software laufenden Raspi 3 (ohne+) einzuspielen, habe ich nun einen anderen Weg versucht:

Ich habe in meinem Raspi 3 (ohne+) eine neue SD-Karte mit 3.41.11.20181126.img eingelegt und dann anschliesend mein Backup von dem Raspi 3 (ohne+) eingespielt.

Diese neue SD-Karte schob ich in den Raspi 3+ mit neuem HF-Mod und siehe da, es funktionierte nach zügigem Boot alles, ….. doch leider nur für ein paar Stunden, dann verlor der Raspi das Netz (schnelles Blinken der blauen LED) und
HM-IP und einige Menüs funktionierten nicht mehr.

Den gleichen Versuch startete ich dann mit einem Raspi 3+ mit kleinem , alten HF-Mod. Nach dem Einspielen, des Backups, lief der Raspi längere Zeit fehlerlos. Am nächsten Morgen wollte ich HM-IP anlernen, das IP-Menue war verschwunden, einige andere Funktionen liefen auch nicht mehr!

Bei allen Versuchen benutzte ich ein gutes 5,1Volt / 5Ampere Netzteil (gut gesiebt, kein Ladegerät!) und hatte es beim Raspi 3+ an die HF-Platine gesteckt.
Da ich kein Linux-Kenner bin werde ich nun auf die nächste Version warten. Ich weis nicht richtig wie ich Rechte vergebe und wie, wo und wann ich z.B. die Taktfrequenz des Raspi drossele usw.
Die Eingaben:
/etc/init.d/S62HMServer stop
/etc/init.d/S62HMServer star
wirkten zwar, aber der Fehler wurde nicht behoben.

Hat der Raspi 3+ doch noch eine andere Abweichung? …..liegt es an der höheren Taktfrequenz? …..oder ??

Mein System läuft (zwar auf dem Raspi ohne +) sehr gut, danke für die tolle Arbeit !!
….. ich bin gespannt, ob es in der nächsten Version auch mit dem Raspi 3+ klappen wird.

Die Leistung ist viele viele --- S P E N D E N --- wert !!
Gruß Jürgen

beckerpa
Beiträge: 14
Registriert: 15.04.2018, 08:34
Wohnort: 56329 St. Goar

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von beckerpa » 07.12.2018, 17:45

N23 hat geschrieben:
03.12.2018, 20:12
Habe seit dem Update auf 3.41.11.20181126 auch Probleme mit nicht reagierenden HmIP Geräten.

Dies tritt vor allem auf wenn mehrere Geräte kurz hintereinander getriggert werden wie z.b. von einem HmIP Wandtaster (Batterie) über ein Zentralenprogramm zeitlich verzögert zwei HmIP Rolladenaktoren (Netz). Hier ist es so das der zweite Aktor beim ersten Mal gar nicht reagiert, wenn der erste Aktor fertig verfahren ist und ich das Programm noch einmal triggere fährt dann meistens auch der zweite Aktor.

In den Logs steht dann was von "Generic error (TIMEOUT)" - Hardware ist ein Raspberry Pi 3 B (ohne +).
Neustart hat auch kein Abhilfe gebracht, wie auch nicht die Aktoren extern (nicht per Zentralenprogramm sondern ioBroker) zeitversetzt zu triggern. Mir kommt es so vor als sei HmIP blockiert solange ein Geräte da Daten versendet...


p.s. Danke Jens für die tolle Arbeit, die Mühe und Zeit die du in RaspberryMatic und andere Projekte (ioBroker Unifi ;-) ) steckst!
Hallo zusammen,

o.g. kann ich in Bezug auf HmIP-SPI bestätigen. Die Präsenzerkennung wird in Abhängigkeit der Rollladenstellung in jedem Raum ein- bzw. ausgeschaltet. Auf Grund der Tatsache, dass die HmIP-FROLL alle das gleiche Programm fahren, kommt es dazu, dass nicht jeder HmIP-SPI die Präsenzerkennung einschaltet, bzw. morgens ausschaltet.
Dies war vor dieser Version nicht der Fall.

Kein großes Problem, aber wollte nur noch einmal darauf hinweisen, dass dieses besteht.


Sonst super, sehr stabil, wie gewohnt!

Vielen Dank Jens.


Gruß aus St. Goar

beckerpa
Raspi 3B mit RasberryMatic mit 111 Geräten / HmIP und HM
Raspi 3B+ mit ioBroker
HmIP AP mit 62 Geräten / HmIP

Benutzeravatar
Centauri2k
Beiträge: 663
Registriert: 17.09.2016, 21:13

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von Centauri2k » 08.12.2018, 13:07

Wenn man in der Zusatzsoftware bei einem verfügbarem Update auf "Herunterladen" klickt, dann wird eine "update-check.cgi" Datei heruntergeladen.

Browser: Safari Version 12.0.2 (14606.3.4)

Andy1981
Beiträge: 276
Registriert: 25.12.2015, 08:41

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von Andy1981 » 08.12.2018, 13:10

Downloadmanager aktiv?
Anderen Browser probiert?
Andy

d3h56r
Beiträge: 136
Registriert: 29.10.2017, 10:23

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von d3h56r » 08.12.2018, 13:58

Centauri2k hat geschrieben:
08.12.2018, 13:07
Wenn man in der Zusatzsoftware bei einem verfügbarem Update auf "Herunterladen" klickt, dann wird eine "update-check.cgi" Datei heruntergeladen.

Browser: Safari Version 12.0.2 (14606.3.4)
Kann ich mit Safari bestätigen.

Michel2017
Beiträge: 11
Registriert: 30.03.2017, 07:58

Re: RaspberryMatic 3.41.11.20181126 – Erfahrungsberichte

Beitrag von Michel2017 » 08.12.2018, 14:36

Auf MacOS mit Safari und Chrome bei mir das gleiche. Mit Firefox gehts.

Antworten

Zurück zu „RaspberryMatic“