[GELÖST] SSH Passwort läst sich nicht speichern

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

satpower
Beiträge: 11
Registriert: 06.12.2018, 17:01

Re: SSH Passwort läst sich nicht speichern

Beitrag von satpower » 06.12.2018, 23:30

Da Jens an den zugrunde liegenden Verschlüsselungsalgorithmen gewerkelt hat, könnte da vielleicht im Eifer des Gefechts ein falscher Algorithmus an der Stelle verwendet worden sein, der dem Betriebssystem etwas anderes als "Hash" einträgt, als das gehashte Passwort.
Würde auch bedeuten, der User bei dem die die ssh mit seinem Passwort durch nur "Update" noch funktioniert und jetzt ein neues generiert, dieses dann auch nicht funktionieren sollte ...

satpower
Beiträge: 11
Registriert: 06.12.2018, 17:01

Re: SSH Passwort läst sich nicht speichern

Beitrag von satpower » 07.12.2018, 16:00

Die Fehlerquelle ist eindeutig bei der RaspberryMatic-Version zu suchen.
Ich habe eine noch ältere Version 2.35.16.20180708 bekommen und bei dieser funktioniert der ssh-zugriff mit neuem Passwort noch.
Die Veränderung muss also zwischen oder ab 3.37.8.20181026 gewesen sein.

MikeEcho
Beiträge: 19
Registriert: 07.03.2018, 11:48

Re: [GELÖST] SSH Passwort läst sich nicht speichern

Beitrag von MikeEcho » 17.12.2018, 15:12

Das Thema ist als gelöst markiert, aber ich finde die Lösung nicht.

Ich kann bei der 3.41.20181126 den SSH Zugang aktivieren, aber kein Kennwort vergeben.

Benutzeravatar
jmaus
Beiträge: 4557
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Kontaktdaten:

Re: [GELÖST] SSH Passwort läst sich nicht speichern

Beitrag von jmaus » 17.12.2018, 17:22

Das Problem sollte bereits seit zwei Firmwareversionen behoben sein. Siehe:
https://github.com/jens-maus/RaspberryMatic/issues/469
RaspberryMatic 3.45.7.20190511 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

MikeEcho
Beiträge: 19
Registriert: 07.03.2018, 11:48

Re: [GELÖST] SSH Passwort läst sich nicht speichern

Beitrag von MikeEcho » 17.12.2018, 18:40

jmaus hat geschrieben:
17.12.2018, 17:22
Das Problem sollte bereits seit zwei Firmwareversionen behoben sein. Siehe:
https://github.com/jens-maus/RaspberryMatic/issues/469
Ich habe mir den Beitrag durchgelesen und es auch auf der Kommandozeile probiert...
rm4.jpg
rm1.PNG
rm1.PNG (13.23 KiB) 216 mal betrachtet
rm2.PNG
rm2.PNG (3.69 KiB) 216 mal betrachtet
rm3.PNG

Benutzeravatar
jmaus
Beiträge: 4557
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Kontaktdaten:

Re: [GELÖST] SSH Passwort läst sich nicht speichern

Beitrag von jmaus » 17.12.2018, 19:05

MikeEcho hat geschrieben:
17.12.2018, 18:40
jmaus hat geschrieben:
17.12.2018, 17:22
Das Problem sollte bereits seit zwei Firmwareversionen behoben sein. Siehe:
https://github.com/jens-maus/RaspberryMatic/issues/469
Ich habe mir den Beitrag durchgelesen und es auch auf der Kommandozeile probiert...
Das sieht nach einem anderen Fehler aus. Gib mal folgendes in der Kommandozeile ein:

Code: Alles auswählen

ls -la /etc/passwd
Und dann noch

Code: Alles auswählen

mount
Und zeig mal die ausgaben
RaspberryMatic 3.45.7.20190511 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

MikeEcho
Beiträge: 19
Registriert: 07.03.2018, 11:48

Re: [GELÖST] SSH Passwort läst sich nicht speichern

Beitrag von MikeEcho » 17.12.2018, 19:26

Hier die Ausgabe der Kommandozeile:
20181217_192149[1].jpg
Gibt es eine elegantere Art & Weise, die Bildschirmausgabe zu senden!? *lach*

Benutzeravatar
jmaus
Beiträge: 4557
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Kontaktdaten:

Re: [GELÖST] SSH Passwort läst sich nicht speichern

Beitrag von jmaus » 17.12.2018, 20:41

MikeEcho hat geschrieben:
17.12.2018, 19:26
Hier die Ausgabe der Kommandozeile:
Danke. Diese Meldungen sind ganz normal und unkritisch. Geb mal noch folgendes aus:

Code: Alles auswählen

ls -la /etc/config/shadow
MikeEcho hat geschrieben:
17.12.2018, 19:26
Gibt es eine elegantere Art & Weise, die Bildschirmausgabe zu senden!? *lach*
Ja, via SSH einloggen und Kommandos da eingeben. :)
RaspberryMatic 3.45.7.20190511 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

MikeEcho
Beiträge: 19
Registriert: 07.03.2018, 11:48

Re: [GELÖST] SSH Passwort läst sich nicht speichern

Beitrag von MikeEcho » 17.12.2018, 21:11

jmaus hat geschrieben:
17.12.2018, 20:41
Ja, via SSH einloggen und Kommandos da eingeben. :)
Wenn das mal nicht ein Henne/Ei Problem ist.


Hier die Ausgabe von Shadow (mit NEUER SD-Karte)
20181217_210957[1].jpg

Antworten

Zurück zu „RaspberryMatic“