Bitte um Hilfe - RaspberryMatic RPI-RF-MOD extrem schlechte Werte

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

richard.mayer
Beiträge: 18
Registriert: 12.05.2016, 11:47

Re: Bitte um Hilfe - RaspberryMatic RPI-RF-MOD extrem schlechte Werte

Beitrag von richard.mayer » 10.12.2018, 14:23

Hallo,

für den einen Raspi habe ich so ein Netzteil mitbestellt.
Den anderen hatte ich mit dem CCU2 Netzteil am laufen.
Ich kann es erst heute Abend prüfen, aber ich war der Meinung dass dieses Charly-ELV-Netzteil und das CCU2 Netzteil baugleich waren. Also auch vom output her identisch.
Ich kann mich natürlich auch irren...

Schöne Grüße

Richard

Depechem
Beiträge: 77
Registriert: 21.10.2018, 07:33
Wohnort: Dresden

Re: Bitte um Hilfe - RaspberryMatic RPI-RF-MOD extrem schlechte Werte

Beitrag von Depechem » 10.12.2018, 20:27

Ich bin mal gespannt wer sich noch meldet. Dieses so super beworbene neue überteuerte RPI-RF-MOD scheint wirklich eine teure Fehlkonstruktion von eQ-3 zu sein. Wobei die Firma dies natürlich nie zugeben würde...wären sie schön blöd.
Gibts denn hier jemand der mit dem neuen Funkmodul gute Werte geliefert bekommt? (Natürlich in original ohne externe Antenne) Gute Werte bedeutet für mich RSSI von max -89 vom Keller bis zum Dachgeschoss. Genau das schaffte ein HM-CFG-USB-2 sowie das alte Funkmodul in Anbindung per USB. Und das zum halben Preis und ohne die GPIOs zu blockieren
Raspimatic auf RPI3b+
HM & HMiP
FHEM

Xel66
Beiträge: 5627
Registriert: 08.05.2013, 23:33
Wohnort: Nordwürttemberg
Hat sich bedankt: 5 Mal
Danksagung erhalten: 22 Mal

Re: Bitte um Hilfe - RaspberryMatic RPI-RF-MOD extrem schlechte Werte

Beitrag von Xel66 » 10.12.2018, 20:50

Die Feldstärke ist eigentlich mich das einzige Kriterium und kann bei identischer "Antennenkonstruktion" und den gleichen Gegenstellen mit ebenso schlechten Antennen nicht viel höher ausfallen. Der beste HF-Verstärker ist immer noch eine hochqualitative Antenne.

Was das Modul besser machen soll, ist der geänderte konstruktive Aufbau und die versetzte Montage, die das Transceiver-Modul weiter weg von der Störstrahlung der Pi-CPU bringen soll. Das Empfangssignal ist also potenziell besser und eine bessere Empfangsgüte (!nicht Feldstärke!) zu erwarten. Das ist aber nicht in so einfachen Werten abzubilden. Ein schwaches Signal mit sauberem Nutzanteil kann eben durchaus eine höhere Güte besitzen als ein starkes Signal mit hohem Störanteil, der ein Dekodieren der Information nicht ermöglicht.

Insofern würde ich mich nicht so an der Feldstärke festklammern. Die gegebenen Bedingungen lassen nicht viel besseres zu. Und wenn man es genau nimmt, verliert das Modul, die CCU mit veränderter Antenne ihre funktechnische Zulassung. Kommt es dadurch zu nachweislich negativen Beeinflussungen von z.B. kommerziellen Funkdiensten, kann diese Bastelei auch richtig ins Geld gehen. Aber wo kein Kläger...

Gruß Xel66
---------------------------------------------------------------------------------
358 Kanäle in 103 Geräten und 114 CUxD-Kanäle in 24 CUxD-Geräten:
253 Programme, 218 Systemvariablen und 144 Direktverknüpfungen,
RaspberryMatic Version 3.45.7.20190622
---------------------------------------------------------------------------------

richard.mayer
Beiträge: 18
Registriert: 12.05.2016, 11:47

Re: Bitte um Hilfe - RaspberryMatic RPI-RF-MOD extrem schlechte Werte

Beitrag von richard.mayer » 10.12.2018, 21:10

Hallo,

zu dem Kommentar mit der Empfangsgüte kann ich nichts sagen - ich bin kein Elektrotechniker.
Ich als "User" sehe nur, dass ich mit der Performance des neuen Moduls nicht zufrieden bin.
Einerseits werden in der RSSI-Tabelle deutlich schlechtere Werte angezeigt. Wie du ja bereits schrteibst, muss das noch nicht schlimm sein.
Andererseits sehe ich einfach, dass z.B. meine "Problemsensoren" in der Garage mit dem Empfangsmodul der CCU2 (ohne externe Antenne) gerade so funktionieren, mit dem Empfangsmodul RPI-RF-MOD aber einfach gar nicht (rödeln ewig orange rum, bis sie dann mit rot quittieren).
Von daher denke ich schon, dass die schlechteren RSSI-Werte von Relevanz sind.

Ich habe anbei mal eine RSSI-Liste meiner Geräte gehängt. Hier wird ja der Empfang wowohl an der Basis (RPi 3B+ mit RPI-RF-MOD), als auch am HMLGW (in meinem Fall meine alte CCU2) angezeigt. Beide Geräte haben das original Stummelantennchen.
Die beiden Devices stehen direkt nebeneinander.

Das ist schon ein ganz ordentlicher Unterschied, oder? Und das zusätzlich zu den erlebten Empfangsproblemen macht micht einfach nicht so glücklich.

Schöne Grüße

Richard
Dateianhänge
RSSI List.pdf
(67.34 KiB) 27-mal heruntergeladen
Zuletzt geändert von richard.mayer am 10.12.2018, 21:16, insgesamt 1-mal geändert.

Depechem
Beiträge: 77
Registriert: 21.10.2018, 07:33
Wohnort: Dresden

Re: Bitte um Hilfe - RaspberryMatic RPI-RF-MOD extrem schlechte Werte

Beitrag von Depechem » 10.12.2018, 21:13

Genau solche Vergleichwerte wie bei mir...
Raspimatic auf RPI3b+
HM & HMiP
FHEM

Xel66
Beiträge: 5627
Registriert: 08.05.2013, 23:33
Wohnort: Nordwürttemberg
Hat sich bedankt: 5 Mal
Danksagung erhalten: 22 Mal

Re: Bitte um Hilfe - RaspberryMatic RPI-RF-MOD extrem schlechte Werte

Beitrag von Xel66 » 10.12.2018, 22:24

richard.mayer hat geschrieben:
10.12.2018, 21:10
Von daher denke ich schon, dass die schlechteren RSSI-Werte von Relevanz sind.
Sie sind von Relevanz aber eben nur die halbe Wahrheit und erlauben lediglich eine grobe Abschätzung der Verhältnisse. Euch ist aber auch aufgefallen, dass die verbauten Antennen unterschiedliche Ausrichtung haben
Um vergleichen zu können, müssen auch beide Vergelichsantennen die gleiche Ausrichtung haben. Und bedingt durch Reflektionen können bei HF wenige Zentimeter auch Empfangsunterschiede ausmachen. Wie beschrieben, RSSI ist eine Momentaufnahme und nur die halbe Wahrheit. Natürlich hat man mit einer höheren Feldstärke auch potenziell besseren Empfangsergebnisse. Aber bei einer Funkvernindung gibt es auch mindestens zwei Teilnehmer. Und die Positionierung der Antennen in den Aktoren ist auch nicht für jeden Anwendungfall und Montageart optimal. Ich habe zwei übereinander montierte Rollladenaktoren in einer Unterputzdose. Während einer einen RSSI von 83db hat, hat der andere 104db mit den entsprechenden Empfangsproblemen. Aber ein Repeater tut gute Dienste, obwohl ich ich kein Freund davon bin.

Gruß Xel66
---------------------------------------------------------------------------------
358 Kanäle in 103 Geräten und 114 CUxD-Kanäle in 24 CUxD-Geräten:
253 Programme, 218 Systemvariablen und 144 Direktverknüpfungen,
RaspberryMatic Version 3.45.7.20190622
---------------------------------------------------------------------------------

Depechem
Beiträge: 77
Registriert: 21.10.2018, 07:33
Wohnort: Dresden

Re: Bitte um Hilfe - RaspberryMatic RPI-RF-MOD extrem schlechte Werte

Beitrag von Depechem » 10.12.2018, 22:47

Xel66 hat geschrieben:
10.12.2018, 22:24

Euch ist aber auch aufgefallen, dass die verbauten Antennen unterschiedliche Ausrichtung haben
Um vergleichen zu können, müssen auch beide Vergelichsantennen die gleiche Ausrichtung haben. Und bedingt durch Reflektionen können bei HF wenige Zentimeter auch Empfangsunterschiede ausmachen. Wie beschrieben, RSSI ist eine Momentaufnahme und nur die halbe Wahrheit. Natürlich hat man mit einer höheren Feldstärke auch potenziell besseren Empfangsergebnisse. Aber bei einer Funkvernindung gibt es auch mindestens zwei Teilnehmer. Und die Positionierung der Antennen in den Aktoren ist auch nicht für jeden Anwendungfall und Montageart optimal.

Gruß Xel66
Danke für deine Ausführungen, das klingt alles richtig, nur geht es hierbei trotzdem noch um den groben Vergleich zwischen den unterschiedlichen Funkmodulen (wobei das neue Funkmodul insbesondere mit besserer Funkreichweite beworben wird)
- Beide Module sowie Aktoren sind an der gleichen Stelle verbaut.
- die Ausrichtung der Antennen am Funkmodul sind für den Anwender nebensächlich da sie für beide Funkmodule von eQ-3 extra so optimal angebracht wurden (ich habe den Charly bereits in alle 6 Richtungen umgedreht ohne bessere Werte zu erhalten.

Gruß Thomas
Raspimatic auf RPI3b+
HM & HMiP
FHEM

richard.mayer
Beiträge: 18
Registriert: 12.05.2016, 11:47

Re: Bitte um Hilfe - RaspberryMatic RPI-RF-MOD extrem schlechte Werte

Beitrag von richard.mayer » 10.12.2018, 23:01

Und noch eine Sache: Wenn es von der Postionierung abhinge, dann müsste der Empfang beim wochenlangen rumspielen mit verschiedenen Standorten im Haus ja auch rein vom der Zufall der Ausrichtung beim Charly irgendwann mal besser gewesen sein, als bei der CCU2. Ich habe auch zwei verschiedene Antennen ausprobiert (Stabantenne und Flachantenne von stall.biz) - beide enttäuschend an der Charly.
Jetzt hab ich die CCU2 als HMLGW aktiv und es läuft so smooth wie seit Wochen nicht mit der Charly. Echt schade.
Die Geschwindigkeit von RaspberryMatic auf dem Pi 3B+ ist natürlich schon Hammer verglichen mit der CCU2 - von daher ist das mit dem Gateway jetzt ok für mich. Aber was ich mit den RPI-RF-MOD Boards anfangen soll weiß ich nicht wirklich.

Xel66
Beiträge: 5627
Registriert: 08.05.2013, 23:33
Wohnort: Nordwürttemberg
Hat sich bedankt: 5 Mal
Danksagung erhalten: 22 Mal

Re: Bitte um Hilfe - RaspberryMatic RPI-RF-MOD extrem schlechte Werte

Beitrag von Xel66 » 10.12.2018, 23:01

Depechem hat geschrieben:
10.12.2018, 22:47
(wobei das neue Funkmodul insbesondere mit besserer Funkreichweite beworben wird)
Bessere Reichweite oder besserere Empfangsqualität? Letztendlich ist das eben Marketinggewäsch basierend auf grundsätzlich besseren technischen Parametern.
Depechem hat geschrieben:
10.12.2018, 22:47
Ausrichtung der Antennen am Funkmodul sind für den Anwender nebensächlich...
Für den Anwender ja, aber eben nicht für die Funkverbindung. Da liegt der Hase im Pfeffer. Dreh mal Deine CCU um 90°. Du wirst deutliche Unterschiede feststellen. Nicht umsonst müssen Sende- und Empfangsantenne gleich ausgerichtet sein. Das ist nun mal Physik und wird sogar technisch beim Satellitenempfang ausgenutzt (in anderen Bereichen auch, aber da ist es dem Anwender nicht präsent). Bei der CACU und den Aktoren wird diesbezüglich etwas in die Trickkiste gegriffen. Aber das ist so üblich.

Gruß Xel66
---------------------------------------------------------------------------------
358 Kanäle in 103 Geräten und 114 CUxD-Kanäle in 24 CUxD-Geräten:
253 Programme, 218 Systemvariablen und 144 Direktverknüpfungen,
RaspberryMatic Version 3.45.7.20190622
---------------------------------------------------------------------------------

richard.mayer
Beiträge: 18
Registriert: 12.05.2016, 11:47

Re: Bitte um Hilfe - RaspberryMatic RPI-RF-MOD extrem schlechte Werte

Beitrag von richard.mayer » 10.12.2018, 23:07

jmaus hat geschrieben:
10.12.2018, 14:04
richard.mayer hat geschrieben:
10.12.2018, 14:01
ja, habe nur mit dem weißen Netzteil mit Hohlstecker von ELV, das auch mit der CCU2 mitgeliefert wird gearbeitet.
Am Micro-USB-Port war nichts angeschlossen.
Verstehe ich das richtig? Du hast das Netzteil der CCU2 abgezogen und für den Betrieb des RPI-RF-MOD genommen und nicht das extra Netzteil mit dem RPI-RF-MOD mitbestellt das dafür vorgesehen ist (siehe https://www.elv.de/elv-steckernetzteil-5v-2-5-a.html) ?
Habe das gerade geprüft - die Netzteile schauen nur auf den ersten Blick identisch aus. Leistung ist unterschiedlich. Hat bei den weiteren Tests jetzt aber keine Besserung gebracht, das 2,5er am Charly hängen zu haben.
83552E85-10D8-4D71-AF3B-6BDBAD1F3123.jpeg
98B52CBE-21CE-4A4C-9E3F-AC02C1257C21.jpeg

Antworten

Zurück zu „RaspberryMatic“