[GELÖST] RaspberryMatic startet sporadisch neu

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

s3993
Beiträge: 6
Registriert: 04.01.2019, 14:02

[GELÖST] RaspberryMatic startet sporadisch neu

Beitrag von s3993 » 04.01.2019, 14:19

Hallo

Ich habe schon seit längerem Probleme mit meinem Raspberrymatic (Hardware Raspberry 3B+).
Alles lief super bis ich ein Update von Version 3.37.8.20181026 auf Version 3.41.11.20181222 gemacht habe.
Mit Version 3.41 fing der Raspberry an sich sporadisch neu zu starten, da im Logfile nichts zu finden war (unter /var/log) andere kenne ich nicht,
habe ich den Raspberry mit der zuvor funktionierenden Version 3.37.8 neu aufgesetzt und das Backup eingespielt.
Jetzt macht er zwar nicht mehr so häufig einen Neustart aber dennoch macht er es.
Aufgefallen ist mir, das er meistens neu startet, wenn ich in der WebUI was mache z.B. Licht an/aus schalte.

Habt ihr bitte einen Hinweis, wie ich der Ursache auf die Schliche kommen kann?

Ich habe auch schon einen anderen Raspberry Pi 3B+ mit einer neuen SD Karte ausprobiert, genau das gleiche Fehlerbild.
Kann es eine Überlastung des Pi's sein? oder ein zu schwaches Netzteil (obwohl es mit diesem seit über einem Jahr fehlerfrei lief)

Danke für eure Hilfe

Gruß s3993
Zuletzt geändert von s3993 am 04.01.2019, 17:34, insgesamt 2-mal geändert.

deltaac
Beiträge: 175
Registriert: 17.02.2016, 11:44

Re: RaspberryMatic startet sporadisch neu

Beitrag von deltaac » 04.01.2019, 14:25

Schon Mal in den Logfile unter /var/log geschaut?

s3993
Beiträge: 6
Registriert: 04.01.2019, 14:02

Re: RaspberryMatic startet sporadisch neu

Beitrag von s3993 » 04.01.2019, 14:31

Ja, aber da finde ich nichts. Oder anders gesagt, ich werde daraus nicht schlau.
Dürfte ich die Logs hochladen, damit ein Fachmann sich das mal anschauen kann?

stan23
Beiträge: 404
Registriert: 13.12.2016, 21:14
Wohnort: Altmühltal
Kontaktdaten:

Re: RaspberryMatic startet sporadisch neu

Beitrag von stan23 » 04.01.2019, 14:38

Hi,
der Inhalt von /var/log/messages geht bei einem Reboot verloren.

Du könntest einen Syslog-Server aufsetzen, oder eine SSH-Session mit PuTTY aufmachen und dir per

Code: Alles auswählen

tail -f /var/log/messages
die Datei streamen lassen.

Beim Reboot bricht die Verbindung ab und die letzten Zeilen sind zu sehen.
Viele Grüße
Marco

RaspberryMatic
~60 Geräte (HM, HmIP, HMW, HBW, AskSin)

darkbrain85
Beiträge: 771
Registriert: 27.06.2015, 22:17

Re: RaspberryMatic startet sporadisch neu

Beitrag von darkbrain85 » 04.01.2019, 14:38

Sporadische Abstürze sind ja beim Raspberry meistens auf das Netzteil zurückzuführen!
Hast Du irgendwas angeschlossen in letzter Zeit?Ein USB Stick reicht da schon...

s3993
Beiträge: 6
Registriert: 04.01.2019, 14:02

Re: RaspberryMatic startet sporadisch neu

Beitrag von s3993 » 04.01.2019, 14:49

Einen Logserver habe ich mir heute aufgesetzt, genau um den Verlust der Logs zu kompensieren.
Ja, stimmt, ich habe einen USB Stick rangesteckt, weil ich gemerkt habe das es leider ohne Stick keine Diagramme mehr gibt.
Danke für den Hinweis. Aber das Netzteil, welches ich benutze, bringt die geforderten 2A, reicht das nicht aus?

s3993
Beiträge: 6
Registriert: 04.01.2019, 14:02

Re: RaspberryMatic startet sporadisch neu

Beitrag von s3993 » 04.01.2019, 15:10

Soeben ist es wieder passiert, ich bin gerade dabei alle Osram Lampen aus dem RaspberryMatic zu löschen (geht das nur einzeln pro gerät oder kann man die auch ALLE auf einmal rausschweissen?)

hier die letzten Zeilen aus dem Livelog Danke stan23 für den Tip :P

Code: Alles auswählen

Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.CONTROL_MODE=0
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.FAULT_REPORTING=0
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.BATTERY_STATE=2.600000
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.VALVE_STATE=4
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.BOOST_STATE=0
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.ACTUAL_TEMPERATURE=18.600000
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.SET_TEMPERATURE=18.000000
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.PARTY_TEMPERATURE=5.000000
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.PARTY_START_TIME=0
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.PARTY_START_DAY=1
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.PARTY_START_MONTH=1
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.PARTY_START_YEAR=0
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.PARTY_STOP_TIME=0
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.PARTY_STOP_DAY=1
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.PARTY_STOP_MONTH=1
Jan  4 15:00:49 ccu2 user.debug rfd: Event: OEQ0856268:4.PARTY_STOP_YEAR=0
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 13 events
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 2 events
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 11 events
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 15 events
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 15 events
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 4 events
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
Jan  4 15:00:49 ccu2 user.debug multimac: C> @833644: #95 TRX Response Ack 04
Jan  4 15:00:49 ccu2 user.debug multimac: SubsystemBidcos::CheckDutyCycleEventThreshold( 2.0, 2.0 ) = 0
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
Jan  4 15:00:49 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
Jan  4 15:00:57 ccu2 user.debug multimac: C> @841332: #57 LLMAC RX @11220ms -51dBm BE 86 10 5D 5A 3C 00 00 00 0A 90 C4 0A 00 00
Jan  4 15:00:57 ccu2 user.debug multimac: Bidcos RX: #BE[BC|Ren|WMup] 5D5A3C->000000 Info: 0A 90 C4 0A 00 00
Jan  4 15:00:57 ccu2 user.debug multimac: GetAckActionForIncomingTelegram() ackAction=AckAction_NotForUs, wakeup=None
Jan  4 15:00:57 ccu2 user.debug multimac: A<: #194 HmBidcos RxTelegram AuthNone #BE[BC|Ren|WMup] 5D5A3C->000000 Info: 0A 90 C4 0A 00 00
Jan  4 15:00:57 ccu2 user.debug rfd: RX for OEQ0855103: @422230672 RSSI=-51dB 0x5D5A3C -> 0x000000 Generic [OEQ2297662]:   CNT=62,RPTEN=1,RPTED=0,BIDI=0,BURST=0,WAKEUP=0,WAKEMEUP=1,BCAST=1,TYPE=0x10   DATA = 0A 90 C4 0A 00 00
Jan  4 15:00:57 ccu2 user.debug rfd: Event: OEQ0855103:4.CONTROL_MODE=0
Jan  4 15:00:57 ccu2 user.debug rfd: Event: OEQ0855103:4.FAULT_REPORTING=0
Jan  4 15:00:57 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
Jan  4 15:00:57 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 1 events
Jan  4 15:00:57 ccu2 user.debug rfd: Event: OEQ0855103:4.BATTERY_STATE=2.500000
Jan  4 15:00:57 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
Jan  4 15:00:57 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 2 events
Jan  4 15:00:57 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send completed
Jan  4 15:00:57 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 3 events
Jan  4 15:00:57 ccu2 user.debug rfd: HSSXmlRpcEventDispatcher::Handle send 3 events
Jan  4 15:00:57 ccu2 user.debug rfd: Event: OEQ0855103:4.VALVE_STATE=0

s3993
Beiträge: 6
Registriert: 04.01.2019, 14:02

Re: RaspberryMatic startet sporadisch neu

Beitrag von s3993 » 04.01.2019, 15:13

Ich schaffe es gerade mal eine Lampe zu löschen, dann macht er einen reboot und ich kann die nächste Lampe löschen.
Ich kann das reproduzieren.
Das kann dauern (:

Benutzeravatar
jmaus
Beiträge: 4193
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Kontaktdaten:

Re: RaspberryMatic startet sporadisch neu

Beitrag von jmaus » 04.01.2019, 16:23

s3993 hat geschrieben:
04.01.2019, 14:49
Danke für den Hinweis. Aber das Netzteil, welches ich benutze, bringt die geforderten 2A, reicht das nicht aus?
Für einen RaspberryPi3 braucht man ZWINGEND ein 2,5A Netzteil das 5,1V liefert und nicht irgendein Chinaböller den man irgendwo aus der Sammelkiste gezogen hat und der gerade so laut Aufkleber die Specs erfüllt. Und wenn du als Funkmodul das RPI-RF-MOD einsetzt musst du auch ZWINGEND ein adequates Netzteil mit 2,5A an das RPI-RF-MOD anschliessen und den RaspberryPi nicht mehr mit Netzteil am microUSB Anschluss betreiben, sonst gibt es zusätzlich auch noch Empfangsprobleme.

Also entweder das hier (wenn man kein RPI-RF-MOD einsetzt):

https://www.heise.de/preisvergleich/ras ... 23319.html

Oder das hier (wenn man ein RPI-RF-MOD einsetzt):

https://www.elv.de/elv-steckernetzteil-5v-2-5-a.html

Also nicht irgendwie versuchen gerade an dieser wichtigen Komponente Geld zu sparen um sich dann zu wundern das irgendwas, irgendwie nicht richtig geht.
RaspberryMatic 3.43.15.20190223 @ TinkerS mit ~150 HomeMatic Geräten + ioBroker – GitHubPayPal

darkbrain85
Beiträge: 771
Registriert: 27.06.2015, 22:17

Re: RaspberryMatic startet sporadisch neu

Beitrag von darkbrain85 » 04.01.2019, 16:44

Das Meanwell Hutschienennetzteil mit 2,4 A funktioniert ebenfalls problemlos. Dies nur zur Vervollständigung....

https://www.amazon.de/DIN-Schienenmonta ... hutschiene

Antworten

Zurück zu „RaspberryMatic“