HM-IP Geräte sind nach Reboot gelöscht

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

therealhunter
Beiträge: 27
Registriert: 31.01.2017, 16:18

HM-IP Geräte sind nach Reboot gelöscht

Beitrag von therealhunter » 26.01.2019, 18:51

Hallo,

mir ist heute aufgefallen, dass meine Homematic IP Geräte nicht mehr in der RaspberryMatic vorhanden sind.
Wie lange diese schon verschwunden sind, kann ich nicht genau sagen, da diese bislang ohne Funktion versehen waren.
Ich habe die Geräte in den Werkszustand versetzt und konnte sie ohne Probleme wieder verbinden. Bei Testen klappte auch alles Probleme.
Habe dann test weise einmal die RaspberryMatic neugestartet, nachdem neustart waren die Geräte (2x HMIP-SWDO-I) wieder verschwunden. Sie konnten aber nach einem Werksreset wieder normal verbunden werden, bis ich das System wieder neugestartet habe.

Auf der RaspberryMatic laufen noch die XML-Api, System-Update, Cux-Daemon und HconnectVPN, ansonsten keine weiteren Addons.

Die aktuelleste Firmware ist auf dem Raspberry vorhanden, es war mit der letzten auch der Fall, ich habe heute extra auf die aktuellste Version, das Update gemacht.

Code: Alles auswählen

Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallReportValueUsage: CallXmlrpcMethod failed [iseXmlRpc.cpp:1673]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: RemoveDPFromCollections: rpc.CallReportValueUsage failed dp id = 12629 [iseManageDP.cpp:439]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =reportValueUsage Params = {"00109709B13648:0","OPERATING_VOLTAGE",0} result= [faultCode:-2,faultString:"Invalid device"] [iseXmlRpc.cpp:2605]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallReportValueUsage: CallXmlrpcMethod failed [iseXmlRpc.cpp:1673]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: RemoveDPFromCollections: rpc.CallReportValueUsage failed dp id = 12628 [iseManageDP.cpp:439]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =reportValueUsage Params = {"00109709B13648:0","LOW_BAT",0} result= [faultCode:-2,faultString:"Invalid device"] [iseXmlRpc.cpp:2605]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallReportValueUsage: CallXmlrpcMethod failed [iseXmlRpc.cpp:1673]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: RemoveDPFromCollections: rpc.CallReportValueUsage failed dp id = 12624 [iseManageDP.cpp:439]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =reportValueUsage Params = {"00109709B13648:0","INSTALL_TEST",0} result= [faultCode:-2,faultString:"Invalid device"] [iseXmlRpc.cpp:2605]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallReportValueUsage: CallXmlrpcMethod failed [iseXmlRpc.cpp:1673]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: RemoveDPFromCollections: rpc.CallReportValueUsage failed dp id = 12623 [iseManageDP.cpp:439]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =reportValueUsage Params = {"00109709B13648:0","ERROR_CODE",0} result= [faultCode:-2,faultString:"Invalid device"] [iseXmlRpc.cpp:2605]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallReportValueUsage: CallXmlrpcMethod failed [iseXmlRpc.cpp:1673]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: RemoveDPFromCollections: rpc.CallReportValueUsage failed dp id = 12622 [iseManageDP.cpp:439]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =reportValueUsage Params = {"00109709B13648:0","DUTY_CYCLE",0} result= [faultCode:-2,faultString:"Invalid device"] [iseXmlRpc.cpp:2605]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallReportValueUsage: CallXmlrpcMethod failed [iseXmlRpc.cpp:1673]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: RemoveDPFromCollections: rpc.CallReportValueUsage failed dp id = 12621 [iseManageDP.cpp:439]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =reportValueUsage Params = {"00109709B13648:0","CONFIG_PENDING",0} result= [faultCode:-2,faultString:"Invalid device"] [iseXmlRpc.cpp:2605]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: IseXmlRpc::CallReportValueUsage: CallXmlrpcMethod failed [iseXmlRpc.cpp:1673]
Jan 27 12:32:45 homematic-ccu2 local0.err ReGaHss: Error: RemoveDPFromCollections: rpc.CallReportValueUsage failed dp id = 12617 [iseManageDP.cpp:439]
Jan 27 12:32:45 homematic-ccu2 user.debug hm_deldev: event fired (delete 00109709B13648)

FranzB94
Beiträge: 4
Registriert: 18.07.2018, 10:37

Re: HM-IP Geräte sind nach Reboot gelöscht

Beitrag von FranzB94 » 28.01.2019, 16:53

Hi therealhunter!
Ja das Spiel läuft bei mir seit Gestern auch. Nach einem Update auf 3.41.11 startete Raspberryimatic garnicht mehr. Dann habe ich die SW auf eine neue Karte aufgespielt. Nun konnte ich endlich meine HmIP-Geräte anmelden, was vorher nicht funktioniert hat. Nach einem Ortswechsel der Zentrale in der Wohnung waren alle angemeldeten HmIP-Geräte wieder verschwunden.

Gruß Franz

Xel66
Beiträge: 5049
Registriert: 08.05.2013, 23:33
Wohnort: Nordwürttemberg

Re: HM-IP Geräte sind nach Reboot gelöscht

Beitrag von Xel66 » 28.01.2019, 18:36

FranzB94 hat geschrieben:
28.01.2019, 16:53
Nach einem Ortswechsel der Zentrale in der Wohnung waren alle angemeldeten HmIP-Geräte wieder verschwunden.
Vermutlich nach Spannungsunterbrechung und ohne vorherige Abmeldung vom WebUI. Dann waren die Geräte noch nicht in die permanent gespeicherte Datenbank geschrieben und nur im Arbeitsspeicher vorhanden. Das Verhalten ist nachvollziehbar.

Gruß Xel66
---------------------------------------------------------------------------------
335 Kanäle in 103 Geräten und 113 CUxD-Kanäle in 23 CUxD-Geräten:
233 Programme, 189 Systemvariablen und 119 Direktverknüpfungen,
RaspberryMatic Version 3.45.5.20190330
---------------------------------------------------------------------------------

shartelt
Beiträge: 2248
Registriert: 14.01.2015, 14:59

Re: HM-IP Geräte sind nach Reboot gelöscht

Beitrag von shartelt » 28.01.2019, 18:55

kurze Frage, habt Ihr ein Firmware Update der HMiP Geräte gemacht und danach nicht gelöscht, resetted und neu angelernt?

therealhunter
Beiträge: 27
Registriert: 31.01.2017, 16:18

Re: HM-IP Geräte sind nach Reboot gelöscht

Beitrag von therealhunter » 28.01.2019, 20:58

shartelt hat geschrieben:
28.01.2019, 18:55
kurze Frage, habt Ihr ein Firmware Update der HMiP Geräte gemacht und danach nicht gelöscht, resetted und neu angelernt?
Nein ich habe von den Geräten kein Firmware Update gemacht.
Habe sie aber nach dem sie weg waren auch mehrfach resetet.
Xel66 hat geschrieben:
28.01.2019, 18:36
FranzB94 hat geschrieben:
28.01.2019, 16:53
Nach einem Ortswechsel der Zentrale in der Wohnung waren alle angemeldeten HmIP-Geräte wieder verschwunden.
Vermutlich nach Spannungsunterbrechung und ohne vorherige Abmeldung vom WebUI. Dann waren die Geräte noch nicht in die permanent gespeicherte Datenbank geschrieben und nur im Arbeitsspeicher vorhanden. Das Verhalten ist nachvollziehbar.

Gruß Xel66
Ist das bei HM Geräten genau so? Oder nur bei HMIP?
Das Problem hatte ich bislang noch nie. War was etwas dagegen spricht das sie wochenlang drin waren und dann plötzlich verschwunden sind. Ich teste aber mal.

Danke

Xel66
Beiträge: 5049
Registriert: 08.05.2013, 23:33
Wohnort: Nordwürttemberg

Re: HM-IP Geräte sind nach Reboot gelöscht

Beitrag von Xel66 » 28.01.2019, 21:05

Nein, spätestens nach 12 Stunden wird eine Datenbanksicherung gemacht. Dann sollten Sie gespeichert sein. Aber ohne diese Speicherung ist das bei allen Änderungen so, egal ob Gerät, Programm, Systemvariable oder andere Einstellung. Zieht man vor der Speicherung ohne Abmelden den Stecker, sit allrs weg. Wenn sie schon länger angelernt waren, muss das eine andere Ursache haben.

Gruß Xel66
---------------------------------------------------------------------------------
335 Kanäle in 103 Geräten und 113 CUxD-Kanäle in 23 CUxD-Geräten:
233 Programme, 189 Systemvariablen und 119 Direktverknüpfungen,
RaspberryMatic Version 3.45.5.20190330
---------------------------------------------------------------------------------

therealhunter
Beiträge: 27
Registriert: 31.01.2017, 16:18

Re: HM-IP Geräte sind nach Reboot gelöscht

Beitrag von therealhunter » 29.01.2019, 15:34

Ja es muss was anderes sein.
Habe sie vor 2 Tagen angemeldet und heute neu gestartet, und sie sind wieder weg.
Noch mal angelernt, abgemeldet und nach einer neuen Anmeldung die Zentrale neugestartet und sie sind wieder weg.

Mit der meldung wieder oben schon gepostet.

Code: Alles auswählen

Jan 27 12:32:45 homematic-ccu2 user.debug hm_deldev: event fired (delete 00109709B13648)

FranzB94
Beiträge: 4
Registriert: 18.07.2018, 10:37

Re: HM-IP Geräte sind nach Reboot gelöscht

Beitrag von FranzB94 » 01.02.2019, 16:37

@Xel66: Danke für deine Antwort. Als Raspimatic-Neuling tappt man in solche Fallen. Ich hatte zwar darauf geachtet, das Duty-Cycle bei 0% stand, aber an die Abmeldung vom GUI habe ich doch wohl nicht gedacht!

Gruß Franz

therealhunter
Beiträge: 27
Registriert: 31.01.2017, 16:18

Re: HM-IP Geräte sind nach Reboot gelöscht

Beitrag von therealhunter » 03.02.2019, 21:44

Hat sonst keiner ne Idee wieso die HMIP Geräte immer nach einem Reboot gelöscht sind?

Benutzeravatar
zautrix
Beiträge: 133
Registriert: 22.05.2016, 18:41
Wohnort: Badisch-Sibirien

Re: HM-IP Geräte sind nach Reboot gelöscht

Beitrag von zautrix » 04.02.2019, 10:12

therealhunter hat geschrieben:
03.02.2019, 21:44
Hat sonst keiner ne Idee wieso die HMIP Geräte immer nach einem Reboot gelöscht sind?
Sind die wirklich gelöscht oder sind die nur in den "Posteingang" verschoben?
Gruß aus Nord-Baden,
z.

Antworten

Zurück zu „RaspberryMatic“