Homematic-raspi-3.41.11.20190126 komme nicht mehr aufs Web

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
kmuenke
Beiträge: 65
Registriert: 07.03.2018, 13:10

Homematic-raspi-3.41.11.20190126 komme nicht mehr aufs Web

Beitrag von kmuenke » 31.01.2019, 14:17

Hallo,

ich habe jetzt seit ca. 3 Tagen neue Version im Einsatz jetzt habe ich gerade ein HmIP-BSL angelernt und wollte mich ein wenig daran versuchen aber leider komme ich nicht mehr auf die Webseite keine Antwort. Wo genau muss ich schauen um den fehler zu finden. Habe auch gerade versucht über die Konsole ein Backup wieder einzuspielen. Leider ohne Erfolg.

Code: Alles auswählen

# /bin/restoreBackup.sh /media/usb1/backup/homematic-raspi-3.41.11.20190126-2019-01-31-0007.sbk
Stopping ReGaHss: OK
Stopping HMIPServer: OK
Stopping rfd: OK
Stopping hs485d: killall: hs485d: no process killed
OK
Stopping lighttpd: OK
start-stop-daemon: warning: killing process 987: No such process
In der messages kommt leider nicht viel

Code: Alles auswählen

Jan 31 14:14:23 homematic-raspi daemon.info cuxd[628]: INIT 'xmlrpc_bin://192.168.2.20:18701' 'hm-rpc.1'
Jan 31 14:14:33 homematic-raspi daemon.info cuxd[628]: INIT 'xmlrpc_bin://192.168.2.20:18701' 'hm-rpc.1'
Log hmserver

Code: Alles auswählen

# vi hmserver.log
Jan 31 14:09:10 de.eq3.lib.util.dynamics.GenericFactory INFO  [main] @GenericFactory
Jan 31 14:09:10 de.eq3.lib.util.dynamics.GenericFactory INFO  [main] created instance of HMServerConfiguration with parameter(s)
Jan 31 14:09:10 de.eq3.lib.util.dynamics.GenericFactory INFO  [main] passed 1 parameter(s), in declarative order [String]
Jan 31 14:09:16 de.eq3.cbcs.devicedescription.ChannelTypeDescription WARN  [Thread-0] Invalid state parameter or subtype: Parameter ERROR_POWER_SHORT_CIRCUIT_BUS_1 subtype=default
Jan 31 14:09:16 de.eq3.cbcs.devicedescription.ChannelTypeDescription WARN  [Thread-0] Invalid state parameter or subtype: Parameter ERROR_POWER_SHORT_CIRCUIT_BUS_2 subtype=default
Jan 31 14:09:16 de.eq3.cbcs.devicedescription.ChannelTypeDescription WARN  [Thread-0] Invalid state parameter or subtype: Parameter ERROR_SHORT_CIRCUIT_DATA_LINE_BUS_1 subtype=default
Jan 31 14:09:16 de.eq3.cbcs.devicedescription.ChannelTypeDescription WARN  [Thread-0] Invalid state parameter or subtype: Parameter ERROR_SHORT_CIRCUIT_DATA_LINE_BUS_2 subtype=default
Jan 31 14:09:16 de.eq3.cbcs.devicedescription.ChannelTypeDescription WARN  [Thread-0] Invalid state parameter or subtype: Parameter ERROR_BUS_CONFIG_MISMATCH subtype=default
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [HMIPTRXWriterWorker] (1) *worker
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [KeyServerWorker] (1) *worker
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [KryoPersistenceWorker] (1) *worker
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [TransactionSubsystemHandler] (1) *worker
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [FirmwareLoaderFileSystem] (1) *worker
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [LocalServerPersistentDataLoader] (1)
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [LocalServerAdapterInitialization] (1)
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [BackendCommandHandler] (1)
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [DeviceInclusionAcceptHandler] (1)
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [CheckDeviceExistHandler] (1)
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [IncomingHMIPFrameHandler] (1)
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [DeviceBackgroundUpdateSubsystem] (1)
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [DeviceLiveUpdateSubsystem] (1)
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [DeviceInclusionDefaultConfigurationChanger] (1)
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [CyclicSmokeDetectorAwakening] (1)
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [LocalServerFirmwareUpdateInitialization] (1)
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [LegacyNotificationHandler] (1) *worker
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [LegacyAPIWorker] (1) *worker
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [LegacyBackendNotificationHandler] (3) *worker
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [LegacyBlindLevelCorrectionHandler] (1) *worker
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: added for deployment [LegacyInitializion] (1)
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: deploying 21 classes to Vert.x
Jan 31 14:09:16 de.eq3.cbcs.vertx.management.VertxManager INFO  [Thread-0] SYSTEM: 21 VertxDeployers initialized
mfg

Karsten

Benutzeravatar
jmaus
Beiträge: 5054
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 7 Mal
Danksagung erhalten: 86 Mal
Kontaktdaten:

Re: Homematic-raspi-3.41.11.20190126 komme nicht mehr aufs Web

Beitrag von jmaus » 31.01.2019, 14:29

kmuenke hat geschrieben:
31.01.2019, 14:17
Habe auch gerade versucht über die Konsole ein Backup wieder einzuspielen. Leider ohne Erfolg.
Nach der Nutzung von restoreBackup.sh musst du natürlich auch einen manuellen Neustart machen.
RaspberryMatic 3.47.18.20190918 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

kmuenke
Beiträge: 65
Registriert: 07.03.2018, 13:10

Re: Homematic-raspi-3.41.11.20190126 komme nicht mehr aufs Web

Beitrag von kmuenke » 31.01.2019, 14:37

Ja klar habe ich gemacht leider ohne Erfolg.

kmuenke
Beiträge: 65
Registriert: 07.03.2018, 13:10

Re: Homematic-raspi-3.41.11.20190126 komme nicht mehr aufs Web

Beitrag von kmuenke » 31.01.2019, 16:10

So nachdem ich jetzt Versucht habe das 3 mal das Backup einzuspielen hat es funktioniert komme wieder auf die Webseite und die Geräte sind wieder da.
Was nur nicht geht ist das Anlernen da kommt leider nur dieses Bild.
Unbenannt.JPG
Im iobroker kommen 2 Instanzen nicht auf die Homematic
Unbenannt.JPG
Zuletzt geändert von kmuenke am 31.01.2019, 16:18, insgesamt 1-mal geändert.

Benutzeravatar
jmaus
Beiträge: 5054
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 7 Mal
Danksagung erhalten: 86 Mal
Kontaktdaten:

Re: Homematic-raspi-3.41.11.20190126 komme nicht mehr aufs Web

Beitrag von jmaus » 31.01.2019, 16:16

Na wenn das so aussieht sollte aber weder BidCos-RF noch homematicIP schaltbar sein von der CCU/RaspberryMatic aus. Ich würde mal eine neue SD Karte probieren und das aktuellste Backup neu einspielen, ohne restoreBackup.sh.
RaspberryMatic 3.47.18.20190918 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

kmuenke
Beiträge: 65
Registriert: 07.03.2018, 13:10

Re: Homematic-raspi-3.41.11.20190126 komme nicht mehr aufs Web

Beitrag von kmuenke » 31.01.2019, 16:37

Hallo Jens,

ja ok aber an dem Raspi ist keine SD Karte sondern eine SSD.

kmuenke
Beiträge: 65
Registriert: 07.03.2018, 13:10

Re: Homematic-raspi-3.41.11.20190126 komme nicht mehr aufs Web

Beitrag von kmuenke » 31.01.2019, 17:03

Hallo Jens,

auf der SSD alle Partionen gelöscht und die Platte Formatiert. Image aufgespielt und Raspberry gestartet. Dann kommt er mit dieser Meldung hoch. Sollte glaube ich nicht so sein.
IMG_8555.jpg
Hier noch das Logfile.
homematic-raspi-2019-01-31.log
(58.6 KiB) 5-mal heruntergeladen
Ein einschalten der SSH Verbindung hat leider auch nicht funktioniert. Nach dem drücken Backup einspielen verschindet das Menue und man landet auf der Startseite.

Oky wieder eine erkenntnis reicher SSD abgeklemmt und SD Karte installiert. System fährt hoch und Backup eingespielt. Reboot komme nicht mehr auf die Webseite.
Zuletzt geändert von kmuenke am 31.01.2019, 17:22, insgesamt 1-mal geändert.

Benutzeravatar
jmaus
Beiträge: 5054
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 7 Mal
Danksagung erhalten: 86 Mal
Kontaktdaten:

Re: Homematic-raspi-3.41.11.20190126 komme nicht mehr aufs Web

Beitrag von jmaus » 31.01.2019, 17:20

Das sieht in der Tat komisch aus und diese bootmeldungen sollten definitiv so nicht kommen. Vor allem das "no space on device" verwundert mich. Entweder ist die SSD kaputt oder das image wurde nicht korrekt draufgeschrieben....
RaspberryMatic 3.47.18.20190918 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

kmuenke
Beiträge: 65
Registriert: 07.03.2018, 13:10

Re: Homematic-raspi-3.41.11.20190126 komme nicht mehr aufs Web

Beitrag von kmuenke » 31.01.2019, 21:45

Oky wieder eine erkenntnis reicher SSD abgeklemmt und SD Karte installiert. System fährt hoch und Backup eingespielt. Reboot komme nicht mehr auf die Webseite. Die Datensicherung (Datei) die bei der SSD mich wieder auf die Startseite verwiesen hat. Gibt es den kein log was mal eine aussage trifft was da nicht stimmt ????

kmuenke
Beiträge: 65
Registriert: 07.03.2018, 13:10

Re: Homematic-raspi-3.41.11.20190126 komme nicht mehr aufs Web

Beitrag von kmuenke » 01.02.2019, 17:35

Hallo,

Version 3.41.11.20181222 auf eine SD Karte gespielt und das Backup von dieser Version eingespielt. Läuft wieder. Auf die neue Version gehe ich erstmal nicht. Leider kann mir ja keiner sagen warum diese Version so zicken macht.

Gruß

Karsten

Antworten

Zurück zu „RaspberryMatic“