Probleme: Strompi3 mit HM-MOD-RPI-PCB

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
swahl
Beiträge: 26
Registriert: 08.03.2019, 07:09

Probleme: Strompi3 mit HM-MOD-RPI-PCB

Beitrag von swahl » 08.03.2019, 07:39

Hallo,

ich nutze einen raspi 3B und wollte diesen mit dem StromPi3 absichern.
Raspberrymatic habe ich in der Version 3.43.15.20190223.

Den Strompi habe ich vor der Montage auf der raspberrymatic in den serialless-mode gesetzt, damit dieser nicht den UART blockiert. Nun habe ich folgende Probleme, die mit Entfernen des Strompi's vollständig verschwinden:

- Nach dem Booten dauert es lange bis die WebUI startet. In der lighthttpd-error.log gibt es vom gw_backend.c die Meldung "connection refused socket: tcp:127.0.0.1:32010". Durch manuelles Starten des ReGaHss Services kann ich mich dann normal einloggen.

- Das messages log ist voll von "RegaHss: Error: IseXmlRpc::CallGet...... failed"

- Die WebUI zeigt regelmäßig ein popup, dass eine Komponente abgestürzt sei.

- Manche System-Menüpunkte wie z.B. "allgemeine Einstellungen" lassen sich nicht mehr öffnen.

- Allerdings funktioniert das Schalten (jedenfalls mancher) der Geräte noch - selbst über Alexa, d.h. XML Schnittstelle

Sobald ich den Strompi entferne sind alle Probleme weg. Hat jemand eine Idee?

Benutzeravatar
jmaus
Beiträge: 4541
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Kontaktdaten:

Re: Probleme: Strompi3 mit HM-MOD-RPI-PCB

Beitrag von jmaus » 08.03.2019, 09:35

swahl hat geschrieben:
08.03.2019, 07:39
ich nutze einen raspi 3B und wollte diesen mit dem StromPi3 absichern.
Raspberrymatic habe ich in der Version 3.43.15.20190223.

[...]

Sobald ich den Strompi entferne sind alle Probleme weg. Hat jemand eine Idee?
Das habe ich ja. Der StromPi3 ist einfach nicht supported! Der Hersteller hat hier leider eine Verschlimmbesserung gegenüber dem Vormodell durchgeführt und es vielleicht zwar mit dem zusätzlichen seriellen Interface gut gemeint. Das kommt allerdings wohl trotz der Möglichkeit dieses abschalten zu können dem Funkmodul in die Quere. Und die Fehler die du siehst resultieren einfach daraus das das Funkmodul nicht mit dem StromPi3 zusammen funktioniert. Ergo, IMHO zurückschicken und gegen ein StromPi2 tauschen oder noch besser gleich zu einer S.USV greifen.
RaspberryMatic 3.45.7.20190511 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

swahl
Beiträge: 26
Registriert: 08.03.2019, 07:09

Re: Probleme: Strompi3 mit HM-MOD-RPI-PCB

Beitrag von swahl » 08.03.2019, 10:49

Besten Dank für die schnelle Antwort. Ich werde es genau so machen!

Antworten

Zurück zu „RaspberryMatic“