Homematic IP (HMIP) Geräte zeigen plötzlich keine Reaktion mehr

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Benutzeravatar
robson
Beiträge: 57
Registriert: 08.06.2016, 19:26
Wohnort: Ruhrpott

Homematic IP (HMIP) Geräte zeigen plötzlich keine Reaktion mehr

Beitrag von robson » 09.03.2019, 20:58

Hallo zusammen,

seit Wochen habe ich an meiner HM-Steuerung nichts mehr unternommen: keine neuen Programme, keine Skripte, keine Updates, etc.

Seit gestern nun lassen sich keinerlei HMIP-Aktoren in meinem Haus mehr über die WebUI ansteuern. Die Betätigung der Tasten An/Aus unter dem Reiter "Geräte" führt zu keinen Servicemeldungen und auch zu keinen Meldungen im Log.
Lichtaktoren (HMIP-BSM) beispielsweise lassen sich nur in sehr unregelmäßigen Abständen auch manuell schalten. Meist aber gar nicht.

Mein Setup: Raspberry 3B+ mit RaspMatic 3.41.11.20190126 und Funkmodul RPI-RF-MOD. Darüber habe ich ein LAN-Gateway und ein WLAN-Gateway verbunden.

Das Logging Detail wurde auf "Alles loggen" gestellt. Hier wurden einige Fehler gefunden, die mir leider nicht viel sagen. Die Fehlermeldungen findet ihr im zweiten Post von Visu und in meinem Post darunter.

Neustarts haben leider nichts gebracht.
Heute habe ich dann auf die aktuellste Firmware Raspmatic 3.43.15.20190223 geupdatet. Leider hat dies auch keine Verbesserungen gebracht. Im Gegenteil. Ich habe nun 17 Servicemeldungen. Vorher waren es 1-2. Dies wird aber vermutlich an der virtuellen Remote für HMIP liegen.

Zusätzlich sind hier und da (genauer kann ich es leider nicht beschreiben) auch HM Classic-Aktoren betroffen. Rollladenaktoren, die nicht reagieren, Tür-Fensterkontakte, bei denen die Kommunikation gestört ist, etc. Die Fehler bei den Classic-Aktoren beheben sich bisher aber meist von selbst.

Die IP-Aktoren hingegen spinnen immer noch.
Mir gehen gerade die Ideen aus, was ich noch machen kann. Kann jemand mit Tipps helfen?
Zuletzt geändert von robson am 10.03.2019, 11:34, insgesamt 2-mal geändert.
Raspberry Pi 3 RaspberryMatic, Raspberry Pi 3 als HMLGW, Rasperry Pi 2 als HMWLGW

Visu
Beiträge: 422
Registriert: 04.12.2016, 23:30

Re: Homematic IP (HMIP) Geräte zeigen plötzlich keine Reaktion mehr

Beitrag von Visu » 10.03.2019, 10:31

Guten Morgen,
ich habe ein ähnliches Verhalten seit 2 Tagen, bei meiner IP Steckdose (HMIP-PS Zwischenstecker) ist die Gerätekommunikation gestört, nach betätigen der Gerätetaste (EIN- AUSschalten) verschwindet die Meldung ohne Bestätigung. Da ich mit dem Aktor keine Geräte schalte und es in keinem Programm verarbeitet wird, habe ich nach diesem Bericht mal versucht den Aktor über die WebUI zu schalten, es kommt sofort die Servicemeldung "Gerätekommunikation gestört". Ich nutze das Teil nur als Repeater für meinen Rauchmelder (HmIP-SWSD), bei dem ist aber alles i.O.
Auch ich habe seit Wochen nichts am Sytem verändert. Die letzte Änderung war das aktuelle Firmwareupdate, das habe ich am 24.02. eingespielt. Weitere Servicemeldungen liegen nicht vor.

Vor dem 24.03. keine Log Einträge zu dem Aktor

Code: Alles auswählen

...
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000218A98F07D6:0","ACTUAL_TEMPERATURE"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: ACTUAL_TEMPERATURE"] [iseXmlRpc.cpp:2605]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallGetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1432]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::ReadValue: CallGetValue failed; sVal = 0.000000 [iseDOMdpHSS.cpp:124]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000218A98F07D6:0","ACTUAL_TEMPERATURE_STATUS"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: ACTUAL_TEMPERATURE_STATUS"] [iseXmlRpc.cpp:2605]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallGetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1432]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::ReadValue: CallGetValue failed; sVal = 0 [iseDOMdpHSS.cpp:124]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000218A98F07D6:0","ERROR_CODE"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: ERROR_CODE"] [iseXmlRpc.cpp:2605]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallGetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1432]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::ReadValue: CallGetValue failed; sVal = 0 [iseDOMdpHSS.cpp:124]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000218A98F07D6:0","ERROR_OVERHEAT"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: ERROR_OVERHEAT"] [iseXmlRpc.cpp:2605]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallGetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1432]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::ReadValue: CallGetValue failed; sVal = 0 [iseDOMdpHSS.cpp:124]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000218A98F07D6:0","OPERATING_VOLTAGE"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: OPERATING_VOLTAGE"] [iseXmlRpc.cpp:2605]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallGetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1432]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::ReadValue: CallGetValue failed; sVal = 0.000000 [iseDOMdpHSS.cpp:124]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000218A98F07D6:0","OPERATING_VOLTAGE_STATUS"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: OPERATING_VOLTAGE_STATUS"] [iseXmlRpc.cpp:2605]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallGetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1432]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::ReadValue: CallGetValue failed; sVal = 0 [iseDOMdpHSS.cpp:124]
....
Mar 10 10:22:45 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =setValue Params = {"000218A98F07D6:3","STATE",true} result= [faultCode:-1,faultString:"Generic error (UNREACH)"] [iseXmlRpc.cpp:2605]
Mar 10 10:22:45 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallSetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1502]
Mar 10 10:22:45 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::WriteValue: CallSetValue failed; address = 000218A98F07D6:3 [iseDOMdpHSS.cpp:76]
G.V.

Benutzeravatar
robson
Beiträge: 57
Registriert: 08.06.2016, 19:26
Wohnort: Ruhrpott

Re: Homematic IP (HMIP) Geräte zeigen plötzlich keine Reaktion mehr

Beitrag von robson » 10.03.2019, 11:06

Visu hat geschrieben:
10.03.2019, 10:31
Guten Morgen,
ich habe ein ähnliches Verhalten seit 2 Tagen, bei meiner IP Steckdose (HMIP-PS Zwischenstecker) ist die Gerätekommunikation gestört, nach betätigen der Gerätetaste (EIN- AUSschalten) verschwindet die Meldung ohne Bestätigung. Da ich mit dem Aktor keine Geräte schalte und es in keinem Programm verarbeitet wird, habe ich nach diesem Bericht mal versucht den Aktor über die WebUI zu schalten, es kommt sofort die Servicemeldung "Gerätekommunikation gestört". Ich nutze das Teil nur als Repeater für meinen Rauchmelder (HmIP-SWSD), bei dem ist aber alles i.O.
Auch ich habe seit Wochen nichts am Sytem verändert. Die letzte Änderung war das aktuelle Firmwareupdate, das habe ich am 24.02. eingespielt. Weitere Servicemeldungen liegen nicht vor.

Vor dem 24.03. keine Log Einträge zu dem Aktor

Code: Alles auswählen

...
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000218A98F07D6:0","ACTUAL_TEMPERATURE"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: ACTUAL_TEMPERATURE"] [iseXmlRpc.cpp:2605]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallGetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1432]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::ReadValue: CallGetValue failed; sVal = 0.000000 [iseDOMdpHSS.cpp:124]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000218A98F07D6:0","ACTUAL_TEMPERATURE_STATUS"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: ACTUAL_TEMPERATURE_STATUS"] [iseXmlRpc.cpp:2605]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallGetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1432]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::ReadValue: CallGetValue failed; sVal = 0 [iseDOMdpHSS.cpp:124]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000218A98F07D6:0","ERROR_CODE"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: ERROR_CODE"] [iseXmlRpc.cpp:2605]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallGetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1432]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::ReadValue: CallGetValue failed; sVal = 0 [iseDOMdpHSS.cpp:124]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000218A98F07D6:0","ERROR_OVERHEAT"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: ERROR_OVERHEAT"] [iseXmlRpc.cpp:2605]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallGetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1432]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::ReadValue: CallGetValue failed; sVal = 0 [iseDOMdpHSS.cpp:124]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000218A98F07D6:0","OPERATING_VOLTAGE"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: OPERATING_VOLTAGE"] [iseXmlRpc.cpp:2605]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallGetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1432]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::ReadValue: CallGetValue failed; sVal = 0.000000 [iseDOMdpHSS.cpp:124]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =getValue Params = {"000218A98F07D6:0","OPERATING_VOLTAGE_STATUS"} result= [faultCode:-5,faultString:"Unknown Parameter value for value key: OPERATING_VOLTAGE_STATUS"] [iseXmlRpc.cpp:2605]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallGetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1432]
Feb 25 13:22:50 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::ReadValue: CallGetValue failed; sVal = 0 [iseDOMdpHSS.cpp:124]
....
Mar 10 10:22:45 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =setValue Params = {"000218A98F07D6:3","STATE",true} result= [faultCode:-1,faultString:"Generic error (UNREACH)"] [iseXmlRpc.cpp:2605]
Mar 10 10:22:45 ccu3-raspi local0.err ReGaHss: Error: IseXmlRpc::CallSetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1502]
Mar 10 10:22:45 ccu3-raspi local0.err ReGaHss: Error: IseHssDP::WriteValue: CallSetValue failed; address = 000218A98F07D6:3 [iseDOMdpHSS.cpp:76]
G.V.
Danke für die Rückmeldung. Zumindest bin ich nicht alleine. Seit über drei Jahren habe ich so ein Verhalten noch nicht gehabt.
Ich habe mein Log nun auch noch mal nach den Fehlermeldungen durchforstet, die du in deinem gefunden hast.
Bei mir sieht es tatsächlich ähnlich aus:

Code: Alles auswählen

Mar  9 21:35:46 homematic-raspi local0.err ReGaHss: Error: IseXmlRpc::CallXmlrpcMethod: execute result isFault; method =setValue Params = {"0001D3C990BE98:3","STATE",false} result= [faultCode:-1,faultString:"Generic error (TIMEOUT)"] [iseXmlRpc.cpp:2605]
Mar  9 21:35:46 homematic-raspi local0.err ReGaHss: Error: IseXmlRpc::CallSetValue: CallXmlrpcMethod failed [iseXmlRpc.cpp:1502]
Mar  9 21:35:46 homematic-raspi local0.err ReGaHss: Error: IseHssDP::WriteValue: CallSetValue failed; address = 0001D3C990BE98:3 [iseDOMdpHSS.cpp:76]
Mar  9 21:35:46 homematic-raspi local0.info ReGaHss: Info: IseXmlRpc::GetInterfaceByID: interface name= HmIP-RF for ID=1237 [iseXmlRpc.cpp:2549]
Mar  9 21:35:46 homematic-raspi local0.info ReGaHss: Info: XmlRpcMethodEvent::execute: Event="0001D3C990BE98:0"."UNREACH"=true [iseXmlRpc.cpp:321]
Mar  9 21:35:46 homematic-raspi local0.debug ReGaHss: Verbose: CHANNEL::SetLastDPActionTime: call on change; id = 2614 [iseDOMchn.h:288]
Mar  9 21:35:46 homematic-raspi local0.debug ReGaHss: Verbose: DEVICE::SetLastActionTime: call on change; id = 2613 [iseDOMdev.h:225]
Mar  9 21:35:46 homematic-raspi local0.debug ReGaHss: Verbose: EventThread::ThreadFunction: wait max timeout = 240000 [iseRTEvent.cpp:69]
Mar  9 21:35:46 homematic-raspi local0.debug ReGaHss: Verbose: XmlRpcMethodEvent::execute: UpdateValue succeeded; val = 1 [iseXmlRpc.cpp:364]
Mar  9 21:35:46 homematic-raspi local0.info ReGaHss: Info: IseXmlRpc::CallXmlrpcMethod: method =getValue params = {"0001D3C990BE98:3","STATE"} result = true [iseXmlRpc.cpp:2610]
Mar  9 21:35:46 homematic-raspi local0.debug ReGaHss: Verbose: CHANNEL::SetLastDPActionTime: call on change; id = 2855 [iseDOMchn.h:288]
Mar  9 21:35:46 homematic-raspi local0.debug ReGaHss: Verbose: DEVICE::SetLastActionTime: call on change; id = 2613 [iseDOMdev.h:225]
Scheinbar habe ich immer nur auf "XmlRpcMethodEvent::execute: UpdateValue succeeded" geschaut. Das sah für mich nicht fehlerhaft aus. Den Timeout und den Error scheine ich konsequent überlesen zu haben :oops:

Da ich das Ganze aktuell nicht auf die Software, sondern mehr auf die Hardware schiebe, versuche ich gleich das alte Funkmodul wieder in Betrieb zu nehmen und danach ein älteres Image aufzuspielen. Ich melde mich danach mal
Raspberry Pi 3 RaspberryMatic, Raspberry Pi 3 als HMLGW, Rasperry Pi 2 als HMWLGW

Benutzeravatar
robson
Beiträge: 57
Registriert: 08.06.2016, 19:26
Wohnort: Ruhrpott

Re: Homematic IP (HMIP) Geräte zeigen plötzlich keine Reaktion mehr

Beitrag von robson » 10.03.2019, 11:30

Ich habe meine Zentrale nun wieder mit dem älteren Funkmodul HM-MOD-RPI-PCB bestückt und mit der aktuellen Firmware gestartet. Die Probleme sind (für dem Moment zumindest) weg und alle Aktoren lassen sich wieder bedienen und schalten, wie gewünscht. Auch hat sich die Anzahl der Servicemeldungen wieder auf 1 reduziert.

Erklären kann ich mir das Ganze aktuell leider nicht, jedoch hadere ich schon seit längerem mit dem neuen Funkmodul und meine mir einzubilden, dass (zumindest bei meiner Installation) die Funkleistung mit dem alten Modul besser war. Ich werde das Ganze in den kommenden Tagen mal genau beobachten.

EDIT:
Auch finde ich aktuell die oben beschriebenen Fehlermeldungen nicht mehr im Log.
Raspberry Pi 3 RaspberryMatic, Raspberry Pi 3 als HMLGW, Rasperry Pi 2 als HMWLGW

Benutzeravatar
robson
Beiträge: 57
Registriert: 08.06.2016, 19:26
Wohnort: Ruhrpott

Re: Homematic IP (HMIP) Geräte zeigen plötzlich keine Reaktion mehr

Beitrag von robson » 10.03.2019, 12:20

Tja, da habe ich mich wohl zu früh gefreut. Die HMIP Aktoren zeigen nach gut einer Stunde wieder das alte fehlerhafte Verhalten. Auch tauchen die oben genannten Fehler im Log wieder auf :(
Raspberry Pi 3 RaspberryMatic, Raspberry Pi 3 als HMLGW, Rasperry Pi 2 als HMWLGW

Visu
Beiträge: 422
Registriert: 04.12.2016, 23:30

Re: Homematic IP (HMIP) Geräte zeigen plötzlich keine Reaktion mehr

Beitrag von Visu » 11.03.2019, 08:31

Jetzt ist es bei mir so, dass die Steckdose eine Gerätestörung hat, diese wird mir via Telegram übermittelt, aber in der WebUI nicht mehr angezeigt :?: :roll:
123.JPG
123.JPG (16.51 KiB) 479 mal betrachtet
im Log ist aber nichts zu finden :?: :roll:

Benutzeravatar
robson
Beiträge: 57
Registriert: 08.06.2016, 19:26
Wohnort: Ruhrpott

Re: Homematic IP (HMIP) Geräte zeigen plötzlich keine Reaktion mehr

Beitrag von robson » 11.03.2019, 19:22

Visu hat geschrieben:
11.03.2019, 08:31
Jetzt ist es bei mir so, dass die Steckdose eine Gerätestörung hat, diese wird mir via Telegram übermittelt, aber in der WebUI nicht mehr angezeigt :?: :roll:
123.JPG

im Log ist aber nichts zu finden :?: :roll:
Welchen Raspberry Pi verwendest du für deine Raspberrymatic?
Raspberry Pi 3 RaspberryMatic, Raspberry Pi 3 als HMLGW, Rasperry Pi 2 als HMWLGW

Visu
Beiträge: 422
Registriert: 04.12.2016, 23:30

Re: Homematic IP (HMIP) Geräte zeigen plötzlich keine Reaktion mehr

Beitrag von Visu » 11.03.2019, 20:14

keinen...
Tinker S mit neuem Funkmodul

Benutzeravatar
robson
Beiträge: 57
Registriert: 08.06.2016, 19:26
Wohnort: Ruhrpott

Re: Homematic IP (HMIP) Geräte zeigen plötzlich keine Reaktion mehr

Beitrag von robson » 13.03.2019, 17:38

Visu hat geschrieben:
11.03.2019, 20:14
keinen...
Tinker S mit neuem Funkmodul
OK. Ich hatte den Raspberry Pi 3B+ als Ursache in Verdacht und kann auf folgendes Ticket referenzieren:
https://github.com/jens-maus/RaspberryMatic/issues/500

Nach Wechsel auf den Raspi 3B (Nicht +) treten die Fehler nun nicht mehr auf. Diesen teste ich nun schon seit zwei Tagen recht intensiv.

Da die Kommunikationsstörungen auf einmal und ohne jegliches Zutun bzw. Änderung des Setups aufgetreten sind, gehe ich daher von einem Hardware-Defekt aus.
Raspberry Pi 3 RaspberryMatic, Raspberry Pi 3 als HMLGW, Rasperry Pi 2 als HMWLGW

Visu
Beiträge: 422
Registriert: 04.12.2016, 23:30

Re: Homematic IP (HMIP) Geräte zeigen plötzlich keine Reaktion mehr

Beitrag von Visu » 14.03.2019, 08:38

bei mir ist komischerweise wieder Ruhe, über die WebUI schalten geht auch wieder :roll: :?:

Antworten

Zurück zu „RaspberryMatic“