Speicherverwaltung der aktuelle RM 3.45.5.20190330 ?!?!?

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
roe1974
Beiträge: 325
Registriert: 17.10.2017, 16:15
Wohnort: Wien

Speicherverwaltung der aktuelle RM 3.45.5.20190330 ?!?!?

Beitrag von roe1974 » 14.04.2019, 11:20

Ich zeichne unter anderem den free Memory der RM auf.
Mir fällt auf, dass sich das Speichermanagement seit der neuen Version verändert hat.
Man erkennt das gut auf der Grafik. Wir das irgendwann zum Problem? Wird hier kein Speicher mehr freigegeben ?
Die "peaks" sind jedesmal ein Neustart der RM.
lg Richard
Unbenannt.JPG

darkbrain85
Beiträge: 825
Registriert: 27.06.2015, 22:17

Re: Speicherverwaltung der aktuelle RM 3.45.5.20190330 ?!?!?

Beitrag von darkbrain85 » 14.04.2019, 12:30

Hier mal meine Speicherauslastung. Ich kann da kein Problem erkennen. RM läuft seit dem Update am 30.03. ohne reboot...

Code: Alles auswählen

# free -m
             total       used       free     shared    buffers     cached
Mem:           968        505        463         12         15        287
-/+ buffers/cache:        202        766
Swap:            0          0          0
# 

nicolas-eric
Beiträge: 2808
Registriert: 07.01.2015, 23:26
Wohnort: Scheeßel

Re: Speicherverwaltung der aktuelle RM 3.45.5.20190330 ?!?!?

Beitrag von nicolas-eric » 14.04.2019, 12:50

Ich hab nur 89kB frei, das mag aber an RedMatic liegen.

hoedlmoser
Beiträge: 176
Registriert: 19.01.2015, 07:42

Re: Speicherverwaltung der aktuelle RM 3.45.5.20190330 ?!?!?

Beitrag von hoedlmoser » 14.04.2019, 12:51

linux wird hier oft missverstanden. aber die seite https://www.linuxatemyram.com versucht das aufzuklären.
RaspberryMatic 3.45.5.20190330 on Charly with Pi 3B+ and Aurel Groundplane binded by openHAB 2.4.0

capitaen_z
Beiträge: 107
Registriert: 05.07.2015, 19:34
Wohnort: Hamburg

Re: Speicherverwaltung der aktuelle RM 3.45.5.20190330 ?!?!?

Beitrag von capitaen_z » 15.04.2019, 17:36

Das Problem ist nicht neu, aktuell gibt es keine Lösung außer dem Reboot:
viewtopic.php?f=65&t=46928&start=60
Leider kann man dann irgendwann z.B. keine Skripte mehr ausführen, bis zum nächsten Reboot...

VG
Leif

Antworten

Zurück zu „RaspberryMatic“