WebUI friert ein, Fehler zu XMLRPC und ReGaHss im Log

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
Burger-King
Beiträge: 6
Registriert: 26.08.2018, 13:18

WebUI friert ein, Fehler zu XMLRPC und ReGaHss im Log

Beitrag von Burger-King » 16.05.2019, 21:48

Hallo zusammen!

Bisher konnte ich ja immer alle Probleme die sich so auftaten mit Hilfe bestehender Beiträge, Google etc. lösen - aber jetzt verlässt mich grade mein Glück - ich brauche eure Hilfe.
Was ist passiert? Das WebUI meiner Zentrale (Pi3 mit RF-Mod und RaspberryMatic) liess sich aufrufen, jedoch kein Untermenü. Das Bild graut aus, es öffnet sich aber kein Fenster. Die IP muss neu aufgerufen werden, neuer Login - dann gleiches Problem. Nachdem ich mir nicht anders zu helfen wusste, habe ich eine neue SD-Karte mit neuster Firmware von Jens aufgesetzt (läuft) - und habe mein Backup wieder eingespielt. Und siehe da: gleiches Problem wieder!!!
Sprich': Der Fehler steckt im Backup. Aber wo? In /var/log/messages fielen mir einige Einträge zu XMLRpc und ReGaHSS auf. Und erst jetzt fällt mir auf: Im WebUI schlägt auch der watchdog zu ReGaHSS an - ob das vorher auch so war - keine Ahnung...

Ich habe euch zwei Auszüge aus dem Log als Bild angehangen, leider weiß' ich nicht, wie ich var/log/messages in eine Datei bekomme. ">" in eine Datei wird wegen "read-only" abgelehnt.

Vielleicht hat Jemand eine Idee, oder Link oder Stichwort, wie ich dem Fehler zu Leibe rücken kann!?

Vielen Dank euch!
Dateianhänge
xmlrpc.PNG
XMLRpc
regahss.PNG
ReGaHSS

Sebastian65432
Beiträge: 99
Registriert: 14.05.2018, 19:50

Re: WebUI friert ein, Fehler zu RpcXML und ReGaHss im Log

Beitrag von Sebastian65432 » 22.05.2019, 10:34

Benutzt du iobroker? Das mit dem Einfrieren der Oberfläche hatte ich mal vor einigen Wochen in Verbindung mit dem iobroker und dem HM Adaptern.
Grüße

Burger-King
Beiträge: 6
Registriert: 26.08.2018, 13:18

Re: WebUI friert ein, Fehler zu XMLRPC und ReGaHss im Log

Beitrag von Burger-King » 25.05.2019, 12:45

Hey Sebastian65432,

Danke für deinen Tipp: ein klares Jain; Ich hatte mal für zwei Tage einen ioBroker auf einem separaten Pi laufen...
Könnte der was hinterlassen haben? Und wie könnte ich das vielleicht noch vor dem Rückspielen des Backups manuell wieder entfernen?
Ich habe grade herausgefunden, dass ich die sbk-Datei mit 7-zip entpacken kann - gibt es hier Dateien, die ich manuell entfernen könnte?

Burger-King
Beiträge: 6
Registriert: 26.08.2018, 13:18

Re: WebUI friert ein, Fehler zu XMLRPC und ReGaHss im Log

Beitrag von Burger-King » 25.05.2019, 14:07

Hallo nochmal...

nachdem ich bei dem manuellen verändern des Backups nicht weitergekommen bin, habe ich mal versucht, das Backup per SSH wieder einzuspielen.
Scheint auch erfolgreich (also scheint zumindest die Datei an sich nicht korrupt). Es scheint aber nicht am Browserupload gelegen zu haben, denn danach ist Alles wie beim Recover via WebUI.

Was mir auffält: Nach dem Neustart fahren zwei Rolladenaktoren kurz an (ca. 1 Sekunde). Das könnte daran liegen, dass ich zuletzt ein Programm angelegt hatte, welches diese Beiden steuern soll. Danach ist wieder alles wie gehabt.

Ich verzweifle langsam, weil ich bei meiner Diagnose nicht weiterkomme...

Muss ich wirklich ALLES neu anlegen :cry: ?

trevyn
Beiträge: 51
Registriert: 25.04.2017, 17:19

Re: WebUI friert ein, Fehler zu XMLRPC und ReGaHss im Log

Beitrag von trevyn » 25.05.2019, 14:17

Burger-King hat geschrieben:
25.05.2019, 12:45
Ich hatte mal für zwei Tage einen ioBroker auf einem separaten Pi laufen...
Könnte der was hinterlassen haben?
Kommt drauf an, was du damit gemacht hast. Per Default lesen die Adapter eigentl. nur aus und Du kannst über die Objekte die Werte von Einträgen verändern. Erzeugung von Objekten findet nur statt, wenn du das aktiv auch tust.
Burger-King hat geschrieben:
25.05.2019, 14:07
Was mir auffält: Nach dem Neustart fahren zwei Rolladenaktoren kurz an (ca. 1 Sekunde). Das könnte daran liegen, dass ich zuletzt ein Programm angelegt hatte, welches diese Beiden steuern soll. Danach ist wieder alles wie gehabt.
Jedes Programm wird bei Neustart der CCU quasi einmal gestartet. Deswegen baut man eine der vorhandenen Systemvariablen so um, dass sie angibt, ob sich die CCU gerade im Reboot-Status befindet und lässt seine Programme dahingehend prüfen und führt nur aus, wenn sie im "normal"-Zustand ist.

Dazu findest du aber hier über die Suche als auch über Google sehr schnell Hilfestellung.

Ein paar der Fehlermeldungen sind beim Neustart der CCU "normal", da scheinbar eine der Schnittstellen noch nicht initialisiert ist. Normalerweise regelt sich das aber sehr flott.
Deine Firewalleinstellungen sind OK?
RPi 3B im Serverschrank mit Aurel Groundplane Antenne an RPI-RF-MOD - Firmware: 3.45.5.20190511
LanGW: RPi Model A 256MB RAM mit HM-MOD-RPI-PCB, ~ 100 Geräte, IOBroker, Lightify
Addons: XML-API 1.20 - CUx-Daemon 2.2.0 - WebMatic 2.2.3

Xel66
Beiträge: 5260
Registriert: 08.05.2013, 23:33
Wohnort: Nordwürttemberg

Re: WebUI friert ein, Fehler zu XMLRPC und ReGaHss im Log

Beitrag von Xel66 » 25.05.2019, 14:28

trevyn hat geschrieben:
25.05.2019, 14:17
Jedes Programm wird bei Neustart der CCU quasi einmal gestartet.
Auch wenn es noch so oft wiederholt wird und es für den Anwender so aussieht, stimmt es immer noch nicht. Es werden die Bedingungen der Programme aus Wahrheitsgehalt geprüft und das dazugehörige DANN eines Programms ausgeführt, wenn die vorhergehende Prüfung der WENN oder SONST WENN-Blöcke ein WAHR ergibt. Also ein Rollladen, der tagsüber hochlaufen soll, wird das bei einem Neustart im betreffenden Zeitraum tun.

Eine böse Falle sind auch enthaltene SONST. Wenn keine der WENN oder SONST WENN-Prüfungen ein WAHR ergibt, wird dieses ausgeführt. Hier kann.man sich auch schön ins Knie schießen und ein SONST kann man nicht mit dem Anwesenheits-Variablen-Trick verhindern.

Gruß Xel66
---------------------------------------------------------------------------------
335 Kanäle in 103 Geräten und 113 CUxD-Kanäle in 23 CUxD-Geräten:
233 Programme, 189 Systemvariablen und 119 Direktverknüpfungen,
RaspberryMatic Version 3.45.5.20190330
---------------------------------------------------------------------------------

trevyn
Beiträge: 51
Registriert: 25.04.2017, 17:19

Re: WebUI friert ein, Fehler zu XMLRPC und ReGaHss im Log

Beitrag von trevyn » 25.05.2019, 15:22

Deswegen stand da auch "quasi".
Und eine Bedingungsprüfung kann ohnehin auch nur stattfinden, indem das zugehörige Programm aufgerufen wird, um die Bedingungen zu prüfen.
(Ich glaub nicht, dass es für ihn aktuell relevant ist, wieso und warum irgendwas passiert, sondern eher, wie er es behebt. In den betreffenden zu findenden Beiträgen steht das dann ja auch ausführlich erklärt.)
RPi 3B im Serverschrank mit Aurel Groundplane Antenne an RPI-RF-MOD - Firmware: 3.45.5.20190511
LanGW: RPi Model A 256MB RAM mit HM-MOD-RPI-PCB, ~ 100 Geräte, IOBroker, Lightify
Addons: XML-API 1.20 - CUx-Daemon 2.2.0 - WebMatic 2.2.3

Xel66
Beiträge: 5260
Registriert: 08.05.2013, 23:33
Wohnort: Nordwürttemberg

Re: WebUI friert ein, Fehler zu XMLRPC und ReGaHss im Log

Beitrag von Xel66 » 25.05.2019, 18:16

trevyn hat geschrieben:
25.05.2019, 15:22
Deswegen stand da auch "quasi".
Was die Behauptung eben nicht wahrer macht, und dieser falsche Sachverhalt mit der steten Wiederholung festsetzt.
trevyn hat geschrieben:
25.05.2019, 15:22
Und eine Bedingungsprüfung kann ohnehin auch nur stattfinden, indem das zugehörige Programm aufgerufen wird, um die Bedingungen zu prüfen.
Ganau so falsch. Die CCU führt eine Liste der als Trigger in Programmen benutzten Geräte, Sensoren, Variablen und Ereignisse und meldet der Datenbank das jeweilige Ereignis. Das Programm (als Subroutine dieser Datenbank) entscheidet dann, ob dieses gemeldete Ereignis eine Änderung oder Aktualisierung ist und führt dann die Bedingungsprüfung aus. Im Ergebnis dessen wird dann eine Aktion durchgeführt (DANN ausgeführt) oder nicht. Das Programm ist nur ein Container von Bedingungen und Aktionen. Irgendwo gab es mal eine Beschreibung zur Abarbeitung von Programmen. Aber eben nicht die technische Beschreibung sondern mit so beschreibenden Funktionen "die CCU klebt einen Zettel an diesen Trigger und merkt sich so...". In Sammys Einsteigerthread ist die Abarbeitung auch beschrieben und ganz technisch hat es black mal ausgeführt.

Du hast Recht. Für die Fehlersuche ist dieses nicht relevant. Für das Grundverständnis zur Funktionsweise durch die Mitleser aber schon. Die CCU arbeitet ereignisorientiert und eben nicht zyklisch irgendwelche Programme ab. Das ist der Grundunterschied.

Bezüglich der Logs sieht das für mich so aus, als ob es Kommunikationsprobleme auf den Schnittstellenprozessen gibt. Als erste Maßnahme würde ich mal die Firewall wieder lockern. Anschließend die Ports prüfen, welcher Dienst sich dahinter verbirgt und dann weiter suchen, warum er auf ggf. gesperrten Ports kommunizieren will. Quatsch, der Client-Prozess meckert ja, vermutlich weil der Server abgestürzt ist (er wird ja auch per Watchdog neu gestartet.)

Gruß Xel66
---------------------------------------------------------------------------------
335 Kanäle in 103 Geräten und 113 CUxD-Kanäle in 23 CUxD-Geräten:
233 Programme, 189 Systemvariablen und 119 Direktverknüpfungen,
RaspberryMatic Version 3.45.5.20190330
---------------------------------------------------------------------------------

Burger-King
Beiträge: 6
Registriert: 26.08.2018, 13:18

Re: WebUI friert ein, Fehler zu XMLRPC und ReGaHss im Log

Beitrag von Burger-King » 25.05.2019, 20:32

Erst einmal danke für eure Antworten und Bemühungen mir zu helfen!

ioBroker
Ich bin bisher nur bis zu dem Punkt gekommen, die beiden Adapter für Homematic ans Laufen zu bekommen.
Also bisher nur reines Anzeigen, ioBroker dürfte eigentlich nie etwas in die Raspberrymatic geschrieben haben.

Programmausführung bei Neustart
Danke für den Hinweis, dieser Umstand ist mir bekannt. Eigentlich habe ich immer eine Pushover-Nachricht bekommen, dass die Waschmaschine fertig ist, wenn die Zentrale neu gestartet hat (waren die letzten Variablen für den Nachrichtentext, Bedingung für das Programm: Waschmaschinenleistung < 5Watt). Warum diese Nachricht nun nicht kommt?!? :?:
Das Rollladenprogramm hat aber überhaupt gar keine Bedingung, sollte nur per Tinymatic ausgelöst werden.

Firewall
Tatsächlich war ich kurz vor dem Absturz nochmal in diesen Einstellungen. Ob ich da was verklickt habe? Gibt es eine conig-Datei in der sbk-Datei, die ich händisch ändern könnte, um das Backup - zumindest testweise(!) - "offen wie ein Scheunentor" einzuspielen?

Antworten

Zurück zu „RaspberryMatic“