Programm läuft sehr unzuverlässig

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Xel66
Beiträge: 5734
Registriert: 08.05.2013, 23:33
Wohnort: Nordwürttemberg
Hat sich bedankt: 6 Mal
Danksagung erhalten: 33 Mal

Re: Programm läuft sehr unzuverlässig

Beitrag von Xel66 » 21.06.2019, 19:37

Das SONST würde ich löschen, dann sollte es auch funktionieren.

Gruß Xel66
---------------------------------------------------------------------------------
358 Kanäle in 103 Geräten und 114 CUxD-Kanäle in 24 CUxD-Geräten:
253 Programme, 218 Systemvariablen und 144 Direktverknüpfungen,
RaspberryMatic Version 3.45.7.20190622
---------------------------------------------------------------------------------

mfgsc
Beiträge: 6
Registriert: 20.06.2019, 10:50

Re: Programm läuft sehr unzuverlässig

Beitrag von mfgsc » 22.06.2019, 12:14

Das mit dem Sonst Zweig habe ich nur zum Ausprobieren eingefügt. Ohne dem "SONST" funktioniert es leider auch nicht.

Ich habe nun aus lauter Verzweiflung alle Programme und Variablen auf der RaspberryMatic gelöscht und folgendermaßen neu programmiert:
2019-06-22-115812_1024x768_scrot.png
2019-06-22-115758_1024x768_scrot.png
2019-06-22-115745_1024x768_scrot.png
3 Programme und eine Systemvariable mit Logikwerte: aktiv/ausgeschaltet

Für jede Taste habe ich ein eigenes Programm geschrieben.
Die Programme werden ausgeführt wenn ich die jeweilige Taste drücke. Das erkenne ich am Datum/Uhrzeit der letzten Ausführung.
Aber es ändert sich nicht der Wert der Systemvariable.

Kurios ist dass unmittelbar nach einem Neustart alles funktioniert wie es soll. Ich kann mit der Taste Hüllschutz oder Vollschutz die Variable auf "aktiv" setzen und mit der Taste Alarm aus wieder auf "ausgeschaltet" setzen.
Das hin und her schalten kann ich ein paar mal machen.
Aber etwa nach 3 min. funktionieren die Programme nicht mehr richtig.

Schöne Grüße mfgsc

Xel66
Beiträge: 5734
Registriert: 08.05.2013, 23:33
Wohnort: Nordwürttemberg
Hat sich bedankt: 6 Mal
Danksagung erhalten: 33 Mal

Re: Programm läuft sehr unzuverlässig

Beitrag von Xel66 » 22.06.2019, 13:21

mfgsc hat geschrieben:
22.06.2019, 12:14
Aber es ändert sich nicht der Wert der Systemvariable.
Was sagt deren Zeitstempel? Gibt es eventuell ein Prigramm, welches die Systemvariable ebenfalls setzt und Dir in die Suppe spuckt?

Gruß Xel66
---------------------------------------------------------------------------------
358 Kanäle in 103 Geräten und 114 CUxD-Kanäle in 24 CUxD-Geräten:
253 Programme, 218 Systemvariablen und 144 Direktverknüpfungen,
RaspberryMatic Version 3.45.7.20190622
---------------------------------------------------------------------------------

mfgsc
Beiträge: 6
Registriert: 20.06.2019, 10:50

Re: Programm läuft sehr unzuverlässig

Beitrag von mfgsc » 22.06.2019, 13:26

Ich habe mir nochmal die Log -Datei angesehen.
Ich habe die Vollschutztaste gedrückt, dann die Hüllschutztaste und dann die Alarm aus Taste.
Bei der Programmausführung (Vollschutz und Hüllschutz) wird das Programm unterbrochen
(ReGaHss: Info: break execute for Program)
Dies passiert beim Tastendruck "Alarm aus" nicht.
Hier wird die Systemvariable gesetzt.
(calling SetState on DP id = 5951 (Alarm-Zone Laden) value = 0)

Könnt Ihr aus dem Log rauslesen warum das eine Programm funktioniert und die anderen beiden Programme nicht?
homematic-raspi-2019-06-22.log
(24.46 KiB) 9-mal heruntergeladen
Schöne Grüße
mfgsc

mfgsc
Beiträge: 6
Registriert: 20.06.2019, 10:50

Re: Programm läuft sehr unzuverlässig

Beitrag von mfgsc » 22.06.2019, 13:31

Der Zeitstempel bei der Variable ändert sich nur beim unscharf stellen.
Ich habe momentan keine anderen Programme die in die Suppe spucken könnten. Ich habe nur drei Programme. Auch keine Direktverknüpfungen.

DGMG
Beiträge: 59
Registriert: 23.11.2014, 21:39

Re: Programm läuft sehr unzuverlässig

Beitrag von DGMG » 01.07.2019, 21:56

Hallo miteinander und hallo mfgsc,

auf der Suche nach einem aktuellen Problem bei mir habe ich diesen Thread gefunden, weil ich vermutlich das identische Problem habe.

Allerdings habe ich eine "normale" CCU3 mit einer Vielzahl von "normalen" Homematic-Komponenten daran.

Problem bei mir, mittlerweile zur Analyse sehr reduziert:

1. Programm soll nach Tastendruck auf HM-RC-8 einen Aktor (Licht) einschalten.

2. Tastendruck nach frischem CCU-Start => funktioniert

3. Tastendruck danach ==> funktioniert nicht mehr, obwohl das Programm "aufgerufen" wird (geprüft am Zeitstempel).

Eigentlich soll etwas komplexeres hinter dem Tastendruck passieren, aber selbst das einfacher Einschalten hat dieses merkwürdige Verhalten, als wäre es....Zufall.

Falls das doch etwas andere ist, bitte kurz mitteilen, dann mache ich dafür ein gesondertes Thema auf.

Oder ...gibt es hier schon eine Lösung/Erklärung?

Mir scheint es ein grundsätzliches Problem zu sein, ggf. "Fernbedienung"? (frische Batterien sind drin .-)

Danke
Dietmar

manfredh
Beiträge: 2308
Registriert: 09.09.2012, 10:41
Hat sich bedankt: 1 Mal
Danksagung erhalten: 24 Mal

Re: Programm läuft sehr unzuverlässig

Beitrag von manfredh » 02.07.2019, 09:21

Hallo Dietmar,

- bitte Screenshot des Programms

- protokolliere doch mal die Taste und schaue dann nach

- Was bedeutet genau "nach frischem Start" und "danach"? Geht es "nach frischem Start" wiederholt? Bis wann?

- Was macht das Programm (Ausführung des Dann), wenn du verodert einen weiteren Auslöser (z.B. eine virtuelle Taste der CCU) einfügst?
Es gibt 10 Arten von Menschen: solche die Binärcode verstehen und solche, die ihn nicht verstehen.

trevyn
Beiträge: 67
Registriert: 25.04.2017, 17:19
Hat sich bedankt: 3 Mal
Danksagung erhalten: 3 Mal

Re: Programm läuft sehr unzuverlässig

Beitrag von trevyn » 02.07.2019, 12:15

manfredh hat geschrieben:
02.07.2019, 09:21
- Was macht das Programm (Ausführung des Dann), wenn du verodert einen weiteren Auslöser (z.B. eine virtuelle Taste der CCU) einfügst?
Oder evtl. das Programm auch einfach mal direkt über die GUI anstoßen und kontrollieren, was passiert.
Falls dort das gleiche Verhalten auftritt, könnte man vielleicht zumindest den Handsender ausschließen.
RPi 3B im Serverschrank mit Aurel Groundplane Antenne an RPI-RF-MOD - Firmware: 3.47.15.20190831
LanGW: RPi Model A 256MB RAM mit HM-MOD-RPI-PCB, ~ 100 Geräte, IOBroker, Lightify
Addons: XML-API 1.20 - CUx-Daemon 2.3.3- WebMatic 2.2.3

manfredh
Beiträge: 2308
Registriert: 09.09.2012, 10:41
Hat sich bedankt: 1 Mal
Danksagung erhalten: 24 Mal

Re: Programm läuft sehr unzuverlässig

Beitrag von manfredh » 02.07.2019, 14:00

Das ist meist keine gute Idee. Ein von Hand angestoßenes Programm führt immer das erste DANN aus - ohne jegliche Bedingungsprüfung.
Es gibt 10 Arten von Menschen: solche die Binärcode verstehen und solche, die ihn nicht verstehen.

DGMG
Beiträge: 59
Registriert: 23.11.2014, 21:39

Re: Programm läuft sehr unzuverlässig

Beitrag von DGMG » 02.07.2019, 21:15

manfredh hat geschrieben:
02.07.2019, 09:21
Hallo Dietmar,

- bitte Screenshot des Programms

- protokolliere doch mal die Taste und schaue dann nach

- Was bedeutet genau "nach frischem Start" und "danach"? Geht es "nach frischem Start" wiederholt? Bis wann?

- Was macht das Programm (Ausführung des Dann), wenn du verodert einen weiteren Auslöser (z.B. eine virtuelle Taste der CCU) einfügst?
Hallo manfred,

in aller kürze im Moment leider nur, ich bin nicht zuhause:

- Screenshot folgt spätestens am Wochenende
- Protokollierung geht auch erst dann .-)
- "Nach frischem Start" = nach Neustart der CCU3
- "danch" = nachdem es EINMAL korrekt funktioniert hat

Wie ich sagte, ich habe das Programm supersimpel gemacht zu Testzwecken:

WENN Tastendruck kurz = DANN Lichtaktor AN.

Mehr ist es nicht.
Firmware ist 3.47.10.

Es fühlt sich tatsächlich so an, als würde die Fernbedienung...ignoriert werden (die Kontrolleuchte leutet grün auf nach kurzem Tastendruck, allerdings startet das Program gar nicht erst (in den o.g. Fällen, wo es dann nicht mehr geht).



Das per WebGUI Starten, ja, das startet den DANN-Zweig und das macht auch das Licht an .-)

Wie gesagt, sobald ich zurück bin und die Zeit habe, kümmere ich mich nochmal drum und melde mich wieder dazu.


Gruß

Dietmar

Antworten

Zurück zu „RaspberryMatic“