[GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Yrol1
Beiträge: 22
Registriert: 16.04.2020, 22:03
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Yrol1 » 09.10.2021, 20:26

Es muss schon in diese Richtung gehen. Das neue Originalnetzteil ist jetzt auch da. Habe aber noch das alte dran. An die Karte glaube ich auch nicht, da die eine "Extreme Pro" ist. Das mit dem Kontakt liegt am nächsten. Vielleicht baue ich bei Gelegenheit mal eine Koax-Kupplung ein. Seit gestern läuft alles auch mit der Karte und mein Messgerät(min-max) hat auch nicht angesprochen. Vielleicht soll ich es dran lassen??

karlachen
Beiträge: 4
Registriert: 24.01.2022, 16:33
System: sonstige
Wohnort: Wuppertal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von karlachen » 26.01.2022, 15:07

Baxxy hat geschrieben:
06.11.2020, 08:40
Aquaplex hat geschrieben:
06.11.2020, 06:39
Das ganze dauert nicht lang, reicht aber für den WatchDog-Alarm.
Der "No internet connection detected WatchDog-Alarm" wird getriggert wenn für etwa 5Min keine Internetverbindung besteht. Die Zeit sollte locker ausreichen um eine Zwangstrennung abzudecken.
Aquaplex hat geschrieben:
06.11.2020, 06:39
Könnte man mit wenig Aufwand eventuell die Zeitspanne einstellen, nach der erst ein No-Internet-Alarm gemeldet wird?
Wenig Aufwand... das kommt auf deine Fähigkeiten an. Da eine RaspberryMatic auf Linux basiert kann man mit den richtigen Kenntnissen quasi alles anpassen. Empfehlen würde ich das aber nicht. Außerdem würden die Änderungen beim nächsten Systemupdate wieder überschrieben.

Die Empfehlung lautet den InternetCheck mittels anlegen der Datei "/etc/config/internetCheckDisabled" komplett zu deaktivieren wenn es dich stört.
Hallo Zusammen,

Stelle mich kurz vor:

Alter 62, bin Anfänger und dabei, mit der RasperryMatic auf einem Raspberry 3+ ein paar Dinge wie Heizkörper, Steckdosen usw. zu steuern.
Das Programm läuft soweit, nur stelle ich mit meinem Pi-hole (auf einem Raspberry 4) fest, das die RaspberryMatic alle 2 Minuten den Internetzugang überprüft, was mir überhaupt nicht gefällt. Alle Versuche, das zu unterbinden (siehe internetCheckDisabled) sind fehlgeschlagen.
Was kann ich jetzt noch tun (ausser den Netzwerkstecker ziehen :-()?

Hat einer von Euch eine praktikable Lösung?

Ich kenne mich ein wenig mit Linux und Programmierung aus, aber wenn ich damit etwas erreichen kann, müsst Ihr mir dafür eine sehr gute Anleitung geben, ich bin halt Anfänger (und schon etwas älter).

Lg. Karlachen
karlachen

never change a runing system

Benutzeravatar
jmaus
Beiträge: 8651
Registriert: 17.02.2015, 14:45
System: Alternative CCU (auf Basis OCCU)
Wohnort: Dresden
Hat sich bedankt: 336 Mal
Danksagung erhalten: 1277 Mal
Kontaktdaten:

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von jmaus » 26.01.2022, 16:27

karlachen hat geschrieben:
26.01.2022, 15:07
Das Programm läuft soweit, nur stelle ich mit meinem Pi-hole (auf einem Raspberry 4) fest, das die RaspberryMatic alle 2 Minuten den Internetzugang überprüft, was mir überhaupt nicht gefällt.
Und was stört dich bitte daran? Tschuldigung, aber da ist per se nichts schlechtes und erst recht nichts unsicheres daran wenn eine Applikation überprüft ob es Internetzugriff hat oder nicht.
karlachen hat geschrieben:
26.01.2022, 15:07
Alle Versuche, das zu unterbinden (siehe internetCheckDisabled) sind fehlgeschlagen.
Geh in der WebUI unter "Systemsteuerung -> Erweiterte Einstellungen" und schalte dort den InternetCheck aus. Komm dann hier aber bitte nicht mehr hier her, wenn es irgendwelche Probleme beim Anlernen von homematicIP Geräten gibt die zum Anlernen einen Internetzugang der Zentrale brauchen. :mrgreen:
RaspberryMatic 3.65.6.20220723 @ Proxmox – ~195 Hm-RF/HmIP-RF/HmIPW Geräte + ioBroker – GitHub / Twitter / Facebook / Sponsors

karlachen
Beiträge: 4
Registriert: 24.01.2022, 16:33
System: sonstige
Wohnort: Wuppertal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von karlachen » 27.01.2022, 15:05

Vielen Dank für die schnelle Antwort

Grundsätzlich stört es mich nicht, das das System das Vorhandensein des Internets überprüft. Aber warum alle 2 Minuten? Mein Qnap-System macht das 1 mal in der Stunde.

Das das Anlernen von IP-Geräten nur mit Internet klappt wusste ich bereits.

Die Einstellung unter "Systemsteurung -> Erweiterte Einstellungen" der Internetprüfung hatte ich bereits gefunden und abgestellt.

Ich nutze die neueste Version der RaspberryMatic auf einem Raspberry pi 3+ auf einem bootfähigen USB-Stick.

Jetzt weiß ich auch nicht mehr weiter ....


evtl. doch ein Fehler im Programm :shock: (duck und wech)
karlachen

never change a runing system

Benutzeravatar
Baxxy
Beiträge: 6384
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 382 Mal
Danksagung erhalten: 1176 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Baxxy » 27.01.2022, 15:12

karlachen hat geschrieben:
27.01.2022, 15:05
Jetzt weiß ich auch nicht mehr weiter ....
Also willst du nicht einfach den "no-Internet" - Alarm loswerden sondern komplett unterbinden das RM die Internetverbindung prüft?

karlachen
Beiträge: 4
Registriert: 24.01.2022, 16:33
System: sonstige
Wohnort: Wuppertal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von karlachen » 27.01.2022, 15:25

.... oder zumindest so einstellen, das die Prüfung nicht alle 2 Minuten stattfindet sonder z. B. 1 mal die Stunde.

Ganz abstellen würde ich aber auch machen, wenn es denn geht....
karlachen

never change a runing system

Benutzeravatar
Baxxy
Beiträge: 6384
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 382 Mal
Danksagung erhalten: 1176 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Baxxy » 28.01.2022, 17:05

karlachen hat geschrieben:
27.01.2022, 15:25
Ganz abstellen
Hmm, ich weiß leider nicht wo der zyklische Ping zu G----e herkommt.
Ist vermutlich fest irgendwo verankert. Ließe sich sicher irgendwie ändern/anpassen, aber sowas ist dann meist nicht Update-fest.

Einfach im Router der RM den Internetzugang verwehren ist keine Option?

Grüße, Baxxy

karlachen
Beiträge: 4
Registriert: 24.01.2022, 16:33
System: sonstige
Wohnort: Wuppertal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von karlachen » 29.01.2022, 08:57

ja sicher, den Router habe ich schon eingestellt, der Internetzugang wird geblockt.

Aber mein Problem ist, das das Pihole-Protokoll vollgemüllt wird und die Anzeige desselben daher ewig dauert (4-5 x ping alle 2 Minuten sind ca. 3.000 Einträge pro Tag).

Ausserdem wird der Router auch dann, wenn ich nicht im Internet unterwegs bin (also, wenn ich schlafe :-)), ständig beschäftigt, also fährt er nie in den Standbymodus.

Ich weiß, ich könnte in auch über Zeitplanung an- und ausschalten lassen, aber damit beseitige ich eigentlich nur die Ursachen und nicht das Problem.

Mein Gigaset DL500A (Telefon) ist auch so ein Gerät, was ständig pingt, aber da kommt man leider nicht in das System rein, also habe ich den Netzwerkstecker gezogen.

Ich werde mal die Crontab untersuchen, vieleicht geht da ja was ....
karlachen

never change a runing system

Pesse
Beiträge: 6
Registriert: 20.12.2020, 16:52
System: CCU

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Pesse » 11.07.2022, 16:38

Hallo,
ich möchte nicht noch Thread zum Thema WatchDog-Alarm eröffnen, deshalb nutze ich mal diesen gelösten Thread.
Ich bekomme seit dem Umstieg auf RaspberryMatic stetig einen WatchDog: high-temp - Alarm auf meiner CCU3. Die Ursache ist mir nicht klar. Das Gerät hängt frei und gut belüftet in meiner Diele - Umgebungstemperatur schließe ich daher aus. Ich habe neben CUxD und Redmatic noch E-Mail, Neo-Server und XML-API installiert und alle auf neuesten Stand wie auch die Firmware. Redmatic habe ich gestoppt, da ich meine ConbeeII nicht zum laufen bekommen habe.
Ich hätte jetzt gerne ein paar Tipps:
  • Wie finde ich die eventuelle softwaremäßige Ursache der Hitzemeldung?
  • Kann man die RaspberryPI in der CCU3 mit Kühlkörper nachrüsten oder lässt das Gehäuse die platzmäßig nicht zu? Hat jemand mit der Lösung eventuell positive Erfahrungen gesammelt?
Ich sage schon mal Danke!

Antworten

Zurück zu „RaspberryMatic“