[GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Yrol1
Beiträge: 22
Registriert: 16.04.2020, 22:03
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Yrol1 » 03.10.2021, 19:45

Ich habe die Spannung natürlich im Gerät gemessen und das sind 5,0V. Ausserdem sitzt das Netzteil 10cm daneben und hat auch ein ordentlich dickes Kabel. Inzwischen läuft mit der neuen SD Karte keine Meldung mehr ein. Ich habe aber noch den alten SW Stand drauf. Nächste Woche kommt das neue Netzteil. Mal sehen. Zuerst werde ich die alte SD-Karte wieder einstecken und wenn der Fehler wieder auftritt, das neue Netzteil anstecken und dann die alte Extreme Pro SD Karte wieder probieren. Die ist ja erst 4 Wochen alt. Ich hoffe, dass mir mal Jemand sagen kann, wie die Watchdog- Überwachungsgrenzen eingestellt sind.

Benutzeravatar
Baxxy
Beiträge: 4196
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 289 Mal
Danksagung erhalten: 735 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Baxxy » 03.10.2021, 19:59

Yrol1 hat geschrieben:
03.10.2021, 19:45
Ich hoffe, dass mir mal Jemand sagen kann, wie die Watchdog- Überwachungsgrenzen eingestellt sind.
Es gibt keine "Überwachungsgrenzen" vom Watchdog. Es wird nur der Status vom System ausgelesen und ggf. alarmiert.
https://harlemsquirrel.github.io/shell/ ... ssues.html

Grüße, Baxxy

Yrol1
Beiträge: 22
Registriert: 16.04.2020, 22:03
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Yrol1 » 03.10.2021, 21:28

Das ist mir unverständlich. Vor 4 Wochen habe ich die SD (auf Empfehlung aus dem Forum) gewechselt, die ca. 2 Jahre alt war, weil Spannungsüberwachung angezeigt wurde und danach war der Fehler weg, aber eben nur bis heute und der Fehler stand auch nach Quittung paar Sekunden danach permanent an. Heute kommt eine neue SD rein und der Fehler ist weg.

MichaelN
Beiträge: 3285
Registriert: 27.04.2020, 10:34
System: CCU
Hat sich bedankt: 260 Mal
Danksagung erhalten: 452 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von MichaelN » 03.10.2021, 21:32

Die Empfehlung kam aufgrund der Meldung "unclean shutdown oder Systemcrash identifiyed"

Yrol1
Beiträge: 22
Registriert: 16.04.2020, 22:03
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Yrol1 » 03.10.2021, 21:48

Das ist erstmal richtig und danach auf Seite 5 oben beginnt die Fehlermeldung Undervoltage.

Xel66
Beiträge: 10065
Registriert: 08.05.2013, 23:33
System: Alternative CCU (auf Basis OCCU)
Wohnort: Nordwürttemberg
Hat sich bedankt: 156 Mal
Danksagung erhalten: 707 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Xel66 » 04.10.2021, 10:29

Ändert nichts an der Tatsache, dass der Pi eine zu geringe Spannung detektiert. Die Einbrüche können gerade bei Schreibaktionen auf der SD, beim Boot, beim Ansprechen des Funkmoduls oder hohen Systemaktivitäten sehr kurz sein, dass Du sie auf einem digitalen Messgerät nicht mal mitbekommst (von einem Zeigergerät ganz zu schweigen). Diese kurzfristigen Stromspitzen (höherer Strom --> Spannungsabfall über das Kabel oder Kontaktstellen --> Absinken der Versorgungsspannung) bringen die Überwachung zum Ansprechen. Im Zweifel glaube ich solchen implementierten Funktionen eher als irgendeinem Messgerät. Nicht umsonst gibt es für das Charly-Funkmodul auch eine Spannungsversorgung über den Rundstecker.

Gruß Xel66
-------------------------------------------------------------------------------------------
343 Kanäle in 118 Geräten und 264 CUxD-Kanäle in 33 CUxD-Geräten:
282 Programme, 246 Systemvariablen und 144 Direktverknüpfungen,
RaspberryMatic Version: 3.59.6.20211009 + Testsystem: CCU2 2.53.27
-------------------------------------------------------------------------------------------
Einsteigerthread, Programmlogik-Thread, WebUI-Handbuch

Yrol1
Beiträge: 22
Registriert: 16.04.2020, 22:03
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Yrol1 » 04.10.2021, 21:58

Ich habe mal etwas weiter gesucht. Du wirst schon auf der richtigen Spur sein. Das Problem wird aber maximal am USB Stecker liegen, denn der ist das Nadelöhr. Der Querschnitt vom Kabel ist es nicht und für solche kurzen Spannungseinbrüche wird ein Stützkondensator auf der Leiterplatte vorgesehen. Da kein Messkabel aus dem Pi herausführt, muss zwangsläufig auf der Platte gemessen werden und dort sitzt der Kondensator, der hoffentlich richtig dimensioniert ist. Ich habe mit min-max-Multimeter(Peak-Detector) gemessen und dann auch noch das Oszilloskop bemüht. Da ist nichts zu entdecken, auch wenn man länger aufzeichnet. Ich könnte auch mal ein Messkabel herausziehen und auf Unterspannung triggern. Das neue Netzteil kommt erst Mitte der Woche. Seit dem Tausch der SD-Karte ist bisher kein Fehler wieder aufgetreten. Ich bin erst am Freitag wieder zurück, dann stecke ich die "alte SD" wieder rein und beobachte weiter.

Benutzeravatar
Baxxy
Beiträge: 4196
Registriert: 18.12.2018, 15:45
System: Alternative CCU (auf Basis OCCU)
Hat sich bedankt: 289 Mal
Danksagung erhalten: 735 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Baxxy » 06.10.2021, 14:48

Yrol1 hat geschrieben:
04.10.2021, 21:58
Das Problem wird aber maximal am USB Stecker liegen,
Gut möglich.
Ob man vielleicht mehr sieht wenn du deine Messungen mal an den GPIO-Pins des Raspberry's wiederholst?

Grüße, Baxxy

Yrol1
Beiträge: 22
Registriert: 16.04.2020, 22:03
Hat sich bedankt: 5 Mal
Danksagung erhalten: 1 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Yrol1 » 08.10.2021, 20:12

Danke für den Hinweis. Heute bin ich wieder zurück und hatte mit der neuen SD-Karte keinerlei Störung. Ich habe jetzt die alte Sd Karte wieder eingesteckt, die vorher nach ein paar Minuten schon den Watchdog-Fehler brachte. Diese läuft inzwischen seit ca. 1h. Mal sehen, was weiter passiert.

Xel66
Beiträge: 10065
Registriert: 08.05.2013, 23:33
System: Alternative CCU (auf Basis OCCU)
Wohnort: Nordwürttemberg
Hat sich bedankt: 156 Mal
Danksagung erhalten: 707 Mal

Re: [GELÖST] WatchDog-Alarm - WatchDog deaktivieren/löschen

Beitrag von Xel66 » 09.10.2021, 08:29

Das hat mit der SD nur am Rande was zu tun. Deine Meldung ist eine Unterspannungsmeldung und die kann neben dem Boot auch kommen, wenn das System stark ausgelastet ist (Backup, Trim, Badblock-Check etc.). Die SD hat da insofern nur Einfluss, wenn Du eine lahme Karte eingesetzt hast, und Schreib-/Lesevorgänge lange dauern und ggf. andere Aktionen noch damit zusammentreffen. Spätestens nach einem derartigen Lauf wirst Du die Meldung mit hinreichend großer Sicherheit wieder sehen (außer Du hast einen Kontaktmangel am SD-Stecker, denn Du jetzt durch Wackeln temporär etwas verbessert hast). Bei Verwendung des aktuellen Funkmoduls ist eine Spannungsversorgung über den Hohlstecker (der stromtragfähiger als eine Micro-SD-Verbindung ist) mit einem entsprechend dimensionierten Netzteil die bessere Lösung. Zu beachten ist ja auch noch, dass das originale Pi-Netzteil für den Betrieb des Pi vorgesehen und dimensioniert (mit etwas Reserve) ist. Das Funkmodul benötigt auch noch mal etwas Energie für seine Aufgaben.

Gruß Xel66
-------------------------------------------------------------------------------------------
343 Kanäle in 118 Geräten und 264 CUxD-Kanäle in 33 CUxD-Geräten:
282 Programme, 246 Systemvariablen und 144 Direktverknüpfungen,
RaspberryMatic Version: 3.59.6.20211009 + Testsystem: CCU2 2.53.27
-------------------------------------------------------------------------------------------
Einsteigerthread, Programmlogik-Thread, WebUI-Handbuch

Antworten

Zurück zu „RaspberryMatic“