Support für Raspberry Pi 4

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Benutzeravatar
jmaus
Beiträge: 5213
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 9 Mal
Danksagung erhalten: 116 Mal
Kontaktdaten:

Re: Support für Raspberry Pi 4

Beitrag von jmaus » 02.07.2019, 11:58

krk-elektrotechnik hat geschrieben:
02.07.2019, 11:50
ich würde es begrüßen, wenn auch das alte Funkmodul auf dem RPI4 unterstützt wird.
Gerade mit externer Antenne habe ich eh keinen großen Unterschied zum neuen festgestellt.
So könnte man erst mal mit wenig Aufwand einen [email protected] nutzen ;)
Na klar wird auch das alte Funkmodul von Alex und mir unterstützt werden. In der seriellen Kommunikation unterscheiden sich die beiden Funkmodule hier nicht wesentlich voneinander sodass diese Unterstützung dann definitiv auch kommen wird.
RaspberryMatic 3.47.22.20191026 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubGitHub Sponsors / PayPalTwitter

krk-elektrotechnik
Beiträge: 81
Registriert: 14.03.2017, 10:45
Wohnort: Borgentreich
Hat sich bedankt: 1 Mal
Kontaktdaten:

Re: Support für Raspberry Pi 4

Beitrag von krk-elektrotechnik » 02.07.2019, 12:17

Klasse, habe nichts anderes erwartet :)
Vielen Dank.

PS: Habe mir mal das Platinenlayout des neuen Funkmoduls angesehen, meine ursprüngliche Vermutung, das man vom Modul ggfs. etwas Material wegnehmen kann, revidiere ich hiermit. Die Leiterbahnen (auch die nicht sichtbaren) gehen extrem weit bis an den Rand.

deimos
Beiträge: 3149
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 13 Mal
Danksagung erhalten: 76 Mal
Kontaktdaten:

Re: Support für Raspberry Pi 4

Beitrag von deimos » 02.07.2019, 12:32

Hi,

ich gehe stark davon aus, dass das alte Funkmodul bei meinem aktuellen Testimage unter https://www.pivccu.de/images/?dir=piVCCU3/testing bereits funktioniert. Ist bisher einfach noch nicht getestet. Bei dem Image ist es auch so, dass das neue Funkmodul funktioniert, sofern man die Firmware 4.0.20 bereits anderweitig auf das Funkmodul gebracht hat (z.b. indem man das Image erstmal mit einem Pi 3 mit aufgestecktem Funkmodul startet).

Viele Grüße
Alex

krk-elektrotechnik
Beiträge: 81
Registriert: 14.03.2017, 10:45
Wohnort: Borgentreich
Hat sich bedankt: 1 Mal
Kontaktdaten:

Re: Support für Raspberry Pi 4

Beitrag von krk-elektrotechnik » 02.07.2019, 12:40

deimos hat geschrieben:
02.07.2019, 12:32
Hi,

ich gehe stark davon aus, dass das alte Funkmodul bei meinem aktuellen Testimage unter https://www.pivccu.de/images/?dir=piVCCU3/testing bereits funktioniert. Ist bisher einfach noch nicht getestet. Bei dem Image ist es auch so, dass das neue Funkmodul funktioniert, sofern man die Firmware 4.0.20 bereits anderweitig auf das Funkmodul gebracht hat (z.b. indem man das Image erstmal mit einem Pi 3 mit aufgestecktem Funkmodul startet).

Viele Grüße
Alex
Hi Alex, super :)
Sobald mein RPI4 ankommt werde ich es testen.
OT: Habe mir zudem auch endlich mal die erforderlichen Bauteile bestellt, das ich endlich mal die HB-RF-USB Platine bestücken und testen kann ;)
Nur den 10nF Kondensator gab es bei Reichelt nicht mehr, habe nun einen mit 25V genommen, sollte ja auch passen.

Viele Grüße
Benjamin

deimos
Beiträge: 3149
Registriert: 20.06.2017, 10:38
Wohnort: Leimersheim
Hat sich bedankt: 13 Mal
Danksagung erhalten: 76 Mal
Kontaktdaten:

Re: Support für Raspberry Pi 4

Beitrag von deimos » 03.07.2019, 13:18

Hi,

ich habe mittlerweile neue Erkenntnisse: Auch wenn es auf den ersten Blick so aussieht, funktioniert weder das RPI-RF-MOD noch das HM-MOD-RPI-PCB, spätestens nach einem Neustart knallt es. Ich konnte aber mittlerweile rausfinden, dass dies an zwei Hardware Änderungen liegt: Es wird einen neuere Revision vom pl011 verwendet, welche ein paar Änderungen enthält, u.A. eine Verdopplung des FIFOs auf 32 Byte. Mit dem aktuellen Code sorgt das dafür, dass die Kommunikation mit dem Funkmodul abbricht, sobald die erste Nachricht mit mehr als 11 Byte gesendet wird.
Ein Fix dafür ist in Arbeit, das wird allerdings noch ein paar Tage dauern.

Viele Grüße
Alex

Benutzeravatar
jmaus
Beiträge: 5213
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 9 Mal
Danksagung erhalten: 116 Mal
Kontaktdaten:

Re: Support für Raspberry Pi 4

Beitrag von jmaus » 03.07.2019, 13:48

deimos hat geschrieben:
03.07.2019, 13:18
ich habe mittlerweile neue Erkenntnisse: Auch wenn es auf den ersten Blick so aussieht, funktioniert weder das RPI-RF-MOD noch das HM-MOD-RPI-PCB, spätestens nach einem Neustart knallt es. Ich konnte aber mittlerweile rausfinden, dass dies an zwei Hardware Änderungen liegt: Es wird einen neuere Revision vom pl011 verwendet, welche ein paar Änderungen enthält, u.A. eine Verdopplung des FIFOs auf 32 Byte. Mit dem aktuellen Code sorgt das dafür, dass die Kommunikation mit dem Funkmodul abbricht, sobald die erste Nachricht mit mehr als 11 Byte gesendet wird.
Ein Fix dafür ist in Arbeit, das wird allerdings noch ein paar Tage dauern.
Danke für deine Arbeiten Alex! Auch wenn der Pi4 support in RaspberryMatic noch eine weile warten muss bis die U-Boot maintainer den Pi4 support selbst Einpflegen schätze ich deine Arbeiten rund um das raw-uart kernel Modul wirklich sehr und freue mich das dann das Problem gelöst sein wird sobald die U-Boot maintainer nachgezogen haben. Auch hoffe ich natürlich das du das in irgendeiner abwärtskompatiblen Art und Weise umsetzen kannst und der uart Treiber selbst die große des FIFOs dann erkennen und entsprechend sich drauf anpassen kann.
RaspberryMatic 3.47.22.20191026 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubGitHub Sponsors / PayPalTwitter

Josl
Beiträge: 56
Registriert: 10.07.2016, 13:49
Wohnort: Niederbayern

Re: Support für Raspberry Pi 4

Beitrag von Josl » 10.07.2019, 19:59

Offensichtlich nicht normgerechte USB-C Buchse am PI 4

https://www.heise.de/newsticker/meldung ... 67303.html


Josl

Hackertomm
Beiträge: 128
Registriert: 18.04.2018, 12:32
Danksagung erhalten: 1 Mal

Re: Support für Raspberry Pi 4

Beitrag von Hackertomm » 11.07.2019, 11:31

Die Buchse ist schon Normgerecht, nur deren Beschaltung entspricht nicht der USB Norm Vorgabe !
Außerdem trifft das Problem nur zu, wenn man nicht ein Original NT nimmt, sondern eines mit einem USB Kabel, welches diesen Chip implementiert hat.
Wird halt alles komplizierter!
Eine Hohlstecker Buchse wäre da viel unkomplizierter.
Dann könnte man z.B. das ELV NT für das neue Funkmodul verwenden...........
Da hat man nämlich einen Hohlstecker und am Modul auch die entspr. Buchse.
Gruß
Hackertomm

Raspberry PI 3B mit Neuem Funkmodul und ext. Antenne, Org. Netzteil und "Charly" Gehäuse, aktuell RaspberryMatic 3.47.18.20190918

dtp
Beiträge: 7018
Registriert: 21.09.2012, 08:09
Wohnort: Stuttgart
Hat sich bedankt: 10 Mal
Danksagung erhalten: 39 Mal

Re: Support für Raspberry Pi 4

Beitrag von dtp » 11.07.2019, 12:28

Hackertomm hat geschrieben:
11.07.2019, 11:31
Eine Hohlstecker Buchse wäre da viel unkomplizierter.
Die birgt dann aber die Gefahr, dass man den Raspi mit einer zu hohen Spannung versorgt. Ich habe leider schon zwei Raspis (einen 3B und einen Zero WH) mit zu hohen Spannungen gekillt. Beim Zero WH waren es gerade mal 6 Volt, die ihn ins Nirvana befördert hatten.

Der Zero W ist genial, weil man mit ihm sehr einfach und schnell eine kleine WLAN-Kamera zusammenbauen kann.
CCU3 mit stets aktueller FW und den Addons "CUxD" und "Programmedrucken", ioBroker auf Synology DiskStation DS718+ im Docker-Container, Homebridge auf Raspberry Pi 3B+;
einige Projekte: zentrales Push-Nachrichten-Programm zPNP, DoorPi-Videotürsprechanlage, An- und Abwesenheitsdetektion per Haustürschloss, zentrales Programm zur Steuerung von Beschattungsgeräten zBSP.

Josl
Beiträge: 56
Registriert: 10.07.2016, 13:49
Wohnort: Niederbayern

Re: Support für Raspberry Pi 4

Beitrag von Josl » 11.07.2019, 21:23

Die Buchse ist nicht normgerecht, weil deren Beschaltung nicht der USB-Norm entspricht. Dies wurde von der Raspberry-Foundation auch eingeräumt und eine entsprechende Boardrevision angekündigt.


Josl

Antworten

Zurück zu „RaspberryMatic“