RaspberryMatic WLAN stotternd/unzuverlässig ... Häufiges [ifplugd(wlan0) restarted]

Einrichtung, Nutzung und Hilfe zu RaspberryMatic (OCCU auf Raspberry Pi)

Moderatoren: jmaus, Co-Administratoren

Antworten
Wookbert
Beiträge: 165
Registriert: 10.05.2013, 18:40

RaspberryMatic WLAN stotternd/unzuverlässig ... Häufiges [ifplugd(wlan0) restarted]

Beitrag von Wookbert » 09.09.2019, 13:53

Ich habe – obwohl ich weder am WLAN-Router, noch an der RaspberryMatic irgendeine Veränderung vorgenommen habe – seit einigen Tagen extreme Probleme mit der WLAN-Verbindung, was sich dadurch äußert, daß ich häufig weder über das CCU-WebUI reinkomme, noch die CCU auf Befehle der AIO Neo Remote reagiert.

In den Alarm-Meldungen ist der Watchdog-Alarm ifplugd(wlan0) restarted zu sehen. Interessant ist die häufige Anzahl der Auslösungen:
Bildschirmfoto 2019-09-09 um 12.35.05.jpeg

Heute mal von RaspberryMatic 3.47.10.20190713 auf 3.47.15.20190831 aktualisiert, aber immer noch das gleiche Bild: Manchmal funktionieren die WLAN-Verbindungen bestens, häufig nicht.

Ideen?

Hominger
Beiträge: 58
Registriert: 06.12.2017, 22:14
Hat sich bedankt: 7 Mal

Re: RaspberryMatic WLAN stotternd/unzuverlässig ... Häufiges [ifplugd(wlan0) restarted]

Beitrag von Hominger » 09.09.2019, 14:42

Und im Log befinden sich dann solche Blöcke.
Dieses Problem habe ich leider auch schon lange, leider bisher ohne Lösung.

(erste und letzte Zeile sind IO, siehe Zeitstempel)

Code: Alles auswählen

Sep  8 03:43:06 homematic daemon.info cuxd[627]: save paramsets(/usr/local/addons/cuxd/cuxd.ps) size:73
Sep  8 10:13:11 homematic daemon.info ifplugd(wlan0)[31273]: Link beat lost.
Sep  8 10:13:11 homematic daemon.notice wpa_supplicant[1224]: wlan0: CTRL-EVENT-DISCONNECTED bssid=xx:df:70:2a:fa:xx reason=0 locally_generated=1
Sep  8 10:13:11 homematic daemon.err ifplugd(wlan0)[31273]: NLAPI: Packet too small or truncated!
Sep  8 10:13:11 homematic daemon.info ifplugd(wlan0)[31273]: Exiting.
Sep  8 10:13:12 homematic daemon.notice wpa_supplicant[1224]: wlan0: Trying to associate with SSID 'XXXXXXXXXXXX'
Sep  8 10:13:13 homematic daemon.notice wpa_supplicant[1224]: wlan0: CTRL-EVENT-ASSOC-REJECT bssid=00:00:00:00:00:00 status_code=16
Sep  8 10:13:14 homematic daemon.notice wpa_supplicant[1224]: wlan0: Trying to associate with SSID 'XXXXXXXXXXXX'
Sep  8 10:13:14 homematic daemon.notice wpa_supplicant[1224]: wlan0: Associated with xx:df:70:2a:fa:xx
Sep  8 10:13:14 homematic daemon.notice wpa_supplicant[1224]: wlan0: CTRL-EVENT-CONNECTED - Connection to xx:df:70:2a:fa:xx completed [id=0 id_str=]
Sep  8 10:13:14 homematic daemon.notice wpa_supplicant[1224]: wlan0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Sep  8 10:13:28 homematic user.err monit[940]: 'ifplugd.wlan0' process is not running
Sep  8 10:13:28 homematic user.info monit[940]: 'ifplugd.wlan0' trying to restart
Sep  8 10:13:28 homematic user.info monit[940]: 'ifplugd.wlan0' restart: '/etc/init.d/S45ifplugd restart wlan0'
Sep  8 10:13:31 homematic daemon.info ifplugd(wlan0)[23285]: ifplugd 0.28 initializing, using NETLINK device monitoring.
Sep  8 10:13:31 homematic daemon.info ifplugd(wlan0)[23285]: Using interface wlan0/XX:27:EB:0C:D2:XX with driver <brcmfmac> (version: 7.45.98.38)
Sep  8 10:13:31 homematic daemon.info ifplugd(wlan0)[23285]: Using detection mode: wireless extension
Sep  8 10:13:31 homematic daemon.info ifplugd(wlan0)[23285]: Initialization complete, link beat detected, interface enabled.
Sep  8 10:13:32 homematic daemon.info ifplugd(wlan0)[23285]: Executing '/etc/ifplugd/ifplugd.action wlan0 up'.
Sep  8 10:13:32 homematic daemon.warn ifplugd(wlan0)[23285]: client: ifup: interface wlan0 already configured
Sep  8 10:13:32 homematic daemon.info ifplugd(wlan0)[23285]: Program executed successfully.
Sep  8 10:13:50 homematic user.err monit[940]: 'ifplugd.wlan0' service restarted 1 times within 1 cycles(s) - exec
Sep  8 10:13:50 homematic user.info monit[940]: 'ifplugd.wlan0' exec: '/bin/triggerAlarm.tcl ifplugd(wlan0) restarted WatchDog-Alarm'
Sep  8 10:13:50 homematic user.info monit[940]: 'ifplugd.wlan0' process is running with pid 23285
Sep  8 10:13:50 homematic user.info monit[940]: 'ifplugd.wlan0' process is running after previous restart timeout (manually recovered?)
Sep  8 14:43:06 homematic daemon.info cuxd[627]: save paramsets(/usr/local/addons/cuxd/cuxd.ps) size:73

Benutzeravatar
jmaus
Beiträge: 4966
Registriert: 17.02.2015, 14:45
Wohnort: Dresden
Hat sich bedankt: 6 Mal
Danksagung erhalten: 61 Mal
Kontaktdaten:

Re: RaspberryMatic WLAN stotternd/unzuverlässig ... Häufiges [ifplugd(wlan0) restarted]

Beitrag von jmaus » 09.09.2019, 14:56

Also für mich liest sich das danach, das monit/RaspberryMatic hier vollkommen recht hat und eben darüber meckert das die WLAN Verbindung weg war und diese versucht entsprechend neuzustarten. Ich tippe also einfach mal auf eine schlechte WLAN Verbindung zu deinem AccessPoint, wohl durch ggf. stärker werdende Nachbarn auf dem selben Kanal oder anderer Funkprobleme. Und das ist eins der Gründe wieso ich persönlich (auch wenn ich WLAN Support für RM eingebaut habe) nichts davon halte seine Hausautomationszentrale via WLAN an sein LAN anzuschliessen. Hier gehört IMMER ein Kabel gelegt, koste es was es wolle ;-)
RaspberryMatic 3.47.18.20190918 @ TinkerS mit ~160 HomeMatic Geräten + ioBroker – GitHubPayPalTwitter

Wookbert
Beiträge: 165
Registriert: 10.05.2013, 18:40

Re: RaspberryMatic WLAN stotternd/unzuverlässig ... Häufiges [ifplugd(wlan0) restarted]

Beitrag von Wookbert » 09.09.2019, 15:45

Eine madige WLAN-Verbindung habe ich auch schon im Verdacht gehabt, wobei die halt in der Vergangenheit nie zu Problemen geführt hat. Diese Watchdog-Funktion ist neu? Vielleicht fällt es dadurch eher auf. Oder hat die RPMatic in der Vergangenheit auch, sobald die WLAN-Verbindung mal schwach bis weg war, den WLAN-Daemon neugestartet? Falls nicht, würde das für mich danach aussehen, als wäre dieses Verhalten mit dem Daemon-Neustart kontraproduktiv.

Meine CCU saß bis eben hinter auf einer Hutschiene hinter der Blechtür im Sicherungskasten. Die Blechtür ist – so darf man annehmen – mit für die WLAN-Probleme verantwortlich (welche aber nochmal, bis vor ein paar Tagen nicht auffielen). Ein Ethernet-Kabel zur CCU im Sicherungskasten wäre in der Tat zu bevorzugen, ist aber nur mit erheblichem Aufwand und Dreck zu verlegen.

Ich habe die CCU jetzt mal näher an den WLAN-Router gesetzt ... womit das WLAN-Problematik in der Tat weg ist, ich jetzt aber das Problem habe, daß ich den HM-LC-Sw1-FM Flurlicht-Aktor im Sicherungskasten nicht mehr erreiche. Nächster Schritt wird dann sein, diesen Aktor dann in der Hohlwand um den Sicherungskasten höher zu setzen, damit der 868 MHz-Funk nicht von der Blechtür abgeschirmt wird.
Zuletzt geändert von Wookbert am 09.09.2019, 18:24, insgesamt 1-mal geändert.

Wookbert
Beiträge: 165
Registriert: 10.05.2013, 18:40

Re: RaspberryMatic WLAN stotternd/unzuverlässig ... Häufiges [ifplugd(wlan0) restarted]

Beitrag von Wookbert » 09.09.2019, 15:53

Call me „Trottel!“. Sicherung vom Flurlicht-Aktor war unten. :lol:

Hominger
Beiträge: 58
Registriert: 06.12.2017, 22:14
Hat sich bedankt: 7 Mal

Re: RaspberryMatic WLAN stotternd/unzuverlässig ... Häufiges [ifplugd(wlan0) restarted]

Beitrag von Hominger » 09.09.2019, 17:44

OK, ich denke die Onboard WLAN's sind da eh etwas schwach auf der Brust. Klar, LAN wäre natürlich ideal - leider hab ich kein Kabel liegen.
Ich habe noch einen Edimax EW-7811UN WLAN-Stick rumliegen, den versuche ich mal zu aktivieren, es könnte eine Lösung sein.
....muss mich nur einlesen, wie ich den verbunden bekomme.

Hominger
Beiträge: 58
Registriert: 06.12.2017, 22:14
Hat sich bedankt: 7 Mal

Re: RaspberryMatic WLAN stotternd/unzuverlässig ... Häufiges [ifplugd(wlan0) restarted]

Beitrag von Hominger » 13.09.2019, 09:11

Ich benötige beim Wechsel des Oboard-WLAN auf einen USB-WLAN-Adapter nochmal Eure Hilfe.
Denn in der Beschreibung hier im Forum wurde ich leider nicht fündig - oder habe einfach nach dem falschen Begriff gesucht.

Wenn ich das richtig verstanden habe, dann muss in der Datei /etc/network/interfaces der Adapter von wlan0 nach wlan1 umgestellt werden ?
Da ja das Dateisystem read-only ist, komme ich hier nicht weiter.
Hat schon jemand auf USB WLAN-Adapter gewechselt, wo mache ich einen Denkfehler ?

Antworten

Zurück zu „RaspberryMatic“